]> git.pld-linux.org Git - packages/gstreamer-openmax.git/blob - gstreamer-openmax.spec
- updated to 1.18.5; now uses meson+hotdoc
[packages/gstreamer-openmax.git] / gstreamer-openmax.spec
1 # TODO:
2 # - find/wait for OMXIL implementation with OMX_VIDEO_CodingVP8 (requires OpenMAX-IL 1.2 or extension?)
3 #   OMX_VIDEO_CodingTheora (not available in raw OpenMAX-IL 1.1.2 or 1.2)
4 # - tizonia >= 0.19.0 as an alternative for bellagio?
5 #
6 # Conditional build:
7 %bcond_without  apidocs         # API documentation
8
9 %define         gst_ver         1.18.5
10 Summary:        GStreamer plug-in that allows communication with OpenMAX IL components
11 Summary(pl.UTF-8):      Wtyczka GStreamera pozwalająca na komunikację z komponentami OpenMAX IL
12 Name:           gstreamer-openmax
13 Version:        1.18.5
14 Release:        1
15 License:        LGPL v2.1+
16 Group:          Libraries
17 Source0:        https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-%{version}.tar.xz
18 # Source0-md5:  9d5cc5515aa7e10082ad36a719735b0a
19 URL:            https://gstreamer.freedesktop.org/
20 BuildRequires:  glib2-devel >= 1:2.44.0
21 BuildRequires:  gstreamer-devel >= %{gst_ver}
22 BuildRequires:  gstreamer-gl-devel >= %{gst_ver}
23 BuildRequires:  gstreamer-plugins-base-devel
24 %{?with_apidocs:BuildRequires:  hotdoc}
25 # currently internal headers used (last bellagio release misses some defines)
26 #BuildRequires: libomxil-bellagio-devel
27 BuildRequires:  meson >= 0.47
28 BuildRequires:  ninja >= 1.5
29 BuildRequires:  pkgconfig
30 BuildRequires:  python >= 2.1
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 # EGL-devel, OpenGL-GLESv2-devel, xorg-lib-libX11-devel  for examples only
35 Requires:       glib2 >= 1:2.44.0
36 Requires:       gstreamer >= %{gst_ver}
37 Requires:       gstreamer-gl-libs >= %{gst_ver}
38 Requires:       libomxil-bellagio
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GstOpenMAX is a GStreamer plug-in that allows communication with
43 OpenMAX IL components.
44
45 OpenMAX IL is an industry standard that provides an abstraction layer
46 for computer graphics, video, and sound routines.
47
48 %description -l pl.UTF-8
49 GstOpenMAX to wtyczka GStreamera pozwalająca na komunikację z
50 komponentami OpenMAX IL.
51
52 OpenMAX IL to standard przemysłowy zapewniający warstwę abstrakcji dla
53 funkcji grafiki komputerowej, obrazu i dźwięku komp.
54
55 %package apidocs
56 Summary:        GStreamer OpenMAX API documentation
57 Summary(pl.UTF-8):      Dokumentacja API wtyczki GStreamera OpenMAX
58 Group:          Documentation
59 BuildArch:      noarch
60
61 %description apidocs
62 GStreamer OpenMAX API documentation.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API wtyczki GStreamera OpenMAX.
66
67 %prep
68 %setup -q -n gst-omx-%{version}
69
70 %build
71 %meson build \
72         --default-library=shared \
73         %{!?with_apidocs:-Ddoc=false} \
74         -Dtarget=bellagio
75
76 %ninja_build -C build
77
78 %if %{with apidocs}
79 cd build/docs
80 LC_ALL=C.UTF-8 hotdoc run --conf-file omx-doc.json
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %ninja_install -C build
87
88 %if %{with apidocs}
89 install -d $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
90 cp -pr build/docs/omx-doc $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
91 %endif
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog NEWS README RELEASE
99 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstomx.so
100 %config(noreplace) %verify(not md5 mtime size) /etc/xdg/gstomx.conf
101
102 %if %{with apidocs}
103 %files apidocs
104 %defattr(644,root,root,755)
105 %{_docdir}/gstreamer-%{gstmver}
106 %endif
This page took 0.069704 seconds and 3 git commands to generate.