]> git.pld-linux.org Git - packages/gstreamer-libav.git/blob - gstreamer-libav.spec
- updated to 1.0.9
[packages/gstreamer-libav.git] / gstreamer-libav.spec
1 #
2 # Conditional build:
3 %bcond_without  vdpau           # build libav without VDPAU support
4 %bcond_with     system_libav    # system libav (note: upstream does not accept bugs with system libav)
5
6 %define         gstname gst-libav
7 %define         gst_major_ver   1.0
8 %define         gst_req_ver     1.0.0
9
10 %include        /usr/lib/rpm/macros.gstreamer
11 Summary:        GStreamer Streaming-media framework plug-in using libav
12 Summary(pl.UTF-8):      Wtyczka do środowiska obróbki strumieni GStreamer używająca libav
13 Name:           gstreamer-libav
14 Version:        1.0.9
15 Release:        1
16 License:        LGPL v2+ (gst part), GPL v2+ (some libav parts)
17 Group:          Libraries
18 Source0:        http://gstreamer.freedesktop.org/src/gst-libav/%{gstname}-%{version}.tar.xz
19 # Source0-md5:  8414f8d4c4a239a74a3d5eadf3d14875
20 URL:            http://gstreamer.net/
21 BuildRequires:  autoconf >= 2.62
22 BuildRequires:  automake >= 1:1.11
23 BuildRequires:  bzip2-devel
24 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
25 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
26 BuildRequires:  gtk-doc >= 1.12
27 BuildRequires:  libtool
28 BuildRequires:  orc-devel >= 0.4.16
29 BuildRequires:  pkgconfig
30 BuildRequires:  python >= 2.1
31 BuildRequires:  rpmbuild(macros) >= 1.470
32 %if %{with system_libav}
33 # libavformat,libavcodec,libavutil,libswscale needed
34 BuildRequires:  libav-devel >= 0.8.8
35 %else
36 # libav dependencies
37 BuildRequires:  SDL-devel
38 BuildRequires:  zlib-devel
39 %ifarch %{ix86} %{x8664}
40 BuildRequires:  yasm
41 %endif
42 %if %{with vdpau}
43 BuildRequires:  libvdpau-devel
44 BuildRequires:  xorg-lib-libXvMC-devel
45 %endif
46 %endif
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  xz
49 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
50 %{?with_system_libav:Requires:  libav >= 0.8.8}
51 Requires:       orc >= 0.4.16
52 Obsoletes:      gstreamer-ffmpeg
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 GStreamer is a streaming-media framework, based on graphs of filters
57 which operate on media data. Applications using this library can do
58 anything from real-time sound processing to playing videos, and just
59 about anything else media-related. Its plugin-based architecture means
60 that new data types or processing capabilities can be added simply by
61 installing new plug-ins.
62
63 This plugin contains the libav codecs, containing codecs for most
64 popular multimedia formats.
65
66 %description -l pl.UTF-8
67 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
68 grafie filtrów operujących na danych medialnych. Aplikacje używające
69 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
70 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
71 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
72 nowych typów danych lub możliwości obróbki.
73
74 Wtyczka ta zawiera kodeki libav, potrafiące zdekodować
75 najpopularniejsze formaty multimedialne.
76
77 %prep
78 %setup -q -n %{gstname}-%{version}
79
80 %build
81 %{__libtoolize}
82 %{__aclocal} -I m4 -I common/m4
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86
87 %configure \
88         CPPFLAGS="%{rpmcppflags}" \
89         %{?with_system_libav:--with-system-libav} \
90         %{?with_vdpau:--with-libav-extra-configure="--enable-vdpau"} \
91         --disable-silent-rules \
92         --disable-static
93 # V=1 is for libav (--disable-silent-rules affects only main gst-libav sources)
94 %{__make} \
95         V=1
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog NEWS README TODO
111 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibav.so
112 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstavscale.so
This page took 0.059896 seconds and 3 git commands to generate.