]> git.pld-linux.org Git - packages/gstreamer-libav.git/blob - gstreamer-libav.spec
da6b50f007ed52136856772f56e3dc911504d112
[packages/gstreamer-libav.git] / gstreamer-libav.spec
1 #
2 # Conditional build:
3 %bcond_without  gpl             # GPL licensed components
4 %bcond_without  vdpau           # build libav without VDPAU support
5 %bcond_with     system_ffmpeg   # system ffmpeg (note: upstream does not accept bugs with system ffmpeg)
6
7 %define         gstname gst-libav
8 %define         gst_major_ver   1.0
9 %define         gst_req_ver     1.6.1
10 %define         gstpb_req_ver   1.6.1
11 %define         ffmpeg_ver      2.8.1
12
13 %include        /usr/lib/rpm/macros.gstreamer
14 Summary:        GStreamer Streaming-media framework plug-in using libav
15 Summary(pl.UTF-8):      Wtyczka do środowiska obróbki strumieni GStreamer używająca libav
16 Name:           gstreamer-libav
17 Version:        1.6.1
18 Release:        2
19 %if %{with gpl}
20 License:        GPL v2+
21 %else
22 License:        LGPL v2+
23 %endif
24 Group:          Libraries
25 Source0:        http://gstreamer.freedesktop.org/src/gst-libav/%{gstname}-%{version}.tar.xz
26 # Source0-md5:  058b22411e1690eee5b71d1ab44eab25
27 Patch0:         link-crystalhd.patch
28 URL:            http://gstreamer.net/
29 BuildRequires:  autoconf >= 2.69
30 BuildRequires:  automake >= 1:1.14
31 BuildRequires:  bzip2-devel
32 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
33 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
34 BuildRequires:  gtk-doc >= 1.12
35 BuildRequires:  libtool >= 2:2.2.6
36 BuildRequires:  orc-devel >= 0.4.16
37 BuildRequires:  pkgconfig >= 1:0.9.0
38 BuildRequires:  python >= 2.1
39 BuildRequires:  rpmbuild(macros) >= 1.470
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  xz
42 BuildRequires:  xz-devel
43 %if %{with system_ffmpeg}
44 # libavformat,libavcodec,libavutil,libswscale needed
45 BuildRequires:  ffmpeg-devel >= %{ffmpeg_ver}
46 %else
47 # libav dependencies
48 BuildRequires:  SDL-devel
49 BuildRequires:  zlib-devel
50 %ifarch %{ix86} %{x8664}
51 BuildRequires:  yasm
52 %endif
53 %if %{with vdpau}
54 BuildRequires:  libvdpau-devel
55 BuildRequires:  xorg-lib-libXvMC-devel
56 %endif
57 %endif
58 Requires:       gstreamer >= %{gst_req_ver}
59 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
60 %if %{with system_ffmpeg}
61 Requires:       ffmpeg-libs >= %{ffmpeg_ver}
62 %endif
63 Requires:       orc >= 0.4.16
64 Obsoletes:      gstreamer-ffmpeg
65 Obsoletes:      gstreamer-real
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 GStreamer is a streaming-media framework, based on graphs of filters
70 which operate on media data. Applications using this library can do
71 anything from real-time sound processing to playing videos, and just
72 about anything else media-related. Its plugin-based architecture means
73 that new data types or processing capabilities can be added simply by
74 installing new plug-ins.
75
76 This plugin contains the libav codecs, containing codecs for most
77 popular multimedia formats.
78
79 %description -l pl.UTF-8
80 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
81 grafie filtrów operujących na danych medialnych. Aplikacje używające
82 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
83 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
84 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
85 nowych typów danych lub możliwości obróbki.
86
87 Wtyczka ta zawiera kodeki libav, potrafiące zdekodować
88 najpopularniejsze formaty multimedialne.
89
90 %package apidocs
91 Summary:        API documentation for GStreamer libav plugin
92 Summary(pl.UTF-8):      Dokumentacja API do wtyczki GStreamera libav
93 Group:          Documentation
94 Requires:       gtk-doc-common
95
96 %description apidocs
97 API documentation for GStreamer libav plugin.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API do wtyczki GStreamera libav.
101
102 %prep
103 %setup -q -n %{gstname}-%{version}
104 %{!?with_system_ffmpeg:%patch0 -p1}
105
106 %build
107 %{__libtoolize}
108 %{__aclocal} -I m4 -I common/m4
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112
113 LIBAV_OPTS="%{?with_vdpau:--enable-vdpau}"
114 %ifarch x32
115 LIBAV_OPTS="$LIBAV_OPTS --disable-asm"
116 %endif
117 %configure \
118         CPPFLAGS="%{rpmcppflags}" \
119         %{?with_system_ffmpeg:--with-system-libav} \
120         --with-libav-extra-configure="$LIBAV_OPTS" \
121         %{?with_gpl:--enable-gpl} \
122         --disable-silent-rules \
123         --disable-static \
124         --with-html-dir=%{_gtkdocdir}
125
126 # V=1 is for libav (--disable-silent-rules affects only main gst-libav sources)
127 %{__make} \
128         V=1
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS README TODO
144 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibav.so
145 # disabled in (upstream) 1.2.0 until someone fixes it
146 #%attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstavscale.so
147
148 %files apidocs
149 %defattr(644,root,root,755)
150 %{_gtkdocdir}/gst-libav-plugins-1.0
This page took 0.032731 seconds and 2 git commands to generate.