]> git.pld-linux.org Git - packages/gstreamer-libav.git/blob - gstreamer-libav.spec
2c1c6521be71ee879c1b13c0be411a94b64e178c
[packages/gstreamer-libav.git] / gstreamer-libav.spec
1 #
2 # Conditional build:
3 %bcond_without  vdpau           # build libav without VDPAU support
4 %bcond_with     system_libav    # system libav (note: upstream does not accept bugs with system libav)
5
6 %define         gstname gst-libav
7 %define         gst_major_ver   1.0
8 %define         gst_req_ver     1.2.0
9 %define         libav_ver       9.9
10
11 %include        /usr/lib/rpm/macros.gstreamer
12 Summary:        GStreamer Streaming-media framework plug-in using libav
13 Summary(pl.UTF-8):      Wtyczka do środowiska obróbki strumieni GStreamer używająca libav
14 Name:           gstreamer-libav
15 Version:        1.2.1
16 Release:        1
17 License:        LGPL v2+ (gst part), GPL v2+ (some libav parts)
18 Group:          Libraries
19 Source0:        http://gstreamer.freedesktop.org/src/gst-libav/%{gstname}-%{version}.tar.xz
20 # Source0-md5:  4c300da1cf14b4e167d65cd5d8de1ef1
21 URL:            http://gstreamer.net/
22 BuildRequires:  autoconf >= 2.62
23 BuildRequires:  automake >= 1:1.11
24 BuildRequires:  bzip2-devel
25 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
26 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
27 BuildRequires:  gtk-doc >= 1.12
28 BuildRequires:  libtool
29 BuildRequires:  orc-devel >= 0.4.16
30 BuildRequires:  pkgconfig
31 BuildRequires:  python >= 2.1
32 BuildRequires:  rpmbuild(macros) >= 1.470
33 %if %{with system_libav}
34 # libavformat,libavcodec,libavutil,libswscale needed
35 BuildRequires:  libav-devel >= %{libav_ver}
36 %else
37 # libav dependencies
38 BuildRequires:  SDL-devel
39 BuildRequires:  zlib-devel
40 %ifarch %{ix86} %{x8664}
41 BuildRequires:  yasm
42 %endif
43 %if %{with vdpau}
44 BuildRequires:  libvdpau-devel
45 BuildRequires:  xorg-lib-libXvMC-devel
46 %endif
47 %endif
48 BuildRequires:  tar >= 1:1.22
49 BuildRequires:  xz
50 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
51 %{?with_system_libav:Requires:  libav >= %{libav_ver}}
52 Requires:       orc >= 0.4.16
53 Obsoletes:      gstreamer-ffmpeg
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 GStreamer is a streaming-media framework, based on graphs of filters
58 which operate on media data. Applications using this library can do
59 anything from real-time sound processing to playing videos, and just
60 about anything else media-related. Its plugin-based architecture means
61 that new data types or processing capabilities can be added simply by
62 installing new plug-ins.
63
64 This plugin contains the libav codecs, containing codecs for most
65 popular multimedia formats.
66
67 %description -l pl.UTF-8
68 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
69 grafie filtrów operujących na danych medialnych. Aplikacje używające
70 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
71 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
72 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
73 nowych typów danych lub możliwości obróbki.
74
75 Wtyczka ta zawiera kodeki libav, potrafiące zdekodować
76 najpopularniejsze formaty multimedialne.
77
78 %prep
79 %setup -q -n %{gstname}-%{version}
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4 -I common/m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87
88 %configure \
89         CPPFLAGS="%{rpmcppflags}" \
90         %{?with_system_libav:--with-system-libav} \
91         %{?with_vdpau:--with-libav-extra-configure="--enable-vdpau"} \
92         --disable-silent-rules \
93         --disable-static
94 # V=1 is for libav (--disable-silent-rules affects only main gst-libav sources)
95 %{__make} \
96         V=1
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog NEWS README TODO
112 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibav.so
113 # disabled in (upstream) 1.2.0 until someone fixes it
114 #%attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstavscale.so
This page took 0.100449 seconds and 2 git commands to generate.