]> git.pld-linux.org Git - packages/gstreamer-editing-services.git/blob - gstreamer-editing-services.spec
- nle component replaces gstreamer-gnonlin
[packages/gstreamer-editing-services.git] / gstreamer-editing-services.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 %define         gst_req_ver     1.6.0
6 %define         gstpb_req_ver   1.6.0
7 Summary:        GStreamer Editing Services library
8 Summary(pl.UTF-8):      Biblioteka funkcji edycyjnych GStreamera (GStreamer Editing Services)
9 Name:           gstreamer-editing-services
10 Version:        1.6.0
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://gstreamer.freedesktop.org/src/gstreamer-editing-services/%{name}-%{version}.tar.xz
15 # Source0-md5:  fd4071d6f2fdd0c302f579b3180115c1
16 URL:            http://gstreamer.net/
17 BuildRequires:  autoconf >= 2.62
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  glib2-devel >= 1:2.34.0
20 BuildRequires:  gobject-introspection-devel >= 0.9.6
21 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
22 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
23 BuildRequires:  gstreamer-validate-devel >= 1.6.0
24 BuildRequires:  gtk-doc >= 1.3
25 BuildRequires:  libtool >= 2:2.2.6
26 BuildRequires:  libxml2-devel >= 2.0
27 BuildRequires:  pkgconfig >= 1:0.9.0
28 BuildRequires:  python >= 1:2.3
29 # what version???
30 #BuildRequires: python-pygobject3-devel >= 4.22
31 BuildRequires:  rpmbuild(macros) >= 1.673
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires:       glib2 >= 1:2.34.0
35 Requires:       gstreamer >= %{gst_req_ver}
36 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
37 Obsoletes:      gstreamer-gnonlin < 1.6.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 GStreamer Editing Services is a high-level library for facilitating
42 the creation of audio/video non-linear editors.
43
44 %description -l pl.UTF-8
45 GStreamer Editing Services to wysokopoziomowa biblioteka ułatwiająca
46 tworzenie nieliniowych edytorów audio/video.
47
48 %package devel
49 Summary:        Header files for GStreamer Editing Services library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GStreamer Editing Services
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       glib2-devel >= 1:2.34.0
54 Requires:       gstreamer-devel >= %{gst_req_ver}
55 Requires:       gstreamer-plugins-base-devel >= %{gstpb_req_ver}
56
57 %description devel
58 Header files for GStreamer Editing Services library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki GStreamer Editing Services.
62
63 %package static
64 Summary:        Static GStreamer Editing Services library
65 Summary(pl.UTF-8):      Statyczba biblioteka GStreamer Editing Services
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static GStreamer Editing Services library.
71
72 %description static -l pl.UTF-8
73 Statyczba biblioteka GStreamer Editing Services.
74
75 %package apidocs
76 Summary:        API documentation for GStreamer Editing Services library
77 Summary(pl.UTF-8):      Dokumentacja API biblioteki GStreamer Editing Services
78 Group:          Documentation
79 Requires:       gtk-doc-common
80 Obsoletes:      gstreamer-gnonlin-apidocs < 1.6.0
81
82 %description apidocs
83 API documentation for GStreamer Editing Services library.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API biblioteki GStreamer Editing Services.
87
88 %package -n bash-completion-gstreamer-editing-services
89 Summary:        Bash completion for GStreamer Editing Services utilities
90 Summary(pl.UTF-8):      Bashowe uzupełnianie paramterów narzędzi GStreamer Editing Services
91 Group:          Applications/Shells
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       bash-completion >= 2.0
94
95 %description -n bash-completion-gstreamer-editing-services
96 Bash completion for GStreamer Editing Services utilities (ges-launch).
97
98 %description -n bash-completion-gstreamer-editing-services -l pl.UTF-8
99 Bashowe uzupełnianie paramterów narzędzi GStreamer Editing Services
100 (ges-launch).
101
102 %prep
103 %setup -q
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I m4 -I common/m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --disable-silent-rules \
113         --enable-gtk-doc \
114         %{?with_static_libs:--enable-static} \
115         --with-bash-completion-dir=%{bash_compdir} \
116         --with-html-dir=%{_gtkdocdir}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         scenariosdir=%{_datadir}/gstreamer-1.0/validate/scenarios
126
127 # obsoleted by pkg-config
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libges-1.0.la
129 # module loaded through glib
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstnle.la
131
132 %py_comp $RPM_BUILD_ROOT%{_libdir}/gst-validate-launcher/python/launcher/apps
133 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/gst-validate-launcher/python/launcher/apps
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS ChangeLog NEWS README RELEASE
144 %attr(755,root,root) %{_bindir}/ges-launch-1.0
145 %attr(755,root,root) %{_libdir}/libges-1.0.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libges-1.0.so.0
147 %{_libdir}/girepository-1.0/GES-1.0.typelib
148 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstnle.so
149 %{_libdir}/gst-validate-launcher/python/launcher/apps/geslaunch.py*
150 %{_datadir}/gstreamer-1.0/validate/scenarios/ges-edit-clip-while-paused.scenario
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libges-1.0.so
155 %{_includedir}/gstreamer-1.0/ges
156 %{_datadir}/gir-1.0/GES-1.0.gir
157 %{_pkgconfigdir}/gst-editing-services-1.0.pc
158
159 %if %{with static_libs}
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/libges-1.0.a
163 %endif
164
165 %files apidocs
166 %defattr(644,root,root,755)
167 %{_gtkdocdir}/ges-1.0
168
169 %files -n bash-completion-gstreamer-editing-services
170 %defattr(644,root,root,755)
171 %{bash_compdir}/ges-launch-1.0
This page took 0.059734 seconds and 4 git commands to generate.