]> git.pld-linux.org Git - packages/gstreamer-editing-services.git/blob - gstreamer-editing-services.spec
45b22be36380571354d23648e0486f3849ad90f6
[packages/gstreamer-editing-services.git] / gstreamer-editing-services.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # Python binding
4 %bcond_without  static_libs     # static library
5
6 %define         gst_req_ver     1.14.4
7 %define         gstpb_req_ver   1.14.4
8 %define         gstvalidate_req_ver     1.12.1
9 Summary:        GStreamer Editing Services library
10 Summary(pl.UTF-8):      Biblioteka funkcji edycyjnych GStreamera (GStreamer Editing Services)
11 Name:           gstreamer-editing-services
12 Version:        1.14.4
13 Release:        1
14 License:        LGPL v2+
15 Group:          Libraries
16 Source0:        https://gstreamer.freedesktop.org/src/gstreamer-editing-services/%{name}-%{version}.tar.xz
17 # Source0-md5:  58d4f59da2b7879214c58a16d1ca68bb
18 URL:            https://gstreamer.freedesktop.org/
19 BuildRequires:  autoconf >= 2.62
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  flex >= 2.5.31
22 BuildRequires:  glib2-devel >= 1:2.40.0
23 BuildRequires:  gobject-introspection-devel >= 0.9.6
24 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
25 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
26 BuildRequires:  gstreamer-validate-devel >= %{gstvalidate_req_ver}
27 BuildRequires:  gtk-doc >= 1.3
28 BuildRequires:  libtool >= 2:2.2.6
29 BuildRequires:  libxml2-devel >= 2.0
30 BuildRequires:  pkgconfig >= 1:0.9.0
31 %if %{with python}
32 BuildRequires:  python >= 1:2.3
33 BuildRequires:  python-pygobject3-devel >= 3.0
34 %endif
35 BuildRequires:  rpmbuild(macros) >= 1.673
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 Requires:       glib2 >= 1:2.40.0
39 Requires:       gstreamer >= %{gst_req_ver}
40 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
41 Requires:       gstreamer-validate >= %{gstvalidate_req_ver}
42 Obsoletes:      gstreamer-gnonlin < 1.6.0
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 GStreamer Editing Services is a high-level library for facilitating
47 the creation of audio/video non-linear editors.
48
49 %description -l pl.UTF-8
50 GStreamer Editing Services to wysokopoziomowa biblioteka ułatwiająca
51 tworzenie nieliniowych edytorów audio/video.
52
53 %package devel
54 Summary:        Header files for GStreamer Editing Services library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GStreamer Editing Services
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       glib2-devel >= 1:2.40.0
59 Requires:       gstreamer-devel >= %{gst_req_ver}
60 Requires:       gstreamer-plugins-base-devel >= %{gstpb_req_ver}
61
62 %description devel
63 Header files for GStreamer Editing Services library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki GStreamer Editing Services.
67
68 %package static
69 Summary:        Static GStreamer Editing Services library
70 Summary(pl.UTF-8):      Statyczba biblioteka GStreamer Editing Services
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static GStreamer Editing Services library.
76
77 %description static -l pl.UTF-8
78 Statyczba biblioteka GStreamer Editing Services.
79
80 %package apidocs
81 Summary:        API documentation for GStreamer Editing Services library
82 Summary(pl.UTF-8):      Dokumentacja API biblioteki GStreamer Editing Services
83 Group:          Documentation
84 Requires:       gtk-doc-common
85 Obsoletes:      gstreamer-gnonlin-apidocs < 1.6.0
86 %if "%{_rpmversion}" >= "5"
87 BuildArch:      noarch
88 %endif
89
90 %description apidocs
91 API documentation for GStreamer Editing Services library.
92
93 %description apidocs -l pl.UTF-8
94 Dokumentacja API biblioteki GStreamer Editing Services.
95
96 %package -n python-gstreamer-editing-services
97 Summary:        Python GI binding for GStreamer Editing Services
98 Summary(pl.UTF-8):      Wiązanie Pythona GI do usług GStreamer Editing Services
99 Group:          Libraries/Python
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       python-pygobject3 >= 3.0
102
103 %description -n python-gstreamer-editing-services
104 Python GI binding for GStreamer Editing Services.
105
106 %description -n python-gstreamer-editing-services -l pl.UTF-8
107 Wiązanie Pythona GI do usług GStreamer Editing Services.
108
109 %package -n bash-completion-gstreamer-editing-services
110 Summary:        Bash completion for GStreamer Editing Services utilities
111 Summary(pl.UTF-8):      Bashowe uzupełnianie paramterów narzędzi GStreamer Editing Services
112 Group:          Applications/Shells
113 Requires:       %{name} = %{version}-%{release}
114 Requires:       bash-completion >= 2.0
115
116 %description -n bash-completion-gstreamer-editing-services
117 Bash completion for GStreamer Editing Services utilities (ges-launch).
118
119 %description -n bash-completion-gstreamer-editing-services -l pl.UTF-8
120 Bashowe uzupełnianie paramterów narzędzi GStreamer Editing Services
121 (ges-launch).
122
123 %prep
124 %setup -q
125
126 %build
127 %{__libtoolize}
128 %{__aclocal} -I m4 -I common/m4
129 %{__autoconf}
130 %{__autoheader}
131 %{__automake}
132 %configure \
133         --disable-silent-rules \
134         --enable-gtk-doc \
135         %{?with_static_libs:--enable-static} \
136         --with-bash-completion-dir=%{bash_compdir} \
137         --with-html-dir=%{_gtkdocdir}
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT \
146         scenariosdir=%{_datadir}/gstreamer-1.0/validate/scenarios
147
148 # obsoleted by pkg-config
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libges-1.0.la
150 # module loaded through glib
151 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstnle.la
152
153 %if %{with python}
154 %py_comp $RPM_BUILD_ROOT%{_libdir}/gst-validate-launcher/python/launcher/apps
155 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/gst-validate-launcher/python/launcher/apps
156 %py_postclean
157 %endif
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS ChangeLog NEWS README RELEASE
168 %attr(755,root,root) %{_bindir}/ges-launch-1.0
169 %attr(755,root,root) %{_libdir}/libges-1.0.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libges-1.0.so.0
171 %{_libdir}/girepository-1.0/GES-1.0.typelib
172 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstnle.so
173 %if %{with python}
174 %{_libdir}/gst-validate-launcher/python/launcher/apps/geslaunch.py*
175 %endif
176 %{_datadir}/gstreamer-1.0/validate/scenarios/ges-edit-clip-while-paused.scenario
177 %{_mandir}/man1/ges-launch-1.0.1*
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libges-1.0.so
182 %{_includedir}/gstreamer-1.0/ges
183 %{_datadir}/gir-1.0/GES-1.0.gir
184 %{_pkgconfigdir}/gst-editing-services-1.0.pc
185
186 %if %{with static_libs}
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libges-1.0.a
190 %{_libdir}/gstreamer-1.0/libgstnle.a
191 %endif
192
193 %files apidocs
194 %defattr(644,root,root,755)
195 %{_gtkdocdir}/ges-1.0
196
197 %if %{with python}
198 %files -n python-gstreamer-editing-services
199 %defattr(644,root,root,755)
200 %dir %{py_sitedir}/gstreamer-editing-services
201 %{py_sitedir}/gstreamer-editing-services/GES.py[co]
202 %endif
203
204 %files -n bash-completion-gstreamer-editing-services
205 %defattr(644,root,root,755)
206 %{bash_compdir}/ges-launch-1.0
This page took 0.091111 seconds and 2 git commands to generate.