]> git.pld-linux.org Git - packages/gstreamer-editing-services.git/blob - gstreamer-editing-services.spec
07f5dead64edc24114c5c35e8d17ca2607081fb1
[packages/gstreamer-editing-services.git] / gstreamer-editing-services.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  python3         # CPython 3.x binding
5 %bcond_without  static_libs     # static library
6
7 %define         gstmver         1.0
8 %define         gst_ver         1.22.0
9 %define         gstpb_ver       1.22.0
10 %define         gstdevtools_ver 1.22.0
11 Summary:        GStreamer Editing Services library
12 Summary(pl.UTF-8):      Biblioteka funkcji edycyjnych GStreamera (GStreamer Editing Services)
13 Name:           gstreamer-editing-services
14 Version:        1.22.6
15 Release:        1
16 License:        LGPL v2+
17 Group:          Libraries
18 Source0:        https://gstreamer.freedesktop.org/src/gstreamer-editing-services/gst-editing-services-%{version}.tar.xz
19 # Source0-md5:  b014530bab0bf609e15b78a77a02af87
20 URL:            https://gstreamer.freedesktop.org/
21 BuildRequires:  bash-completion-devel >= 1:2.0
22 BuildRequires:  flex >= 2.5.31
23 BuildRequires:  glib2-devel >= 1:2.62.0
24 BuildRequires:  gobject-introspection-devel >= 0.9.6
25 BuildRequires:  gstreamer-devel >= %{gst_ver}
26 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
27 BuildRequires:  gstreamer-plugins-bad-devel >= %{gstpb_ver}
28 BuildRequires:  gstreamer-validate-devel >= %{gstdevtools_ver}
29 %{?with_apidocs:BuildRequires:  hotdoc >= 0.11.0}
30 BuildRequires:  meson >= 0.62
31 BuildRequires:  ninja >= 1.5
32 BuildRequires:  libxml2-devel >= 2.0
33 BuildRequires:  pkgconfig >= 1:0.9.0
34 %if %{with python3}
35 BuildRequires:  python3 >= 1:3.4
36 # for proper overrides dir detection
37 BuildRequires:  python3-pygobject3
38 %endif
39 BuildRequires:  rpm-build >= 4.6
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.736
42 BuildRequires:  tar >= 1:1.22
43 BuildRequires:  xz
44 Requires:       glib2 >= 1:2.62.0
45 Requires:       gstreamer >= %{gst_ver}
46 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
47 Requires:       gstreamer-validate >= %{gstdevtools_ver}
48 Obsoletes:      gstreamer-gnonlin < 1.6.0
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 # must be consistent with python-pygobject3.spec because of "..overrides" and "..importer" imports
52 %define         py3_gi_overridesdir     %{py3_sitedir}/gi/overrides
53
54 %description
55 GStreamer Editing Services is a high-level library for facilitating
56 the creation of audio/video non-linear editors.
57
58 %description -l pl.UTF-8
59 GStreamer Editing Services to wysokopoziomowa biblioteka ułatwiająca
60 tworzenie nieliniowych edytorów audio/video.
61
62 %package devel
63 Summary:        Header files for GStreamer Editing Services library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GStreamer Editing Services
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       glib2-devel >= 1:2.62.0
68 Requires:       gstreamer-devel >= %{gst_ver}
69 Requires:       gstreamer-plugins-base-devel >= %{gstpb_ver}
70
71 %description devel
72 Header files for GStreamer Editing Services library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki GStreamer Editing Services.
76
77 %package static
78 Summary:        Static GStreamer Editing Services library
79 Summary(pl.UTF-8):      Statyczba biblioteka GStreamer Editing Services
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static GStreamer Editing Services library.
85
86 %description static -l pl.UTF-8
87 Statyczba biblioteka GStreamer Editing Services.
88
89 %package apidocs
90 Summary:        API documentation for GStreamer Editing Services library
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki GStreamer Editing Services
92 Group:          Documentation
93 Obsoletes:      gstreamer-gnonlin-apidocs < 1.6.0
94 BuildArch:      noarch
95
96 %description apidocs
97 API documentation for GStreamer Editing Services library.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API biblioteki GStreamer Editing Services.
101
102 %package -n python3-gstreamer-editing-services
103 Summary:        Python GI binding for GStreamer Editing Services
104 Summary(pl.UTF-8):      Wiązanie Pythona GI do usług GStreamer Editing Services
105 Group:          Libraries/Python
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       python3-pygobject3 >= 3.0
108 Obsoletes:      python-gstreamer-editing-services < 1.18
109
110 %description -n python3-gstreamer-editing-services
111 Python GI binding for GStreamer Editing Services.
112
113 %description -n python3-gstreamer-editing-services -l pl.UTF-8
114 Wiązanie Pythona GI do usług GStreamer Editing Services.
115
116 %package -n bash-completion-gstreamer-editing-services
117 Summary:        Bash completion for GStreamer Editing Services utilities
118 Summary(pl.UTF-8):      Bashowe uzupełnianie paramterów narzędzi GStreamer Editing Services
119 Group:          Applications/Shells
120 Requires:       %{name} = %{version}-%{release}
121 Requires:       bash-completion >= 1:2.0
122 BuildArch:      noarch
123
124 %description -n bash-completion-gstreamer-editing-services
125 Bash completion for GStreamer Editing Services utilities (ges-launch).
126
127 %description -n bash-completion-gstreamer-editing-services -l pl.UTF-8
128 Bashowe uzupełnianie paramterów narzędzi GStreamer Editing Services
129 (ges-launch).
130
131 %prep
132 %setup -q -n gst-editing-services-%{version}
133
134 %build
135 %meson build \
136         %{!?with_apidocs:-Ddoc=false} \
137         -Dpygi-overrides-dir=%{py3_sitedir}/gi/overrides
138
139 %ninja_build -C build
140
141 %if %{with apidocs}
142 cd build/docs
143 for component in ges gst-editing-services nle ; do
144         LC_ALL=C.UTF-8 hotdoc run --conf-file ${component}-doc.json
145 done
146 %endif
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %ninja_install -C build
152
153 %if %{with static_libs}
154 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgst*.a
155 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/pkgconfig
156 %endif
157
158 %if %{with python3}
159 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
160 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
161 %endif
162
163 %if %{with apidocs}
164 install -d $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
165 cp -pr build/docs/{ges,gst-editing-services,nle}-doc $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
166 %endif
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc AUTHORS ChangeLog NEWS README RELEASE
177 %attr(755,root,root) %{_bindir}/ges-launch-1.0
178 %attr(755,root,root) %{_libdir}/libges-1.0.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libges-1.0.so.0
180 %{_libdir}/girepository-1.0/GES-1.0.typelib
181 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstges.so
182 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstnle.so
183 %if %{with python3}
184 %{_libdir}/gst-validate-launcher/python/launcher/apps/geslaunch.py*
185 %endif
186 %{_datadir}/gstreamer-1.0/validate/scenarios/ges-edit-clip-while-paused.scenario
187 %{_mandir}/man1/ges-launch-1.0.1*
188
189 %files devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libges-1.0.so
192 %{_includedir}/gstreamer-1.0/ges
193 %{_datadir}/gir-1.0/GES-1.0.gir
194 %{_pkgconfigdir}/gst-editing-services-1.0.pc
195
196 %if %{with static_libs}
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/libges-1.0.a
200 %endif
201
202 %if %{with apidocs}
203 %files apidocs
204 %defattr(644,root,root,755)
205 %{_docdir}/gstreamer-%{gstmver}/ges-doc
206 %{_docdir}/gstreamer-%{gstmver}/gst-editing-services-doc
207 %{_docdir}/gstreamer-%{gstmver}/nle-doc
208 %endif
209
210 %if %{with python3}
211 %files -n python3-gstreamer-editing-services
212 %defattr(644,root,root,755)
213 %{py3_gi_overridesdir}/GES.py
214 %{py3_gi_overridesdir}/__pycache__/GES.cpython-*.py[co]
215 %endif
216
217 %files -n bash-completion-gstreamer-editing-services
218 %defattr(644,root,root,755)
219 %{bash_compdir}/ges-launch-1.0
This page took 0.165006 seconds and 2 git commands to generate.