]> git.pld-linux.org Git - packages/gstreamer-devtools.git/blob - gstreamer-devtools.spec
- updated to 1.22.6
[packages/gstreamer-devtools.git] / gstreamer-devtools.spec
1 # TODO: package debug-viewer?
2 #
3 # Conditional build:
4 %bcond_without  apidocs # API documentation
5
6 %define         gstmver         1.0
7 %define         gst_ver         1.22.0
8 %define         gstpb_ver       1.22.0
9 %define         gstrtsp_ver     %{gst_ver}
10 Summary:        GStreamer development and validation tools
11 Summary(pl.UTF-8):      Narzędzia programistyczne i sprawdzające do GStreamera
12 Name:           gstreamer-devtools
13 Version:        1.22.6
14 Release:        1
15 License:        LGPL v2.1+
16 Group:          Libraries
17 Source0:        https://gstreamer.freedesktop.org/src/gst-devtools/gst-devtools-%{version}.tar.xz
18 # Source0-md5:  8b24d2872dcf261bdc5a3c86408d6578
19 URL:            https://gstreamer.freedesktop.org/
20 BuildRequires:  cairo-devel
21 BuildRequires:  gettext-devel >= 0.17
22 BuildRequires:  glib2-devel >= 1:2.62.0
23 BuildRequires:  gobject-introspection-devel >= 0.6.3
24 BuildRequires:  gstreamer-devel >= %{gst_ver}
25 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
26 BuildRequires:  gstreamer-rtsp-server-devel >= %{gstrtsp_ver}
27 BuildRequires:  gtk+3-devel >= 3.0
28 %{?with_apidocs:BuildRequires:  hotdoc}
29 BuildRequires:  json-glib-devel >= 1.0
30 BuildRequires:  meson >= 0.62
31 BuildRequires:  ninja >= 1.5
32 BuildRequires:  pkgconfig >= 1:0.9.0
33 BuildRequires:  python3 >= 1:3.4
34 BuildRequires:  rpm-build >= 4.6
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 GStreamer development and validation tools including GstValidate, a
42 testing framework aiming at providing GStreamer developers tools that
43 check the GstElements they write behave the way they are supposed to.
44
45 %description -l pl.UTF-8
46 Narzędzia programistyczne i sprawdzające do GStreamera, w tym
47 GstValidate, szkielet testowy, którego celem jest zapewnienie
48 programistom narzędzi sprawdzających, czy obiekty GstElement zachowują
49 się w pożądany sposób.
50
51 %package apidocs
52 Summary:        API documentation for GstValidate library
53 Summary(pl.UTF-8):      Dokumentacja API biblioteki GstValidate
54 Group:          Documentation
55 Obsoletes:      gstreamer-validate-apidocs < 1.18
56 BuildArch:      noarch
57
58 %description apidocs
59 API documentation for GstValidate library.
60
61 %description apidocs -l pl.UTF-8
62 Dokumentacja API biblioteki GstValidate.
63
64 %package -n gstreamer-validate
65 Summary:        GstValidate - suite of tools to run GStreamer integration tests
66 Summary(pl.UTF-8):      GstValidate - zestaw narzędzi do uruchamiania testów integracyjnych GStreamera
67 Group:          Libraries
68 Requires:       glib2 >= 1:2.62.0
69 Requires:       gstreamer >= %{gst_ver}
70 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
71 Requires:       gstreamer-rtsp-server >= %{gstrtsp_ver}
72 Requires:       json-glib >= 1.0
73 Requires:       python3-modules >= 1:3.4
74
75 %description -n gstreamer-validate
76 The goal of GstValidate is to be able to detect when elements are not
77 behaving as expected and report it to the user so he knows how things
78 are supposed to work inside a GstPipeline. In the end, fixing issues
79 found by the tool will ensure that all elements behave all together in
80 the expected way.
81
82 %description -n gstreamer-validate -l pl.UTF-8
83 Celem GstValidate jest umożliwienie wykrycia sytuacji, kiedy elementy
84 nie zachowują się w sposób oczekiwany i zgłaszanie tego faktu
85 użytkownikowi tak, aby wiedział, jak powinny działać elementy wewnątrz
86 GstPipeline. W efekcie, poprawienie problemów wykrytych przez to
87 narzędzie zapewni, że wszystkie elementy razem będą się zachowywały w
88 sposób zgodny z oczekiwaniami.
89
90 %package -n gstreamer-validate-devel
91 Summary:        Header files for GstValidate library
92 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GstValidate
93 Group:          Development/Libraries
94 Requires:       glib2-devel >= 1:2.62.0
95 Requires:       gstreamer-devel >= %{gst_ver}
96 Requires:       gstreamer-plugins-base-devel >= %{gstpb_ver}
97 Requires:       gstreamer-validate = %{version}-%{release}
98
99 %description -n gstreamer-validate-devel
100 Header files for GstValidate library.
101
102 %description -n gstreamer-validate-devel -l pl.UTF-8
103 Pliki nagłówkowe biblioteki GstValidate.
104
105 %prep
106 %setup -q -n gst-devtools-%{version}
107
108 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' validate/tools/gst-validate-launcher.in
109
110 %build
111 %meson build \
112         --default-library=shared \
113         %{!?with_apidocs:-Ddoc=false}
114
115 %ninja_build -C build
116
117 %if %{with apidocs}
118 cd build/docs
119 LC_ALL=C.UTF-8 hotdoc run --conf-file gst-devtools-doc.json
120 %endif
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %ninja_install -C build
126
127 %if %{with apidocs}
128 install -d $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
129 cp -pr build/docs/gst-devtools-doc $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
130 %endif
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -n gstreamer-validate -p /sbin/ldconfig
136 %postun -n gstreamer-validate -p /sbin/ldconfig
137
138 %if %{with apidocs}
139 %files apidocs
140 %defattr(644,root,root,755)
141 %{_docdir}/gstreamer-%{gstmver}/gst-devtools-doc
142 %endif
143
144 %files -n gstreamer-validate
145 %defattr(644,root,root,755)
146 %doc ChangeLog NEWS RELEASE validate/README
147 %attr(755,root,root) %{_bindir}/gst-validate-1.0
148 %attr(755,root,root) %{_bindir}/gst-validate-images-check-1.0
149 %attr(755,root,root) %{_bindir}/gst-validate-launcher
150 %attr(755,root,root) %{_bindir}/gst-validate-media-check-1.0
151 %attr(755,root,root) %{_bindir}/gst-validate-rtsp-server-1.0
152 %attr(755,root,root) %{_bindir}/gst-validate-transcoding-1.0
153 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-1.0.so.0
155 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-default-overrides-1.0.so.0
157 %{_libdir}/girepository-1.0/GstValidate-1.0.typelib
158 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstvalidatetracer.so
159 %dir %{_libdir}/gstreamer-1.0/validate
160 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatefaultinjection.so
161 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategapplication.so
162 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategtk.so
163 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatessim.so
164 %{_libdir}/gst-validate-launcher
165 %dir %{_datadir}/gstreamer-1.0
166 %{_datadir}/gstreamer-1.0/validate
167
168 %files -n gstreamer-validate-devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so
171 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so
172 %{_includedir}/gstreamer-1.0/gst/validate
173 %{_pkgconfigdir}/gstreamer-validate-1.0.pc
174 %{_datadir}/gir-1.0/GstValidate-1.0.gir
This page took 0.085522 seconds and 4 git commands to generate.