]> git.pld-linux.org Git - packages/gstreamer-devtools.git/blob - gstreamer-devtools.spec
- based on gstreamer-validate.spec, updated to 1.18.5 (uses meson+hotdoc now)
[packages/gstreamer-devtools.git] / gstreamer-devtools.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 %define         gst_ver         1.18.5
6 %define         gstpb_ver       1.18.5
7 %define         gstrtsp_ver     %{gst_ver}
8 Summary:        GStreamer development and validation tools
9 Summary(pl.UTF-8):      Narzędzia programistyczne i sprawdzające do GStreamera
10 Name:           gstreamer-devtools
11 Version:        1.18.5
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          Libraries
15 Source0:        https://gstreamer.freedesktop.org/src/gst-devtools/gst-devtools-%{version}.tar.xz
16 # Source0-md5:  12656dc06805c4de8e3ee48d80545785
17 URL:            https://gstreamer.freedesktop.org/
18 BuildRequires:  cairo-devel
19 BuildRequires:  gettext-devel >= 0.17
20 BuildRequires:  glib2-devel >= 1:2.44.0
21 BuildRequires:  gobject-introspection-devel >= 0.6.3
22 BuildRequires:  gstreamer-devel >= %{gst_ver}
23 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
24 BuildRequires:  gstreamer-rtsp-server-devel >= %{gstrtsp_ver}
25 BuildRequires:  gtk+3-devel >= 3.0
26 %{?with_apidocs:BuildRequires:  hotdoc}
27 BuildRequires:  json-glib-devel >= 1.0
28 BuildRequires:  meson >= 0.48
29 BuildRequires:  ninja >= 1.5
30 BuildRequires:  pkgconfig >= 1:0.9.0
31 BuildRequires:  python3 >= 1:3.4
32 BuildRequires:  rpm-build >= 4.6
33 BuildRequires:  sed >= 4.0
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GStreamer development and validation tools including GstValidate, a
40 testing framework aiming at providing GStreamer developers tools that
41 check the GstElements they write behave the way they are supposed to.
42
43 %description -l pl.UTF-8
44 Narzędzia programistyczne i sprawdzające do GStreamera, w tym
45 GstValidate, szkielet testowy, którego celem jest zapewnienie
46 programistom narzędzi sprawdzających, czy obiekty GstElement zachowują
47 się w pożądany sposób.
48
49 %package apidocs
50 Summary:        API documentation for GstValidate library
51 Summary(pl.UTF-8):      Dokumentacja API biblioteki GstValidate
52 Group:          Documentation
53 Obsoletes:      gstreamer-validate-apidocs < 1.18
54 BuildArch:      noarch
55
56 %description apidocs
57 API documentation for GstValidate library.
58
59 %description apidocs -l pl.UTF-8
60 Dokumentacja API biblioteki GstValidate.
61
62 %package -n gstreamer-validate
63 Summary:        GstValidate - suite of tools to run GStreamer integration tests
64 Summary(pl.UTF-8):      GstValidate - zestaw narzędzi do uruchamiania testów integracyjnych GStreamera
65 Group:          Libraries
66 Requires:       glib2 >= 1:2.44.0
67 Requires:       gstreamer >= %{gst_ver}
68 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
69 Requires:       gstreamer-rtsp-server >= %{gstrtsp_ver}
70 Requires:       json-glib >= 1.0
71 Requires:       python3-modules >= 1:3.4
72
73 %description -n gstreamer-validate
74 The goal of GstValidate is to be able to detect when elements are not
75 behaving as expected and report it to the user so he knows how things
76 are supposed to work inside a GstPipeline. In the end, fixing issues
77 found by the tool will ensure that all elements behave all together in
78 the expected way.
79
80 %description -n gstreamer-validate -l pl.UTF-8
81 Celem GstValidate jest umożliwienie wykrycia sytuacji, kiedy elementy
82 nie zachowują się w sposób oczekiwany i zgłaszanie tego faktu
83 użytkownikowi tak, aby wiedział, jak powinny działać elementy wewnątrz
84 GstPipeline. W efekcie, poprawienie problemów wykrytych przez to
85 narzędzie zapewni, że wszystkie elementy razem będą się zachowywały w
86 sposób zgodny z oczekiwaniami.
87
88 %package -n gstreamer-validate-devel
89 Summary:        Header files for GstValidate library
90 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GstValidate
91 Group:          Development/Libraries
92 Requires:       glib2-devel >= 1:2.44.0
93 Requires:       gstreamer-devel >= %{gst_ver}
94 Requires:       gstreamer-plugins-base-devel >= %{gstpb_ver}
95 Requires:       gstreamer-validate = %{version}-%{release}
96
97 %description -n gstreamer-validate-devel
98 Header files for GstValidate library.
99
100 %description -n gstreamer-validate-devel -l pl.UTF-8
101 Pliki nagłówkowe biblioteki GstValidate.
102
103 %prep
104 %setup -q -n gst-devtools-%{version}
105
106 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' validate/tools/gst-validate-launcher.in
107
108 %build
109 %meson build \
110         --default-library=shared \
111         %{!?with_apidocs:-Ddoc=false}
112
113 %ninja_build -C build
114
115 %if %{with apidocs}
116 cd build/docs
117 LC_ALL=C.UTF-8 hotdoc run --conf-file gst-devtools-doc.json
118 %endif
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %ninja_install -C build
124
125 %if %{with apidocs}
126 install -d $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
127 cp -pr build/docs/gst-devtools-doc $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
128 %endif
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -n gstreamer-validate -p /sbin/ldconfig
134 %postun -n gstreamer-validate -p /sbin/ldconfig
135
136 %if %{with apidocs}
137 %files apidocs
138 %defattr(644,root,root,755)
139 %{_docdir}/gstreamer-%{gstmver}/gst-devtools-doc
140 %endif
141
142 %files -n gstreamer-validate
143 %defattr(644,root,root,755)
144 %doc ChangeLog NEWS RELEASE validate/README
145 %attr(755,root,root) %{_bindir}/gst-validate-1.0
146 %attr(755,root,root) %{_bindir}/gst-validate-images-check-1.0
147 %attr(755,root,root) %{_bindir}/gst-validate-launcher
148 %attr(755,root,root) %{_bindir}/gst-validate-media-check-1.0
149 %attr(755,root,root) %{_bindir}/gst-validate-rtsp-server-1.0
150 %attr(755,root,root) %{_bindir}/gst-validate-transcoding-1.0
151 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-1.0.so.0
153 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libgstvalidate-default-overrides-1.0.so.0
155 %{_libdir}/girepository-1.0/GstValidate-1.0.typelib
156 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstvalidatetracer.so
157 %dir %{_libdir}/gstreamer-1.0/validate
158 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatefaultinjection.so
159 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategapplication.so
160 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidategtk.so
161 %attr(755,root,root) %{_libdir}/gstreamer-1.0/validate/libgstvalidatessim.so
162 %{_libdir}/gst-validate-launcher
163 %dir %{_datadir}/gstreamer-1.0
164 %{_datadir}/gstreamer-1.0/validate
165
166 %files -n gstreamer-validate-devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libgstvalidate-1.0.so
169 %attr(755,root,root) %{_libdir}/libgstvalidate-default-overrides-1.0.so
170 %{_includedir}/gstreamer-1.0/gst/validate
171 %{_pkgconfigdir}/gst-validate-1.0.pc
172 %{_datadir}/gir-1.0/GstValidate-1.0.gir
This page took 0.053623 seconds and 4 git commands to generate.