]> git.pld-linux.org Git - packages/gssntlmssp.git/blob - gssntlmssp.spec
4efb6e5d084017f71d2cbf501178b1dafff25be4
[packages/gssntlmssp.git] / gssntlmssp.spec
1 # TODO:
2 # - implement mech.d in heimdal (e.g. by cat /etc/gss/mech.d/*.conf > /etc/gss/mech in %post scripts)
3 # - apidocs (doxygen config missing)
4 #
5 # Conditional build:
6 %bcond_with     apidocs # API documentation (doxygen config missing in sources)
7 #
8 Summary:        GSSAPI NTLMSSP mechanism
9 Summary(pl.UTF-8):      Mechanizm GSSAPI NTLMSSP
10 Name:           gssntlmssp
11 Version:        0.7.0
12 Release:        1
13 License:        LGPL v3+
14 Group:          Libraries
15 # also https://github.com/simo5/gss-ntlmssp but no releases there
16 Source0:        http://releases.pagure.org/gssntlmssp/%{name}-%{version}.tar.gz
17 # Source0-md5:  5f890092ecf8a566b7556fca2b60d6cc
18 Patch0:         %{name}-heimdal.patch
19 Patch1:         %{name}-openssl1.1.patch
20 URL:            https://pagure.io/gssntlmssp
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.11
23 BuildRequires:  docbook-style-xsl-nons
24 BuildRequires:  doxygen
25 BuildRequires:  gettext-tools
26 BuildRequires:  heimdal-devel
27 # pkgconfig(wbclient)
28 BuildRequires:  libsmbclient-devel
29 BuildRequires:  libtool >= 2:2
30 BuildRequires:  libunistring-devel
31 BuildRequires:  libxslt-progs
32 BuildRequires:  openssl-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  po4a
35 BuildRequires:  zlib-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A GSSAPI Mechanism that implements NTLMSSP.
40
41 %description -l pl.UTF-8
42 Mechanizm GSSAPI implementujący NTLMSSP.
43
44 %package devel
45 Summary:        Header file for GSSAPI NTLMSSP extensions
46 Summary(pl.UTF-8):      Plik nagłówkowy rozszerzeń GSSAPI NTLMSSP
47 Group:          Development/Libraries
48 Requires:       heimdal-devel
49
50 %description devel
51 Header file with definition for custom GSSAPI extensions for NTLMSSP.
52
53 %description devel -l pl.UTF-8
54 Plik nagłówkowy z definicjami rozszerzeń GSSAPI dla NTLMSSP.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p1
60
61 %build
62 %{__libtoolize}
63 %{__aclocal} -I m4 -I .
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67 %configure \
68         --disable-silent-rules
69 %{__make}
70
71 %if %{with apidocs}
72 %{__make} docs
73 %endif
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 # loadable module
82 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gssntlmssp/*.la
83
84 install -d $RPM_BUILD_ROOT/etc/gss/mech.d
85 cp -p examples/mech.ntlmssp $RPM_BUILD_ROOT/etc/gss/mech.d/ntlmssp.conf
86
87 %find_lang %{name}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %if 0
93 # TODO: needs support in heimdal.spec
94 # (/etc/gss/mech as ghost, move current content with appropriate comment to /etc/gss/mech.d/00_init.conf)
95 %post
96 umask 022
97 cat /etc/gss/mech.d/*.conf >$RPM_BUILD_ROOT/etc/gss/mech
98
99 %postun
100 umask 022
101 if [ "$1" = "0" ]; then
102         cat /etc/gss/mech.d/*.conf >$RPM_BUILD_ROOT/etc/gss/mech
103 fi
104 %endif
105
106 %files -f %{name}.lang
107 %defattr(644,root,root,755)
108 %dir %{_libdir}/gssntlmssp
109 %attr(755,root,root) %{_libdir}/gssntlmssp/gssntlmssp.so
110 /etc/gss/mech.d/ntlmssp.conf
111 %{_mandir}/man8/gssntlmssp.8*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_includedir}/gssapi/gssapi_ntlmssp.h
This page took 0.067406 seconds and 2 git commands to generate.