]> git.pld-linux.org Git - packages/gssdp.git/blob - gssdp.spec
noarch vala subpackage
[packages/gssdp.git] / gssdp.spec
1 #
2 # Conditional build:
3 %bcond_without  vala    # Vala bindings
4
5 Summary:        GObject-based SSDP (Simple Service Discovery Protocol) library
6 Summary(pl.UTF-8):      Biblioteka SSDP (Simple Service Discovery Protocol) oparta na GObject
7 Name:           gssdp
8 # note: 0.14.x is stable, 0.15.x unstable
9 Version:        0.14.14
10 Release:        2
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gssdp/0.14/%{name}-%{version}.tar.xz
14 # Source0-md5:  ca87b922225b4443dfa459389fa316fe
15 URL:            http://gupnp.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  glib2-devel >= 1:2.32
20 BuildRequires:  gobject-introspection-devel >= 1.36.0
21 BuildRequires:  gtk+3-devel >= 3.0
22 BuildRequires:  gtk-doc >= 1.14
23 BuildRequires:  libsoup-devel >= 2.26.1
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  pkgconfig
26 BuildRequires:  tar >= 1:1.22
27 %{?with_vala:BuildRequires:     vala >= 2:0.20}
28 BuildRequires:  xz
29 Requires:       glib2 >= 1:2.32
30 Requires:       gtk+3 >= 3.0
31 Requires:       libsoup >= 2.26.1
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 GSSDP is a GObject-based API that implements resource discovery and
36 announcement over SSDP (Simple Service Discovery Protocol).
37
38 %description -l pl.UTF-8
39 GSSDP to oparte na bibliotece GObject API implementujące wykrywanie i
40 rozgłaszanie zasobów przy użyciu protokołu SSDP (Simple Service
41 Discovery Protocol).
42
43 %package devel
44 Summary:        Header files for GSSDP
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GSSDP
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.32
49 Requires:       libsoup-devel >= 2.26.1
50
51 %description devel
52 This package contains header files for GSSDP library.
53
54 %description devel -l pl.UTF-8
55 Ten pakiet zawiera pliki nagłówkowe biblioteki GSSDP.
56
57 %package static
58 Summary:        Static GSSDP library
59 Summary(pl.UTF-8):      Statyczna biblioteka GSSDP
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static GSSDP library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka GSSDP.
68
69 %package apidocs
70 Summary:        GSSDP API documentation
71 Summary(pl.UTF-8):      Dokumentacja API GSSDP
72 Group:          Documentation
73 Requires:       gtk-doc-common
74
75 %description apidocs
76 GSSDP API documentation.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API GSSDP.
80
81 %package -n vala-gssdp
82 Summary:        Vala binding for GSSDP library
83 Summary(pl.UTF-8):      Wiązanie języka Vala do biblioteki GSSDP
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       vala >= 2:0.20
87 %if "%{_rpmversion}" >= "5"
88 BuildArch:      noarch
89 %endif
90
91 %description -n vala-gssdp
92 Vala binding for GSSDP library.
93
94 %description -n vala-gssdp -l pl.UTF-8
95 Wiązanie języka Vala do biblioteki GSSDP.
96
97 %prep
98 %setup -q
99
100 %build
101 %{__gtkdocize}
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --disable-silent-rules \
109         --enable-gtk-doc \
110         --with-html-dir=%{_gtkdocdir}
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS NEWS README
131 %attr(755,root,root) %{_bindir}/gssdp-device-sniffer
132 %attr(755,root,root) %{_libdir}/libgssdp-1.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libgssdp-1.0.so.3
134 %{_libdir}/girepository-1.0/GSSDP-1.0.typelib
135 %{_datadir}/gssdp
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libgssdp-1.0.so
140 %{_datadir}/gir-1.0/GSSDP-1.0.gir
141 %{_includedir}/gssdp-1.0
142 %{_pkgconfigdir}/gssdp-1.0.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libgssdp-1.0.a
147
148 %files apidocs
149 %defattr(644,root,root,755)
150 %{_gtkdocdir}/gssdp
151
152 %if %{with vala}
153 %files -n vala-gssdp
154 %defattr(644,root,root,755)
155 %{_datadir}/vala/vapi/gssdp-1.0.deps
156 %{_datadir}/vala/vapi/gssdp-1.0.vapi
157 %endif
This page took 0.054654 seconds and 4 git commands to generate.