]> git.pld-linux.org Git - packages/gssdp.git/blob - gssdp.spec
- updated to 1.2.3
[packages/gssdp.git] / gssdp.spec
1 #
2 # Conditional build:
3 %bcond_without  vala    # Vala bindings
4
5 Summary:        GObject-based SSDP (Simple Service Discovery Protocol) library
6 Summary(pl.UTF-8):      Biblioteka SSDP (Simple Service Discovery Protocol) oparta na GObject
7 Name:           gssdp
8 # note: 1.2.x is stable, 1.3.x unstable
9 Version:        1.2.3
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gssdp/1.2/%{name}-%{version}.tar.xz
14 # Source0-md5:  ef3295a965c06ce0f683522391fbb910
15 URL:            https://wiki.gnome.org/Projects/GUPnP
16 BuildRequires:  docbook-dtd412-xml
17 BuildRequires:  glib2-devel >= 1:2.54
18 BuildRequires:  gobject-introspection-devel >= 1.36.0
19 BuildRequires:  gtk+3-devel >= 3.12
20 BuildRequires:  gtk-doc >= 1.14
21 BuildRequires:  libsoup-devel >= 2.26.1
22 BuildRequires:  meson
23 BuildRequires:  ninja >= 1.5
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpmbuild(macros) >= 1.736
26 BuildRequires:  tar >= 1:1.22
27 %{?with_vala:BuildRequires:     vala >= 2:0.20}
28 BuildRequires:  xz
29 Requires:       glib2 >= 1:2.54
30 Requires:       libsoup >= 2.26.1
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 GSSDP is a GObject-based API that implements resource discovery and
35 announcement over SSDP (Simple Service Discovery Protocol).
36
37 %description -l pl.UTF-8
38 GSSDP to oparte na bibliotece GObject API implementujące wykrywanie i
39 rozgłaszanie zasobów przy użyciu protokołu SSDP (Simple Service
40 Discovery Protocol).
41
42 %package sniffer
43 Summary:        Graphical SSDP sniffer
44 Summary(pl.UTF-8):      Graficzny sniffer SSDP
45 Group:          X11/Applications/Networking
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       gtk+3 >= 3.12
48
49 %description sniffer
50 Graphical SSDP sniffer.
51
52 %description sniffer -l pl.UTF-8
53 Graficzny sniffer SSDP.
54
55 %package devel
56 Summary:        Header files for GSSDP
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GSSDP
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       glib2-devel >= 1:2.54
61 Requires:       libsoup-devel >= 2.26.1
62
63 %description devel
64 This package contains header files for GSSDP library.
65
66 %description devel -l pl.UTF-8
67 Ten pakiet zawiera pliki nagłówkowe biblioteki GSSDP.
68
69 %package static
70 Summary:        Static GSSDP library
71 Summary(pl.UTF-8):      Statyczna biblioteka GSSDP
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static GSSDP library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka GSSDP.
80
81 %package apidocs
82 Summary:        GSSDP API documentation
83 Summary(pl.UTF-8):      Dokumentacja API GSSDP
84 Group:          Documentation
85 Requires:       gtk-doc-common
86 %if "%{_rpmversion}" >= "5"
87 BuildArch:      noarch
88 %endif
89
90 %description apidocs
91 GSSDP API documentation.
92
93 %description apidocs -l pl.UTF-8
94 Dokumentacja API GSSDP.
95
96 %package -n vala-gssdp
97 Summary:        Vala binding for GSSDP library
98 Summary(pl.UTF-8):      Wiązanie języka Vala do biblioteki GSSDP
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 Requires:       vala >= 2:0.20
102 %if "%{_rpmversion}" >= "5"
103 BuildArch:      noarch
104 %endif
105
106 %description -n vala-gssdp
107 Vala binding for GSSDP library.
108
109 %description -n vala-gssdp -l pl.UTF-8
110 Wiązanie języka Vala do biblioteki GSSDP.
111
112 %prep
113 %setup -q
114
115 %build
116 %meson build \
117         -Dgtk_doc=true
118
119 %ninja_build -C build
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %ninja_install -C build
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS NEWS README
135 %attr(755,root,root) %{_libdir}/libgssdp-1.2.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libgssdp-1.2.so.0
137 %{_libdir}/girepository-1.0/GSSDP-1.2.typelib
138
139 %files sniffer
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/gssdp-device-sniffer
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libgssdp-1.2.so
146 %{_datadir}/gir-1.0/GSSDP-1.2.gir
147 %{_includedir}/gssdp-1.2
148 %{_pkgconfigdir}/gssdp-1.2.pc
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libgssdp-1.2.a
153
154 %files apidocs
155 %defattr(644,root,root,755)
156 %{_gtkdocdir}/gssdp
157
158 %if %{with vala}
159 %files -n vala-gssdp
160 %defattr(644,root,root,755)
161 %{_datadir}/vala/vapi/gssdp-1.2.deps
162 %{_datadir}/vala/vapi/gssdp-1.2.vapi
163 %endif
This page took 0.050357 seconds and 3 git commands to generate.