]> git.pld-linux.org Git - packages/gssdp.git/blob - gssdp.spec
- post gtk-doc cleanup
[packages/gssdp.git] / gssdp.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # gi-docgen based API documentation
4 %bcond_without  vala    # Vala bindings
5 %bcond_with     sniffer # sniffer package (GUI)
6
7 Summary:        GObject-based SSDP (Simple Service Discovery Protocol) library
8 Summary(pl.UTF-8):      Biblioteka SSDP (Simple Service Discovery Protocol) oparta na GObject
9 Name:           gssdp
10 # note: 1.4.x is stable libsoup 2.x based version; for libsoup3 based 1.6+ see gssdp1.6.spec
11 Version:        1.4.1
12 Release:        2
13 License:        LGPL v2+
14 Group:          Libraries
15 Source0:        https://download.gnome.org/sources/gssdp/1.4/%{name}-%{version}.tar.xz
16 # Source0-md5:  468514c096b6768a040e382de51fe85d
17 URL:            https://wiki.gnome.org/Projects/GUPnP
18 BuildRequires:  docbook-dtd412-xml
19 %{?with_apidocs:BuildRequires:  gi-docgen >= 2021.1}
20 BuildRequires:  glib2-devel >= 1:2.54
21 BuildRequires:  gobject-introspection-devel >= 1.36.0
22 %{?with_sniffer:BuildRequires:  gtk4-devel >= 4}
23 BuildRequires:  libsoup-devel >= 2.26.1
24 BuildRequires:  meson >= 0.54.0
25 BuildRequires:  ninja >= 1.5
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  rpmbuild(macros) >= 2.029
29 BuildRequires:  tar >= 1:1.22
30 %{?with_vala:BuildRequires:     vala >= 2:0.20}
31 BuildRequires:  xz
32 Requires:       glib2 >= 1:2.54
33 Requires:       libsoup >= 2.26.1
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 GSSDP is a GObject-based API that implements resource discovery and
38 announcement over SSDP (Simple Service Discovery Protocol).
39
40 %description -l pl.UTF-8
41 GSSDP to oparte na bibliotece GObject API implementujące wykrywanie i
42 rozgłaszanie zasobów przy użyciu protokołu SSDP (Simple Service
43 Discovery Protocol).
44
45 %package sniffer
46 Summary:        Graphical SSDP sniffer
47 Summary(pl.UTF-8):      Graficzny sniffer SSDP
48 Group:          X11/Applications/Networking
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       gtk4 >= 4
51
52 %description sniffer
53 Graphical SSDP sniffer.
54
55 %description sniffer -l pl.UTF-8
56 Graficzny sniffer SSDP.
57
58 %package devel
59 Summary:        Header files for GSSDP
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GSSDP
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       glib2-devel >= 1:2.54
64 Requires:       libsoup-devel >= 2.26.1
65
66 %description devel
67 This package contains header files for GSSDP library.
68
69 %description devel -l pl.UTF-8
70 Ten pakiet zawiera pliki nagłówkowe biblioteki GSSDP.
71
72 %package static
73 Summary:        Static GSSDP library
74 Summary(pl.UTF-8):      Statyczna biblioteka GSSDP
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static GSSDP library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka GSSDP.
83
84 %package apidocs
85 Summary:        GSSDP API documentation
86 Summary(pl.UTF-8):      Dokumentacja API GSSDP
87 Group:          Documentation
88 BuildArch:      noarch
89
90 %description apidocs
91 GSSDP API documentation.
92
93 %description apidocs -l pl.UTF-8
94 Dokumentacja API GSSDP.
95
96 %package -n vala-gssdp
97 Summary:        Vala binding for GSSDP library
98 Summary(pl.UTF-8):      Wiązanie języka Vala do biblioteki GSSDP
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 Requires:       vala >= 2:0.20
102 BuildArch:      noarch
103
104 %description -n vala-gssdp
105 Vala binding for GSSDP library.
106
107 %description -n vala-gssdp -l pl.UTF-8
108 Wiązanie języka Vala do biblioteki GSSDP.
109
110 %prep
111 %setup -q
112
113 %build
114 %meson build \
115         %{?with_apidocs:-Dgtk_doc=true} \
116         %{!?with_sniffer:-Dsniffer=false}
117
118 %ninja_build -C build
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %ninja_install -C build
124
125 %if %{with apidocs}
126 install -d $RPM_BUILD_ROOT%{_gidocdir}
127 %{__mv} $RPM_BUILD_ROOT%{_docdir}/gssdp-1.2 $RPM_BUILD_ROOT%{_gidocdir}
128 %endif
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README.md
139 %attr(755,root,root) %{_libdir}/libgssdp-1.2.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libgssdp-1.2.so.0
141 %{_libdir}/girepository-1.0/GSSDP-1.2.typelib
142
143 %if %{with sniffer}
144 %files sniffer
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/gssdp-device-sniffer
147 %endif
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libgssdp-1.2.so
152 %{_datadir}/gir-1.0/GSSDP-1.2.gir
153 %{_includedir}/gssdp-1.2
154 %{_pkgconfigdir}/gssdp-1.2.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libgssdp-1.2.a
159
160 %if %{with apidocs}
161 %files apidocs
162 %defattr(644,root,root,755)
163 %{_gidocdir}/gssdp-1.2
164 %endif
165
166 %if %{with vala}
167 %files -n vala-gssdp
168 %defattr(644,root,root,755)
169 %{_datadir}/vala/vapi/gssdp-1.2.deps
170 %{_datadir}/vala/vapi/gssdp-1.2.vapi
171 %endif
This page took 0.061689 seconds and 3 git commands to generate.