]> git.pld-linux.org Git - packages/gssdp.git/blob - gssdp.spec
126ca25d3af96a205592a0fbf289e19cca32a9de
[packages/gssdp.git] / gssdp.spec
1 #
2 # Conditional build:
3 %bcond_with     vala    # Vala bindings
4 #
5 Summary:        GObject-based SSDP (Simple Service Discovery Protocol) library
6 Summary(pl.UTF-8):      Biblioteka SSDP (Simple Service Discovery Protocol) oparta na GObject
7 Name:           gssdp
8 # note: 0.12.x is stable, 0.13.x unstable
9 Version:        0.12.2
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gssdp/0.12/%{name}-%{version}.tar.xz
14 # Source0-md5:  7805d3062706bdba4f088ce7e96a9293
15 URL:            http://gupnp.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  glib2-devel >= 1:2.22
20 BuildRequires:  gobject-introspection-devel >= 0.6.7
21 BuildRequires:  gtk+2-devel >= 2:2.12.0
22 BuildRequires:  gtk-doc >= 1.0
23 BuildRequires:  libsoup-devel >= 2.26.1
24 BuildRequires:  libtool >= 2:2.2
25 BuildRequires:  pkgconfig
26 BuildRequires:  tar >= 1:1.22
27 %{?with_vala:BuildRequires:     vala >= 0.17}
28 BuildRequires:  xz
29 Requires:       glib2 >= 1:2.22
30 Requires:       gtk+2 >= 2:2.12.0
31 Requires:       libsoup >= 2.26.1
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 GSSDP is a GObject-based API that implements resource discovery and
36 announcement over SSDP (Simple Service Discovery Protocol).
37
38 %description -l pl.UTF-8
39 GSSDP to oparte na bibliotece GObject API implementujące wykrywanie i
40 rozgłaszanie zasobów przy użyciu protokołu SSDP (Simple Service
41 Discovery Protocol).
42
43 %package devel
44 Summary:        Header files for GSSDP
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GSSDP
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.22
49 Requires:       libsoup-devel >= 2.26.1
50
51 %description devel
52 This package contains header files for GSSDP library.
53
54 %description devel -l pl.UTF-8
55 Ten pakiet zawiera pliki nagłówkowe biblioteki GSSDP.
56
57 %package static
58 Summary:        Static GSSDP library
59 Summary(pl.UTF-8):      Statyczna biblioteka GSSDP
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static GSSDP library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka GSSDP.
68
69 %package apidocs
70 Summary:        GSSDP API documentation
71 Summary(pl.UTF-8):      Dokumentacja API GSSDP
72 Group:          Documentation
73 Requires:       gtk-doc-common
74
75 %description apidocs
76 GSSDP API documentation.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API GSSDP.
80
81 %package -n vala-gssdp
82 Summary:        Vala binding for GSSDP library
83 Summary(pl.UTF-8):      Wiązanie języka Vala do biblioteki GSSDP
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       vala >= 0.14
87
88 %description -n vala-gssdp
89 Vala binding for GSSDP library.
90
91 %description -n vala-gssdp -l pl.UTF-8
92 Wiązanie języka Vala do biblioteki GSSDP.
93
94 %prep
95 %setup -q
96
97 %if %{without vala}
98 echo 'AC_DEFUN([VALA_PROG_VAPIGEN],[VAPIGEN=])' >> acinclude.m4
99 %endif
100
101 %build
102 mkdir m4
103 %{__gtkdocize}
104 %{__libtoolize}
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --disable-silent-rules \
111         --enable-gtk-doc \
112         --with-html-dir=%{_gtkdocdir}
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README
133 %attr(755,root,root) %{_bindir}/gssdp-device-sniffer
134 %attr(755,root,root) %{_libdir}/libgssdp-1.0.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libgssdp-1.0.so.3
136 %{_libdir}/girepository-1.0/GSSDP-1.0.typelib
137 %{_datadir}/gssdp
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libgssdp-1.0.so
142 %{_datadir}/gir-1.0/GSSDP-1.0.gir
143 %{_includedir}/gssdp-1.0
144 %{_pkgconfigdir}/gssdp-1.0.pc
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libgssdp-1.0.a
149
150 %files apidocs
151 %defattr(644,root,root,755)
152 %{_gtkdocdir}/gssdp
153
154 %if %{with vala}
155 %files -n vala-gssdp
156 %defattr(644,root,root,755)
157 %{_datadir}/vala/vapi/gssdp-1.0.deps
158 %{_datadir}/vala/vapi/gssdp-1.0.vapi
159 %endif
This page took 0.04481 seconds and 2 git commands to generate.