]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- unconditional noarch subpackages
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  kerberos5       # GSSAPI mechanism
5 %bcond_with     gss             # GNU GSS as GSSAPI implementation
6 %bcond_without  heimdal         # Heimdal as GSSAPI implementation (default)
7 %bcond_with     krb5            # MIT Kerberos as GSSAPI implementation
8 %bcond_with     shishi          # KERBEROS_V5 mechanism (based on shishi, currently broken)
9 %bcond_without  ntlm            # NTLM mechanism
10 %bcond_without  static_libs     # static library
11
12 %if %{with gss} || %{with krb5}
13 %undefine       with_heimdal
14 %endif
15 %if %{without kerberos5}
16 %undefine       with_gss
17 %undefine       with_heimdal
18 %undefine       with_krb5
19 %endif
20 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
21 Summary(pl.UTF-8):      GNU SASL - implementacja Simple Authentication and Security Layer
22 Name:           gsasl
23 Version:        1.10.0
24 Release:        1
25 License:        LGPL v2.1+ (library), GPL v3+ (gsasl tool)
26 Group:          Libraries
27 Source0:        https://ftp.gnu.org/gnu/gsasl/%{name}-%{version}.tar.gz
28 # Source0-md5:  70918edd489eabceb622945940871348
29 Patch0:         %{name}-info.patch
30 Patch2:         %{name}-link.patch
31 URL:            http://www.gnu.org/software/gsasl/
32 BuildRequires:  autoconf >= 2.64
33 BuildRequires:  automake >= 1:1.13
34 BuildRequires:  docbook-dtd412-xml
35 BuildRequires:  gettext-tools >= 0.19.8
36 BuildRequires:  gnutls-devel >= 3.4
37 %{?with_gss:BuildRequires:      gss-devel >= 1.0.0}
38 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.1}
39 %{?with_heimdal:BuildRequires:  heimdal-devel}
40 %{!?with_apidocs:BuildRequires: help2man}
41 %{?with_krb5:BuildRequires:     krb5-devel}
42 # used by examples/saml20 (noinst only)
43 #BuildRequires: lasso-devel >= 2.2.1
44 BuildRequires:  libgcrypt-devel >= 1.3.0
45 BuildRequires:  libidn-devel >= 0.1.0
46 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
47 BuildRequires:  libtool >= 2:2
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpmbuild(macros) >= 1.752
50 %{?with_shishi:BuildRequires:   shishi-devel}
51 BuildRequires:  texinfo
52 Requires(post,postun):  /sbin/ldconfig
53 Requires:       libgcrypt >= 1.3.0
54 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
55 Obsoletes:      libgsasl
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 GNU SASL is an implementation of the Simple Authentication and
60 Security Layer framework and a few common SASL mechanisms. SASL is
61 used by network servers (e.g., IMAP, SMTP) to request authentication
62 from clients, and in clients to authenticate against servers.
63
64 GNU SASL contains a library (`libgsasl'), a command line utility
65 (`gsasl') to access the library from the shell, and a manual. The
66 library includes support for the SASL framework (with authentication
67 functions and application data privacy and integrity functions) and at
68 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
69 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
70
71 The library is portable because it does not do network communication
72 by itself, but rather leaves it up to the calling application. The
73 library is flexible with regards to the authorization infrastructure
74 used, as it utilizes callbacks into the application to decide whether
75 an user is authorized or not.
76
77 %description -l pl.UTF-8
78 GNU SASL to implementacja szkieletu Simple Authentication and Security
79 Layer (prostej warstwy uwierzytelniania i bezpieczeństwa) oraz kilku
80 popularnych mechanizmów SASL. SASL jest używane przez serwery sieciowe
81 (np. IMAP i SMTP) do żądania uwierzytelnienia od klientów oraz w
82 klientach do uwierzytelniania względem serwerów.
83
84 GNU SASL zawiera bibliotekę (libgsasl), narzędzie działające z linii
85 poleceń (gsasl) pozwalające na korzystanie z biblioteki z poziomu
86 powłoki oraz dokumentację. Biblioteka ma obsługę szkieletu SASL (z
87 funkcjami uwierzytelniającymi oraz zapewniającymi prywatność i
88 spójność danych aplikacji) oraz przynajmniej częściową obsługę
89 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
90 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
91
92 Biblioteka jest przenośna, ponieważ sama nie korzysta z komunikacji
93 sieciowej, pozostawiając to wywołującej ją aplikacji. Biblioteka jest
94 elastyczna ze względu na używaną infrastrukturę uwierzytelniania,
95 ponieważ korzysta z callbacków w aplikacji przy decydowaniu, czy
96 użytkownik jest autoryzowany.
97
98 %package devel
99 Summary:        Header files for GNU SASL library
100 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GNU SASL
101 License:        LGPL v2.1+
102 Group:          Development/Libraries
103 Requires:       %{name} = %{version}-%{release}
104 %if %{with gss}
105 Requires:       gss-devel >= 1.0.0
106 %else
107 %{?with_heimdal:Requires:       heimdal-devel}
108 %endif
109 Requires:       libgcrypt-devel >= 1.3.0
110 Requires:       libidn-devel >= 0.1.0
111 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
112 %{?with_shishi:Requires:        shishi-devel}
113 Obsoletes:      libgsasl-devel
114
115 %description devel
116 Header files for GNU SASL library.
117
118 %description devel -l pl.UTF-8
119 Pliki nagłówkowe biblioteki GNU SASL.
120
121 %package static
122 Summary:        Static GNU SASL library
123 Summary(pl.UTF-8):      Statyczna biblioteka GNU SASL
124 License:        LGPL v2.1+
125 Group:          Development/Libraries
126 Requires:       %{name}-devel = %{version}-%{release}
127 Obsoletes:      libgsasl-static
128
129 %description static
130 Static GNU SASL library.
131
132 %description static -l pl.UTF-8
133 Statyczna biblioteka GNU SASL.
134
135 %package apidocs
136 Summary:        API documentation for GNU SASL library
137 Summary(pl.UTF-8):      Dokumentacja API biblioteki GNU SASL
138 Group:          Documentation
139 Conflicts:      gsasl-devel < 1.8.0-5
140 BuildArch:      noarch
141
142 %description apidocs
143 API documentation for GNU SASL library.
144
145 %description apidocs -l pl.UTF-8
146 Dokumentacja API biblioteki GNU SASL.
147
148 %prep
149 %setup -q
150 %patch0 -p1
151 %patch2 -p1
152
153 %{__rm} po/stamp-po
154 # use system file (from gettext-tools)
155 %{__rm} lib/m4/lib-link.m4
156
157 %build
158 %{__gettextize}
159 %{__libtoolize}
160 %{__aclocal} -I m4
161 %{__autoconf}
162 %{__autoheader}
163 %{__automake}
164 cd lib
165 %{__libtoolize}
166 %{__aclocal} -I m4
167 %{__autoconf}
168 %{__autoheader}
169 %{__automake}
170 cd ..
171 %configure \
172         --disable-silent-rules \
173         %{?with_apidocs:--enable-gtk-doc} \
174         %{!?with_ntlm:--disable-ntlm} \
175         %{!?with_static_libs:--disable-static} \
176         %{?with_shishi:--enable-kerberos_v5} \
177         --with-gssapi-impl=%{?with_gss:gss}%{?with_heimdal:heimdal}%{?with_krb5:mit}%{!?with_kerberos5:no} \
178         --with-html-dir=%{_gtkdocdir} \
179         --with-libgcrypt
180
181 %{__make}
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185
186 %{__make} install \
187         DESTDIR=$RPM_BUILD_ROOT
188
189 # obsoleted by pkg-config
190 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgsasl.la
191
192 # libgsasl for lib, gsasl for app
193 %find_lang %{name} --all-name
194
195 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
196
197 %clean
198 rm -rf $RPM_BUILD_ROOT
199
200 %post
201 /sbin/ldconfig
202 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
203
204 %postun
205 /sbin/ldconfig
206 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
207
208 %files -f %{name}.lang
209 %defattr(644,root,root,755)
210 %doc AUTHORS ChangeLog NEWS README THANKS
211 %attr(755,root,root) %{_bindir}/gsasl
212 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
213 %attr(755,root,root) %ghost %{_libdir}/libgsasl.so.7
214 %{_mandir}/man1/gsasl.1*
215 %{_infodir}/gsasl.info*
216
217 %files devel
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libgsasl.so
220 %{_includedir}/gsasl*.h
221 %{_pkgconfigdir}/libgsasl.pc
222 %{_mandir}/man3/gsasl_*.3*
223
224 %if %{with static_libs}
225 %files static
226 %defattr(644,root,root,755)
227 %{_libdir}/libgsasl.a
228 %endif
229
230 %if %{with apidocs}
231 %files apidocs
232 %defattr(644,root,root,755)
233 %{_gtkdocdir}/gsasl
234 %endif
This page took 0.064407 seconds and 3 git commands to generate.