]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
f4c1234dc36b382184ccd7478a53ebd17fdcb5a3
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664} x32
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} x32 ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664} x32
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} x32 ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 %define         rel     1
43 Summary:        GRand Unified Bootloader
44 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
45 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
46 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
47 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
48 Name:           grub2
49 Version:        2.02
50 Release:        3
51 License:        GPL v2
52 Group:          Base
53 Source0:        ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
54 # Source0-md5:  8a4a2a95aac551fb0fba860ceabfa1d3
55 Source1:        update-grub
56 Source2:        update-grub.8
57 Source3:        grub.sysconfig
58 Source4:        grub-custom.cfg
59 Patch1:         pld-sysconfdir.patch
60 Patch2:         grub-garbage.patch
61 Patch3:         grub-lvmdevice.patch
62 Patch4:         pld-mkconfigdir.patch
63 Patch5:         grub-mkconfig-diagnostics.patch
64 Patch6:         posix.patch
65 Patch7:         %{name}-fonts_path.patch
66 Patch8:         add-vlan-tag-support.patch
67 Patch9:         just-say-linux.patch
68 Patch10:        ignore-kernel-symlinks.patch
69 Patch11:        choose-preferred-initrd.patch
70 Patch12:        %{name}-cfg.patch
71 Patch13:        efi-net-fix.patch
72 Patch14:        blscfg.patch
73 # https://git.archlinux.org/svntogit/packages.git/plain/trunk/0002-intel-ucode.patch?h=packages/grub
74 Patch15:        intel-ucode.patch
75 Patch16:        xfs.patch
76 URL:            http://www.gnu.org/software/grub/
77 BuildRequires:  autoconf >= 2.53
78 BuildRequires:  automake >= 1:1.11.1-1
79 BuildRequires:  bison
80 BuildRequires:  device-mapper-devel
81 BuildRequires:  flex >= 2.5.35
82 BuildRequires:  fonts-TTF-DejaVu
83 BuildRequires:  freetype-devel >= 2
84 BuildRequires:  gawk
85 BuildRequires:  gcc >= 5:3.4
86 BuildRequires:  gettext-tools
87 BuildRequires:  glibc-localedb-all
88 BuildRequires:  glibc-static
89 BuildRequires:  help2man
90 BuildRequires:  libfuse-devel
91 BuildRequires:  libtool
92 BuildRequires:  ncurses-devel
93 BuildRequires:  python
94 BuildRequires:  python-modules
95 BuildRequires:  rpm >= 4.4.9-56
96 BuildRequires:  rpmbuild(macros) >= 1.213
97 BuildRequires:  sed >= 4.0
98 BuildRequires:  tar >= 1:1.22
99 BuildRequires:  texinfo
100 BuildRequires:  xz
101 BuildRequires:  xz-devel
102 %ifarch %{x8664}
103 BuildRequires:  /usr/lib/libc.so
104 %if "%{pld_release}" == "ac"
105 BuildRequires:  libgcc32
106 %else
107 BuildRequires:  gcc-multilib-32
108 %endif
109 %endif
110 Requires:       %{name}-platform = %{version}-%{release}
111 Requires:       pld-release
112 Requires:       which
113 %ifarch %{ix86} %{x8664}
114 Suggests:       %{name}-platform-pc
115 %endif
116 Suggests:       cdrkit-mkisofs
117 Suggests:       os-prober
118 Provides:       bootloader
119 Conflicts:      grub
120 ExclusiveArch:  %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
121 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
122
123 %define         _sbindir        /sbin
124 %define         _bindir         %{_sbindir}
125 %define         _libdir         /lib
126 %define         _datadir        %{_libdir}
127 %define         _libexecdir     %{_libdir}/grub
128 %define         _grubdir        /boot/grub
129 %define         _localedir      /usr/share/locale
130
131 # part of grub code is not relocable (these are not Linux libs)
132 # stack protector also breaks non-Linux binaries
133 # any kind of forced optimizations makes grub2 unreliable (random
134 # reboots and hangs on boot menu screen)
135 %define         filterout_c     -fPIC -O.
136 %undefine       _ssp_cflags
137 %undefine       _fortify_cflags
138
139 %description
140 GRUB is a GPLed bootloader intended to unify bootloading across x86
141 operating systems. In addition to loading the Linux and *BSD kernels,
142 it implements the Multiboot standard, which allows for flexible
143 loading of multiple boot images (needed for modular kernels such as
144 the GNU Hurd).
145
146 GRUB 2 is derived from PUPA which was a research project to
147 investigate the next generation of GRUB. GRUB 2 has been rewritten
148 from scratch to clean up everything for modularity and portability.
149
150 GRUB 2 targets at the following goals:
151 - Scripting support, such as conditionals, loops, variables and
152   functions.
153 - Graphical interface.
154 - Dynamic loading of modules in order to extend itself at the run time
155   rather than at the build time.
156 - Portability for various architectures.
157 - Internationalization. This includes support for non-ASCII character
158   code, message catalogs like gettext, fonts, graphics console, and so
159   on.
160 - Real memory management, to make GNU GRUB more extensible.
161 - Modular, hierarchical, object-oriented framework for file systems,
162   files, devices, drives, terminals, commands, partition tables and OS
163   loaders.
164 - Cross-platform installation which allows for installing GRUB from a
165   different architecture.
166 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
167 - Fix design mistakes in GRUB Legacy, which could not be solved for
168   backward-compatibility, such as the way of numbering partitions.
169
170 %description -l de.UTF-8
171 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
172 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
173 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
174
175 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
176 und wird unter der GPL vertrieben. Aufgrund seiner höheren
177 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
178 traditionellen Boot-Loader LILO.
179
180 %description -l hu.UTF-8
181 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
182 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
183 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
184 GNU Hurd).
185
186 GRUB2 céljai a következők:
187 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
188   függvények.
189 - grafikus felület
190 - modulok dinamikus betöltése futási időben
191 - hordozhatóság több architektúrára
192 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
193   mint gettext, betűtípusok, grafikus konzolon, és így tovább
194 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
195 - moduláris, hierarchikus, objektum-orientált keretrendszer
196   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
197   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
198
199 %description -l es.UTF-8
200 Éste es GRUB - Grand Unified Boot Loader - un administrador de
201 inicialización capaz de entrar en la mayoría de los sistemas
202 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
203 también en la mayoría de los sistemas operacionales comerciales para
204 PC.
205
206 El administrador GRUB puede ser una buena alternativa a LILO, para
207 usuarios conmás experiencia y que deseen obtener más recursos de su
208 cargador de inicialización (boot loader).
209
210 %description -l pl.UTF-8
211 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
212 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
213 Linuksa i *BSD: posiada również implementację standardu Multiboot,
214 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
215 (czego wymagają modułowe jądra, takie jak GNU Hurd).
216
217 %description -l pt_BR.UTF-8
218 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
219 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
220 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
221 operacionais comerciais para PC.
222
223 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
224 avançados e que querem mais recursos de seu boot loader.
225
226 %package -n bash-completion-%{name}
227 Summary:        bash-completion for GRUB
228 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
229 Group:          Applications/Shells
230 Requires:       bash-completion
231 %if "%{_rpmversion}" >= "5"
232 BuildArch:      noarch
233 %endif
234
235 %description -n bash-completion-%{name}
236 This package provides bash-completion for GRUB.
237
238 %description -n bash-completion-%{name} -l pl.UTF-8
239 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
240
241 %package platform-pc
242 Summary:        PC BIOS platform support for GRUB
243 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
244 Group:          Base
245 Provides:       %{name}-platform = %{version}-%{release}
246
247 %description platform-pc
248 PC BIOS platform support for GRUB.
249
250 %description platform-pc -l pl.UTF-8
251 Obsługa platformy PC BIOS dla GRUB-a.
252
253 %package platform-efi
254 Summary:        (U)EFI platform support for GRUB
255 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
256 Group:          Base
257 Suggests:       efibootmgr
258 Provides:       %{name}-platform = %{version}-%{release}
259
260 %description platform-efi
261 (U)EFI platform support for GRUB.
262
263 %description platform-efi -l pl.UTF-8
264 Obsługa platformy (U)EFI dla GRUB-a.
265
266 %package mkfont
267 Summary:        GRUB font files converter
268 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
269 Group:          Base
270
271 %description mkfont
272 Converts common font file formats into PF2.
273
274 %description mkfont -l pl.UTF-8
275 Program do konwersji popularnych formatów plików fontów do PF2.
276
277 %package theme-starfield
278 Summary:        starfield theme for GRUB
279 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
280 Group:          Base
281
282 %description theme-starfield
283 starfield theme for GRUB.
284
285 %description theme-starfield -l pl.UTF-8
286 Motyw starfield dla GRUB-a.
287
288 %prep
289 %setup -q -n grub-%{version}
290 %patch1 -p1
291 %patch2 -p1
292 %patch3 -p1
293 %patch4 -p1
294 %patch5 -p1
295 %patch6 -p1
296 %patch7 -p1
297 %patch8 -p1
298 %patch9 -p1
299 %patch10 -p1
300 %patch11 -p1
301 %patch12 -p0
302 %patch13 -p1
303 %patch14 -p1
304 %patch15 -p1
305 %patch16 -p1
306
307 # we don't have C.utf-8 and need an UTF-8 locale for build
308 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
309
310 %build
311 # if gold is used then grub doesn't even boot
312 # https://savannah.gnu.org/bugs/?34539
313 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
314 install -d our-ld
315 ln -f -s /usr/bin/ld.bfd our-ld/ld
316 export PATH=$(pwd)/our-ld:$PATH
317
318 ## not only the typicall autotools stuff
319 #./autogen.sh
320
321 #{__gettextize}
322 %{__aclocal} -I m4
323 %{__autoconf}
324 %{__autoheader}
325 %{__automake}
326
327 for platform in %{platforms} ; do
328         install -d build-${platform}
329         cd build-${platform}
330
331         if [ "$platform" != "efi" ] ; then
332                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
333         else
334                 platform_opts=""
335         fi
336
337         ln -f -s ../configure .
338         # mawk stalls at ./genmoddep.awk, so force gawk
339         AWK=gawk \
340         %configure \
341                 --with-platform=${platform} \
342                 --disable-werror \
343                 --enable-grub-themes \
344         %if %{with grubemu}
345                 --enable-grub-emu-usb \
346                 --enable-grub-emu-sdl \
347                 --enable-grub-emu-pci \
348         %endif
349                 $platform_opts \
350                 TARGET_LDFLAGS=-static
351
352         %{__make} -j1 -C po update-gmo
353         %{__make}
354         cd ..
355 done
356
357 %install
358 rm -rf $RPM_BUILD_ROOT
359
360 for platform in %{platforms} ; do
361         cd build-${platform}
362         %{__make} install \
363                 pkgdatadir=%{_libexecdir} \
364                 pkglibdir=%{_libexecdir} \
365                 DESTDIR=$RPM_BUILD_ROOT
366         cd ..
367 done
368
369 # not in Th (?)
370 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
371 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
372
373 %find_lang grub
374
375 # this must be after 'make install'
376 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
377
378 install -d $RPM_BUILD_ROOT%{_grubdir}
379 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
380
381 # grub.d/41_custom
382 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
383 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
384
385 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
386 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
387
388 install -d $RPM_BUILD_ROOT/etc/sysconfig
389 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
390
391 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
392 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
393
394 # platform specific, unnecessarily always installed
395 %ifnarch %{ix86} %{x8664} x32
396 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
397 %endif
398 %ifnarch sparc64
399 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
400 %endif
401
402 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
403 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
404 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
405
406 # needs to be exactly 1KiB
407 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
408 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
409
410 %clean
411 rm -rf $RPM_BUILD_ROOT
412
413 %post -p %{_sbindir}/postshell
414 -/usr/sbin/fix-info-dir -c %{_infodir}
415
416 %postun -p %{_sbindir}/postshell
417 -/usr/sbin/fix-info-dir -c %{_infodir}
418
419 %triggerpostun -- %{name} < 2.00-2
420 # Note this trigger on version upgrade needed only for upgrade from
421 # old grub2 packages which contained modules in /boot/grub
422 # or were built with optimizations enabled
423 # don't do anything on --downgrade
424 if [ $1 -le 1 ]; then
425         exit 0
426 fi
427 echo "Grub was upgraded, trying to setup it to boot sector"
428 /sbin/grub-install '(hd0)' || :
429
430 %triggerpostun -- %{name} < 1.99-7.3
431 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
432 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
433         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
434         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
435 fi
436
437 %files -f grub.lang
438 %defattr(644,root,root,755)
439 %doc AUTHORS ChangeLog NEWS README THANKS TODO
440 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
441 %attr(755,root,root) %{_sbindir}/grub-editenv
442 %attr(755,root,root) %{_sbindir}/grub-fstest
443 %attr(755,root,root) %{_sbindir}/grub-file
444 %attr(755,root,root) %{_sbindir}/grub-glue-efi
445 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
446 %attr(755,root,root) %{_sbindir}/grub-install
447 %attr(755,root,root) %{_sbindir}/grub-macbless
448 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
449 %attr(755,root,root) %{_sbindir}/grub-mkconfig
450 %attr(755,root,root) %{_sbindir}/grub-mklayout
451 %attr(755,root,root) %{_sbindir}/grub-mknetdir
452 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
453 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
454 %attr(755,root,root) %{_sbindir}/grub-mkrescue
455 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
456 %attr(755,root,root) %{_sbindir}/grub-mount
457 %attr(755,root,root) %{_sbindir}/grub-ofpathname
458 %attr(755,root,root) %{_sbindir}/grub-reboot
459 %attr(755,root,root) %{_sbindir}/grub-render-label
460 %attr(755,root,root) %{_sbindir}/grub-script-check
461 %attr(755,root,root) %{_sbindir}/grub-set-default
462 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
463 %attr(755,root,root) %{_sbindir}/update-grub
464 %ifarch %{ix86} %{x8664} x32
465 %attr(755,root,root) %{_sbindir}/grub-bios-setup
466 %{_mandir}/man8/grub-bios-setup.8*
467 %endif
468 %ifarch %{ix86} %{x8664} x32
469 %attr(755,root,root) %{_sbindir}/grub-mkimage
470 %{_mandir}/man1/grub-mkimage.1*
471 %else
472 %attr(755,root,root) %{_sbindir}/grub-probe
473 %{_mandir}/man8/grub-probe.8*
474 %endif
475 %ifarch sparc64
476 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
477 %{_mandir}/man8/grub-sparc64-setup.8*
478 %endif
479 %{_mandir}/man1/grub-editenv.1*
480 %{_mandir}/man1/grub-file.1*
481 %{_mandir}/man1/grub-fstest.1*
482 %{_mandir}/man1/grub-glue-efi.1*
483 %{_mandir}/man1/grub-kbdcomp.1*
484 %{_mandir}/man1/grub-menulst2cfg.1*
485 %{_mandir}/man1/grub-mklayout.1*
486 %{_mandir}/man1/grub-mknetdir.1*
487 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
488 %{_mandir}/man1/grub-mkrelpath.1*
489 %{_mandir}/man1/grub-mkrescue.1*
490 %{_mandir}/man1/grub-mkstandalone.1*
491 %{_mandir}/man1/grub-mount.1*
492 %{_mandir}/man1/grub-render-label.1*
493 %{_mandir}/man1/grub-script-check.1*
494 %{_mandir}/man1/grub-syslinux2cfg.1*
495 %{_mandir}/man8/grub-install.8*
496 %{_mandir}/man8/grub-macbless.8*
497 %{_mandir}/man8/grub-mkconfig.8*
498 %{_mandir}/man8/grub-ofpathname.8*
499 %{_mandir}/man8/grub-reboot.8*
500 %{_mandir}/man8/grub-set-default.8*
501 %{_mandir}/man8/update-grub.8*
502 %if %{with grubemu}
503 %attr(755,root,root) %{_sbindir}/grub-emu
504 %{_mandir}/man8/grub-emu.8*
505 %endif
506 %{_libexecdir}/grub-mkconfig_lib
507
508 %dir %{_grubdir}
509 %dir %{_libexecdir}
510 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
511
512 %dir %{_libexecdir}/locale
513 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
514 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
515
516 # generated by grub at runtime
517 %ghost %{_grubdir}/device.map
518 %ghost %{_grubdir}/core.img
519 %ghost %{_grubdir}/grubenv
520
521 %dir /lib/grub.d
522 %doc /lib/grub.d/README
523 %attr(755,root,root) /lib/grub.d/00_header
524 %attr(755,root,root) /lib/grub.d/10_linux
525 %attr(755,root,root) /lib/grub.d/20_linux_xen
526 %attr(755,root,root) /lib/grub.d/30_os-prober
527 %attr(755,root,root) /lib/grub.d/41_custom
528
529 # these are now installed only on matching hosts
530 #%attr(755,root,root) /lib/grub.d/10_hurd
531 #%attr(755,root,root) /lib/grub.d/10_illumos
532 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
533 #%attr(755,root,root) /lib/grub.d/10_netbsd
534 #%attr(755,root,root) /lib/grub.d/10_xnu
535
536 %ifarch %{ix86} %{x8664} x32
537 %attr(755,root,root) %{_sbindir}/grub-probe
538 %{_mandir}/man8/grub-probe.8*
539 %endif
540
541 %{_infodir}/grub*.info*
542
543 %dir %{_datadir}/grub/themes
544
545 %if %{with pc}
546 %files platform-pc
547 %defattr(644,root,root,755)
548 %dir %{_libexecdir}/*-pc
549 %{_libexecdir}/*-pc/modinfo.sh
550 %{_libexecdir}/*-pc/*.exec
551 %{_libexecdir}/*-pc/*.image
552 %{_libexecdir}/*-pc/*.lst
553 %{_libexecdir}/*-pc/*.mod
554 %{_libexecdir}/*-pc/*.module
555 %{_libexecdir}/*-pc/lzma_decompress.img
556 %{_libexecdir}/*-pc/config.h
557 %{_libexecdir}/*-pc/gdb_grub
558 %{_libexecdir}/*-pc/gmodule.pl
559 %if %{with efiemu}
560 %{_libexecdir}/*-pc/efiemu*.o
561 %endif
562 %{_libexecdir}/*-pc/kernel.img
563 %ifarch %{ix86} %{x8664} x32 sparc sparc64
564 %{_libexecdir}/*-pc/boot.img
565 %{_libexecdir}/*-pc/boot_hybrid.img
566 %{_libexecdir}/*-pc/cdboot.img
567 %{_libexecdir}/*-pc/diskboot.img
568 %{_libexecdir}/*-pc/lnxboot.img
569 %{_libexecdir}/*-pc/pxeboot.img
570 %endif
571 %endif
572
573 %if %{with efi}
574 %files platform-efi
575 %defattr(644,root,root,755)
576 %dir %{_libexecdir}/*-efi
577 %{_libexecdir}/*-efi/modinfo.sh
578 %{_libexecdir}/*-efi/*.exec
579 %{_libexecdir}/*-efi/*.lst
580 %{_libexecdir}/*-efi/*.mod
581 %{_libexecdir}/*-efi/*.module
582 %{_libexecdir}/*-efi/config.h
583 %{_libexecdir}/*-efi/gdb_grub
584 %{_libexecdir}/*-efi/gmodule.pl
585 %{_libexecdir}/*-efi/kernel.img
586 %endif
587
588 %files mkfont
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_sbindir}/grub-mkfont
591 %{_mandir}/man1/grub-mkfont.1*
592
593 %files theme-starfield
594 %defattr(644,root,root,755)
595 %{_datadir}/grub/themes/starfield
596
597 %files -n bash-completion-%{name}
598 %defattr(644,root,root,755)
599 /etc/bash_completion.d/grub
This page took 0.09727 seconds and 2 git commands to generate.