]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
c6ad6cb0e55802dd788c965095b5aefa43d5ef5e
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %if "%{cc_version}" < "3.4"
17 # cc does not support:
18 # cc1: sorry, unimplemented: code model `large' not supported yet
19 %undefine       with_efiemu
20 %endif
21
22 %ifnarch %{ix86} %{x8664}
23 %undefine       with_pc
24 %endif
25 %ifnarch %{ix86} %{x8664} ia64
26 %undefine       with_efi
27 %endif
28
29 %ifnarch %{x8664}
30 # non-x86_64 arch doesn't support this
31 %undefine       with_efiemu
32 %endif
33
34 # the 'most natural' platform should go last
35 %ifarch %{ix86} %{x8664} ia64
36 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
37 %endif
38 %ifarch ppc ppc64 sparc64
39 %define         platforms ieee1275
40 %endif
41 %ifarch mips
42 %define         platforms arc
43 %endif
44 %ifarch mipsel
45 %define         platforms loongson
46 %endif
47
48 Summary:        GRand Unified Bootloader
49 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
50 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
51 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
52 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
53 Name:           grub2
54 Version:        2.00
55 Release:        0.6
56 License:        GPL v2
57 Group:          Base
58 Source0:        http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
59 # Source0-md5:  a1043102fbc7bcedbf53e7ee3d17ab91
60 Source1:        update-grub
61 Source2:        update-grub.8
62 Source3:        grub.sysconfig
63 Source4:        grub-custom.cfg
64 Patch0:         pld-initrd.patch
65 Patch1:         pld-sysconfdir.patch
66 Patch2:         grub-garbage.patch
67 Patch3:         grub-lvmdevice.patch
68 Patch4:         pld-mkconfigdir.patch
69 Patch5:         grub-mkconfig-diagnostics.patch
70 Patch6:         ppc.patch
71 Patch7:         %{name}-awk.patch
72 Patch8:         posix.patch
73 Patch9:         %{name}-gets.patch
74 Patch10:        %{name}-fonts_path.patch
75 Patch11:        %{name}-tftp_fix.patch
76 Patch12:        add-vlan-tag-support.patch
77 Patch13:        just-say-linux.patch
78 Patch14:        add-GRUB-DISABLE-SUBMENU-option.patch
79 Patch15:        add-X-option-to-printf-functions.patch
80 Patch16:        dhcp-client-id-and-uuid-options-added.patch
81 Patch17:        fix-http-crash.patch
82 Patch18:        Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
83 Patch19:        search-for-specific-config-file-for-netboot.patch
84 URL:            http://www.gnu.org/software/grub/
85 BuildRequires:  autoconf >= 2.53
86 BuildRequires:  automake >= 1:1.11.1-1
87 BuildRequires:  bison
88 BuildRequires:  device-mapper-devel
89 BuildRequires:  flex >= 2.5.35
90 BuildRequires:  fonts-TTF-DejaVu
91 BuildRequires:  freetype-devel >= 2
92 BuildRequires:  gawk
93 BuildRequires:  gettext-devel
94 BuildRequires:  glibc-static
95 BuildRequires:  help2man
96 BuildRequires:  libfuse-devel
97 BuildRequires:  libtool
98 BuildRequires:  ncurses-devel
99 BuildRequires:  rpm >= 4.4.9-56
100 BuildRequires:  rpmbuild(macros) >= 1.213
101 BuildRequires:  sed >= 4.0
102 BuildRequires:  tar >= 1:1.22
103 BuildRequires:  texinfo
104 BuildRequires:  xz
105 BuildRequires:  xz-devel
106 %ifarch %{x8664}
107 BuildRequires:  /usr/lib/libc.so
108 %if "%{pld_release}" == "ac"
109 BuildRequires:  libgcc32
110 %else
111 BuildRequires:  gcc-multilib
112 %endif
113 %endif
114 Requires:       %{name}-platform = %{version}-%{release}
115 Requires:       which
116 %ifarch %{ix86} %{x8664}
117 Suggests:       %{name}-platform-pc
118 %endif
119 Suggests:       cdrkit-mkisofs
120 Suggests:       os-prober
121 Provides:       bootloader
122 Conflicts:      grub
123 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 %define         _sbindir        /sbin
127 %define         _bindir         %{_sbindir}
128 %define         _libdir         /lib
129 %define         _datadir        %{_libdir}
130 %define         _libexecdir     %{_libdir}/grub
131 %define         _grubdir        /boot/grub
132 %define         _localedir      /usr/share/locale
133
134 # part of grub code is not relocable (these are not Linux libs)
135 # stack protector also breaks non-Linux binaries
136 %define         filterout_c     -fPIC
137 %undefine       _ssp_cflags
138
139 %description
140 GRUB is a GPLed bootloader intended to unify bootloading across x86
141 operating systems. In addition to loading the Linux and *BSD kernels,
142 it implements the Multiboot standard, which allows for flexible
143 loading of multiple boot images (needed for modular kernels such as
144 the GNU Hurd).
145
146 GRUB 2 is derived from PUPA which was a research project to
147 investigate the next generation of GRUB. GRUB 2 has been rewritten
148 from scratch to clean up everything for modularity and portability.
149
150 GRUB 2 targets at the following goals:
151 - Scripting support, such as conditionals, loops, variables and
152   functions.
153 - Graphical interface.
154 - Dynamic loading of modules in order to extend itself at the run time
155   rather than at the build time.
156 - Portability for various architectures.
157 - Internationalization. This includes support for non-ASCII character
158   code, message catalogs like gettext, fonts, graphics console, and so
159   on.
160 - Real memory management, to make GNU GRUB more extensible.
161 - Modular, hierarchical, object-oriented framework for file systems,
162   files, devices, drives, terminals, commands, partition tables and OS
163   loaders.
164 - Cross-platform installation which allows for installing GRUB from a
165   different architecture.
166 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
167 - Fix design mistakes in GRUB Legacy, which could not be solved for
168   backward-compatibility, such as the way of numbering partitions.
169
170 %description -l de.UTF-8
171 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
172 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
173 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
174
175 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
176 und wird unter der GPL vertrieben. Aufgrund seiner höheren
177 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
178 traditionellen Boot-Loader LILO.
179
180 %description -l hu.UTF-8
181 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
182 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
183 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
184 GNU Hurd).
185
186 GRUB2 céljai a következők:
187 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
188   függvények.
189 - grafikus felület
190 - modulok dinamikus betöltése futási időben
191 - hordozhatóság több architektúrára
192 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
193   mint gettext, betűtípusok, grafikus konzolon, és így tovább
194 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
195 - moduláris, hierarchikus, objektum-orientált keretrendszer
196   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
197   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
198
199 %description -l es.UTF-8
200 Éste es GRUB - Grand Unified Boot Loader - un administrador de
201 inicialización capaz de entrar en la mayoría de los sistemas
202 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
203 también en la mayoría de los sistemas operacionales comerciales para
204 PC.
205
206 El administrador GRUB puede ser una buena alternativa a LILO, para
207 usuarios conmás experiencia y que deseen obtener más recursos de su
208 cargador de inicialización (boot loader).
209
210 %description -l pl.UTF-8
211 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
212 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
213 Linuksa i *BSD: posiada również implementację standardu Multiboot,
214 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
215 (czego wymagają modułowe jądra, takie jak GNU Hurd).
216
217 %description -l pt_BR.UTF-8
218 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
219 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
220 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
221 operacionais comerciais para PC.
222
223 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
224 avançados e que querem mais recursos de seu boot loader.
225
226 %package -n bash-completion-%{name}
227 Summary:        bash-completion for GRUB
228 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
229 Group:          Applications/Shells
230 Requires:       bash-completion
231
232 %description -n bash-completion-%{name}
233 This package provides bash-completion for GRUB.
234
235 %description -n bash-completion-%{name} -l pl.UTF-8
236 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
237
238 %package platform-pc
239 Summary:        PC BIOS platform support for GRUB
240 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
241 Group:          Base
242 Provides:       %{name}-platform = %{version}-%{release}
243
244 %description platform-pc
245 PC BIOS platform support for GRUB.
246
247 %description platform-pc -l pl.UTF-8
248 Obsługa platformy PC BIOS dla GRUB-a.
249
250 %package platform-efi
251 Summary:        (U)EFI platform support for GRUB
252 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
253 Group:          Base
254 Suggests:       efibootmgr
255 Provides:       %{name}-platform = %{version}-%{release}
256
257 %description platform-efi
258 (U)EFI platform support for GRUB.
259
260 %description platform-efi -l pl.UTF-8
261 Obsługa platformy (U)EFI dla GRUB-a.
262
263 %package mkfont
264 Summary:        GRUB font files converter
265 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
266 Group:          Base
267
268 %description mkfont
269 Converts common font file formats into PF2.
270
271 %description mkfont -l pl.UTF-8
272 Program do konwersji popularnych formatów plików fontów do PF2.
273
274 %package theme-starfield
275 Summary:        starfield theme for GRUB
276 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
277 Group:          Base
278
279 %description theme-starfield
280 starfield theme for GRUB.
281
282 %description theme-starfield -l pl.UTF-8
283 Motyw starfield dla GRUB-a.
284
285 %prep
286 %setup -q -n grub-%{version}
287 %patch0 -p1
288 %patch1 -p1
289 %patch2 -p1
290 %patch3 -p1
291 %patch4 -p1
292 %patch5 -p1
293 %patch6 -p1
294 %patch7 -p1
295 %patch8 -p1
296 %patch9 -p1
297 %patch10 -p1
298 %patch11 -p1
299 %patch12 -p1
300 %patch13 -p1
301 %patch14 -p1
302 %patch15 -p1
303 %patch16 -p1
304 %patch17 -p1
305 %patch18 -p1
306 %patch19 -p1
307
308 %if "%{cc_version}" < "3.4"
309 grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
310 %{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
311 %endif
312
313 %build
314 # if gold is used then grub doesn't even boot
315 install -d our-ld
316 ln -s /usr/bin/ld.bfd our-ld/ld
317 export PATH=$(pwd)/our-ld:$PATH
318
319 cp -f /usr/share/automake/config.sub .
320 %{__libtoolize}
321 %{__aclocal} -I m4
322 %{__autoheader}
323 echo timestamp > stamp-h.in
324 %{__autoconf}
325 %{__automake}
326 export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
327
328 for platform in %{platforms} ; do
329         install -d build-${platform}
330         cd build-${platform}
331
332         if [ "$platform" != "efi" ] ; then
333                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
334         else
335                 platform_opts=""
336         fi
337
338         ln -s ../configure .
339         # mawk stalls at ./genmoddep.awk, so force gawk
340         AWK=gawk \
341         %configure \
342                 --with-platform=${platform} \
343                 --disable-werror \
344         %if %{with grubemu}
345                 --enable-grub-emu-usb \
346                 --enable-grub-emu-sdl \
347                 --enable-grub-emu-pci \
348         %endif
349                 $platform_opts \
350                 TARGET_LDFLAGS=-static
351
352         %{__make}
353         cd ..
354 done
355
356 %install
357 rm -rf $RPM_BUILD_ROOT
358
359 for platform in %{platforms} ; do
360         cd build-${platform}
361         %{__make} install \
362                 pkgdatadir=%{_libexecdir} \
363                 pkglibdir=%{_libexecdir} \
364                 DESTDIR=$RPM_BUILD_ROOT
365         cd ..
366 done
367
368 # not in Th (?)
369 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
370 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
371
372 %find_lang grub
373
374 # this must be after 'make install'
375 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
376
377 install -d $RPM_BUILD_ROOT%{_grubdir}
378 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
379
380 # grub.d/41_custom
381 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
382 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
383
384 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
385 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
386
387 install -d $RPM_BUILD_ROOT/etc/sysconfig
388 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
389
390 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
391 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
392
393 # platform specific, unnecessarily always installed
394 %ifnarch %{ix86} %{x8664}
395 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
396 %endif
397 %ifnarch sparc64
398 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
399 %endif
400
401 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
402 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
403 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
404
405 # needs to be exactly 1KiB
406 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
407 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
408
409 %clean
410 rm -rf $RPM_BUILD_ROOT
411
412 %post -p %{_sbindir}/postshell
413 -/usr/sbin/fix-info-dir -c %{_infodir}
414
415 %postun -p %{_sbindir}/postshell
416 -/usr/sbin/fix-info-dir -c %{_infodir}
417
418 %triggerpostun -- %{name} < 2.00-0.1
419 # Note this trigger on version upgrade
420 # needed only for upgrade from old grub2 packages
421 # which contained modules in /boot/grub
422 # don't do anything on --downgrade
423 if [ $1 -le 1 ]; then
424         exit 0
425 fi
426 echo "Grub was upgraded, trying to setup it to boot sector"
427 /sbin/grub-install '(hd0)' || :
428
429 %triggerpostun -- %{name} < 1.99-7.3
430 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
431 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
432         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
433         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
434 fi
435
436 %files -f grub.lang
437 %defattr(644,root,root,755)
438 %doc AUTHORS ChangeLog NEWS README THANKS TODO
439 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
440 %attr(755,root,root) %{_sbindir}/grub-editenv
441 %attr(755,root,root) %{_sbindir}/grub-fstest
442 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
443 %attr(755,root,root) %{_sbindir}/grub-install
444 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
445 %attr(755,root,root) %{_sbindir}/grub-mkconfig
446 %attr(755,root,root) %{_sbindir}/grub-mklayout
447 %attr(755,root,root) %{_sbindir}/grub-mknetdir
448 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
449 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
450 %attr(755,root,root) %{_sbindir}/grub-mkrescue
451 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
452 %attr(755,root,root) %{_sbindir}/grub-mount
453 %attr(755,root,root) %{_sbindir}/grub-ofpathname
454 %attr(755,root,root) %{_sbindir}/grub-reboot
455 %attr(755,root,root) %{_sbindir}/grub-script-check
456 %attr(755,root,root) %{_sbindir}/grub-set-default
457 %attr(755,root,root) %{_sbindir}/update-grub
458 %ifarch %{ix86} %{x8664}
459 %attr(755,root,root) %{_sbindir}/grub-bios-setup
460 %{_mandir}/man8/grub-bios-setup.8*
461 %endif
462 %ifarch %{ix86} %{x8664}
463 %attr(755,root,root) %{_sbindir}/grub-mkimage
464 %{_mandir}/man1/grub-mkimage.1*
465 %else
466 %attr(755,root,root) %{_sbindir}/grub-probe
467 %{_mandir}/man8/grub-probe.8*
468 %endif
469 %ifarch sparc64
470 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
471 %{_mandir}/man8/grub-sparc64-setup.8*
472 %endif
473 %{_mandir}/man1/grub-editenv.1*
474 %{_mandir}/man1/grub-fstest.1*
475 %{_mandir}/man1/grub-kbdcomp.1*
476 %{_mandir}/man1/grub-menulst2cfg.1*
477 %{_mandir}/man1/grub-mklayout.1*
478 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
479 %{_mandir}/man1/grub-mkrelpath.1*
480 %{_mandir}/man1/grub-mkrescue.1*
481 %{_mandir}/man1/grub-mkstandalone.1*
482 %{_mandir}/man1/grub-mount.1*
483 %{_mandir}/man1/grub-script-check.1*
484 %{_mandir}/man8/grub-install.8*
485 %{_mandir}/man8/grub-mkconfig.8*
486 %{_mandir}/man8/grub-mknetdir.8*
487 %{_mandir}/man8/grub-ofpathname.8*
488 %{_mandir}/man8/grub-reboot.8*
489 %{_mandir}/man8/grub-set-default.8*
490 %{_mandir}/man8/update-grub.8*
491 %if %{with grubemu}
492 %attr(755,root,root) %{_sbindir}/grub-emu
493 %{_mandir}/man8/grub-emu.8*
494 %endif
495 %{_libexecdir}/grub-mkconfig_lib
496
497 %dir %{_grubdir}
498 %dir %{_libexecdir}
499 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
500
501 %dir %{_libexecdir}/locale
502 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
503 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
504
505 # generated by grub at runtime
506 %ghost %{_grubdir}/device.map
507 %ghost %{_grubdir}/core.img
508 %ghost %{_grubdir}/grubenv
509
510 %dir /lib/grub.d
511 %doc /lib/grub.d/README
512 %attr(755,root,root) /lib/grub.d/00_header
513 %attr(755,root,root) /lib/grub.d/10_linux
514 %attr(755,root,root) /lib/grub.d/20_linux_xen
515 %attr(755,root,root) /lib/grub.d/30_os-prober
516 %attr(755,root,root) /lib/grub.d/41_custom
517
518 %ifarch %{ix86} %{x8664}
519 %attr(755,root,root) %{_sbindir}/grub-probe
520 %{_mandir}/man8/grub-probe.8*
521 %endif
522
523 %{_infodir}/grub*.info*
524
525 %dir %{_datadir}/grub/themes
526
527 %if %{with pc}
528 %files platform-pc
529 %defattr(644,root,root,755)
530 %dir %{_libexecdir}/*-pc
531 %{_libexecdir}/*-pc/modinfo.sh
532 %{_libexecdir}/*-pc/*.exec
533 %{_libexecdir}/*-pc/*.image
534 %{_libexecdir}/*-pc/*.lst
535 %{_libexecdir}/*-pc/*.mod
536 %{_libexecdir}/*-pc/*.module
537 %{_libexecdir}/*-pc/lzma_decompress.img
538 %{_libexecdir}/*-pc/config.h
539 %{_libexecdir}/*-pc/gdb_grub
540 %{_libexecdir}/*-pc/gmodule.pl
541 %if %{with efiemu}
542 %{_libexecdir}/*-pc/efiemu*.o
543 %endif
544 %{_libexecdir}/*-pc/kernel.img
545 %ifarch %{ix86} %{x8664} sparc sparc64
546 %{_libexecdir}/*-pc/boot.img
547 %{_libexecdir}/*-pc/cdboot.img
548 %{_libexecdir}/*-pc/diskboot.img
549 %{_libexecdir}/*-pc/lnxboot.img
550 %{_libexecdir}/*-pc/pxeboot.img
551 %endif
552 %endif
553
554 %if %{with efi}
555 %files platform-efi
556 %defattr(644,root,root,755)
557 %dir %{_libexecdir}/*-efi
558 %{_libexecdir}/*-efi/modinfo.sh
559 %{_libexecdir}/*-efi/*.exec
560 %{_libexecdir}/*-efi/*.lst
561 %{_libexecdir}/*-efi/*.mod
562 %{_libexecdir}/*-efi/*.module
563 %{_libexecdir}/*-efi/config.h
564 %{_libexecdir}/*-efi/gdb_grub
565 %{_libexecdir}/*-efi/gmodule.pl
566 %{_libexecdir}/*-efi/kernel.img
567 %endif
568
569 %files mkfont
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_sbindir}/grub-mkfont
572 %{_mandir}/man1/grub-mkfont.1*
573
574 %files theme-starfield
575 %defattr(644,root,root,755)
576 %{_datadir}/grub/themes/starfield
577
578 %files -n bash-completion-%{name}
579 %defattr(644,root,root,755)
580 /etc/bash_completion.d/grub
This page took 0.091238 seconds and 2 git commands to generate.