]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
b29436ad87303811aaa310065c5306d1dac938b5
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664} x32
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} x32 ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664} x32
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} x32 ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 %define         rel     1
43 Summary:        GRand Unified Bootloader
44 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
45 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
46 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
47 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
48 Name:           grub2
49 Version:        2.02
50 Release:        1
51 License:        GPL v2
52 Group:          Base
53 Source0:        ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
54 # Source0-md5:  8a4a2a95aac551fb0fba860ceabfa1d3
55 Source1:        update-grub
56 Source2:        update-grub.8
57 Source3:        grub.sysconfig
58 Source4:        grub-custom.cfg
59 Patch1:         pld-sysconfdir.patch
60 Patch2:         grub-garbage.patch
61 Patch3:         grub-lvmdevice.patch
62 Patch4:         pld-mkconfigdir.patch
63 Patch5:         grub-mkconfig-diagnostics.patch
64 Patch6:         posix.patch
65 Patch7:         %{name}-fonts_path.patch
66 Patch8:         add-vlan-tag-support.patch
67 Patch9:         just-say-linux.patch
68 Patch10:        ignore-kernel-symlinks.patch
69 Patch11:        choose-preferred-initrd.patch
70 Patch12:        %{name}-cfg.patch
71 Patch13:        efi-net-fix.patch
72 Patch14:        blscfg.patch
73 URL:            http://www.gnu.org/software/grub/
74 BuildRequires:  autoconf >= 2.53
75 BuildRequires:  automake >= 1:1.11.1-1
76 BuildRequires:  bison
77 BuildRequires:  device-mapper-devel
78 BuildRequires:  flex >= 2.5.35
79 BuildRequires:  fonts-TTF-DejaVu
80 BuildRequires:  freetype-devel >= 2
81 BuildRequires:  gawk
82 BuildRequires:  gcc >= 5:3.4
83 BuildRequires:  gettext-tools
84 BuildRequires:  glibc-localedb-all
85 BuildRequires:  glibc-static
86 BuildRequires:  help2man
87 BuildRequires:  libfuse-devel
88 BuildRequires:  libtool
89 BuildRequires:  ncurses-devel
90 BuildRequires:  python
91 BuildRequires:  python-modules
92 BuildRequires:  rpm >= 4.4.9-56
93 BuildRequires:  rpmbuild(macros) >= 1.213
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  tar >= 1:1.22
96 BuildRequires:  texinfo
97 BuildRequires:  xz
98 BuildRequires:  xz-devel
99 %ifarch %{x8664}
100 BuildRequires:  /usr/lib/libc.so
101 %if "%{pld_release}" == "ac"
102 BuildRequires:  libgcc32
103 %else
104 BuildRequires:  gcc-multilib-32
105 %endif
106 %endif
107 Requires:       %{name}-platform = %{version}-%{release}
108 Requires:       pld-release
109 Requires:       which
110 %ifarch %{ix86} %{x8664}
111 Suggests:       %{name}-platform-pc
112 %endif
113 Suggests:       cdrkit-mkisofs
114 Suggests:       os-prober
115 Provides:       bootloader
116 Conflicts:      grub
117 ExclusiveArch:  %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %define         _sbindir        /sbin
121 %define         _bindir         %{_sbindir}
122 %define         _libdir         /lib
123 %define         _datadir        %{_libdir}
124 %define         _libexecdir     %{_libdir}/grub
125 %define         _grubdir        /boot/grub
126 %define         _localedir      /usr/share/locale
127
128 # part of grub code is not relocable (these are not Linux libs)
129 # stack protector also breaks non-Linux binaries
130 # any kind of forced optimizations makes grub2 unreliable (random
131 # reboots and hangs on boot menu screen)
132 %define         filterout_c     -fPIC -O.
133 %undefine       _ssp_cflags
134 %undefine       _fortify_cflags
135
136 %description
137 GRUB is a GPLed bootloader intended to unify bootloading across x86
138 operating systems. In addition to loading the Linux and *BSD kernels,
139 it implements the Multiboot standard, which allows for flexible
140 loading of multiple boot images (needed for modular kernels such as
141 the GNU Hurd).
142
143 GRUB 2 is derived from PUPA which was a research project to
144 investigate the next generation of GRUB. GRUB 2 has been rewritten
145 from scratch to clean up everything for modularity and portability.
146
147 GRUB 2 targets at the following goals:
148 - Scripting support, such as conditionals, loops, variables and
149   functions.
150 - Graphical interface.
151 - Dynamic loading of modules in order to extend itself at the run time
152   rather than at the build time.
153 - Portability for various architectures.
154 - Internationalization. This includes support for non-ASCII character
155   code, message catalogs like gettext, fonts, graphics console, and so
156   on.
157 - Real memory management, to make GNU GRUB more extensible.
158 - Modular, hierarchical, object-oriented framework for file systems,
159   files, devices, drives, terminals, commands, partition tables and OS
160   loaders.
161 - Cross-platform installation which allows for installing GRUB from a
162   different architecture.
163 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
164 - Fix design mistakes in GRUB Legacy, which could not be solved for
165   backward-compatibility, such as the way of numbering partitions.
166
167 %description -l de.UTF-8
168 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
169 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
170 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
171
172 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
173 und wird unter der GPL vertrieben. Aufgrund seiner höheren
174 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
175 traditionellen Boot-Loader LILO.
176
177 %description -l hu.UTF-8
178 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
179 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
180 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
181 GNU Hurd).
182
183 GRUB2 céljai a következők:
184 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
185   függvények.
186 - grafikus felület
187 - modulok dinamikus betöltése futási időben
188 - hordozhatóság több architektúrára
189 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
190   mint gettext, betűtípusok, grafikus konzolon, és így tovább
191 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
192 - moduláris, hierarchikus, objektum-orientált keretrendszer
193   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
194   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
195
196 %description -l es.UTF-8
197 Éste es GRUB - Grand Unified Boot Loader - un administrador de
198 inicialización capaz de entrar en la mayoría de los sistemas
199 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
200 también en la mayoría de los sistemas operacionales comerciales para
201 PC.
202
203 El administrador GRUB puede ser una buena alternativa a LILO, para
204 usuarios conmás experiencia y que deseen obtener más recursos de su
205 cargador de inicialización (boot loader).
206
207 %description -l pl.UTF-8
208 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
209 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
210 Linuksa i *BSD: posiada również implementację standardu Multiboot,
211 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
212 (czego wymagają modułowe jądra, takie jak GNU Hurd).
213
214 %description -l pt_BR.UTF-8
215 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
216 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
217 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
218 operacionais comerciais para PC.
219
220 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
221 avançados e que querem mais recursos de seu boot loader.
222
223 %package -n bash-completion-%{name}
224 Summary:        bash-completion for GRUB
225 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
226 Group:          Applications/Shells
227 Requires:       bash-completion
228 %if "%{_rpmversion}" >= "5"
229 BuildArch:      noarch
230 %endif
231
232 %description -n bash-completion-%{name}
233 This package provides bash-completion for GRUB.
234
235 %description -n bash-completion-%{name} -l pl.UTF-8
236 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
237
238 %package platform-pc
239 Summary:        PC BIOS platform support for GRUB
240 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
241 Group:          Base
242 Provides:       %{name}-platform = %{version}-%{release}
243
244 %description platform-pc
245 PC BIOS platform support for GRUB.
246
247 %description platform-pc -l pl.UTF-8
248 Obsługa platformy PC BIOS dla GRUB-a.
249
250 %package platform-efi
251 Summary:        (U)EFI platform support for GRUB
252 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
253 Group:          Base
254 Suggests:       efibootmgr
255 Provides:       %{name}-platform = %{version}-%{release}
256
257 %description platform-efi
258 (U)EFI platform support for GRUB.
259
260 %description platform-efi -l pl.UTF-8
261 Obsługa platformy (U)EFI dla GRUB-a.
262
263 %package mkfont
264 Summary:        GRUB font files converter
265 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
266 Group:          Base
267
268 %description mkfont
269 Converts common font file formats into PF2.
270
271 %description mkfont -l pl.UTF-8
272 Program do konwersji popularnych formatów plików fontów do PF2.
273
274 %package theme-starfield
275 Summary:        starfield theme for GRUB
276 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
277 Group:          Base
278
279 %description theme-starfield
280 starfield theme for GRUB.
281
282 %description theme-starfield -l pl.UTF-8
283 Motyw starfield dla GRUB-a.
284
285 %prep
286 %setup -q -n grub-%{version}
287 %patch1 -p1
288 %patch2 -p1
289 %patch3 -p1
290 %patch4 -p1
291 %patch5 -p1
292 %patch6 -p1
293 %patch7 -p1
294 %patch8 -p1
295 %patch9 -p1
296 %patch10 -p1
297 %patch11 -p1
298 %patch12 -p0
299 %patch13 -p1
300 %patch14 -p1
301
302 # we don't have C.utf-8 and need an UTF-8 locale for build
303 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
304
305 %build
306 # if gold is used then grub doesn't even boot
307 # https://savannah.gnu.org/bugs/?34539
308 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
309 install -d our-ld
310 ln -f -s /usr/bin/ld.bfd our-ld/ld
311 export PATH=$(pwd)/our-ld:$PATH
312
313 ## not only the typicall autotools stuff
314 #./autogen.sh
315
316 #{__gettextize}
317 %{__aclocal} -I m4
318 %{__autoconf}
319 %{__autoheader}
320 %{__automake}
321
322 for platform in %{platforms} ; do
323         install -d build-${platform}
324         cd build-${platform}
325
326         if [ "$platform" != "efi" ] ; then
327                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
328         else
329                 platform_opts=""
330         fi
331
332         ln -f -s ../configure .
333         # mawk stalls at ./genmoddep.awk, so force gawk
334         AWK=gawk \
335         %configure \
336                 --with-platform=${platform} \
337                 --disable-werror \
338         %if %{with grubemu}
339                 --enable-grub-emu-usb \
340                 --enable-grub-emu-sdl \
341                 --enable-grub-emu-pci \
342         %endif
343                 $platform_opts \
344                 TARGET_LDFLAGS=-static
345
346         %{__make} -j1 -C po update-gmo
347         %{__make}
348         cd ..
349 done
350
351 %install
352 rm -rf $RPM_BUILD_ROOT
353
354 for platform in %{platforms} ; do
355         cd build-${platform}
356         %{__make} install \
357                 pkgdatadir=%{_libexecdir} \
358                 pkglibdir=%{_libexecdir} \
359                 DESTDIR=$RPM_BUILD_ROOT
360         cd ..
361 done
362
363 # not in Th (?)
364 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
365 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
366
367 %find_lang grub
368
369 # this must be after 'make install'
370 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
371
372 install -d $RPM_BUILD_ROOT%{_grubdir}
373 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
374
375 # grub.d/41_custom
376 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
377 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
378
379 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
380 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
381
382 install -d $RPM_BUILD_ROOT/etc/sysconfig
383 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
384
385 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
386 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
387
388 # platform specific, unnecessarily always installed
389 %ifnarch %{ix86} %{x8664} x32
390 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
391 %endif
392 %ifnarch sparc64
393 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
394 %endif
395
396 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
397 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
398 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
399
400 # needs to be exactly 1KiB
401 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
402 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
403
404 %clean
405 rm -rf $RPM_BUILD_ROOT
406
407 %post -p %{_sbindir}/postshell
408 -/usr/sbin/fix-info-dir -c %{_infodir}
409
410 %postun -p %{_sbindir}/postshell
411 -/usr/sbin/fix-info-dir -c %{_infodir}
412
413 %triggerpostun -- %{name} < 2.00-2
414 # Note this trigger on version upgrade needed only for upgrade from
415 # old grub2 packages which contained modules in /boot/grub
416 # or were built with optimizations enabled
417 # don't do anything on --downgrade
418 if [ $1 -le 1 ]; then
419         exit 0
420 fi
421 echo "Grub was upgraded, trying to setup it to boot sector"
422 /sbin/grub-install '(hd0)' || :
423
424 %triggerpostun -- %{name} < 1.99-7.3
425 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
426 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
427         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
428         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
429 fi
430
431 %files -f grub.lang
432 %defattr(644,root,root,755)
433 %doc AUTHORS ChangeLog NEWS README THANKS TODO
434 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
435 %attr(755,root,root) %{_sbindir}/grub-editenv
436 %attr(755,root,root) %{_sbindir}/grub-fstest
437 %attr(755,root,root) %{_sbindir}/grub-file
438 %attr(755,root,root) %{_sbindir}/grub-glue-efi
439 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
440 %attr(755,root,root) %{_sbindir}/grub-install
441 %attr(755,root,root) %{_sbindir}/grub-macbless
442 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
443 %attr(755,root,root) %{_sbindir}/grub-mkconfig
444 %attr(755,root,root) %{_sbindir}/grub-mklayout
445 %attr(755,root,root) %{_sbindir}/grub-mknetdir
446 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
447 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
448 %attr(755,root,root) %{_sbindir}/grub-mkrescue
449 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
450 %attr(755,root,root) %{_sbindir}/grub-mount
451 %attr(755,root,root) %{_sbindir}/grub-ofpathname
452 %attr(755,root,root) %{_sbindir}/grub-reboot
453 %attr(755,root,root) %{_sbindir}/grub-render-label
454 %attr(755,root,root) %{_sbindir}/grub-script-check
455 %attr(755,root,root) %{_sbindir}/grub-set-default
456 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
457 %attr(755,root,root) %{_sbindir}/update-grub
458 %ifarch %{ix86} %{x8664} x32
459 %attr(755,root,root) %{_sbindir}/grub-bios-setup
460 %{_mandir}/man8/grub-bios-setup.8*
461 %endif
462 %ifarch %{ix86} %{x8664} x32
463 %attr(755,root,root) %{_sbindir}/grub-mkimage
464 %{_mandir}/man1/grub-mkimage.1*
465 %else
466 %attr(755,root,root) %{_sbindir}/grub-probe
467 %{_mandir}/man8/grub-probe.8*
468 %endif
469 %ifarch sparc64
470 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
471 %{_mandir}/man8/grub-sparc64-setup.8*
472 %endif
473 %{_mandir}/man1/grub-editenv.1*
474 %{_mandir}/man1/grub-file.1*
475 %{_mandir}/man1/grub-fstest.1*
476 %{_mandir}/man1/grub-glue-efi.1*
477 %{_mandir}/man1/grub-kbdcomp.1*
478 %{_mandir}/man1/grub-menulst2cfg.1*
479 %{_mandir}/man1/grub-mklayout.1*
480 %{_mandir}/man1/grub-mknetdir.1*
481 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
482 %{_mandir}/man1/grub-mkrelpath.1*
483 %{_mandir}/man1/grub-mkrescue.1*
484 %{_mandir}/man1/grub-mkstandalone.1*
485 %{_mandir}/man1/grub-mount.1*
486 %{_mandir}/man1/grub-render-label.1*
487 %{_mandir}/man1/grub-script-check.1*
488 %{_mandir}/man1/grub-syslinux2cfg.1*
489 %{_mandir}/man8/grub-install.8*
490 %{_mandir}/man8/grub-macbless.8*
491 %{_mandir}/man8/grub-mkconfig.8*
492 %{_mandir}/man8/grub-ofpathname.8*
493 %{_mandir}/man8/grub-reboot.8*
494 %{_mandir}/man8/grub-set-default.8*
495 %{_mandir}/man8/update-grub.8*
496 %if %{with grubemu}
497 %attr(755,root,root) %{_sbindir}/grub-emu
498 %{_mandir}/man8/grub-emu.8*
499 %endif
500 %{_libexecdir}/grub-mkconfig_lib
501
502 %dir %{_grubdir}
503 %dir %{_libexecdir}
504 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
505
506 %dir %{_libexecdir}/locale
507 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
508 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
509
510 # generated by grub at runtime
511 %ghost %{_grubdir}/device.map
512 %ghost %{_grubdir}/core.img
513 %ghost %{_grubdir}/grubenv
514
515 %dir /lib/grub.d
516 %doc /lib/grub.d/README
517 %attr(755,root,root) /lib/grub.d/00_header
518 %attr(755,root,root) /lib/grub.d/10_linux
519 %attr(755,root,root) /lib/grub.d/20_linux_xen
520 %attr(755,root,root) /lib/grub.d/30_os-prober
521 %attr(755,root,root) /lib/grub.d/41_custom
522
523 # these are now installed only on matching hosts
524 #%attr(755,root,root) /lib/grub.d/10_hurd
525 #%attr(755,root,root) /lib/grub.d/10_illumos
526 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
527 #%attr(755,root,root) /lib/grub.d/10_netbsd
528 #%attr(755,root,root) /lib/grub.d/10_xnu
529
530 %ifarch %{ix86} %{x8664} x32
531 %attr(755,root,root) %{_sbindir}/grub-probe
532 %{_mandir}/man8/grub-probe.8*
533 %endif
534
535 %{_infodir}/grub*.info*
536
537 %dir %{_datadir}/grub/themes
538
539 %if %{with pc}
540 %files platform-pc
541 %defattr(644,root,root,755)
542 %dir %{_libexecdir}/*-pc
543 %{_libexecdir}/*-pc/modinfo.sh
544 %{_libexecdir}/*-pc/*.exec
545 %{_libexecdir}/*-pc/*.image
546 %{_libexecdir}/*-pc/*.lst
547 %{_libexecdir}/*-pc/*.mod
548 %{_libexecdir}/*-pc/*.module
549 %{_libexecdir}/*-pc/lzma_decompress.img
550 %{_libexecdir}/*-pc/config.h
551 %{_libexecdir}/*-pc/gdb_grub
552 %{_libexecdir}/*-pc/gmodule.pl
553 %if %{with efiemu}
554 %{_libexecdir}/*-pc/efiemu*.o
555 %endif
556 %{_libexecdir}/*-pc/kernel.img
557 %ifarch %{ix86} %{x8664} x32 sparc sparc64
558 %{_libexecdir}/*-pc/boot.img
559 %{_libexecdir}/*-pc/boot_hybrid.img
560 %{_libexecdir}/*-pc/cdboot.img
561 %{_libexecdir}/*-pc/diskboot.img
562 %{_libexecdir}/*-pc/lnxboot.img
563 %{_libexecdir}/*-pc/pxeboot.img
564 %endif
565 %endif
566
567 %if %{with efi}
568 %files platform-efi
569 %defattr(644,root,root,755)
570 %dir %{_libexecdir}/*-efi
571 %{_libexecdir}/*-efi/modinfo.sh
572 %{_libexecdir}/*-efi/*.exec
573 %{_libexecdir}/*-efi/*.lst
574 %{_libexecdir}/*-efi/*.mod
575 %{_libexecdir}/*-efi/*.module
576 %{_libexecdir}/*-efi/config.h
577 %{_libexecdir}/*-efi/gdb_grub
578 %{_libexecdir}/*-efi/gmodule.pl
579 %{_libexecdir}/*-efi/kernel.img
580 %endif
581
582 %files mkfont
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_sbindir}/grub-mkfont
585 %{_mandir}/man1/grub-mkfont.1*
586
587 %files theme-starfield
588 %defattr(644,root,root,755)
589 %{_datadir}/grub/themes/starfield
590
591 %files -n bash-completion-%{name}
592 %defattr(644,root,root,755)
593 /etc/bash_completion.d/grub
This page took 0.058046 seconds and 2 git commands to generate.