]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
- rel 2
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664}
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664}
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 Name:           grub2
48 Version:        2.00
49 Release:        2
50 License:        GPL v2
51 Group:          Base
52 Source0:        http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
53 # Source0-md5:  a1043102fbc7bcedbf53e7ee3d17ab91
54 Source1:        update-grub
55 Source2:        update-grub.8
56 Source3:        grub.sysconfig
57 Source4:        grub-custom.cfg
58 Patch1:         pld-sysconfdir.patch
59 Patch2:         grub-garbage.patch
60 Patch3:         grub-lvmdevice.patch
61 Patch4:         pld-mkconfigdir.patch
62 Patch5:         grub-mkconfig-diagnostics.patch
63 Patch6:         ppc.patch
64 Patch7:         %{name}-awk.patch
65 Patch8:         posix.patch
66 Patch9:         %{name}-gets.patch
67 Patch10:        %{name}-fonts_path.patch
68 Patch11:        %{name}-tftp_fix.patch
69 Patch12:        add-vlan-tag-support.patch
70 Patch13:        just-say-linux.patch
71 Patch14:        add-GRUB-DISABLE-SUBMENU-option.patch
72 Patch15:        add-X-option-to-printf-functions.patch
73 Patch16:        dhcp-client-id-and-uuid-options-added.patch
74 Patch17:        fix-http-crash.patch
75 Patch18:        Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
76 Patch19:        search-for-specific-config-file-for-netboot.patch
77 Patch20:        ignore-kernel-symlinks.patch
78 Patch21:        choose-preferred-initrd.patch
79 URL:            http://www.gnu.org/software/grub/
80 BuildRequires:  autoconf >= 2.53
81 BuildRequires:  automake >= 1:1.11.1-1
82 BuildRequires:  bison
83 BuildRequires:  device-mapper-devel
84 BuildRequires:  flex >= 2.5.35
85 BuildRequires:  fonts-TTF-DejaVu
86 BuildRequires:  freetype-devel >= 2
87 BuildRequires:  gawk
88 BuildRequires:  gettext-devel
89 BuildRequires:  glibc-static
90 BuildRequires:  help2man
91 BuildRequires:  libfuse-devel
92 BuildRequires:  libtool
93 BuildRequires:  ncurses-devel
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.213
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  tar >= 1:1.22
98 BuildRequires:  texinfo
99 BuildRequires:  xz
100 BuildRequires:  xz-devel
101 %ifarch %{x8664}
102 BuildRequires:  /usr/lib/libc.so
103 %if "%{pld_release}" == "ac"
104 BuildRequires:  libgcc32
105 %else
106 BuildRequires:  gcc-multilib
107 %endif
108 %endif
109 Requires:       %{name}-platform = %{version}-%{release}
110 Requires:       which
111 %ifarch %{ix86} %{x8664}
112 Suggests:       %{name}-platform-pc
113 %endif
114 Suggests:       cdrkit-mkisofs
115 Suggests:       os-prober
116 Provides:       bootloader
117 Conflicts:      grub
118 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
119 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121 %define         _sbindir        /sbin
122 %define         _bindir         %{_sbindir}
123 %define         _libdir         /lib
124 %define         _datadir        %{_libdir}
125 %define         _libexecdir     %{_libdir}/grub
126 %define         _grubdir        /boot/grub
127 %define         _localedir      /usr/share/locale
128
129 # part of grub code is not relocable (these are not Linux libs)
130 # stack protector also breaks non-Linux binaries
131 # any kind of forced optimizations makes grub2 unreliable (random
132 # reboots and hangs on boot menu screen)
133 %define         filterout_c     -fPIC -O.
134 %undefine       _ssp_cflags
135 %undefine       _fortify_cflags
136
137 %description
138 GRUB is a GPLed bootloader intended to unify bootloading across x86
139 operating systems. In addition to loading the Linux and *BSD kernels,
140 it implements the Multiboot standard, which allows for flexible
141 loading of multiple boot images (needed for modular kernels such as
142 the GNU Hurd).
143
144 GRUB 2 is derived from PUPA which was a research project to
145 investigate the next generation of GRUB. GRUB 2 has been rewritten
146 from scratch to clean up everything for modularity and portability.
147
148 GRUB 2 targets at the following goals:
149 - Scripting support, such as conditionals, loops, variables and
150   functions.
151 - Graphical interface.
152 - Dynamic loading of modules in order to extend itself at the run time
153   rather than at the build time.
154 - Portability for various architectures.
155 - Internationalization. This includes support for non-ASCII character
156   code, message catalogs like gettext, fonts, graphics console, and so
157   on.
158 - Real memory management, to make GNU GRUB more extensible.
159 - Modular, hierarchical, object-oriented framework for file systems,
160   files, devices, drives, terminals, commands, partition tables and OS
161   loaders.
162 - Cross-platform installation which allows for installing GRUB from a
163   different architecture.
164 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
165 - Fix design mistakes in GRUB Legacy, which could not be solved for
166   backward-compatibility, such as the way of numbering partitions.
167
168 %description -l de.UTF-8
169 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
170 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
171 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
172
173 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
174 und wird unter der GPL vertrieben. Aufgrund seiner höheren
175 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
176 traditionellen Boot-Loader LILO.
177
178 %description -l hu.UTF-8
179 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
180 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
181 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
182 GNU Hurd).
183
184 GRUB2 céljai a következők:
185 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
186   függvények.
187 - grafikus felület
188 - modulok dinamikus betöltése futási időben
189 - hordozhatóság több architektúrára
190 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
191   mint gettext, betűtípusok, grafikus konzolon, és így tovább
192 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
193 - moduláris, hierarchikus, objektum-orientált keretrendszer
194   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
195   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
196
197 %description -l es.UTF-8
198 Éste es GRUB - Grand Unified Boot Loader - un administrador de
199 inicialización capaz de entrar en la mayoría de los sistemas
200 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
201 también en la mayoría de los sistemas operacionales comerciales para
202 PC.
203
204 El administrador GRUB puede ser una buena alternativa a LILO, para
205 usuarios conmás experiencia y que deseen obtener más recursos de su
206 cargador de inicialización (boot loader).
207
208 %description -l pl.UTF-8
209 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
210 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
211 Linuksa i *BSD: posiada również implementację standardu Multiboot,
212 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
213 (czego wymagają modułowe jądra, takie jak GNU Hurd).
214
215 %description -l pt_BR.UTF-8
216 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
217 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
218 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
219 operacionais comerciais para PC.
220
221 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
222 avançados e que querem mais recursos de seu boot loader.
223
224 %package -n bash-completion-%{name}
225 Summary:        bash-completion for GRUB
226 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
227 Group:          Applications/Shells
228 Requires:       bash-completion
229
230 %description -n bash-completion-%{name}
231 This package provides bash-completion for GRUB.
232
233 %description -n bash-completion-%{name} -l pl.UTF-8
234 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
235
236 %package platform-pc
237 Summary:        PC BIOS platform support for GRUB
238 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
239 Group:          Base
240 Provides:       %{name}-platform = %{version}-%{release}
241
242 %description platform-pc
243 PC BIOS platform support for GRUB.
244
245 %description platform-pc -l pl.UTF-8
246 Obsługa platformy PC BIOS dla GRUB-a.
247
248 %package platform-efi
249 Summary:        (U)EFI platform support for GRUB
250 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
251 Group:          Base
252 Suggests:       efibootmgr
253 Provides:       %{name}-platform = %{version}-%{release}
254
255 %description platform-efi
256 (U)EFI platform support for GRUB.
257
258 %description platform-efi -l pl.UTF-8
259 Obsługa platformy (U)EFI dla GRUB-a.
260
261 %package mkfont
262 Summary:        GRUB font files converter
263 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
264 Group:          Base
265
266 %description mkfont
267 Converts common font file formats into PF2.
268
269 %description mkfont -l pl.UTF-8
270 Program do konwersji popularnych formatów plików fontów do PF2.
271
272 %package theme-starfield
273 Summary:        starfield theme for GRUB
274 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
275 Group:          Base
276
277 %description theme-starfield
278 starfield theme for GRUB.
279
280 %description theme-starfield -l pl.UTF-8
281 Motyw starfield dla GRUB-a.
282
283 %prep
284 %setup -q -n grub-%{version}
285 %patch1 -p1
286 %patch2 -p1
287 %patch3 -p1
288 %patch4 -p1
289 %patch5 -p1
290 %patch6 -p1
291 %patch7 -p1
292 %patch8 -p1
293 %patch9 -p1
294 %patch10 -p1
295 %patch11 -p1
296 %patch12 -p1
297 %patch13 -p1
298 %patch14 -p1
299 %patch15 -p1
300 %patch16 -p1
301 %patch17 -p1
302 %patch18 -p1
303 %patch19 -p1
304 %patch20 -p1
305 %patch21 -p1
306
307 %build
308 # if gold is used then grub doesn't even boot
309 install -d our-ld
310 ln -s /usr/bin/ld.bfd our-ld/ld
311 export PATH=$(pwd)/our-ld:$PATH
312
313 cp -f /usr/share/automake/config.sub .
314 %{__libtoolize}
315 %{__aclocal} -I m4
316 %{__autoheader}
317 echo timestamp > stamp-h.in
318 %{__autoconf}
319 %{__automake}
320
321 for platform in %{platforms} ; do
322         install -d build-${platform}
323         cd build-${platform}
324
325         if [ "$platform" != "efi" ] ; then
326                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
327         else
328                 platform_opts=""
329         fi
330
331         ln -s ../configure .
332         # mawk stalls at ./genmoddep.awk, so force gawk
333         AWK=gawk \
334         %configure \
335                 --with-platform=${platform} \
336                 --disable-werror \
337         %if %{with grubemu}
338                 --enable-grub-emu-usb \
339                 --enable-grub-emu-sdl \
340                 --enable-grub-emu-pci \
341         %endif
342                 $platform_opts \
343                 TARGET_LDFLAGS=-static
344
345         %{__make}
346         cd ..
347 done
348
349 %install
350 rm -rf $RPM_BUILD_ROOT
351
352 for platform in %{platforms} ; do
353         cd build-${platform}
354         %{__make} install \
355                 pkgdatadir=%{_libexecdir} \
356                 pkglibdir=%{_libexecdir} \
357                 DESTDIR=$RPM_BUILD_ROOT
358         cd ..
359 done
360
361 # not in Th (?)
362 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
363 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
364
365 %find_lang grub
366
367 # this must be after 'make install'
368 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
369
370 install -d $RPM_BUILD_ROOT%{_grubdir}
371 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
372
373 # grub.d/41_custom
374 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
375 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
376
377 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
378 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
379
380 install -d $RPM_BUILD_ROOT/etc/sysconfig
381 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
382
383 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
384 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
385
386 # platform specific, unnecessarily always installed
387 %ifnarch %{ix86} %{x8664}
388 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
389 %endif
390 %ifnarch sparc64
391 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
392 %endif
393
394 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
395 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
396 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
397
398 # needs to be exactly 1KiB
399 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
400 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
401
402 %clean
403 rm -rf $RPM_BUILD_ROOT
404
405 %post -p %{_sbindir}/postshell
406 -/usr/sbin/fix-info-dir -c %{_infodir}
407
408 %postun -p %{_sbindir}/postshell
409 -/usr/sbin/fix-info-dir -c %{_infodir}
410
411 %triggerpostun -- %{name} < 2.00-2
412 # Note this trigger on version upgrade needed only for upgrade from
413 # old grub2 packages which contained modules in /boot/grub
414 # or were built with optimizations enabled
415 # don't do anything on --downgrade
416 if [ $1 -le 1 ]; then
417         exit 0
418 fi
419 echo "Grub was upgraded, trying to setup it to boot sector"
420 /sbin/grub-install '(hd0)' || :
421
422 %triggerpostun -- %{name} < 1.99-7.3
423 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
424 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
425         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
426         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
427 fi
428
429 %files -f grub.lang
430 %defattr(644,root,root,755)
431 %doc AUTHORS ChangeLog NEWS README THANKS TODO
432 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
433 %attr(755,root,root) %{_sbindir}/grub-editenv
434 %attr(755,root,root) %{_sbindir}/grub-fstest
435 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
436 %attr(755,root,root) %{_sbindir}/grub-install
437 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
438 %attr(755,root,root) %{_sbindir}/grub-mkconfig
439 %attr(755,root,root) %{_sbindir}/grub-mklayout
440 %attr(755,root,root) %{_sbindir}/grub-mknetdir
441 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
442 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
443 %attr(755,root,root) %{_sbindir}/grub-mkrescue
444 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
445 %attr(755,root,root) %{_sbindir}/grub-mount
446 %attr(755,root,root) %{_sbindir}/grub-ofpathname
447 %attr(755,root,root) %{_sbindir}/grub-reboot
448 %attr(755,root,root) %{_sbindir}/grub-script-check
449 %attr(755,root,root) %{_sbindir}/grub-set-default
450 %attr(755,root,root) %{_sbindir}/update-grub
451 %ifarch %{ix86} %{x8664}
452 %attr(755,root,root) %{_sbindir}/grub-bios-setup
453 %{_mandir}/man8/grub-bios-setup.8*
454 %endif
455 %ifarch %{ix86} %{x8664}
456 %attr(755,root,root) %{_sbindir}/grub-mkimage
457 %{_mandir}/man1/grub-mkimage.1*
458 %else
459 %attr(755,root,root) %{_sbindir}/grub-probe
460 %{_mandir}/man8/grub-probe.8*
461 %endif
462 %ifarch sparc64
463 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
464 %{_mandir}/man8/grub-sparc64-setup.8*
465 %endif
466 %{_mandir}/man1/grub-editenv.1*
467 %{_mandir}/man1/grub-fstest.1*
468 %{_mandir}/man1/grub-kbdcomp.1*
469 %{_mandir}/man1/grub-menulst2cfg.1*
470 %{_mandir}/man1/grub-mklayout.1*
471 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
472 %{_mandir}/man1/grub-mkrelpath.1*
473 %{_mandir}/man1/grub-mkrescue.1*
474 %{_mandir}/man1/grub-mkstandalone.1*
475 %{_mandir}/man1/grub-mount.1*
476 %{_mandir}/man1/grub-script-check.1*
477 %{_mandir}/man8/grub-install.8*
478 %{_mandir}/man8/grub-mkconfig.8*
479 %{_mandir}/man8/grub-mknetdir.8*
480 %{_mandir}/man8/grub-ofpathname.8*
481 %{_mandir}/man8/grub-reboot.8*
482 %{_mandir}/man8/grub-set-default.8*
483 %{_mandir}/man8/update-grub.8*
484 %if %{with grubemu}
485 %attr(755,root,root) %{_sbindir}/grub-emu
486 %{_mandir}/man8/grub-emu.8*
487 %endif
488 %{_libexecdir}/grub-mkconfig_lib
489
490 %dir %{_grubdir}
491 %dir %{_libexecdir}
492 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
493
494 %dir %{_libexecdir}/locale
495 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
496 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
497
498 # generated by grub at runtime
499 %ghost %{_grubdir}/device.map
500 %ghost %{_grubdir}/core.img
501 %ghost %{_grubdir}/grubenv
502
503 %dir /lib/grub.d
504 %doc /lib/grub.d/README
505 %attr(755,root,root) /lib/grub.d/00_header
506 %attr(755,root,root) /lib/grub.d/10_linux
507 %attr(755,root,root) /lib/grub.d/20_linux_xen
508 %attr(755,root,root) /lib/grub.d/30_os-prober
509 %attr(755,root,root) /lib/grub.d/41_custom
510
511 %ifarch %{ix86} %{x8664}
512 %attr(755,root,root) %{_sbindir}/grub-probe
513 %{_mandir}/man8/grub-probe.8*
514 %endif
515
516 %{_infodir}/grub*.info*
517
518 %dir %{_datadir}/grub/themes
519
520 %if %{with pc}
521 %files platform-pc
522 %defattr(644,root,root,755)
523 %dir %{_libexecdir}/*-pc
524 %{_libexecdir}/*-pc/modinfo.sh
525 %{_libexecdir}/*-pc/*.exec
526 %{_libexecdir}/*-pc/*.image
527 %{_libexecdir}/*-pc/*.lst
528 %{_libexecdir}/*-pc/*.mod
529 %{_libexecdir}/*-pc/*.module
530 %{_libexecdir}/*-pc/lzma_decompress.img
531 %{_libexecdir}/*-pc/config.h
532 %{_libexecdir}/*-pc/gdb_grub
533 %{_libexecdir}/*-pc/gmodule.pl
534 %if %{with efiemu}
535 %{_libexecdir}/*-pc/efiemu*.o
536 %endif
537 %{_libexecdir}/*-pc/kernel.img
538 %ifarch %{ix86} %{x8664} sparc sparc64
539 %{_libexecdir}/*-pc/boot.img
540 %{_libexecdir}/*-pc/cdboot.img
541 %{_libexecdir}/*-pc/diskboot.img
542 %{_libexecdir}/*-pc/lnxboot.img
543 %{_libexecdir}/*-pc/pxeboot.img
544 %endif
545 %endif
546
547 %if %{with efi}
548 %files platform-efi
549 %defattr(644,root,root,755)
550 %dir %{_libexecdir}/*-efi
551 %{_libexecdir}/*-efi/modinfo.sh
552 %{_libexecdir}/*-efi/*.exec
553 %{_libexecdir}/*-efi/*.lst
554 %{_libexecdir}/*-efi/*.mod
555 %{_libexecdir}/*-efi/*.module
556 %{_libexecdir}/*-efi/config.h
557 %{_libexecdir}/*-efi/gdb_grub
558 %{_libexecdir}/*-efi/gmodule.pl
559 %{_libexecdir}/*-efi/kernel.img
560 %endif
561
562 %files mkfont
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_sbindir}/grub-mkfont
565 %{_mandir}/man1/grub-mkfont.1*
566
567 %files theme-starfield
568 %defattr(644,root,root,755)
569 %{_datadir}/grub/themes/starfield
570
571 %files -n bash-completion-%{name}
572 %defattr(644,root,root,755)
573 /etc/bash_completion.d/grub
This page took 0.147233 seconds and 3 git commands to generate.