]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
- rel 1.1
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %if "%{cc_version}" < "3.4"
17 # cc does not support:
18 # cc1: sorry, unimplemented: code model `large' not supported yet
19 %undefine       with_efiemu
20 %endif
21
22 %ifnarch %{ix86} %{x8664}
23 %undefine       with_pc
24 %endif
25 %ifnarch %{ix86} %{x8664} ia64
26 %undefine       with_efi
27 %endif
28
29 %ifnarch %{x8664}
30 # non-x86_64 arch doesn't support this
31 %undefine       with_efiemu
32 %endif
33
34 # the 'most natural' platform should go last
35 %ifarch %{ix86} %{x8664} ia64
36 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
37 %endif
38 %ifarch ppc ppc64 sparc64
39 %define         platforms ieee1275
40 %endif
41 %ifarch mips
42 %define         platforms arc
43 %endif
44 %ifarch mipsel
45 %define         platforms loongson
46 %endif
47
48 Summary:        GRand Unified Bootloader
49 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
50 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
51 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
52 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
53 Name:           grub2
54 Version:        2.00
55 Release:        1.1
56 License:        GPL v2
57 Group:          Base
58 Source0:        http://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
59 # Source0-md5:  a1043102fbc7bcedbf53e7ee3d17ab91
60 Source1:        update-grub
61 Source2:        update-grub.8
62 Source3:        grub.sysconfig
63 Source4:        grub-custom.cfg
64 Patch1:         pld-sysconfdir.patch
65 Patch2:         grub-garbage.patch
66 Patch3:         grub-lvmdevice.patch
67 Patch4:         pld-mkconfigdir.patch
68 Patch5:         grub-mkconfig-diagnostics.patch
69 Patch6:         ppc.patch
70 Patch7:         %{name}-awk.patch
71 Patch8:         posix.patch
72 Patch9:         %{name}-gets.patch
73 Patch10:        %{name}-fonts_path.patch
74 Patch11:        %{name}-tftp_fix.patch
75 Patch12:        add-vlan-tag-support.patch
76 Patch13:        just-say-linux.patch
77 Patch14:        add-GRUB-DISABLE-SUBMENU-option.patch
78 Patch15:        add-X-option-to-printf-functions.patch
79 Patch16:        dhcp-client-id-and-uuid-options-added.patch
80 Patch17:        fix-http-crash.patch
81 Patch18:        Issue-separate-DNS-queries-for-ipv4-and-ipv6.patch
82 Patch19:        search-for-specific-config-file-for-netboot.patch
83 Patch20:        ignore-kernel-symlinks.patch
84 Patch21:        choose-preferred-initrd.patch
85 URL:            http://www.gnu.org/software/grub/
86 BuildRequires:  autoconf >= 2.53
87 BuildRequires:  automake >= 1:1.11.1-1
88 BuildRequires:  bison
89 BuildRequires:  device-mapper-devel
90 BuildRequires:  flex >= 2.5.35
91 BuildRequires:  fonts-TTF-DejaVu
92 BuildRequires:  freetype-devel >= 2
93 BuildRequires:  gawk
94 BuildRequires:  gettext-devel
95 BuildRequires:  glibc-static
96 BuildRequires:  help2man
97 BuildRequires:  libfuse-devel
98 BuildRequires:  libtool
99 BuildRequires:  ncurses-devel
100 BuildRequires:  rpm >= 4.4.9-56
101 BuildRequires:  rpmbuild(macros) >= 1.213
102 BuildRequires:  sed >= 4.0
103 BuildRequires:  tar >= 1:1.22
104 BuildRequires:  texinfo
105 BuildRequires:  xz
106 BuildRequires:  xz-devel
107 %ifarch %{x8664}
108 BuildRequires:  /usr/lib/libc.so
109 %if "%{pld_release}" == "ac"
110 BuildRequires:  libgcc32
111 %else
112 BuildRequires:  gcc-multilib
113 %endif
114 %endif
115 Requires:       %{name}-platform = %{version}-%{release}
116 Requires:       which
117 %ifarch %{ix86} %{x8664}
118 Suggests:       %{name}-platform-pc
119 %endif
120 Suggests:       cdrkit-mkisofs
121 Suggests:       os-prober
122 Provides:       bootloader
123 Conflicts:      grub
124 ExclusiveArch:  %{ix86} %{x8664} ia64 mips mipsel ppc ppc64 sparc64
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         _sbindir        /sbin
128 %define         _bindir         %{_sbindir}
129 %define         _libdir         /lib
130 %define         _datadir        %{_libdir}
131 %define         _libexecdir     %{_libdir}/grub
132 %define         _grubdir        /boot/grub
133 %define         _localedir      /usr/share/locale
134
135 # part of grub code is not relocable (these are not Linux libs)
136 # stack protector also breaks non-Linux binaries
137 %define         filterout_c     -fPIC -O.
138 %undefine       _ssp_cflags
139 %undefine       _fortify_cflags
140
141 %description
142 GRUB is a GPLed bootloader intended to unify bootloading across x86
143 operating systems. In addition to loading the Linux and *BSD kernels,
144 it implements the Multiboot standard, which allows for flexible
145 loading of multiple boot images (needed for modular kernels such as
146 the GNU Hurd).
147
148 GRUB 2 is derived from PUPA which was a research project to
149 investigate the next generation of GRUB. GRUB 2 has been rewritten
150 from scratch to clean up everything for modularity and portability.
151
152 GRUB 2 targets at the following goals:
153 - Scripting support, such as conditionals, loops, variables and
154   functions.
155 - Graphical interface.
156 - Dynamic loading of modules in order to extend itself at the run time
157   rather than at the build time.
158 - Portability for various architectures.
159 - Internationalization. This includes support for non-ASCII character
160   code, message catalogs like gettext, fonts, graphics console, and so
161   on.
162 - Real memory management, to make GNU GRUB more extensible.
163 - Modular, hierarchical, object-oriented framework for file systems,
164   files, devices, drives, terminals, commands, partition tables and OS
165   loaders.
166 - Cross-platform installation which allows for installing GRUB from a
167   different architecture.
168 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
169 - Fix design mistakes in GRUB Legacy, which could not be solved for
170   backward-compatibility, such as the way of numbering partitions.
171
172 %description -l de.UTF-8
173 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
174 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
175 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
176
177 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
178 und wird unter der GPL vertrieben. Aufgrund seiner höheren
179 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
180 traditionellen Boot-Loader LILO.
181
182 %description -l hu.UTF-8
183 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
184 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
185 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
186 GNU Hurd).
187
188 GRUB2 céljai a következők:
189 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
190   függvények.
191 - grafikus felület
192 - modulok dinamikus betöltése futási időben
193 - hordozhatóság több architektúrára
194 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
195   mint gettext, betűtípusok, grafikus konzolon, és így tovább
196 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
197 - moduláris, hierarchikus, objektum-orientált keretrendszer
198   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
199   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
200
201 %description -l es.UTF-8
202 Éste es GRUB - Grand Unified Boot Loader - un administrador de
203 inicialización capaz de entrar en la mayoría de los sistemas
204 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
205 también en la mayoría de los sistemas operacionales comerciales para
206 PC.
207
208 El administrador GRUB puede ser una buena alternativa a LILO, para
209 usuarios conmás experiencia y que deseen obtener más recursos de su
210 cargador de inicialización (boot loader).
211
212 %description -l pl.UTF-8
213 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
214 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
215 Linuksa i *BSD: posiada również implementację standardu Multiboot,
216 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
217 (czego wymagają modułowe jądra, takie jak GNU Hurd).
218
219 %description -l pt_BR.UTF-8
220 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
221 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
222 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
223 operacionais comerciais para PC.
224
225 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
226 avançados e que querem mais recursos de seu boot loader.
227
228 %package -n bash-completion-%{name}
229 Summary:        bash-completion for GRUB
230 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
231 Group:          Applications/Shells
232 Requires:       bash-completion
233
234 %description -n bash-completion-%{name}
235 This package provides bash-completion for GRUB.
236
237 %description -n bash-completion-%{name} -l pl.UTF-8
238 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
239
240 %package platform-pc
241 Summary:        PC BIOS platform support for GRUB
242 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
243 Group:          Base
244 Provides:       %{name}-platform = %{version}-%{release}
245
246 %description platform-pc
247 PC BIOS platform support for GRUB.
248
249 %description platform-pc -l pl.UTF-8
250 Obsługa platformy PC BIOS dla GRUB-a.
251
252 %package platform-efi
253 Summary:        (U)EFI platform support for GRUB
254 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
255 Group:          Base
256 Suggests:       efibootmgr
257 Provides:       %{name}-platform = %{version}-%{release}
258
259 %description platform-efi
260 (U)EFI platform support for GRUB.
261
262 %description platform-efi -l pl.UTF-8
263 Obsługa platformy (U)EFI dla GRUB-a.
264
265 %package mkfont
266 Summary:        GRUB font files converter
267 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
268 Group:          Base
269
270 %description mkfont
271 Converts common font file formats into PF2.
272
273 %description mkfont -l pl.UTF-8
274 Program do konwersji popularnych formatów plików fontów do PF2.
275
276 %package theme-starfield
277 Summary:        starfield theme for GRUB
278 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
279 Group:          Base
280
281 %description theme-starfield
282 starfield theme for GRUB.
283
284 %description theme-starfield -l pl.UTF-8
285 Motyw starfield dla GRUB-a.
286
287 %prep
288 %setup -q -n grub-%{version}
289 %patch1 -p1
290 %patch2 -p1
291 %patch3 -p1
292 %patch4 -p1
293 %patch5 -p1
294 %patch6 -p1
295 %patch7 -p1
296 %patch8 -p1
297 %patch9 -p1
298 %patch10 -p1
299 %patch11 -p1
300 %patch12 -p1
301 %patch13 -p1
302 %patch14 -p1
303 %patch15 -p1
304 %patch16 -p1
305 %patch17 -p1
306 %patch18 -p1
307 %patch19 -p1
308 %patch20 -p1
309 %patch21 -p1
310
311 %if "%{cc_version}" < "3.4"
312 grep -rl -- -Wno-missing-field-initializers . | xargs %{__sed} -i -e 's,-Wno-missing-field-initializers,,'
313 %{__sed} -i -e '/video_mod_CFLAGS/s/$/ -Wno-error/' conf/common.rmk
314 %endif
315
316 %build
317 # if gold is used then grub doesn't even boot
318 #install -d our-ld
319 #ln -s /usr/bin/ld.bfd our-ld/ld
320 #export PATH=$(pwd)/our-ld:$PATH
321
322 cp -f /usr/share/automake/config.sub .
323 %{__libtoolize}
324 %{__aclocal} -I m4
325 %{__autoheader}
326 echo timestamp > stamp-h.in
327 %{__autoconf}
328 %{__automake}
329 export CFLAGS="%{rpmcflags} -Os %{?debug:-g}"
330
331 for platform in %{platforms} ; do
332         install -d build-${platform}
333         cd build-${platform}
334
335         if [ "$platform" != "efi" ] ; then
336                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
337         else
338                 platform_opts=""
339         fi
340
341         ln -s ../configure .
342         # mawk stalls at ./genmoddep.awk, so force gawk
343         AWK=gawk \
344         %configure \
345                 --with-platform=${platform} \
346                 --disable-werror \
347         %if %{with grubemu}
348                 --enable-grub-emu-usb \
349                 --enable-grub-emu-sdl \
350                 --enable-grub-emu-pci \
351         %endif
352                 $platform_opts \
353                 TARGET_LDFLAGS=-static
354
355         %{__make}
356         cd ..
357 done
358
359 %install
360 rm -rf $RPM_BUILD_ROOT
361
362 for platform in %{platforms} ; do
363         cd build-${platform}
364         %{__make} install \
365                 pkgdatadir=%{_libexecdir} \
366                 pkglibdir=%{_libexecdir} \
367                 DESTDIR=$RPM_BUILD_ROOT
368         cd ..
369 done
370
371 # not in Th (?)
372 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
373 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
374
375 %find_lang grub
376
377 # this must be after 'make install'
378 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
379
380 install -d $RPM_BUILD_ROOT%{_grubdir}
381 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
382
383 # grub.d/41_custom
384 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
385 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
386
387 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
388 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
389
390 install -d $RPM_BUILD_ROOT/etc/sysconfig
391 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
392
393 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
394 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
395
396 # platform specific, unnecessarily always installed
397 %ifnarch %{ix86} %{x8664}
398 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
399 %endif
400 %ifnarch sparc64
401 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
402 %endif
403
404 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
405 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
406 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
407
408 # needs to be exactly 1KiB
409 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
410 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
411
412 %clean
413 rm -rf $RPM_BUILD_ROOT
414
415 %post -p %{_sbindir}/postshell
416 -/usr/sbin/fix-info-dir -c %{_infodir}
417
418 %postun -p %{_sbindir}/postshell
419 -/usr/sbin/fix-info-dir -c %{_infodir}
420
421 %triggerpostun -- %{name} < 2.00-0.1
422 # Note this trigger on version upgrade
423 # needed only for upgrade from old grub2 packages
424 # which contained modules in /boot/grub
425 # don't do anything on --downgrade
426 if [ $1 -le 1 ]; then
427         exit 0
428 fi
429 echo "Grub was upgraded, trying to setup it to boot sector"
430 /sbin/grub-install '(hd0)' || :
431
432 %triggerpostun -- %{name} < 1.99-7.3
433 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
434 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
435         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
436         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
437 fi
438
439 %files -f grub.lang
440 %defattr(644,root,root,755)
441 %doc AUTHORS ChangeLog NEWS README THANKS TODO
442 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
443 %attr(755,root,root) %{_sbindir}/grub-editenv
444 %attr(755,root,root) %{_sbindir}/grub-fstest
445 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
446 %attr(755,root,root) %{_sbindir}/grub-install
447 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
448 %attr(755,root,root) %{_sbindir}/grub-mkconfig
449 %attr(755,root,root) %{_sbindir}/grub-mklayout
450 %attr(755,root,root) %{_sbindir}/grub-mknetdir
451 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
452 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
453 %attr(755,root,root) %{_sbindir}/grub-mkrescue
454 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
455 %attr(755,root,root) %{_sbindir}/grub-mount
456 %attr(755,root,root) %{_sbindir}/grub-ofpathname
457 %attr(755,root,root) %{_sbindir}/grub-reboot
458 %attr(755,root,root) %{_sbindir}/grub-script-check
459 %attr(755,root,root) %{_sbindir}/grub-set-default
460 %attr(755,root,root) %{_sbindir}/update-grub
461 %ifarch %{ix86} %{x8664}
462 %attr(755,root,root) %{_sbindir}/grub-bios-setup
463 %{_mandir}/man8/grub-bios-setup.8*
464 %endif
465 %ifarch %{ix86} %{x8664}
466 %attr(755,root,root) %{_sbindir}/grub-mkimage
467 %{_mandir}/man1/grub-mkimage.1*
468 %else
469 %attr(755,root,root) %{_sbindir}/grub-probe
470 %{_mandir}/man8/grub-probe.8*
471 %endif
472 %ifarch sparc64
473 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
474 %{_mandir}/man8/grub-sparc64-setup.8*
475 %endif
476 %{_mandir}/man1/grub-editenv.1*
477 %{_mandir}/man1/grub-fstest.1*
478 %{_mandir}/man1/grub-kbdcomp.1*
479 %{_mandir}/man1/grub-menulst2cfg.1*
480 %{_mandir}/man1/grub-mklayout.1*
481 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
482 %{_mandir}/man1/grub-mkrelpath.1*
483 %{_mandir}/man1/grub-mkrescue.1*
484 %{_mandir}/man1/grub-mkstandalone.1*
485 %{_mandir}/man1/grub-mount.1*
486 %{_mandir}/man1/grub-script-check.1*
487 %{_mandir}/man8/grub-install.8*
488 %{_mandir}/man8/grub-mkconfig.8*
489 %{_mandir}/man8/grub-mknetdir.8*
490 %{_mandir}/man8/grub-ofpathname.8*
491 %{_mandir}/man8/grub-reboot.8*
492 %{_mandir}/man8/grub-set-default.8*
493 %{_mandir}/man8/update-grub.8*
494 %if %{with grubemu}
495 %attr(755,root,root) %{_sbindir}/grub-emu
496 %{_mandir}/man8/grub-emu.8*
497 %endif
498 %{_libexecdir}/grub-mkconfig_lib
499
500 %dir %{_grubdir}
501 %dir %{_libexecdir}
502 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
503
504 %dir %{_libexecdir}/locale
505 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
506 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
507
508 # generated by grub at runtime
509 %ghost %{_grubdir}/device.map
510 %ghost %{_grubdir}/core.img
511 %ghost %{_grubdir}/grubenv
512
513 %dir /lib/grub.d
514 %doc /lib/grub.d/README
515 %attr(755,root,root) /lib/grub.d/00_header
516 %attr(755,root,root) /lib/grub.d/10_linux
517 %attr(755,root,root) /lib/grub.d/20_linux_xen
518 %attr(755,root,root) /lib/grub.d/30_os-prober
519 %attr(755,root,root) /lib/grub.d/41_custom
520
521 %ifarch %{ix86} %{x8664}
522 %attr(755,root,root) %{_sbindir}/grub-probe
523 %{_mandir}/man8/grub-probe.8*
524 %endif
525
526 %{_infodir}/grub*.info*
527
528 %dir %{_datadir}/grub/themes
529
530 %if %{with pc}
531 %files platform-pc
532 %defattr(644,root,root,755)
533 %dir %{_libexecdir}/*-pc
534 %{_libexecdir}/*-pc/modinfo.sh
535 %{_libexecdir}/*-pc/*.exec
536 %{_libexecdir}/*-pc/*.image
537 %{_libexecdir}/*-pc/*.lst
538 %{_libexecdir}/*-pc/*.mod
539 %{_libexecdir}/*-pc/*.module
540 %{_libexecdir}/*-pc/lzma_decompress.img
541 %{_libexecdir}/*-pc/config.h
542 %{_libexecdir}/*-pc/gdb_grub
543 %{_libexecdir}/*-pc/gmodule.pl
544 %if %{with efiemu}
545 %{_libexecdir}/*-pc/efiemu*.o
546 %endif
547 %{_libexecdir}/*-pc/kernel.img
548 %ifarch %{ix86} %{x8664} sparc sparc64
549 %{_libexecdir}/*-pc/boot.img
550 %{_libexecdir}/*-pc/cdboot.img
551 %{_libexecdir}/*-pc/diskboot.img
552 %{_libexecdir}/*-pc/lnxboot.img
553 %{_libexecdir}/*-pc/pxeboot.img
554 %endif
555 %endif
556
557 %if %{with efi}
558 %files platform-efi
559 %defattr(644,root,root,755)
560 %dir %{_libexecdir}/*-efi
561 %{_libexecdir}/*-efi/modinfo.sh
562 %{_libexecdir}/*-efi/*.exec
563 %{_libexecdir}/*-efi/*.lst
564 %{_libexecdir}/*-efi/*.mod
565 %{_libexecdir}/*-efi/*.module
566 %{_libexecdir}/*-efi/config.h
567 %{_libexecdir}/*-efi/gdb_grub
568 %{_libexecdir}/*-efi/gmodule.pl
569 %{_libexecdir}/*-efi/kernel.img
570 %endif
571
572 %files mkfont
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_sbindir}/grub-mkfont
575 %{_mandir}/man1/grub-mkfont.1*
576
577 %files theme-starfield
578 %defattr(644,root,root,755)
579 %{_datadir}/grub/themes/starfield
580
581 %files -n bash-completion-%{name}
582 %defattr(644,root,root,755)
583 /etc/bash_completion.d/grub
This page took 0.068714 seconds and 3 git commands to generate.