]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
- typo
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664} x32
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} x32 ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664} x32
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} x32 ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 %define         rel     4
43 Summary:        GRand Unified Bootloader
44 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
45 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
46 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
47 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
48 %define beta    beta2
49 Name:           grub2
50 Version:        2.02
51 Release:        0.%{beta}.%{rel}
52 License:        GPL v2
53 Group:          Base
54 # git://git.savannah.gnu.org/grub.git
55 # git checkout %{version}~%{beta} ; make dist
56 Source0:        grub-%{version}~%{beta}.tar.gz
57 # Source0-md5:  ca6c18f6c5f1ed05b7444017a40573d9
58 Source1:        update-grub
59 Source2:        update-grub.8
60 Source3:        grub.sysconfig
61 Source4:        grub-custom.cfg
62 # ./linguas.sh
63 # TS=$(date +'%Y%m%d') ; tar cjvf grub-po-2.00.git$TS.tar.bz2 po/*.po po/LINGUAS
64 Source5:        grub-po-%{version}.git20140104.tar.bz2
65 # Source5-md5:  aeef3e636178093cf9d780d92da7afdb
66 Patch1:         pld-sysconfdir.patch
67 Patch2:         grub-garbage.patch
68 Patch3:         grub-lvmdevice.patch
69 Patch4:         pld-mkconfigdir.patch
70 Patch5:         grub-mkconfig-diagnostics.patch
71 Patch6:         posix.patch
72 Patch7:         %{name}-fonts_path.patch
73 Patch8:         add-vlan-tag-support.patch
74 Patch9:         just-say-linux.patch
75 Patch10:        ignore-kernel-symlinks.patch
76 Patch11:        choose-preferred-initrd.patch
77 Patch12:        %{name}-cfg.patch
78 Patch13:        efi-net-fix.patch
79 Patch14:        grub2-xfs-Add-helper-for-inode-size.patch
80 Patch15:        grub2-xfs-Convert-inode-numbers-to-cpu-endianity-immediate.patch
81 Patch16:        grub2-xfs-Fix-termination-loop-for-directory-iteration.patch
82 Patch17:        grub2-xfs-V5-filesystem-format-support.patch
83 URL:            http://www.gnu.org/software/grub/
84 BuildRequires:  autoconf >= 2.53
85 BuildRequires:  automake >= 1:1.11.1-1
86 BuildRequires:  bison
87 BuildRequires:  device-mapper-devel
88 BuildRequires:  flex >= 2.5.35
89 BuildRequires:  fonts-TTF-DejaVu
90 BuildRequires:  freetype-devel >= 2
91 BuildRequires:  gawk
92 BuildRequires:  gcc >= 5:3.4
93 BuildRequires:  gettext-tools
94 BuildRequires:  glibc-localedb-all
95 BuildRequires:  glibc-static
96 BuildRequires:  help2man
97 BuildRequires:  libfuse-devel
98 BuildRequires:  libtool
99 BuildRequires:  ncurses-devel
100 BuildRequires:  python
101 BuildRequires:  python-modules
102 BuildRequires:  rpm >= 4.4.9-56
103 BuildRequires:  rpmbuild(macros) >= 1.213
104 BuildRequires:  sed >= 4.0
105 BuildRequires:  tar >= 1:1.22
106 BuildRequires:  texinfo
107 BuildRequires:  xz
108 BuildRequires:  xz-devel
109 %ifarch %{x8664}
110 BuildRequires:  /usr/lib/libc.so
111 %if "%{pld_release}" == "ac"
112 BuildRequires:  libgcc32
113 %else
114 BuildRequires:  gcc-multilib-32
115 %endif
116 %endif
117 Requires:       %{name}-platform = %{version}-%{release}
118 Requires:       pld-release
119 Requires:       which
120 %ifarch %{ix86} %{x8664}
121 Suggests:       %{name}-platform-pc
122 %endif
123 Suggests:       cdrkit-mkisofs
124 Suggests:       os-prober
125 Provides:       bootloader
126 Conflicts:      grub
127 ExclusiveArch:  %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
128 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
129
130 %define         _sbindir        /sbin
131 %define         _bindir         %{_sbindir}
132 %define         _libdir         /lib
133 %define         _datadir        %{_libdir}
134 %define         _libexecdir     %{_libdir}/grub
135 %define         _grubdir        /boot/grub
136 %define         _localedir      /usr/share/locale
137
138 # part of grub code is not relocable (these are not Linux libs)
139 # stack protector also breaks non-Linux binaries
140 # any kind of forced optimizations makes grub2 unreliable (random
141 # reboots and hangs on boot menu screen)
142 %define         filterout_c     -fPIC -O.
143 %undefine       _ssp_cflags
144 %undefine       _fortify_cflags
145
146 %description
147 GRUB is a GPLed bootloader intended to unify bootloading across x86
148 operating systems. In addition to loading the Linux and *BSD kernels,
149 it implements the Multiboot standard, which allows for flexible
150 loading of multiple boot images (needed for modular kernels such as
151 the GNU Hurd).
152
153 GRUB 2 is derived from PUPA which was a research project to
154 investigate the next generation of GRUB. GRUB 2 has been rewritten
155 from scratch to clean up everything for modularity and portability.
156
157 GRUB 2 targets at the following goals:
158 - Scripting support, such as conditionals, loops, variables and
159   functions.
160 - Graphical interface.
161 - Dynamic loading of modules in order to extend itself at the run time
162   rather than at the build time.
163 - Portability for various architectures.
164 - Internationalization. This includes support for non-ASCII character
165   code, message catalogs like gettext, fonts, graphics console, and so
166   on.
167 - Real memory management, to make GNU GRUB more extensible.
168 - Modular, hierarchical, object-oriented framework for file systems,
169   files, devices, drives, terminals, commands, partition tables and OS
170   loaders.
171 - Cross-platform installation which allows for installing GRUB from a
172   different architecture.
173 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
174 - Fix design mistakes in GRUB Legacy, which could not be solved for
175   backward-compatibility, such as the way of numbering partitions.
176
177 %description -l de.UTF-8
178 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
179 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
180 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
181
182 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
183 und wird unter der GPL vertrieben. Aufgrund seiner höheren
184 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
185 traditionellen Boot-Loader LILO.
186
187 %description -l hu.UTF-8
188 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
189 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
190 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
191 GNU Hurd).
192
193 GRUB2 céljai a következők:
194 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
195   függvények.
196 - grafikus felület
197 - modulok dinamikus betöltése futási időben
198 - hordozhatóság több architektúrára
199 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
200   mint gettext, betűtípusok, grafikus konzolon, és így tovább
201 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
202 - moduláris, hierarchikus, objektum-orientált keretrendszer
203   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
204   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
205
206 %description -l es.UTF-8
207 Éste es GRUB - Grand Unified Boot Loader - un administrador de
208 inicialización capaz de entrar en la mayoría de los sistemas
209 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
210 también en la mayoría de los sistemas operacionales comerciales para
211 PC.
212
213 El administrador GRUB puede ser una buena alternativa a LILO, para
214 usuarios conmás experiencia y que deseen obtener más recursos de su
215 cargador de inicialización (boot loader).
216
217 %description -l pl.UTF-8
218 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
219 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
220 Linuksa i *BSD: posiada również implementację standardu Multiboot,
221 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
222 (czego wymagają modułowe jądra, takie jak GNU Hurd).
223
224 %description -l pt_BR.UTF-8
225 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
226 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
227 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
228 operacionais comerciais para PC.
229
230 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
231 avançados e que querem mais recursos de seu boot loader.
232
233 %package -n bash-completion-%{name}
234 Summary:        bash-completion for GRUB
235 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
236 Group:          Applications/Shells
237 Requires:       bash-completion
238 %if "%{_rpmversion}" >= "5"
239 BuildArch:      noarch
240 %endif
241
242 %description -n bash-completion-%{name}
243 This package provides bash-completion for GRUB.
244
245 %description -n bash-completion-%{name} -l pl.UTF-8
246 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
247
248 %package platform-pc
249 Summary:        PC BIOS platform support for GRUB
250 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
251 Group:          Base
252 Provides:       %{name}-platform = %{version}-%{release}
253
254 %description platform-pc
255 PC BIOS platform support for GRUB.
256
257 %description platform-pc -l pl.UTF-8
258 Obsługa platformy PC BIOS dla GRUB-a.
259
260 %package platform-efi
261 Summary:        (U)EFI platform support for GRUB
262 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
263 Group:          Base
264 Suggests:       efibootmgr
265 Provides:       %{name}-platform = %{version}-%{release}
266
267 %description platform-efi
268 (U)EFI platform support for GRUB.
269
270 %description platform-efi -l pl.UTF-8
271 Obsługa platformy (U)EFI dla GRUB-a.
272
273 %package mkfont
274 Summary:        GRUB font files converter
275 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
276 Group:          Base
277
278 %description mkfont
279 Converts common font file formats into PF2.
280
281 %description mkfont -l pl.UTF-8
282 Program do konwersji popularnych formatów plików fontów do PF2.
283
284 %package theme-starfield
285 Summary:        starfield theme for GRUB
286 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
287 Group:          Base
288
289 %description theme-starfield
290 starfield theme for GRUB.
291
292 %description theme-starfield -l pl.UTF-8
293 Motyw starfield dla GRUB-a.
294
295 %prep
296 %setup -q -n grub-%{version}~%{beta} -a5
297 %patch1 -p1
298 %patch2 -p1
299 %patch3 -p1
300 %patch4 -p1
301 %patch5 -p1
302 %patch6 -p1
303 %patch7 -p1
304 %patch8 -p1
305 %patch9 -p1
306 %patch10 -p1
307 %patch11 -p1
308 %patch12 -p0
309 %patch13 -p1
310 %patch14 -p1
311 %patch15 -p1
312 %patch16 -p1
313 %patch17 -p1
314
315 # we don't have C.utf-8 and need an UTF-8 locale for build
316 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
317
318 %build
319 # if gold is used then grub doesn't even boot
320 # https://savannah.gnu.org/bugs/?34539
321 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
322 install -d our-ld
323 ln -f -s /usr/bin/ld.bfd our-ld/ld
324 export PATH=$(pwd)/our-ld:$PATH
325
326 ## not only the typicall autotools stuff
327 #./autogen.sh
328
329 #{__gettextize}
330 %{__aclocal} -I m4
331 %{__autoconf}
332 %{__autoheader}
333 %{__automake}
334
335 for platform in %{platforms} ; do
336         install -d build-${platform}
337         cd build-${platform}
338
339         if [ "$platform" != "efi" ] ; then
340                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
341         else
342                 platform_opts=""
343         fi
344
345         ln -f -s ../configure .
346         # mawk stalls at ./genmoddep.awk, so force gawk
347         AWK=gawk \
348         %configure \
349                 --with-platform=${platform} \
350                 --disable-werror \
351         %if %{with grubemu}
352                 --enable-grub-emu-usb \
353                 --enable-grub-emu-sdl \
354                 --enable-grub-emu-pci \
355         %endif
356                 $platform_opts \
357                 TARGET_LDFLAGS=-static
358
359         %{__make} -j1 -C po update-gmo
360         %{__make}
361         cd ..
362 done
363
364 %install
365 rm -rf $RPM_BUILD_ROOT
366
367 for platform in %{platforms} ; do
368         cd build-${platform}
369         %{__make} install \
370                 pkgdatadir=%{_libexecdir} \
371                 pkglibdir=%{_libexecdir} \
372                 DESTDIR=$RPM_BUILD_ROOT
373         cd ..
374 done
375
376 # not in Th (?)
377 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
378 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
379
380 %find_lang grub
381
382 # this must be after 'make install'
383 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
384
385 install -d $RPM_BUILD_ROOT%{_grubdir}
386 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
387
388 # grub.d/41_custom
389 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
390 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
391
392 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
393 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
394
395 install -d $RPM_BUILD_ROOT/etc/sysconfig
396 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
397
398 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
399 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
400
401 # platform specific, unnecessarily always installed
402 %ifnarch %{ix86} %{x8664} x32
403 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
404 %endif
405 %ifnarch sparc64
406 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
407 %endif
408
409 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
410 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
411 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
412
413 # needs to be exactly 1KiB
414 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
415 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
416
417 %clean
418 rm -rf $RPM_BUILD_ROOT
419
420 %post -p %{_sbindir}/postshell
421 -/usr/sbin/fix-info-dir -c %{_infodir}
422
423 %postun -p %{_sbindir}/postshell
424 -/usr/sbin/fix-info-dir -c %{_infodir}
425
426 %triggerpostun -- %{name} < 2.00-2
427 # Note this trigger on version upgrade needed only for upgrade from
428 # old grub2 packages which contained modules in /boot/grub
429 # or were built with optimizations enabled
430 # don't do anything on --downgrade
431 if [ $1 -le 1 ]; then
432         exit 0
433 fi
434 echo "Grub was upgraded, trying to setup it to boot sector"
435 /sbin/grub-install '(hd0)' || :
436
437 %triggerpostun -- %{name} < 1.99-7.3
438 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
439 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
440         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
441         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
442 fi
443
444 %files -f grub.lang
445 %defattr(644,root,root,755)
446 %doc AUTHORS ChangeLog NEWS README THANKS TODO
447 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
448 %attr(755,root,root) %{_sbindir}/grub-editenv
449 %attr(755,root,root) %{_sbindir}/grub-fstest
450 %attr(755,root,root) %{_sbindir}/grub-file
451 %attr(755,root,root) %{_sbindir}/grub-glue-efi
452 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
453 %attr(755,root,root) %{_sbindir}/grub-install
454 %attr(755,root,root) %{_sbindir}/grub-macbless
455 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
456 %attr(755,root,root) %{_sbindir}/grub-mkconfig
457 %attr(755,root,root) %{_sbindir}/grub-mklayout
458 %attr(755,root,root) %{_sbindir}/grub-mknetdir
459 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
460 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
461 %attr(755,root,root) %{_sbindir}/grub-mkrescue
462 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
463 %attr(755,root,root) %{_sbindir}/grub-mount
464 %attr(755,root,root) %{_sbindir}/grub-ofpathname
465 %attr(755,root,root) %{_sbindir}/grub-reboot
466 %attr(755,root,root) %{_sbindir}/grub-render-label
467 %attr(755,root,root) %{_sbindir}/grub-script-check
468 %attr(755,root,root) %{_sbindir}/grub-set-default
469 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
470 %attr(755,root,root) %{_sbindir}/update-grub
471 %ifarch %{ix86} %{x8664} x32
472 %attr(755,root,root) %{_sbindir}/grub-bios-setup
473 %{_mandir}/man8/grub-bios-setup.8*
474 %endif
475 %ifarch %{ix86} %{x8664} x32
476 %attr(755,root,root) %{_sbindir}/grub-mkimage
477 %{_mandir}/man1/grub-mkimage.1*
478 %else
479 %attr(755,root,root) %{_sbindir}/grub-probe
480 %{_mandir}/man8/grub-probe.8*
481 %endif
482 %ifarch sparc64
483 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
484 %{_mandir}/man8/grub-sparc64-setup.8*
485 %endif
486 %{_mandir}/man1/grub-editenv.1*
487 %{_mandir}/man1/grub-file.1*
488 %{_mandir}/man1/grub-fstest.1*
489 %{_mandir}/man1/grub-glue-efi.1*
490 %{_mandir}/man1/grub-kbdcomp.1*
491 %{_mandir}/man1/grub-macbless.1*
492 %{_mandir}/man1/grub-menulst2cfg.1*
493 %{_mandir}/man1/grub-mklayout.1*
494 %{_mandir}/man1/grub-mknetdir.1*
495 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
496 %{_mandir}/man1/grub-mkrelpath.1*
497 %{_mandir}/man1/grub-mkrescue.1*
498 %{_mandir}/man1/grub-mkstandalone.1*
499 %{_mandir}/man1/grub-mount.1*
500 %{_mandir}/man1/grub-render-label.1*
501 %{_mandir}/man1/grub-script-check.1*
502 %{_mandir}/man1/grub-syslinux2cfg.1*
503 %{_mandir}/man8/grub-install.8*
504 %{_mandir}/man8/grub-mkconfig.8*
505 %{_mandir}/man8/grub-ofpathname.8*
506 %{_mandir}/man8/grub-reboot.8*
507 %{_mandir}/man8/grub-set-default.8*
508 %{_mandir}/man8/update-grub.8*
509 %if %{with grubemu}
510 %attr(755,root,root) %{_sbindir}/grub-emu
511 %{_mandir}/man8/grub-emu.8*
512 %endif
513 %{_libexecdir}/grub-mkconfig_lib
514
515 %dir %{_grubdir}
516 %dir %{_libexecdir}
517 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
518
519 %dir %{_libexecdir}/locale
520 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
521 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
522
523 # generated by grub at runtime
524 %ghost %{_grubdir}/device.map
525 %ghost %{_grubdir}/core.img
526 %ghost %{_grubdir}/grubenv
527
528 %dir /lib/grub.d
529 %doc /lib/grub.d/README
530 %attr(755,root,root) /lib/grub.d/00_header
531 %attr(755,root,root) /lib/grub.d/10_linux
532 %attr(755,root,root) /lib/grub.d/20_linux_xen
533 %attr(755,root,root) /lib/grub.d/30_os-prober
534 %attr(755,root,root) /lib/grub.d/41_custom
535
536 # these are now installed only on matching hosts
537 #%attr(755,root,root) /lib/grub.d/10_hurd
538 #%attr(755,root,root) /lib/grub.d/10_illumos
539 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
540 #%attr(755,root,root) /lib/grub.d/10_netbsd
541 #%attr(755,root,root) /lib/grub.d/10_xnu
542
543 %ifarch %{ix86} %{x8664} x32
544 %attr(755,root,root) %{_sbindir}/grub-probe
545 %{_mandir}/man8/grub-probe.8*
546 %endif
547
548 %{_infodir}/grub*.info*
549
550 %dir %{_datadir}/grub/themes
551
552 %if %{with pc}
553 %files platform-pc
554 %defattr(644,root,root,755)
555 %dir %{_libexecdir}/*-pc
556 %{_libexecdir}/*-pc/modinfo.sh
557 %{_libexecdir}/*-pc/*.exec
558 %{_libexecdir}/*-pc/*.image
559 %{_libexecdir}/*-pc/*.lst
560 %{_libexecdir}/*-pc/*.mod
561 %{_libexecdir}/*-pc/*.module
562 %{_libexecdir}/*-pc/lzma_decompress.img
563 %{_libexecdir}/*-pc/config.h
564 %{_libexecdir}/*-pc/gdb_grub
565 %{_libexecdir}/*-pc/gmodule.pl
566 %if %{with efiemu}
567 %{_libexecdir}/*-pc/efiemu*.o
568 %endif
569 %{_libexecdir}/*-pc/kernel.img
570 %ifarch %{ix86} %{x8664} x32 sparc sparc64
571 %{_libexecdir}/*-pc/boot.img
572 %{_libexecdir}/*-pc/boot_hybrid.img
573 %{_libexecdir}/*-pc/cdboot.img
574 %{_libexecdir}/*-pc/diskboot.img
575 %{_libexecdir}/*-pc/lnxboot.img
576 %{_libexecdir}/*-pc/pxeboot.img
577 %endif
578 %endif
579
580 %if %{with efi}
581 %files platform-efi
582 %defattr(644,root,root,755)
583 %dir %{_libexecdir}/*-efi
584 %{_libexecdir}/*-efi/modinfo.sh
585 %{_libexecdir}/*-efi/*.exec
586 %{_libexecdir}/*-efi/*.lst
587 %{_libexecdir}/*-efi/*.mod
588 %{_libexecdir}/*-efi/*.module
589 %{_libexecdir}/*-efi/config.h
590 %{_libexecdir}/*-efi/gdb_grub
591 %{_libexecdir}/*-efi/gmodule.pl
592 %{_libexecdir}/*-efi/kernel.img
593 %endif
594
595 %files mkfont
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_sbindir}/grub-mkfont
598 %{_mandir}/man1/grub-mkfont.1*
599
600 %files theme-starfield
601 %defattr(644,root,root,755)
602 %{_datadir}/grub/themes/starfield
603
604 %files -n bash-completion-%{name}
605 %defattr(644,root,root,755)
606 /etc/bash_completion.d/grub
This page took 0.066268 seconds and 3 git commands to generate.