]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
- add x32 support
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664} x32
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} x32 ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664} x32
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} x32 ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 Summary:        GRand Unified Bootloader
43 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
44 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
45 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
46 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
47 %define beta    beta2
48 Name:           grub2
49 Version:        2.02
50 Release:        0.%{beta}.3
51 License:        GPL v2
52 Group:          Base
53 # git://git.savannah.gnu.org/grub.git
54 # git checkout %{version}~%{beta} ; make dist
55 Source0:        grub-%{version}~%{beta}.tar.gz
56 # Source0-md5:  ca6c18f6c5f1ed05b7444017a40573d9
57 Source1:        update-grub
58 Source2:        update-grub.8
59 Source3:        grub.sysconfig
60 Source4:        grub-custom.cfg
61 # ./linguas.sh
62 # TS=$(date +'%Y%m%d') ; tar cjvf grub-po-2.00.git$TS.tar.bz2 po/*.po po/LINGUAS
63 Source5:        grub-po-%{version}.git20140104.tar.bz2
64 # Source5-md5:  aeef3e636178093cf9d780d92da7afdb
65 Patch1:         pld-sysconfdir.patch
66 Patch2:         grub-garbage.patch
67 Patch3:         grub-lvmdevice.patch
68 Patch4:         pld-mkconfigdir.patch
69 Patch5:         grub-mkconfig-diagnostics.patch
70 Patch6:         posix.patch
71 Patch7:         %{name}-fonts_path.patch
72 Patch8:         add-vlan-tag-support.patch
73 Patch9:         just-say-linux.patch
74 Patch10:        ignore-kernel-symlinks.patch
75 Patch11:        choose-preferred-initrd.patch
76 Patch12:        %{name}-cfg.patch
77 Patch13:        efi-net-fix.patch
78 URL:            http://www.gnu.org/software/grub/
79 BuildRequires:  autoconf >= 2.53
80 BuildRequires:  automake >= 1:1.11.1-1
81 BuildRequires:  bison
82 BuildRequires:  device-mapper-devel
83 BuildRequires:  flex >= 2.5.35
84 BuildRequires:  fonts-TTF-DejaVu
85 BuildRequires:  freetype-devel >= 2
86 BuildRequires:  gawk
87 BuildRequires:  gcc >= 5:3.4
88 BuildRequires:  gettext-tools
89 BuildRequires:  glibc-localedb-all
90 BuildRequires:  glibc-static
91 BuildRequires:  help2man
92 BuildRequires:  libfuse-devel
93 BuildRequires:  libtool
94 BuildRequires:  ncurses-devel
95 BuildRequires:  python
96 BuildRequires:  python-modules
97 BuildRequires:  rpm >= 4.4.9-56
98 BuildRequires:  rpmbuild(macros) >= 1.213
99 BuildRequires:  sed >= 4.0
100 BuildRequires:  tar >= 1:1.22
101 BuildRequires:  texinfo
102 BuildRequires:  xz
103 BuildRequires:  xz-devel
104 %ifarch %{x8664}
105 BuildRequires:  /usr/lib/libc.so
106 %if "%{pld_release}" == "ac"
107 BuildRequires:  libgcc32
108 %else
109 BuildRequires:  gcc-multilib-32
110 %endif
111 %endif
112 Requires:       %{name}-platform = %{version}-%{release}
113 Requires:       pld-release
114 Requires:       which
115 %ifarch %{ix86} %{x8664}
116 Suggests:       %{name}-platform-pc
117 %endif
118 Suggests:       cdrkit-mkisofs
119 Suggests:       os-prober
120 Provides:       bootloader
121 Conflicts:      grub
122 ExclusiveArch:  %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %define         _sbindir        /sbin
126 %define         _bindir         %{_sbindir}
127 %define         _libdir         /lib
128 %define         _datadir        %{_libdir}
129 %define         _libexecdir     %{_libdir}/grub
130 %define         _grubdir        /boot/grub
131 %define         _localedir      /usr/share/locale
132
133 # part of grub code is not relocable (these are not Linux libs)
134 # stack protector also breaks non-Linux binaries
135 # any kind of forced optimizations makes grub2 unreliable (random
136 # reboots and hangs on boot menu screen)
137 %define         filterout_c     -fPIC -O.
138 %undefine       _ssp_cflags
139 %undefine       _fortify_cflags
140
141 %description
142 GRUB is a GPLed bootloader intended to unify bootloading across x86
143 operating systems. In addition to loading the Linux and *BSD kernels,
144 it implements the Multiboot standard, which allows for flexible
145 loading of multiple boot images (needed for modular kernels such as
146 the GNU Hurd).
147
148 GRUB 2 is derived from PUPA which was a research project to
149 investigate the next generation of GRUB. GRUB 2 has been rewritten
150 from scratch to clean up everything for modularity and portability.
151
152 GRUB 2 targets at the following goals:
153 - Scripting support, such as conditionals, loops, variables and
154   functions.
155 - Graphical interface.
156 - Dynamic loading of modules in order to extend itself at the run time
157   rather than at the build time.
158 - Portability for various architectures.
159 - Internationalization. This includes support for non-ASCII character
160   code, message catalogs like gettext, fonts, graphics console, and so
161   on.
162 - Real memory management, to make GNU GRUB more extensible.
163 - Modular, hierarchical, object-oriented framework for file systems,
164   files, devices, drives, terminals, commands, partition tables and OS
165   loaders.
166 - Cross-platform installation which allows for installing GRUB from a
167   different architecture.
168 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
169 - Fix design mistakes in GRUB Legacy, which could not be solved for
170   backward-compatibility, such as the way of numbering partitions.
171
172 %description -l de.UTF-8
173 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
174 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
175 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
176
177 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
178 und wird unter der GPL vertrieben. Aufgrund seiner höheren
179 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
180 traditionellen Boot-Loader LILO.
181
182 %description -l hu.UTF-8
183 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
184 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
185 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
186 GNU Hurd).
187
188 GRUB2 céljai a következők:
189 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
190   függvények.
191 - grafikus felület
192 - modulok dinamikus betöltése futási időben
193 - hordozhatóság több architektúrára
194 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
195   mint gettext, betűtípusok, grafikus konzolon, és így tovább
196 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
197 - moduláris, hierarchikus, objektum-orientált keretrendszer
198   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
199   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
200
201 %description -l es.UTF-8
202 Éste es GRUB - Grand Unified Boot Loader - un administrador de
203 inicialización capaz de entrar en la mayoría de los sistemas
204 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
205 también en la mayoría de los sistemas operacionales comerciales para
206 PC.
207
208 El administrador GRUB puede ser una buena alternativa a LILO, para
209 usuarios conmás experiencia y que deseen obtener más recursos de su
210 cargador de inicialización (boot loader).
211
212 %description -l pl.UTF-8
213 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
214 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
215 Linuksa i *BSD: posiada również implementację standardu Multiboot,
216 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
217 (czego wymagają modułowe jądra, takie jak GNU Hurd).
218
219 %description -l pt_BR.UTF-8
220 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
221 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
222 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
223 operacionais comerciais para PC.
224
225 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
226 avançados e que querem mais recursos de seu boot loader.
227
228 %package -n bash-completion-%{name}
229 Summary:        bash-completion for GRUB
230 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
231 Group:          Applications/Shells
232 Requires:       bash-completion
233 %if "%{_rpmversion}" >= "5"
234 BuildArch:      noarch
235 %endif
236
237 %description -n bash-completion-%{name}
238 This package provides bash-completion for GRUB.
239
240 %description -n bash-completion-%{name} -l pl.UTF-8
241 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
242
243 %package platform-pc
244 Summary:        PC BIOS platform support for GRUB
245 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
246 Group:          Base
247 Provides:       %{name}-platform = %{version}-%{release}
248
249 %description platform-pc
250 PC BIOS platform support for GRUB.
251
252 %description platform-pc -l pl.UTF-8
253 Obsługa platformy PC BIOS dla GRUB-a.
254
255 %package platform-efi
256 Summary:        (U)EFI platform support for GRUB
257 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
258 Group:          Base
259 Suggests:       efibootmgr
260 Provides:       %{name}-platform = %{version}-%{release}
261
262 %description platform-efi
263 (U)EFI platform support for GRUB.
264
265 %description platform-efi -l pl.UTF-8
266 Obsługa platformy (U)EFI dla GRUB-a.
267
268 %package mkfont
269 Summary:        GRUB font files converter
270 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
271 Group:          Base
272
273 %description mkfont
274 Converts common font file formats into PF2.
275
276 %description mkfont -l pl.UTF-8
277 Program do konwersji popularnych formatów plików fontów do PF2.
278
279 %package theme-starfield
280 Summary:        starfield theme for GRUB
281 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
282 Group:          Base
283
284 %description theme-starfield
285 starfield theme for GRUB.
286
287 %description theme-starfield -l pl.UTF-8
288 Motyw starfield dla GRUB-a.
289
290 %prep
291 %setup -q -n grub-%{version}~%{beta} -a5
292 %patch1 -p1
293 %patch2 -p1
294 %patch3 -p1
295 %patch4 -p1
296 %patch5 -p1
297 %patch6 -p1
298 %patch7 -p1
299 %patch8 -p1
300 %patch9 -p1
301 %patch10 -p1
302 %patch11 -p1
303 %patch12 -p0
304 %patch13 -p1
305
306 # we don't have C.utf-8 and need an UTF-8 locale for build
307 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
308
309 %build
310 # if gold is used then grub doesn't even boot
311 # https://savannah.gnu.org/bugs/?34539
312 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
313 install -d our-ld
314 ln -f -s /usr/bin/ld.bfd our-ld/ld
315 export PATH=$(pwd)/our-ld:$PATH
316
317 ## not only the typicall autotools stuff
318 #./autogen.sh
319
320 #{__gettextize}
321 %{__aclocal} -I m4
322 %{__autoconf}
323 %{__autoheader}
324 %{__automake}
325
326 for platform in %{platforms} ; do
327         install -d build-${platform}
328         cd build-${platform}
329
330         if [ "$platform" != "efi" ] ; then
331                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
332         else
333                 platform_opts=""
334         fi
335
336         ln -f -s ../configure .
337         # mawk stalls at ./genmoddep.awk, so force gawk
338         AWK=gawk \
339         %configure \
340                 --with-platform=${platform} \
341                 --disable-werror \
342         %if %{with grubemu}
343                 --enable-grub-emu-usb \
344                 --enable-grub-emu-sdl \
345                 --enable-grub-emu-pci \
346         %endif
347                 $platform_opts \
348                 TARGET_LDFLAGS=-static
349
350         %{__make} -j1 -C po update-gmo
351         %{__make}
352         cd ..
353 done
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357
358 for platform in %{platforms} ; do
359         cd build-${platform}
360         %{__make} install \
361                 pkgdatadir=%{_libexecdir} \
362                 pkglibdir=%{_libexecdir} \
363                 DESTDIR=$RPM_BUILD_ROOT
364         cd ..
365 done
366
367 # not in Th (?)
368 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
369 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
370
371 %find_lang grub
372
373 # this must be after 'make install'
374 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
375
376 install -d $RPM_BUILD_ROOT%{_grubdir}
377 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
378
379 # grub.d/41_custom
380 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
381 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
382
383 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
384 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
385
386 install -d $RPM_BUILD_ROOT/etc/sysconfig
387 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
388
389 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
390 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
391
392 # platform specific, unnecessarily always installed
393 %ifnarch %{ix86} %{x8664} x32
394 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
395 %endif
396 %ifnarch sparc64
397 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
398 %endif
399
400 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
401 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
402 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
403
404 # needs to be exactly 1KiB
405 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
406 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
407
408 %clean
409 rm -rf $RPM_BUILD_ROOT
410
411 %post -p %{_sbindir}/postshell
412 -/usr/sbin/fix-info-dir -c %{_infodir}
413
414 %postun -p %{_sbindir}/postshell
415 -/usr/sbin/fix-info-dir -c %{_infodir}
416
417 %triggerpostun -- %{name} < 2.00-2
418 # Note this trigger on version upgrade needed only for upgrade from
419 # old grub2 packages which contained modules in /boot/grub
420 # or were built with optimizations enabled
421 # don't do anything on --downgrade
422 if [ $1 -le 1 ]; then
423         exit 0
424 fi
425 echo "Grub was upgraded, trying to setup it to boot sector"
426 /sbin/grub-install '(hd0)' || :
427
428 %triggerpostun -- %{name} < 1.99-7.3
429 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
430 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
431         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
432         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
433 fi
434
435 %files -f grub.lang
436 %defattr(644,root,root,755)
437 %doc AUTHORS ChangeLog NEWS README THANKS TODO
438 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
439 %attr(755,root,root) %{_sbindir}/grub-editenv
440 %attr(755,root,root) %{_sbindir}/grub-fstest
441 %attr(755,root,root) %{_sbindir}/grub-file
442 %attr(755,root,root) %{_sbindir}/grub-glue-efi
443 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
444 %attr(755,root,root) %{_sbindir}/grub-install
445 %attr(755,root,root) %{_sbindir}/grub-macbless
446 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
447 %attr(755,root,root) %{_sbindir}/grub-mkconfig
448 %attr(755,root,root) %{_sbindir}/grub-mklayout
449 %attr(755,root,root) %{_sbindir}/grub-mknetdir
450 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
451 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
452 %attr(755,root,root) %{_sbindir}/grub-mkrescue
453 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
454 %attr(755,root,root) %{_sbindir}/grub-mount
455 %attr(755,root,root) %{_sbindir}/grub-ofpathname
456 %attr(755,root,root) %{_sbindir}/grub-reboot
457 %attr(755,root,root) %{_sbindir}/grub-render-label
458 %attr(755,root,root) %{_sbindir}/grub-script-check
459 %attr(755,root,root) %{_sbindir}/grub-set-default
460 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
461 %attr(755,root,root) %{_sbindir}/update-grub
462 %ifarch %{ix86} %{x8664} x32
463 %attr(755,root,root) %{_sbindir}/grub-bios-setup
464 %{_mandir}/man8/grub-bios-setup.8*
465 %endif
466 %ifarch %{ix86} %{x8664} x32
467 %attr(755,root,root) %{_sbindir}/grub-mkimage
468 %{_mandir}/man1/grub-mkimage.1*
469 %else
470 %attr(755,root,root) %{_sbindir}/grub-probe
471 %{_mandir}/man8/grub-probe.8*
472 %endif
473 %ifarch sparc64
474 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
475 %{_mandir}/man8/grub-sparc64-setup.8*
476 %endif
477 %{_mandir}/man1/grub-editenv.1*
478 %{_mandir}/man1/grub-file.1*
479 %{_mandir}/man1/grub-fstest.1*
480 %{_mandir}/man1/grub-glue-efi.1*
481 %{_mandir}/man1/grub-kbdcomp.1*
482 %{_mandir}/man1/grub-macbless.1*
483 %{_mandir}/man1/grub-menulst2cfg.1*
484 %{_mandir}/man1/grub-mklayout.1*
485 %{_mandir}/man1/grub-mknetdir.1*
486 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
487 %{_mandir}/man1/grub-mkrelpath.1*
488 %{_mandir}/man1/grub-mkrescue.1*
489 %{_mandir}/man1/grub-mkstandalone.1*
490 %{_mandir}/man1/grub-mount.1*
491 %{_mandir}/man1/grub-render-label.1*
492 %{_mandir}/man1/grub-script-check.1*
493 %{_mandir}/man1/grub-syslinux2cfg.1*
494 %{_mandir}/man8/grub-install.8*
495 %{_mandir}/man8/grub-mkconfig.8*
496 %{_mandir}/man8/grub-ofpathname.8*
497 %{_mandir}/man8/grub-reboot.8*
498 %{_mandir}/man8/grub-set-default.8*
499 %{_mandir}/man8/update-grub.8*
500 %if %{with grubemu}
501 %attr(755,root,root) %{_sbindir}/grub-emu
502 %{_mandir}/man8/grub-emu.8*
503 %endif
504 %{_libexecdir}/grub-mkconfig_lib
505
506 %dir %{_grubdir}
507 %dir %{_libexecdir}
508 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
509
510 %dir %{_libexecdir}/locale
511 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
512 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
513
514 # generated by grub at runtime
515 %ghost %{_grubdir}/device.map
516 %ghost %{_grubdir}/core.img
517 %ghost %{_grubdir}/grubenv
518
519 %dir /lib/grub.d
520 %doc /lib/grub.d/README
521 %attr(755,root,root) /lib/grub.d/00_header
522 %attr(755,root,root) /lib/grub.d/10_linux
523 %attr(755,root,root) /lib/grub.d/20_linux_xen
524 %attr(755,root,root) /lib/grub.d/30_os-prober
525 %attr(755,root,root) /lib/grub.d/41_custom
526
527 # these are now installed only on matching hosts
528 #%attr(755,root,root) /lib/grub.d/10_hurd
529 #%attr(755,root,root) /lib/grub.d/10_illumos
530 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
531 #%attr(755,root,root) /lib/grub.d/10_netbsd
532 #%attr(755,root,root) /lib/grub.d/10_xnu
533
534 %ifarch %{ix86} %{x8664} x32
535 %attr(755,root,root) %{_sbindir}/grub-probe
536 %{_mandir}/man8/grub-probe.8*
537 %endif
538
539 %{_infodir}/grub*.info*
540
541 %dir %{_datadir}/grub/themes
542
543 %if %{with pc}
544 %files platform-pc
545 %defattr(644,root,root,755)
546 %dir %{_libexecdir}/*-pc
547 %{_libexecdir}/*-pc/modinfo.sh
548 %{_libexecdir}/*-pc/*.exec
549 %{_libexecdir}/*-pc/*.image
550 %{_libexecdir}/*-pc/*.lst
551 %{_libexecdir}/*-pc/*.mod
552 %{_libexecdir}/*-pc/*.module
553 %{_libexecdir}/*-pc/lzma_decompress.img
554 %{_libexecdir}/*-pc/config.h
555 %{_libexecdir}/*-pc/gdb_grub
556 %{_libexecdir}/*-pc/gmodule.pl
557 %if %{with efiemu}
558 %{_libexecdir}/*-pc/efiemu*.o
559 %endif
560 %{_libexecdir}/*-pc/kernel.img
561 %ifarch %{ix86} %{x8664} x32 sparc sparc64
562 %{_libexecdir}/*-pc/boot.img
563 %{_libexecdir}/*-pc/boot_hybrid.img
564 %{_libexecdir}/*-pc/cdboot.img
565 %{_libexecdir}/*-pc/diskboot.img
566 %{_libexecdir}/*-pc/lnxboot.img
567 %{_libexecdir}/*-pc/pxeboot.img
568 %endif
569 %endif
570
571 %if %{with efi}
572 %files platform-efi
573 %defattr(644,root,root,755)
574 %dir %{_libexecdir}/*-efi
575 %{_libexecdir}/*-efi/modinfo.sh
576 %{_libexecdir}/*-efi/*.exec
577 %{_libexecdir}/*-efi/*.lst
578 %{_libexecdir}/*-efi/*.mod
579 %{_libexecdir}/*-efi/*.module
580 %{_libexecdir}/*-efi/config.h
581 %{_libexecdir}/*-efi/gdb_grub
582 %{_libexecdir}/*-efi/gmodule.pl
583 %{_libexecdir}/*-efi/kernel.img
584 %endif
585
586 %files mkfont
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_sbindir}/grub-mkfont
589 %{_mandir}/man1/grub-mkfont.1*
590
591 %files theme-starfield
592 %defattr(644,root,root,755)
593 %{_datadir}/grub/themes/starfield
594
595 %files -n bash-completion-%{name}
596 %defattr(644,root,root,755)
597 /etc/bash_completion.d/grub
This page took 0.130769 seconds and 3 git commands to generate.