]> git.pld-linux.org Git - packages/grub2.git/blob - grub2.spec
- rel 2; make grub-mkconfig add ucode to grub config when needed
[packages/grub2.git] / grub2.spec
1 # TODO
2 # - reap out which in probe scripts and drop R: which
3 # - subpackages? e.g. modules and utils
4 # - check where is that locale path: /boot/grub/locale and fix it or change it
5 # - grubemu notes
6 #   --enable-grub-emu-usb conflicts with --enable-grub-emu-pci, emu-pci seems experimental
7 #   - to build and install the `grub-emu' debugging utility we need to re-run build with --target=emu
8 #   - put grub-emu to subpackage if it is fixed
9 #
10 # Conditional build:
11 %bcond_with     grubemu # build grub-emu debugging utility
12 %bcond_without  efiemu  # build efiemu runtimes
13 %bcond_without  pc      # do not build for PC BIOS platform
14 %bcond_without  efi     # do not build for EFI platform
15
16 %ifnarch %{ix86} %{x8664} x32
17 %undefine       with_pc
18 %endif
19 %ifnarch %{ix86} %{x8664} x32 ia64
20 %undefine       with_efi
21 %endif
22
23 %ifnarch %{x8664} x32
24 # non-x86_64 arch doesn't support this
25 %undefine       with_efiemu
26 %endif
27
28 # the 'most natural' platform should go last
29 %ifarch %{ix86} %{x8664} x32 ia64
30 %define         platforms %{?with_efi:efi} %{?with_pc:pc}
31 %endif
32 %ifarch ppc ppc64 sparc64
33 %define         platforms ieee1275
34 %endif
35 %ifarch mips
36 %define         platforms arc
37 %endif
38 %ifarch mipsel
39 %define         platforms loongson
40 %endif
41
42 %define         rel     1
43 Summary:        GRand Unified Bootloader
44 Summary(de.UTF-8):      GRUB2 - ein Bootloader für x86 und ppc
45 Summary(hu.UTF-8):      GRUB2 - rendszerbetöltő x86 és ppc gépekhez
46 Summary(pl.UTF-8):      GRUB2 - bootloader dla x86 i ppc
47 Summary(pt_BR.UTF-8):   Gerenciador de inicialização GRUB2
48 Name:           grub2
49 Version:        2.02
50 Release:        2
51 License:        GPL v2
52 Group:          Base
53 Source0:        ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
54 # Source0-md5:  8a4a2a95aac551fb0fba860ceabfa1d3
55 Source1:        update-grub
56 Source2:        update-grub.8
57 Source3:        grub.sysconfig
58 Source4:        grub-custom.cfg
59 Patch1:         pld-sysconfdir.patch
60 Patch2:         grub-garbage.patch
61 Patch3:         grub-lvmdevice.patch
62 Patch4:         pld-mkconfigdir.patch
63 Patch5:         grub-mkconfig-diagnostics.patch
64 Patch6:         posix.patch
65 Patch7:         %{name}-fonts_path.patch
66 Patch8:         add-vlan-tag-support.patch
67 Patch9:         just-say-linux.patch
68 Patch10:        ignore-kernel-symlinks.patch
69 Patch11:        choose-preferred-initrd.patch
70 Patch12:        %{name}-cfg.patch
71 Patch13:        efi-net-fix.patch
72 Patch14:        blscfg.patch
73 # https://git.archlinux.org/svntogit/packages.git/plain/trunk/0002-intel-ucode.patch?h=packages/grub
74 Patch15:        intel-ucode.patch
75 URL:            http://www.gnu.org/software/grub/
76 BuildRequires:  autoconf >= 2.53
77 BuildRequires:  automake >= 1:1.11.1-1
78 BuildRequires:  bison
79 BuildRequires:  device-mapper-devel
80 BuildRequires:  flex >= 2.5.35
81 BuildRequires:  fonts-TTF-DejaVu
82 BuildRequires:  freetype-devel >= 2
83 BuildRequires:  gawk
84 BuildRequires:  gcc >= 5:3.4
85 BuildRequires:  gettext-tools
86 BuildRequires:  glibc-localedb-all
87 BuildRequires:  glibc-static
88 BuildRequires:  help2man
89 BuildRequires:  libfuse-devel
90 BuildRequires:  libtool
91 BuildRequires:  ncurses-devel
92 BuildRequires:  python
93 BuildRequires:  python-modules
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.213
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  tar >= 1:1.22
98 BuildRequires:  texinfo
99 BuildRequires:  xz
100 BuildRequires:  xz-devel
101 %ifarch %{x8664}
102 BuildRequires:  /usr/lib/libc.so
103 %if "%{pld_release}" == "ac"
104 BuildRequires:  libgcc32
105 %else
106 BuildRequires:  gcc-multilib-32
107 %endif
108 %endif
109 Requires:       %{name}-platform = %{version}-%{release}
110 Requires:       pld-release
111 Requires:       which
112 %ifarch %{ix86} %{x8664}
113 Suggests:       %{name}-platform-pc
114 %endif
115 Suggests:       cdrkit-mkisofs
116 Suggests:       os-prober
117 Provides:       bootloader
118 Conflicts:      grub
119 ExclusiveArch:  %{ix86} %{x8664} x32 ia64 mips mipsel ppc ppc64 sparc64
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         _sbindir        /sbin
123 %define         _bindir         %{_sbindir}
124 %define         _libdir         /lib
125 %define         _datadir        %{_libdir}
126 %define         _libexecdir     %{_libdir}/grub
127 %define         _grubdir        /boot/grub
128 %define         _localedir      /usr/share/locale
129
130 # part of grub code is not relocable (these are not Linux libs)
131 # stack protector also breaks non-Linux binaries
132 # any kind of forced optimizations makes grub2 unreliable (random
133 # reboots and hangs on boot menu screen)
134 %define         filterout_c     -fPIC -O.
135 %undefine       _ssp_cflags
136 %undefine       _fortify_cflags
137
138 %description
139 GRUB is a GPLed bootloader intended to unify bootloading across x86
140 operating systems. In addition to loading the Linux and *BSD kernels,
141 it implements the Multiboot standard, which allows for flexible
142 loading of multiple boot images (needed for modular kernels such as
143 the GNU Hurd).
144
145 GRUB 2 is derived from PUPA which was a research project to
146 investigate the next generation of GRUB. GRUB 2 has been rewritten
147 from scratch to clean up everything for modularity and portability.
148
149 GRUB 2 targets at the following goals:
150 - Scripting support, such as conditionals, loops, variables and
151   functions.
152 - Graphical interface.
153 - Dynamic loading of modules in order to extend itself at the run time
154   rather than at the build time.
155 - Portability for various architectures.
156 - Internationalization. This includes support for non-ASCII character
157   code, message catalogs like gettext, fonts, graphics console, and so
158   on.
159 - Real memory management, to make GNU GRUB more extensible.
160 - Modular, hierarchical, object-oriented framework for file systems,
161   files, devices, drives, terminals, commands, partition tables and OS
162   loaders.
163 - Cross-platform installation which allows for installing GRUB from a
164   different architecture.
165 - Rescue mode saves unbootable cases. Stage 1.5 was eliminated.
166 - Fix design mistakes in GRUB Legacy, which could not be solved for
167   backward-compatibility, such as the way of numbering partitions.
168
169 %description -l de.UTF-8
170 GRUB (GRand Unified Boot-loader) ist ein Bootloader, der oft auf
171 Rechnern eingesetzt wird, auf denen das freie Betriebssystem Linux
172 läuft. GRUB löst den betagten LILO (Linux-Loader) ab.
173
174 GRUB wurde innerhalb des GNU Hurd-Projektes als Boot-Loader entwickelt
175 und wird unter der GPL vertrieben. Aufgrund seiner höheren
176 Flexibilität verdrängt GRUB in vielen Linux-Distributionen den
177 traditionellen Boot-Loader LILO.
178
179 %description -l hu.UTF-8
180 GRUB egy GPL liszenszű rendszerbetöltő. Linux és *BSD kernelek
181 betöltése mellett támogatja a Multiboot standard-ot, amely lehetővé
182 teszi boot képek betöltését (moduláris kerneleknek kell, mint pl. a
183 GNU Hurd).
184
185 GRUB2 céljai a következők:
186 - szkriptelés támogatása, úgymint feltételek, ciklusok, változók,
187   függvények.
188 - grafikus felület
189 - modulok dinamikus betöltése futási időben
190 - hordozhatóság több architektúrára
191 - többnyelvűség: nem-ASCII karakterek támogatása, üzenetkatalógusok,
192   mint gettext, betűtípusok, grafikus konzolon, és így tovább
193 - valós memória kezelés, amellyel még bővíthetőbbé tehetjük
194 - moduláris, hierarchikus, objektum-orientált keretrendszer
195   fájlrendszerekhez, fájlokhoz, eszközökhöz, meghajtókhoz,
196   terminálokhoz, parancsokhoz, partíciós táblákhoz és OS betöltőkhöz
197
198 %description -l es.UTF-8
199 Éste es GRUB - Grand Unified Boot Loader - un administrador de
200 inicialización capaz de entrar en la mayoría de los sistemas
201 operacionales libres - Linux, FreeBSD, NetBSD, GNU Mach, etc. como
202 también en la mayoría de los sistemas operacionales comerciales para
203 PC.
204
205 El administrador GRUB puede ser una buena alternativa a LILO, para
206 usuarios conmás experiencia y que deseen obtener más recursos de su
207 cargador de inicialización (boot loader).
208
209 %description -l pl.UTF-8
210 GRUB jest bootloaderem na licencji GNU GPL, mającym na celu unifikację
211 procesu bootowania na systemach x86. Potrafi nie tylko ładować jądra
212 Linuksa i *BSD: posiada również implementację standardu Multiboot,
213 który pozwala na elastyczne ładowanie wielu obrazów bootowalnych
214 (czego wymagają modułowe jądra, takie jak GNU Hurd).
215
216 %description -l pt_BR.UTF-8
217 Esse é o GRUB - Grand Unified Boot Loader - um gerenciador de boot
218 capaz de entrar na maioria dos sistemas operacionais livres - Linux,
219 FreeBSD, NetBSD, GNU Mach, etc. assim como na maioria dos sistemas
220 operacionais comerciais para PC.
221
222 O GRUB pode ser uma boa alternativa ao LILO, para usuários mais
223 avançados e que querem mais recursos de seu boot loader.
224
225 %package -n bash-completion-%{name}
226 Summary:        bash-completion for GRUB
227 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla GRUB-a
228 Group:          Applications/Shells
229 Requires:       bash-completion
230 %if "%{_rpmversion}" >= "5"
231 BuildArch:      noarch
232 %endif
233
234 %description -n bash-completion-%{name}
235 This package provides bash-completion for GRUB.
236
237 %description -n bash-completion-%{name} -l pl.UTF-8
238 Pakiet ten dostarcza bashowe uzupełnianie nazw dla GRUB-a.
239
240 %package platform-pc
241 Summary:        PC BIOS platform support for GRUB
242 Summary(pl.UTF-8):      Obsługa platformy PC BIOS dla GRUB-a
243 Group:          Base
244 Provides:       %{name}-platform = %{version}-%{release}
245
246 %description platform-pc
247 PC BIOS platform support for GRUB.
248
249 %description platform-pc -l pl.UTF-8
250 Obsługa platformy PC BIOS dla GRUB-a.
251
252 %package platform-efi
253 Summary:        (U)EFI platform support for GRUB
254 Summary(pl.UTF-8):      Obsługa platformy (U)EFI dla GRUB-a
255 Group:          Base
256 Suggests:       efibootmgr
257 Provides:       %{name}-platform = %{version}-%{release}
258
259 %description platform-efi
260 (U)EFI platform support for GRUB.
261
262 %description platform-efi -l pl.UTF-8
263 Obsługa platformy (U)EFI dla GRUB-a.
264
265 %package mkfont
266 Summary:        GRUB font files converter
267 Summary(pl.UTF-8):      Konwerter plików fontów GRUB-a
268 Group:          Base
269
270 %description mkfont
271 Converts common font file formats into PF2.
272
273 %description mkfont -l pl.UTF-8
274 Program do konwersji popularnych formatów plików fontów do PF2.
275
276 %package theme-starfield
277 Summary:        starfield theme for GRUB
278 Summary(pl.UTF-8):      Motyw starfield dla GRUB-a
279 Group:          Base
280
281 %description theme-starfield
282 starfield theme for GRUB.
283
284 %description theme-starfield -l pl.UTF-8
285 Motyw starfield dla GRUB-a.
286
287 %prep
288 %setup -q -n grub-%{version}
289 %patch1 -p1
290 %patch2 -p1
291 %patch3 -p1
292 %patch4 -p1
293 %patch5 -p1
294 %patch6 -p1
295 %patch7 -p1
296 %patch8 -p1
297 %patch9 -p1
298 %patch10 -p1
299 %patch11 -p1
300 %patch12 -p0
301 %patch13 -p1
302 %patch14 -p1
303 %patch15 -p1
304
305 # we don't have C.utf-8 and need an UTF-8 locale for build
306 sed -i -e 's/LC_ALL=C.UTF-8/LC_ALL=en_US.utf-8/g' po/Makefile* po/Rules*
307
308 %build
309 # if gold is used then grub doesn't even boot
310 # https://savannah.gnu.org/bugs/?34539
311 # http://sourceware.org/bugzilla/show_bug.cgi?id=14196
312 install -d our-ld
313 ln -f -s /usr/bin/ld.bfd our-ld/ld
314 export PATH=$(pwd)/our-ld:$PATH
315
316 ## not only the typicall autotools stuff
317 #./autogen.sh
318
319 #{__gettextize}
320 %{__aclocal} -I m4
321 %{__autoconf}
322 %{__autoheader}
323 %{__automake}
324
325 for platform in %{platforms} ; do
326         install -d build-${platform}
327         cd build-${platform}
328
329         if [ "$platform" != "efi" ] ; then
330                 platform_opts="--enable-efiemu%{!?with_efiemu:=no}"
331         else
332                 platform_opts=""
333         fi
334
335         ln -f -s ../configure .
336         # mawk stalls at ./genmoddep.awk, so force gawk
337         AWK=gawk \
338         %configure \
339                 --with-platform=${platform} \
340                 --disable-werror \
341         %if %{with grubemu}
342                 --enable-grub-emu-usb \
343                 --enable-grub-emu-sdl \
344                 --enable-grub-emu-pci \
345         %endif
346                 $platform_opts \
347                 TARGET_LDFLAGS=-static
348
349         %{__make} -j1 -C po update-gmo
350         %{__make}
351         cd ..
352 done
353
354 %install
355 rm -rf $RPM_BUILD_ROOT
356
357 for platform in %{platforms} ; do
358         cd build-${platform}
359         %{__make} install \
360                 pkgdatadir=%{_libexecdir} \
361                 pkglibdir=%{_libexecdir} \
362                 DESTDIR=$RPM_BUILD_ROOT
363         cd ..
364 done
365
366 # not in Th (?)
367 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/de@hebrew
368 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en@{arabic,cyrillic,greek,hebrew,piglatin}
369
370 %find_lang grub
371
372 # this must be after 'make install'
373 install -d $RPM_BUILD_ROOT%{_libexecdir}/locale
374
375 install -d $RPM_BUILD_ROOT%{_grubdir}
376 cp -p docs/grub.cfg $RPM_BUILD_ROOT%{_grubdir}
377
378 # grub.d/41_custom
379 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_grubdir}/custom.cfg
380 %{__rm} $RPM_BUILD_ROOT/lib/grub.d/40_custom
381
382 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/update-grub
383 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man8/update-grub.8
384
385 install -d $RPM_BUILD_ROOT/etc/sysconfig
386 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/grub
387
388 # rm -f, because it sometimes exists, sometimes not, depending which texlive you have installed
389 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
390
391 # platform specific, unnecessarily always installed
392 %ifnarch %{ix86} %{x8664} x32
393 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-bios-setup,%{_mandir}/man8/grub-bios-setup.8}
394 %endif
395 %ifnarch sparc64
396 %{__rm} $RPM_BUILD_ROOT{%{_sbindir}/grub-sparc64-setup,%{_mandir}/man8/grub-sparc64-setup.8}
397 %endif
398
399 # core.img - bootable image generated by grub-mkimage(1) via grub-install(1)
400 touch $RPM_BUILD_ROOT%{_grubdir}/core.img
401 touch $RPM_BUILD_ROOT%{_grubdir}/device.map
402
403 # needs to be exactly 1KiB
404 # but we're ghosting it. so whom are we kidding here? :P (maybe %config it in future?)
405 dd bs=1024 if=/dev/zero count=1 of=$RPM_BUILD_ROOT%{_grubdir}/grubenv
406
407 %clean
408 rm -rf $RPM_BUILD_ROOT
409
410 %post -p %{_sbindir}/postshell
411 -/usr/sbin/fix-info-dir -c %{_infodir}
412
413 %postun -p %{_sbindir}/postshell
414 -/usr/sbin/fix-info-dir -c %{_infodir}
415
416 %triggerpostun -- %{name} < 2.00-2
417 # Note this trigger on version upgrade needed only for upgrade from
418 # old grub2 packages which contained modules in /boot/grub
419 # or were built with optimizations enabled
420 # don't do anything on --downgrade
421 if [ $1 -le 1 ]; then
422         exit 0
423 fi
424 echo "Grub was upgraded, trying to setup it to boot sector"
425 /sbin/grub-install '(hd0)' || :
426
427 %triggerpostun -- %{name} < 1.99-7.3
428 # migrate /etc/grub.d/custom.cfg.rpmsave  -> /boot/grub/custom.cfg
429 if [ -f %{_sysconfdir}/grub.d/custom.cfg.rpmsave ]; then
430         cp -f %{_grubdir}/custom.cfg{,.rpmnew}
431         mv -f  %{_sysconfdir}/grub.d/custom.cfg.rpmsave %{_grubdir}/custom.cfg
432 fi
433
434 %files -f grub.lang
435 %defattr(644,root,root,755)
436 %doc AUTHORS ChangeLog NEWS README THANKS TODO
437 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/grub
438 %attr(755,root,root) %{_sbindir}/grub-editenv
439 %attr(755,root,root) %{_sbindir}/grub-fstest
440 %attr(755,root,root) %{_sbindir}/grub-file
441 %attr(755,root,root) %{_sbindir}/grub-glue-efi
442 %attr(755,root,root) %{_sbindir}/grub-kbdcomp
443 %attr(755,root,root) %{_sbindir}/grub-install
444 %attr(755,root,root) %{_sbindir}/grub-macbless
445 %attr(755,root,root) %{_sbindir}/grub-menulst2cfg
446 %attr(755,root,root) %{_sbindir}/grub-mkconfig
447 %attr(755,root,root) %{_sbindir}/grub-mklayout
448 %attr(755,root,root) %{_sbindir}/grub-mknetdir
449 %attr(755,root,root) %{_sbindir}/grub-mkpasswd-pbkdf2
450 %attr(755,root,root) %{_sbindir}/grub-mkrelpath
451 %attr(755,root,root) %{_sbindir}/grub-mkrescue
452 %attr(755,root,root) %{_sbindir}/grub-mkstandalone
453 %attr(755,root,root) %{_sbindir}/grub-mount
454 %attr(755,root,root) %{_sbindir}/grub-ofpathname
455 %attr(755,root,root) %{_sbindir}/grub-reboot
456 %attr(755,root,root) %{_sbindir}/grub-render-label
457 %attr(755,root,root) %{_sbindir}/grub-script-check
458 %attr(755,root,root) %{_sbindir}/grub-set-default
459 %attr(755,root,root) %{_sbindir}/grub-syslinux2cfg
460 %attr(755,root,root) %{_sbindir}/update-grub
461 %ifarch %{ix86} %{x8664} x32
462 %attr(755,root,root) %{_sbindir}/grub-bios-setup
463 %{_mandir}/man8/grub-bios-setup.8*
464 %endif
465 %ifarch %{ix86} %{x8664} x32
466 %attr(755,root,root) %{_sbindir}/grub-mkimage
467 %{_mandir}/man1/grub-mkimage.1*
468 %else
469 %attr(755,root,root) %{_sbindir}/grub-probe
470 %{_mandir}/man8/grub-probe.8*
471 %endif
472 %ifarch sparc64
473 %attr(755,root,root) %{_sbindir}/grub-sparc64-setup
474 %{_mandir}/man8/grub-sparc64-setup.8*
475 %endif
476 %{_mandir}/man1/grub-editenv.1*
477 %{_mandir}/man1/grub-file.1*
478 %{_mandir}/man1/grub-fstest.1*
479 %{_mandir}/man1/grub-glue-efi.1*
480 %{_mandir}/man1/grub-kbdcomp.1*
481 %{_mandir}/man1/grub-menulst2cfg.1*
482 %{_mandir}/man1/grub-mklayout.1*
483 %{_mandir}/man1/grub-mknetdir.1*
484 %{_mandir}/man1/grub-mkpasswd-pbkdf2.1*
485 %{_mandir}/man1/grub-mkrelpath.1*
486 %{_mandir}/man1/grub-mkrescue.1*
487 %{_mandir}/man1/grub-mkstandalone.1*
488 %{_mandir}/man1/grub-mount.1*
489 %{_mandir}/man1/grub-render-label.1*
490 %{_mandir}/man1/grub-script-check.1*
491 %{_mandir}/man1/grub-syslinux2cfg.1*
492 %{_mandir}/man8/grub-install.8*
493 %{_mandir}/man8/grub-macbless.8*
494 %{_mandir}/man8/grub-mkconfig.8*
495 %{_mandir}/man8/grub-ofpathname.8*
496 %{_mandir}/man8/grub-reboot.8*
497 %{_mandir}/man8/grub-set-default.8*
498 %{_mandir}/man8/update-grub.8*
499 %if %{with grubemu}
500 %attr(755,root,root) %{_sbindir}/grub-emu
501 %{_mandir}/man8/grub-emu.8*
502 %endif
503 %{_libexecdir}/grub-mkconfig_lib
504
505 %dir %{_grubdir}
506 %dir %{_libexecdir}
507 # XXX: check this locale dir location and if it is neccesaary to exist on /boot
508
509 %dir %{_libexecdir}/locale
510 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/grub.cfg
511 %config(noreplace) %verify(not md5 mtime size) %{_grubdir}/custom.cfg
512
513 # generated by grub at runtime
514 %ghost %{_grubdir}/device.map
515 %ghost %{_grubdir}/core.img
516 %ghost %{_grubdir}/grubenv
517
518 %dir /lib/grub.d
519 %doc /lib/grub.d/README
520 %attr(755,root,root) /lib/grub.d/00_header
521 %attr(755,root,root) /lib/grub.d/10_linux
522 %attr(755,root,root) /lib/grub.d/20_linux_xen
523 %attr(755,root,root) /lib/grub.d/30_os-prober
524 %attr(755,root,root) /lib/grub.d/41_custom
525
526 # these are now installed only on matching hosts
527 #%attr(755,root,root) /lib/grub.d/10_hurd
528 #%attr(755,root,root) /lib/grub.d/10_illumos
529 #%attr(755,root,root) /lib/grub.d/10_kfreebsd
530 #%attr(755,root,root) /lib/grub.d/10_netbsd
531 #%attr(755,root,root) /lib/grub.d/10_xnu
532
533 %ifarch %{ix86} %{x8664} x32
534 %attr(755,root,root) %{_sbindir}/grub-probe
535 %{_mandir}/man8/grub-probe.8*
536 %endif
537
538 %{_infodir}/grub*.info*
539
540 %dir %{_datadir}/grub/themes
541
542 %if %{with pc}
543 %files platform-pc
544 %defattr(644,root,root,755)
545 %dir %{_libexecdir}/*-pc
546 %{_libexecdir}/*-pc/modinfo.sh
547 %{_libexecdir}/*-pc/*.exec
548 %{_libexecdir}/*-pc/*.image
549 %{_libexecdir}/*-pc/*.lst
550 %{_libexecdir}/*-pc/*.mod
551 %{_libexecdir}/*-pc/*.module
552 %{_libexecdir}/*-pc/lzma_decompress.img
553 %{_libexecdir}/*-pc/config.h
554 %{_libexecdir}/*-pc/gdb_grub
555 %{_libexecdir}/*-pc/gmodule.pl
556 %if %{with efiemu}
557 %{_libexecdir}/*-pc/efiemu*.o
558 %endif
559 %{_libexecdir}/*-pc/kernel.img
560 %ifarch %{ix86} %{x8664} x32 sparc sparc64
561 %{_libexecdir}/*-pc/boot.img
562 %{_libexecdir}/*-pc/boot_hybrid.img
563 %{_libexecdir}/*-pc/cdboot.img
564 %{_libexecdir}/*-pc/diskboot.img
565 %{_libexecdir}/*-pc/lnxboot.img
566 %{_libexecdir}/*-pc/pxeboot.img
567 %endif
568 %endif
569
570 %if %{with efi}
571 %files platform-efi
572 %defattr(644,root,root,755)
573 %dir %{_libexecdir}/*-efi
574 %{_libexecdir}/*-efi/modinfo.sh
575 %{_libexecdir}/*-efi/*.exec
576 %{_libexecdir}/*-efi/*.lst
577 %{_libexecdir}/*-efi/*.mod
578 %{_libexecdir}/*-efi/*.module
579 %{_libexecdir}/*-efi/config.h
580 %{_libexecdir}/*-efi/gdb_grub
581 %{_libexecdir}/*-efi/gmodule.pl
582 %{_libexecdir}/*-efi/kernel.img
583 %endif
584
585 %files mkfont
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_sbindir}/grub-mkfont
588 %{_mandir}/man1/grub-mkfont.1*
589
590 %files theme-starfield
591 %defattr(644,root,root,755)
592 %{_datadir}/grub/themes/starfield
593
594 %files -n bash-completion-%{name}
595 %defattr(644,root,root,755)
596 /etc/bash_completion.d/grub
This page took 0.216317 seconds and 3 git commands to generate.