]> git.pld-linux.org Git - packages/groovy.git/blob - groovy.spec
eda03ed43292e3b8775db4af32e8ac627dedfef4
[packages/groovy.git] / groovy.spec
1 #
2 # Conditional build:
3 %bcond_without  indy    # use libraries without invokedynamic support (compatible with JRE 1.5+)
4 #
5 Summary:        Dynamic language for the Java Platform
6 Name:           groovy
7 Version:        2.4.10
8 Release:        1
9 License:        Apache v2.0
10 Group:          Development/Languages/Java
11 Source0:        https://dl.bintray.com/groovy/maven/apache-%{name}-binary-%{version}.zip
12 # Source0-md5:  d73b320c568e5b937ea66bf0b09201ad
13 URL:            http://groovy-lang.org/
14 %if %{with indy}
15 Requires:       jdk >= 1.7
16 %else
17 Requires:       jdk >= 1.5
18 %endif
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Groovy is an agile and dynamic language for the Java Virtual Machine,
24 built upon Java with features inspired by languages like Python, Ruby
25 and Smalltalk. It seamlessly integrates with all existing Java objects
26 and libraries and compiles straight to Java bytecode so you can use it
27 anywhere you can use Java.
28
29 %prep
30 %setup -q
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name}/bin}
35 for b in grape groovy groovyConsole groovyc groovydoc groovysh java2groovy startGroovy; do
36         ln -sf %{_datadir}/%{name}/bin/$b $RPM_BUILD_ROOT%{_bindir}/$b
37 done
38
39 install -d $RPM_BUILD_ROOT
40 cp -a bin conf lib $RPM_BUILD_ROOT%{_datadir}/%{name}
41
42 %if %{with indy}
43 for f in indy/*-indy.jar; do
44         targetname=$(basename $f -indy.jar).jar
45         %{__cp} -p $f \
46                 $RPM_BUILD_ROOT%{_datadir}/%{name}/lib/$targetname
47 done
48 %endif
49
50 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/bin/*.bat
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %attr(755,root,root) %{_bindir}/grape
58 %attr(755,root,root) %{_bindir}/groovy
59 %attr(755,root,root) %{_bindir}/groovyConsole
60 %attr(755,root,root) %{_bindir}/groovyc
61 %attr(755,root,root) %{_bindir}/groovydoc
62 %attr(755,root,root) %{_bindir}/groovysh
63 %attr(755,root,root) %{_bindir}/java2groovy
64 %attr(755,root,root) %{_bindir}/startGroovy
65 %dir %{_datadir}/%{name}
66 %dir %{_datadir}/%{name}/bin
67 %attr(755,root,root) %{_datadir}/%{name}/bin/grape
68 %attr(755,root,root) %{_datadir}/%{name}/bin/groovy
69 %attr(755,root,root) %{_datadir}/%{name}/bin/groovyConsole
70 %attr(755,root,root) %{_datadir}/%{name}/bin/groovyc
71 %attr(755,root,root) %{_datadir}/%{name}/bin/groovydoc
72 %attr(755,root,root) %{_datadir}/%{name}/bin/groovysh
73 %attr(755,root,root) %{_datadir}/%{name}/bin/java2groovy
74 %attr(755,root,root) %{_datadir}/%{name}/bin/startGroovy
75 %{_datadir}/%{name}/conf
76 %{_datadir}/%{name}/lib
This page took 0.060092 seconds and 2 git commands to generate.