]> git.pld-linux.org Git - packages/grive.git/blob - grive.spec
9630e2643bbbebf95549032938268f989344f6be
[packages/grive.git] / grive.spec
1 %define         commit          27817e835fe115ebbda5410ec904aa49a2ad01f1
2 # %(c=%{commit}; echo ${c:0:7})
3 %define         shortcommit     27817e8
4 %define         cdate           20130702
5 Summary:        An open source Linux client for Google Drive
6 Name:           grive
7 Version:        0.3.0
8 Release:        0.%{cdate}git%{shortcommit}.5
9 License:        GPL v2
10 Group:          Applications/Networking
11 Source0:        https://github.com/Grive/grive/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
12 # Source0-md5:  4f3c3411588f889801bd5b9297e6e2c9
13 # https://github.com/Grive/grive/issues/187
14 Patch0:         json-c.patch
15 Patch1:         %{name}-bgrive_cmake_fix.patch
16 Patch2:         build.patch
17 URL:            http://www.lbreda.com/grive/
18 BuildRequires:  QtCore-devel
19 BuildRequires:  binutils-devel
20 BuildRequires:  boost-devel
21 BuildRequires:  cmake
22 BuildRequires:  curl-devel
23 BuildRequires:  expat-devel
24 BuildRequires:  json-c-devel >= 0.11
25 BuildRequires:  libgcrypt-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  yajl-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The purpose of this project is to provide an independent
33 implementation of Google Drive client. It uses the Google Document
34 List API to talk to the servers in Google.
35
36 %package -n bgrive
37 Summary:        Qt frontend for %{name}
38 Group:          Applications/Networking
39 Requires:       %{name} = %{version}-%{release}
40
41 %description -n bgrive
42 GUI frontend for %{name}
43
44 %prep
45 %setup -q -n %{name}-%{commit}
46 %patch0 -p1
47 %patch1 -p1
48 %patch2 -p1
49
50 %build
51 install -d build
52 cd build
53 %cmake ..
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 %{__make} -C build install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README
67 %attr(755,root,root) %{_bindir}/%{name}
68 %{_mandir}/man1/%{name}.1*
69
70 %files -n bgrive
71 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_bindir}/bgrive
This page took 0.067914 seconds and 2 git commands to generate.