]> git.pld-linux.org Git - packages/grive.git/blob - grive.spec
- rel 6
[packages/grive.git] / grive.spec
1 %define         commit          27817e835fe115ebbda5410ec904aa49a2ad01f1
2 # %(c=%{commit}; echo ${c:0:7})
3 %define         shortcommit     27817e8
4 %define         cdate           20130702
5 %define         rel             6
6 Summary:        An open source Linux client for Google Drive
7 Name:           grive
8 Version:        0.3.0
9 Release:        0.%{cdate}git%{shortcommit}.%{rel}
10 License:        GPL v2
11 Group:          Applications/Networking
12 Source0:        https://github.com/Grive/grive/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
13 # Source0-md5:  4f3c3411588f889801bd5b9297e6e2c9
14 # https://github.com/Grive/grive/issues/187
15 Patch0:         json-c.patch
16 Patch1:         %{name}-bgrive_cmake_fix.patch
17 Patch2:         build.patch
18 URL:            http://www.lbreda.com/grive/
19 BuildRequires:  QtCore-devel
20 BuildRequires:  binutils-devel
21 BuildRequires:  boost-devel
22 BuildRequires:  cmake
23 BuildRequires:  curl-devel
24 BuildRequires:  expat-devel
25 BuildRequires:  json-c-devel >= 0.11
26 BuildRequires:  libgcrypt-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  openssl-devel
29 BuildRequires:  yajl-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The purpose of this project is to provide an independent
34 implementation of Google Drive client. It uses the Google Document
35 List API to talk to the servers in Google.
36
37 %package -n bgrive
38 Summary:        Qt frontend for %{name}
39 Group:          Applications/Networking
40 Requires:       %{name} = %{version}-%{release}
41
42 %description -n bgrive
43 GUI frontend for %{name}
44
45 %prep
46 %setup -q -n %{name}-%{commit}
47 %patch0 -p1
48 %patch1 -p1
49 %patch2 -p1
50
51 %build
52 install -d build
53 cd build
54 %cmake ..
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} -C build install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README
68 %attr(755,root,root) %{_bindir}/%{name}
69 %{_mandir}/man1/%{name}.1*
70
71 %files -n bgrive
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_bindir}/bgrive
This page took 0.063669 seconds and 3 git commands to generate.