]> git.pld-linux.org Git - packages/grive.git/blob - grive.spec
2c0e1edeafa8dbbc094b0a2cecd669cba3029de0
[packages/grive.git] / grive.spec
1 %define         commit          27817e835fe115ebbda5410ec904aa49a2ad01f1
2 # bash: %%(c=%{commit}; echo ${c:0:7})
3 %define         shortcommit     27817e8
4 %define         cdate           20130702
5 %define         rel             41
6 Summary:        An open source Linux client for Google Drive
7 Summary(pl.UTF-8):      Linuksowy, mające otwarte źródła klient Google Drive
8 Name:           grive
9 Version:        0.3.0
10 Release:        0.%{cdate}git%{shortcommit}.%{rel}
11 License:        GPL v2
12 Group:          Applications/Networking
13 Source0:        https://github.com/Grive/grive/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
14 # Source0-md5:  4f3c3411588f889801bd5b9297e6e2c9
15 # https://github.com/Grive/grive/issues/187
16 Patch0:         json-c.patch
17 Patch1:         %{name}-bgrive_cmake_fix.patch
18 Patch2:         build.patch
19 Patch3:         binutils-2.34.patch
20 Patch4:         %{name}-json-c-0.14.patch
21 URL:            https://github.com/Grive/grive
22 BuildRequires:  QtCore-devel >= 4
23 BuildRequires:  QtGui-devel >= 4
24 BuildRequires:  binutils-devel
25 BuildRequires:  boost-devel >= 1.40.0
26 BuildRequires:  cmake >= 2.8
27 BuildRequires:  curl-devel
28 BuildRequires:  expat-devel
29 BuildRequires:  json-c-devel >= 0.11
30 BuildRequires:  libgcrypt-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  qt4-build
34 BuildRequires:  rpmbuild(macros) >= 1.605
35 BuildRequires:  yajl-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The purpose of this project is to provide an independent
40 implementation of Google Drive client. It uses the Google Document
41 List API to talk to the servers in Google.
42
43 %description -l pl.UTF-8
44 Celem tego projektu jest zapewnienie niezależnej implementacji klienta
45 Google Drive. Do komunikacji z serwerami Google'a wykorzystuje API
46 Google Document List.
47
48 %package -n bgrive
49 Summary:        Qt frontend for Grive
50 Summary(pl.UTF-8):      Interfejs Qt do Grive
51 Group:          Applications/Networking
52 Requires:       %{name} = %{version}-%{release}
53
54 %description -n bgrive
55 GUI frontend for Grive.
56
57 %description -n bgrive -l pl.UTF-8
58 Graficzny interfejs użytkownika do Grive.
59
60 %prep
61 %setup -q -n %{name}-%{commit}
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65 %patch3 -p1
66 %patch4 -p1
67
68 %build
69 install -d build
70 cd build
71 %cmake ..
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} -C build install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README
86 %attr(755,root,root) %{_bindir}/grive
87 %{_mandir}/man1/grive.1*
88
89 %files -n bgrive
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_bindir}/bgrive
This page took 0.1025 seconds and 2 git commands to generate.