]> git.pld-linux.org Git - packages/grass.git/blob - grass.spec
7d11dc14cbe52373e5c7262e0ed34c2182834e4a
[packages/grass.git] / grass.spec
1 # TODO
2 # - openDWG
3 #
4 # Conditional build, see http://grass.itc.it/grass61/source/REQUIREMENTS.html
5 # for description of optional requirements.
6 %bcond_without  mysql   # MySQL support
7 %bcond_without  odbc    # unixODBC support
8
9 Summary:        The Geographic Resources Analysis Support System
10 Summary(pl.UTF-8):      System obsługujący analizę zasobów geograficznych
11 Name:           grass
12 Version:        7.4.0
13 Release:        4
14 Epoch:          1
15 License:        GPL v2+
16 Group:          X11/Applications
17 Source0:        http://grass.osgeo.org/grass74/source/%{name}-%{version}.tar.gz
18 # Source0-md5:  15b9eb019d6c132c1a65455b3283cf69
19 Patch0:         %{name}-soname.patch
20 Patch1:         %{name}-ac.patch
21 Patch3:         %{name}-ctypesgen.patch
22 URL:            http://grass.osgeo.org/
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  autoconf >= 2.13
25 BuildRequires:  automake
26 BuildRequires:  bison
27 BuildRequires:  blas-devel
28 BuildRequires:  cairo-devel
29 BuildRequires:  fftw3-devel >= 3
30 BuildRequires:  flex
31 BuildRequires:  freetype-devel >= 2.0.0
32 BuildRequires:  gcc-fortran
33 BuildRequires:  gd-devel
34 BuildRequires:  gdal-devel
35 BuildRequires:  gdbm-devel
36 BuildRequires:  geos-devel
37 BuildRequires:  lapack-devel
38 BuildRequires:  libjpeg-devel
39 BuildRequires:  libpng-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtiff-devel
42 # man or man-db
43 BuildRequires:  /usr/bin/man
44 %{?with_mysql:BuildRequires:    mysql-devel}
45 BuildRequires:  pkgconfig
46 BuildRequires:  postgresql-backend-devel
47 BuildRequires:  postgresql-devel
48 BuildRequires:  proj-devel >= 4.4.6
49 BuildRequires:  proj-progs
50 BuildRequires:  python-devel >= 1:2.3
51 BuildRequires:  python-wxPython
52 BuildRequires:  readline-devel
53 BuildRequires:  sed >= 4.0
54 BuildRequires:  sqlite3-devel >= 3.0
55 %{?with_odbc:BuildRequires:     unixODBC-devel}
56 BuildRequires:  wxGTK2-unicode-devel >= 2.8.1
57 BuildRequires:  xorg-lib-libX11-devel
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXt-devel
60 BuildRequires:  zlib-devel
61 # R language?
62 Requires:       proj >= 4.4.6
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         gver    %{version}
66 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
67 %define         _sysconfdir     /etc/X11
68
69 %description
70 GRASS (the Geographic Resources Analysis Support System) is a software
71 raster- and vector-based GIS (Geographic Information System), image
72 processing system, graphics production system, and spatial modeling
73 system. GRASS contains many modules for raster data manipulation,
74 vector data manipulation, rendering images on the monitor or paper,
75 multispectral image processing, point data management and general data
76 management. It also has tools for interfacing with digitizers,
77 scanners, and the RIM, Informix, Postgres, and Oracle databases.
78
79 %description -l pl.UTF-8
80 GRASS (System Wspierania Analiz Zasobów Geograficznych) jest rastrowym
81 oraz wektorowym systemem GIS (System Informacji Geograficznej),
82 obróbki obrazów, tworzenia grafiki oraz modelowania przestrzennego.
83 GRASS zawiera wiele modułów wspomagających manipulację danymi
84 rastrowymi i wektorowymi, renderowanie obrazów na monitorze lub
85 papierze, obróbkę multispektralnych obrazów, punktowe oraz ogólne
86 zarządzanie danymi. Zawiera również narzędzia do współpracy z
87 digitizerami, skanerami oraz bazami RIM, Informix, Postgres oraz
88 Oracle.
89
90 %package OpenGL
91 Summary:        NVIZ - a 3D-tool for GRASS
92 Summary(pl.UTF-8):      NVIZ - narzędzie 3D dla GRASSa
93 Group:          X11/Applications
94 Requires:       %{name} = %{epoch}:%{version}-%{release}
95
96 %description OpenGL
97 Package contains nviz, which is a GRASS module-in-progress which
98 allows users to realistically render multiple surfaces in a 3D space,
99 optionally using thematic coloring, draping GRASS vector files over
100 the surfaces, and displaying GRASS site files either draped on the
101 surfaces or as 3D point locations.
102
103 %description OpenGL -l pl.UTF-8
104 Pakiet zawiera moduł nviz, który rozszerza funkcjonalność systemu
105 GRASS o możliwość realistycznego renderowania wielu powierzchni w
106 trójwymiarowej przestrzeni. Na renderowanych powierzchniach, które
107 mogą być tematycznie kolorowane, można zawieszać pliki wektorowe
108 GRASSa.
109
110 %package pg
111 Summary:        PostgreSQL database interface
112 Summary(pl.UTF-8):      Interfejs do bazy PostgreSQL
113 Group:          X11/Applications
114 Requires:       %{name} = %{epoch}:%{version}-%{release}
115
116 %description pg
117 PostgreSQL database interface for GRASS.
118
119 %description pg -l pl.UTF-8
120 Interfejs do bazy PostgreSQL dla GRASSa.
121
122 %package odbc
123 Summary:        ODBC database interface
124 Summary(pl.UTF-8):      Interfejs ODBC dla GRASSa
125 Group:          X11/Applications
126 Requires:       %{name} = %{epoch}:%{version}-%{release}
127
128 %description odbc
129 ODBC database interface for GRASS.
130
131 %description odbc -l pl.UTF-8
132 Interfejs ODBC dla GRASSa.
133
134 %package devel
135 Summary:        Header files and static libraries for GRASS
136 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki statyczne systemu GRASS
137 Group:          X11/Development/Libraries
138 Requires:       %{name} = %{epoch}:%{version}-%{release}
139
140 %description devel
141 Header files and static libraries for GRASS.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe i biblioteki statyczne systemu GRASS.
145
146 %prep
147 %setup -q
148 %patch0 -p1
149 %patch1 -p1
150 %patch3 -p1
151
152 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
153         display/d.text/test.pl
154         raster/r.topidx/gridatb.to.arc.pl \
155         raster/r.topidx/arc.to.gridatb.pl
156
157 find general gui imagery lib/python/pygrass lib/init raster scripts temporal tools -name '*.py' | xargs grep -l '/usr/bin/env python' | xargs %{__sed} -i -e '1s,/usr/bin/env python,%{__python},'
158
159 %build
160 %{__libtoolize}
161 %{__aclocal}
162 %{__autoconf}
163 %configure \
164 %if "%{_lib}" == "lib64"
165         --enable-64bit \
166 %endif
167         --enable-largefile \
168         --with-includes=%{_includedir} \
169         --with-libs=%{_libdir} \
170         --with-blas \
171         --with-cairo \
172         --with-cxx \
173         --with-freetype \
174         --with-freetype-includes=/usr/include/freetype2 \
175         --with-geos=/usr/bin/geos-config \
176         --with-lapack \
177         %{?with_mysql:--with-mysql} \
178         %{?with_mysql:--with-mysql-includes=/usr/include/mysql} \
179         --with-nls \
180         %{?with_odbc:--with-odbc} \
181         --with-opengl \
182         --with-postgres \
183         --with-postgres-includes=/usr/include/postgresql/server \
184         --with-proj-share=/usr/share/proj \
185         --with-readline \
186         --with-sqlite \
187         --with-wxwidgets=/usr/bin/wx-gtk2-unicode-config
188
189 %{__make}
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193
194 %{__make} install \
195         prefix=$RPM_BUILD_ROOT%{_libdir} \
196         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
197         PREFIX=$RPM_BUILD_ROOT%{_libdir}
198
199 install -d $RPM_BUILD_ROOT{%{_datadir},%{_includedir}/grass74}
200 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/include/* $RPM_BUILD_ROOT%{_includedir}/grass74
201 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/lib/* $RPM_BUILD_ROOT%{_libdir}
202 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/locale $RPM_BUILD_ROOT%{_datadir}
203 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/docs/man $RPM_BUILD_ROOT%{_datadir}
204 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/share/{appdata,applications,icons} $RPM_BUILD_ROOT%{_datadir}
205
206 # these manual cover topics, not programs, so shouldn't exist in section 1
207 # (maybe in section 7, but names are too common anyway); keep HTML version only
208 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{cairodriver,database,databaseintro,display,displaydrivers,full_index,general,helptext,htmldriver,imagery,imageryintro,index,keywords,pngdriver,postscript,projectionintro,psdriver,raster,rasterintro,raster3d,raster3dintro,sql,temporal,temporalintro,topics,variables,vector,vectorascii,vectorintro}.1
209
210 # non-standard icons
211 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/40x40
212
213 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/docs
214
215 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{id_ID,id}
216 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{zh,zh_CN}
217
218 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/AUTHORS
219 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/CHANGES
220 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/COPYING
221 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/GPL.TXT
222 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/REQUIREMENTS.html
223
224 %find_lang %{name} --all-name
225
226 %clean
227 rm -rf $RPM_BUILD_ROOT
228
229 %post   -p /sbin/ldconfig
230 %postun -p /sbin/ldconfig
231
232 %files -f %{name}.lang
233 %defattr(644,root,root,755)
234 %doc AUTHORS CHANGES COPYING README TODO
235 #%attr(755,root,root) %{_bindir}/grass74
236 %attr(755,root,root) %{_libdir}/libgrass_*.%{version}.so
237 %dir %{_libdir}/grass-%{gver}
238 %dir %{_libdir}/grass-%{gver}/*.csv
239 %attr(755,root,root) %{_libdir}/grass-%{gver}/config.status
240 %attr(755,root,root) %{_libdir}/grass-%{gver}/bin
241 %attr(755,root,root) %{_libdir}/grass-%{gver}/driver
242 %dir %{_libdir}/grass-%{gver}/etc
243 %{_libdir}/grass-%{gver}/etc/VERSIONNUMBER
244 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/clean_temp
245 %{_libdir}/grass-%{gver}/etc/colors
246 %{_libdir}/grass-%{gver}/etc/colors.desc
247 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/current_time_s_ms
248 %{_libdir}/grass-%{gver}/etc/d.mon
249 %{_libdir}/grass-%{gver}/etc/d.polar
250 %{_libdir}/grass-%{gver}/etc/db.test
251 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/echo
252 %{_libdir}/grass-%{gver}/etc/element_list
253 %{_libdir}/grass-%{gver}/etc/fontcap
254 %{_libdir}/grass-%{gver}/etc/grass74.py
255 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/i.find
256 %{_libdir}/grass-%{gver}/etc/license
257 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/lister
258 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/lock
259 %{_libdir}/grass-%{gver}/etc/paint
260 %{_libdir}/grass-%{gver}/etc/proj
261 %{_libdir}/grass-%{gver}/etc/psdriver.ps
262 %{_libdir}/grass-%{gver}/etc/python
263 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/r.in.wms
264 %dir %{_libdir}/grass-%{gver}/etc/r.watershed
265 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/r.watershed/ram
266 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/r.watershed/seg
267 %{_libdir}/grass-%{gver}/etc/renamed_options
268 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/run
269 %{_libdir}/grass-%{gver}/etc/sql
270 %{_libdir}/grass-%{gver}/etc/symbol
271 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/wxpyimgview_gui.py
272 %{_libdir}/grass-%{gver}/fonts
273 %dir %{_libdir}/grass-%{gver}/gui
274 %{_libdir}/grass-%{gver}/gui/icons
275 %{_libdir}/grass-%{gver}/gui/images
276 %dir %{_libdir}/grass-%{gver}/gui/scripts
277 %attr(755,root,root) %{_libdir}/grass-%{gver}/gui/scripts/d.*
278 %dir %{_libdir}/grass-%{gver}/gui/wxpython
279 %{_libdir}/grass-%{gver}/gui/wxpython/README
280 %{_libdir}/grass-%{gver}/gui/wxpython/animation
281 %{_libdir}/grass-%{gver}/gui/wxpython/core
282 %{_libdir}/grass-%{gver}/gui/wxpython/datacatalog
283 %{_libdir}/grass-%{gver}/gui/wxpython/dbmgr
284 %{_libdir}/grass-%{gver}/gui/wxpython/gcp
285 %{_libdir}/grass-%{gver}/gui/wxpython/gmodeler
286 %{_libdir}/grass-%{gver}/gui/wxpython/gui_core
287 %{_libdir}/grass-%{gver}/gui/wxpython/iclass
288 %{_libdir}/grass-%{gver}/gui/wxpython/icons
289 %{_libdir}/grass-%{gver}/gui/wxpython/image2target
290 %{_libdir}/grass-%{gver}/gui/wxpython/iscatt
291 %{_libdir}/grass-%{gver}/gui/wxpython/lmgr
292 %{_libdir}/grass-%{gver}/gui/wxpython/location_wizard
293 %{_libdir}/grass-%{gver}/gui/wxpython/mapdisp
294 %{_libdir}/grass-%{gver}/gui/wxpython/mapswipe
295 %{_libdir}/grass-%{gver}/gui/wxpython/mapwin
296 %{_libdir}/grass-%{gver}/gui/wxpython/modules
297 %{_libdir}/grass-%{gver}/gui/wxpython/nviz
298 %{_libdir}/grass-%{gver}/gui/wxpython/photo2image
299 %{_libdir}/grass-%{gver}/gui/wxpython/psmap
300 %{_libdir}/grass-%{gver}/gui/wxpython/rdigit
301 %{_libdir}/grass-%{gver}/gui/wxpython/rlisetup
302 %{_libdir}/grass-%{gver}/gui/wxpython/startup
303 %{_libdir}/grass-%{gver}/gui/wxpython/timeline
304 %{_libdir}/grass-%{gver}/gui/wxpython/tplot
305 %{_libdir}/grass-%{gver}/gui/wxpython/vdigit
306 %{_libdir}/grass-%{gver}/gui/wxpython/vnet
307 %{_libdir}/grass-%{gver}/gui/wxpython/web_services
308 %{_libdir}/grass-%{gver}/gui/wxpython/wxplot
309 %{_libdir}/grass-%{gver}/gui/wxpython/xml
310 %{_libdir}/grass-%{gver}/gui/wxpython/gis_set*.py*
311 %{_libdir}/grass-%{gver}/gui/wxpython/wxgui.py*
312 %{_libdir}/grass-%{gver}/gui/xml
313 %attr(755,root,root) %{_libdir}/grass-%{gver}/scripts
314 %dir %{_libdir}/grass-%{gver}/tools
315 %attr(755,root,root) %{_libdir}/grass-%{gver}/tools/g.echo
316 %attr(755,root,root) %{_libdir}/grass-%{gver}/tools/g.html2man.py
317 %{_libdir}/grass-%{gver}/tools/ggroff.py*
318 %{_libdir}/grass-%{gver}/tools/ghtml.py*
319 %attr(755,root,root) %{_libdir}/grass-%{gver}/tools/mkhtml.py
320 %{_libdir}/grass-%{gver}/translation_status.json
321 # default (demo?) database - subpackage?
322 %{_libdir}/grass-%{gver}/demolocation
323 %{_datadir}/appdata/grass.appdata.xml
324 %{_desktopdir}/grass.desktop
325 %{_iconsdir}/hicolor/*x*/apps/grass.png
326 %{_iconsdir}/hicolor/scalable/apps/grass.svg
327 %{_mandir}/man1/d.*.1*
328 %{_mandir}/man1/db.*.1*
329 %{_mandir}/man1/g.*.1*
330 %{_mandir}/man1/*_graphical.1*
331 %{_mandir}/man1/graphical_index.1*
332 %{_mandir}/man1/grass*.1*
333 %{_mandir}/man1/i.*.1*
334 %{_mandir}/man1/lrs.1*
335 %{_mandir}/man1/m.*.1*
336 %{_mandir}/man1/manual_gallery.1*
337 %{_mandir}/man1/miscellaneous.1*
338 %{_mandir}/man1/parser_standard_options.1*
339 %{_mandir}/man1/ps.map.1*
340 %{_mandir}/man1/r.*.1*
341 %{_mandir}/man1/r3.*.1*
342 %{_mandir}/man1/t.*.1*
343 %{_mandir}/man1/topic_*.1*
344 %{_mandir}/man1/v.*.1*
345 %{_mandir}/man1/wxGUI.1*
346 %{_mandir}/man1/wxGUI.*.1*
347 %{_mandir}/man1/wxpyimgview.1*
348 %{_mandir}/man1/ximgview.1*
349
350 %files devel
351 %defattr(644,root,root,755)
352 %doc dist.*/docs/html/*
353 %attr(755,root,root) %{_libdir}/libgrass_*[!0-9].so
354 %attr(755,root,root) %{_libdir}/libgrass_btree2.so
355 %attr(755,root,root) %{_libdir}/libgrass_dig2.so
356 %{_libdir}/libgrass_iostream.%{version}.a
357 %{_includedir}/grass74
This page took 0.080725 seconds and 2 git commands to generate.