]> git.pld-linux.org Git - packages/graphviz.git/blob - graphviz.spec
- separated gvedit and smyrna
[packages/graphviz.git] / graphviz.spec
1 # TODO
2 # - %{_libdir}/graphviz/config is not FHS friendly path as config
3 # - io language binding: io-graphviz
4 # - some plugin subpackages? (libgvplugin_*: gs=ghostscript, gtk, lasi, ming, visio, webp)
5 #
6 # Conditional build:
7 %bcond_without  dotnet          # don't build C# bindings
8 %bcond_without  golang          # don't build Go bindings
9 %bcond_without  java            # don't build Java bindings
10 %bcond_without  ocaml           # don't build ocaml bindings
11 %bcond_without  php             # don't build php bindings
12 %bcond_without  perl            # don't build perl bindings
13 %bcond_without  ruby            # don't build ruby bindings
14 %bcond_without  tcl             # don't build tcl bindings
15 %bcond_without  lua             # don't build lua bindings
16 %bcond_without  r               # don't build R bindings
17 %bcond_without  python          # don't build python bindings
18 %bcond_with     io              # don't build io language bindings
19 %bcond_without  guile           # don't build guile bindings
20 %bcond_without  ming            # don't build ming support
21 %bcond_without  devil           # don't build devil plugin
22 %bcond_without  qt              # Qt features (gvedit utility)
23 %bcond_without  smyrna          # SMYRNA utility (large graph viewer)
24 %bcond_without  ipsepcola       # IPSEPCOLA features in neato engine [C++ portability problems]
25
26 %define         tclver  8.5
27 %ifarch i386
28 %undefine with_dotnet
29 %endif
30 %ifnarch %{ix86} %{x8664}
31 %undefine with_java
32 %endif
33 %ifarch i386 i486
34 %undefine with_java
35 %endif
36 %ifnarch %{ix86} %{x8664} %{arm}
37 %undefine with_golang
38 %endif
39 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
40 Summary:        Graph Visualization Tools
41 Summary(pl.UTF-8):      Narzędzie do wizualizacji w postaci grafów
42 Name:           graphviz
43 Version:        2.30.1
44 Release:        1
45 License:        CPL v1.0
46 Group:          X11/Applications/Graphics
47 Source0:        http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
48 # Source0-md5:  8130785a8f1fb8a57f6b839b617e85fa
49 Patch0:         %{name}-fontpath.patch
50 Patch1:         %{name}-tk.patch
51 Patch2:         %{name}-bad-header.patch
52 Patch3:         %{name}-php.patch
53 Patch4:         %{name}-ltdl.patch
54 Patch5:         %{name}-go.patch
55 Patch6:         %{name}-php_modules_dir.patch
56 Patch7:         %{name}-ruby.patch
57 Patch8:         %{name}-guile.patch
58 Patch9:         %{name}-libgraph.patch
59 Patch10:        %{name}-ming.patch
60 Patch11:        %{name}-visio.patch
61 Patch12:        %{name}-webp.patch
62 Patch13:        %{name}-format.patch
63 URL:            http://www.graphviz.org/
64 %{?with_devil:BuildRequires:    DevIL-devel}
65 %{?with_r:BuildRequires:        R}
66 BuildRequires:  autoconf >= 2.61
67 BuildRequires:  automake
68 BuildRequires:  bison
69 BuildRequires:  expat-devel >= 1.95
70 BuildRequires:  flex
71 BuildRequires:  fontconfig-devel
72 BuildRequires:  freetype-devel >= 2.0.0
73 BuildRequires:  gawk
74 BuildRequires:  gd-devel >= 2.0.34
75 BuildRequires:  gdk-pixbuf2-devel >= 2.0
76 BuildRequires:  gettext-devel
77 BuildRequires:  ghostscript-devel
78 %{?with_golang:BuildRequires:   golang}
79 BuildRequires:  gtk+2-devel >= 2:2.8.0
80 BuildRequires:  gts-devel
81 %{?with_guile:BuildRequires:    guile-devel >= 2.0}
82 #BuildRequires: io
83 %if %{with java}
84 BuildRequires:  jdk
85 BuildRequires:  jpackage-utils
86 %endif
87 BuildRequires:  libLASi-devel
88 BuildRequires:  libjpeg-devel
89 BuildRequires:  libltdl-devel >= 2:2
90 BuildRequires:  libpng-devel
91 BuildRequires:  librsvg-devel >= 2.0
92 BuildRequires:  libstdc++-devel
93 BuildRequires:  libtool >= 2:2
94 BuildRequires:  libwebp-devel
95 BuildRequires:  libvisio-devel
96 # for lua51 binary
97 %if %{with lua}
98 BuildRequires:  lua51
99 BuildRequires:  lua51-devel >= 5.1
100 %endif
101 %{?with_ming:BuildRequires:     ming-devel >= 0.4}
102 %{?with_dotnet:BuildRequires:   mono-csharp}
103 %{?with_ocaml:BuildRequires:    ocaml}
104 BuildRequires:  pango-devel >= 1:1.14.9
105 BuildRequires:  perl-devel
106 %if %{with php}
107 BuildRequires:  php-devel >= 3:5.0.0
108 BuildRequires:  php-program >= 4:5.0
109 %endif
110 BuildRequires:  pkgconfig
111 %{?with_python:BuildRequires:   python-devel}
112 %{?with_perl:BuildRequires:     rpm-perlprov}
113 %{?with_python:BuildRequires:   rpm-pythonprov}
114 BuildRequires:  rpmbuild(macros) >= 1.519
115 %{?with_ruby:BuildRequires:     ruby-devel}
116 BuildRequires:  sed >= 4.0
117 # swig-csharp,swig-go,swig-java,swig-lua,swig-ocaml in main swig
118 # swig-io ???
119 BuildRequires:  swig >= 1.3
120 %{?with_guile:BuildRequires:    swig-guile >= 2.0.3}
121 %{?with_perl:BuildRequires:     swig-perl >= 1.3}
122 %{?with_php:BuildRequires:      swig-php >= 1.3.40}
123 BuildRequires:  swig-python >= 1.3
124 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3}
125 %if %{with tcl}
126 BuildRequires:  swig-tcl >= 1.3
127 BuildRequires:  tcl-devel >= 8.3.0
128 BuildRequires:  tk-devel >= 8.3.0
129 %endif
130 BuildRequires:  xorg-lib-libX11-devel
131 BuildRequires:  xorg-lib-libXaw-devel
132 BuildRequires:  xorg-lib-libXpm-devel
133 # tested in configure, actually not used
134 #BuildRequires: xorg-lib-libXrender-devel
135 BuildRequires:  zlib-devel
136 %if %{with smyrna}
137 BuildRequires:  OpenGL-glut-devel
138 # only tested, actually not used
139 #BuildRequires: gtkglarea-devel >= 2.0
140 BuildRequires:  gtkglext-devel >= 1.0
141 BuildRequires:  libglade2-devel >= 2.0
142 %endif
143 %if %{with qt}
144 BuildRequires:  QtCore-devel >= 4
145 BuildRequires:  QtGui-devel >= 4
146 BuildRequires:  qt4-qmake >= 4
147 %endif
148 Requires(post,postun):  /sbin/ldconfig
149 Requires:       fonts-Type1-urw
150 Requires:       gd >= 2.0.33-5
151 Requires:       pango >= 1:1.14.9
152 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
153
154 %description
155 A collection of tools and tcl packages for the manipulation and layout
156 of graphs (as in nodes and edges, not as in barcharts).
157
158 %description -l pl.UTF-8
159 Kolekcja narzędzi oraz pakietów tcl służących do manipulacji i
160 rozmieszczania grafów.
161
162 %package devel
163 Summary:        Header files for graphviz libraries
164 Summary(pl.UTF-8):      Pliki nagłówkowe do bibliotek graphviz
165 Group:          X11/Development/Libraries
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       gd-devel >= 2.0.34
168 Requires:       libltdl-devel >= 2:2
169
170 %description devel
171 This package contains the header files for graphviz libraries.
172
173 %description devel -l pl.UTF-8
174 Ten pakiet zawiera pliki nagłówkowe do bibliotek graphviz.
175
176 %package gvedit
177 Summary:        gvedit - simple graph editor and viewer based on Qt
178 Summary(pl.UTF-8):      gvedit - prosty edytor i przeglądarka grafów oparta na Qt
179 Group:          X11/Applications/Graphics
180 Requires:       %{name} = %{version}-%{release}
181
182 %description gvedit
183 gvedit provides a simple Qt-based graph editor and viewer.
184
185 %description gvedit -l l.UTF-8
186 gvedit to prosty edytor i przeglądarka grafów oparta na Qt.
187
188 %package smyrna
189 Summary:        SMYRNA large graph viewer
190 Summary(pl.UTF-8):      SMYRNA - przeglądarka dużych grafów
191 Group:          X11/Applications/Graphics
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       gtkglext >= 1.0
194
195 %description smyrna
196 SMYRNA is an interactive viewer for graphs in the DOT format. It is
197 especially designed to handle large graphs, and allows flat and
198 topological fisheye views.
199
200 %description smyrna -l pl.UTF-8
201 SMYRNA to interaktywna przeglądarka grafów w formacie DOT. Jest
202 przeznaczona szczególnie do obsługi dużych grafów, udostępnia widok
203 płaski oraz topologiczny typu "rybie oko".
204
205 %package doc-html
206 Summary:        HTML documentation for graphviz
207 Summary(pl.UTF-8):      Dokumentacja do graphviza w formacie HTML
208 Group:          Documentation
209
210 %description doc-html
211 HTML documentation for graphviz.
212
213 %description doc-html -l pl.UTF-8
214 Dokumentacja do graphviza w formacie HTML.
215
216 %package doc-pdf
217 Summary:        PDF documentation for graphviz
218 Summary(pl.UTF-8):      Dokumentacja do graphviza w formacie PDF
219 Group:          Documentation
220
221 %description doc-pdf
222 PDF documentation for graphviz.
223
224 %description doc-pdf -l pl.UTF-8
225 Dokumentacja do graphviza w formacie PDF.
226
227 %package graphs
228 Summary:        Demo graphs for graphviz
229 Summary(pl.UTF-8):      Przykładowe grafy dla graphviza
230 Group:          X11/Applications/Graphics
231 Requires:       %{name} = %{version}-%{release}
232
233 %description graphs
234 This package provides some example graphs.
235
236 %description graphs -l pl.UTF-8
237 Ten pakiet zawiera trochę przykładowych grafów.
238
239 %package -n golang-%{name}
240 Summary:        Go binding for graphviz
241 Summary(pl.UTF-8):      Wiązania języka Go dla graphviza
242 Group:          Libraries
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       golang
245
246 %description -n golang-%{name}
247 Go binding for graphviz.
248
249 %description -n golang-%{name} -l pl.UTF-8
250 Wiązania języka Go dla graphviza.
251
252 %package -n guile-%{name}
253 Summary:        Guile binding for graphviz
254 Summary(pl.UTF-8):      Wiązania Guile dla graphviza
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257 Obsoletes:      graphviz-guile
258
259 %description -n guile-%{name}
260 Guile binding for graphviz.
261
262 %description -n guile-%{name} -l pl.UTF-8
263 Wiązania Guile dla graphviza.
264
265 %package -n java-%{name}
266 Summary:        Java binding for graphviz
267 Summary(pl.UTF-8):      Wiązania Javy dla graphviza
268 Group:          Libraries
269 Requires:       %{name} = %{version}-%{release}
270 Obsoletes:      graphviz-java
271
272 %description -n java-%{name}
273 Java binding for graphviz.
274
275 %description -n java-%{name} -l pl.UTF-8
276 Wiązania Javy dla graphviza.
277
278 %package -n lua-%{name}
279 Summary:        LUA binding for graphviz
280 Summary(pl.UTF-8):      Wiązania LUA dla graphviza
281 Group:          Libraries
282 Requires:       %{name} = %{version}-%{release}
283 Obsoletes:      graphviz-lua
284
285 %description -n lua-%{name}
286 LUA binding for graphviz.
287
288 %description -n lua-%{name} -l pl.UTF-8
289 Wiązania LUA dla graphviza.
290
291 %package -n ocaml-%{name}
292 Summary:        OCaml binding for graphviz
293 Summary(pl.UTF-8):      Wiązania OCamla dla graphviza
294 Group:          Libraries
295 Requires:       %{name} = %{version}-%{release}
296 Obsoletes:      graphviz-ocaml
297
298 %description -n ocaml-%{name}
299 OCaml binding for graphviz.
300
301 %description -n ocaml-%{name} -l pl.UTF-8
302 Wiązania OCamla dla graphviza.
303
304 %package -n perl-%{name}
305 Summary:        Perl binding for graphviz
306 Summary(pl.UTF-8):      Wiązania Perla dla graphviza
307 Group:          Libraries
308 Requires:       %{name} = %{version}-%{release}
309
310 %description -n perl-%{name}
311 Perl binding for graphviz.
312
313 %description -n perl-%{name} -l pl.UTF-8
314 Wiązania Perla dla graphviza.
315
316 %package -n php-%{name}
317 Summary:        PHP binding for graphviz
318 Summary(pl.UTF-8):      Wiązania PHP dla graphviza
319 Group:          Libraries
320 Requires:       %{name} = %{version}-%{release}
321 Obsoletes:      graphviz-php
322 %{?requires_php_extension}
323
324 %description -n php-%{name}
325 PHP binding for graphviz.
326
327 %description -n php-%{name} -l pl.UTF-8
328 Wiązania PHP dla graphviza.
329
330 %package -n python-%{name}
331 Summary:        Python binding for graphviz
332 Summary(pl.UTF-8):      Wiązania Pythona dla graphviza
333 Group:          Libraries
334 Requires:       %{name} = %{version}-%{release}
335 Obsoletes:      graphviz-python
336
337 %description -n python-%{name}
338 Python binding for graphviz.
339
340 %description -n python-%{name} -l pl.UTF-8
341 Wiązania Pythona dla graphviza.
342
343 %package -n ruby-%{name}
344 Summary:        Ruby binding for graphviz
345 Summary(pl.UTF-8):      Wiązania Ruby'ego dla graphviza
346 Group:          Libraries
347 Requires:       %{name} = %{version}-%{release}
348 Obsoletes:      graphviz-ruby
349
350 %description -n ruby-%{name}
351 Ruby binding for graphviz.
352
353 %description -n ruby-%{name} -l pl.UTF-8
354 Wiązania Ruby'ego dla graphviza.
355
356 %package -n dotnet-%{name}-sharp
357 Summary:        C# binding for graphviz
358 Summary(pl.UTF-8):      Wiązania C# dla graphviza
359 Group:          Libraries
360 Requires:       %{name} = %{version}-%{release}
361 Obsoletes:      graphviz-sharp
362 Obsoletes:      sharp-graphviz
363
364 %description -n dotnet-%{name}-sharp
365 C# binding for graphviz.
366
367 %description -n dotnet-%{name}-sharp -l pl.UTF-8
368 Wiązania C# dla graphviza.
369
370 %package -n tcl-%{name}
371 Summary:        Tcl extension tools for graphviz
372 Summary(pl.UTF-8):      Rozszerzenia Tcl dla graphviza
373 Group:          X11/Applications/Graphics
374 Requires:       %{name} = %{version}-%{release}
375 Obsoletes:      graphviz-tcl
376
377 %description -n tcl-%{name}
378 This package contains the various Tcl packages (extensions) using
379 graphviz.
380
381 %description -n tcl-%{name} -l pl.UTF-8
382 Ten pakiet zawiera różne pakiety (rozszerzenia) Tcl używające
383 graphviza.
384
385 %package -n R-%{name}
386 Summary:        graphviz bindings for R language
387 Summary(pl.UTF-8):      Wiązania graphviza dla języka R
388 Group:          X11/Applications/Graphics
389 Requires:       %{name} = %{version}-%{release}
390
391 %description -n R-%{name}
392 graphviz bindings for R language.
393
394 %description -n R-%{name} -l pl.UTF-8
395 Wiązania graphviza dla języka R.
396
397 %prep
398 %setup -q
399 %patch0 -p1
400 %patch1 -p1
401 %patch3 -p1
402 %patch4 -p1
403 %patch5 -p1
404 %patch6 -p1
405 %patch7 -p1
406 %patch8 -p1
407 %patch9 -p1
408 %patch10 -p1
409 %patch11 -p1
410 %patch12 -p1
411 %patch13 -p1
412
413 %{__sed} '1s@/usr/bin/lua$@/usr/bin/lua51@' -i tclpkg/gv/demo/modgraph.lua
414
415 %{__rm} m4/*.m4
416
417 %build
418 touch config/config.rpath
419 %{__libtoolize} --ltdl
420 %{__aclocal} -I m4
421 %{__autoconf}
422 %{__autoheader}
423 %{__automake}
424
425 CPPFLAGS="%{rpmcppflags}"
426 %if %{with java}
427 JAVA_HOME=%{java_home}
428 export JAVA_HOME
429 CPPFLAGS="$CPPFLAGS -I$JAVA_HOME/include -I$JAVA_HOME/include/linux"
430 %endif
431
432 export CPPFLAGS
433
434 %configure \
435         LUA=/usr/bin/lua51 \
436         lua_suffix=51 \
437         %{!?with_devil:--disable-devil} \
438         %{?with_golang:--enable-go} \
439         %{!?with_java:--disable-java} \
440         --disable-ltdl-install \
441         %{!?with_lua:--disable-lua} \
442         %{!?with_ocaml:--disable-ocaml} \
443         %{!?with_perl:--disable-perl} \
444         %{!?with_php:--disable-php} \
445         %{!?with_r:--disable-r} \
446         %{!?with_ruby:--disable-ruby} \
447         %{!?with_dotnet:--disable-sharp} \
448         %{!?with_tcl:--disable-tcl} \
449         --disable-silent-rules \
450         --disable-static \
451         %{?with_ipsepcola:--with-ipsepcola} \
452         %{?with_ming:--with-ming} \
453         %{!?with_qt:--without-qt} \
454         %{?with_smyrna:--with-smyrna} \
455         --with-visio \
456         --with-webp
457
458 %{__make}
459
460 %install
461 rm -rf $RPM_BUILD_ROOT
462
463 %{__make} install \
464         PHP_INSTALL_DIR=%{php_extensiondir} \
465         DESTDIR=$RPM_BUILD_ROOT
466
467 %if %{with php}
468 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
469 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{name}.ini
470 ; Enable gv.so extension module
471 extension=gv.so
472 EOF
473
474 # drop the symlinks and install to php dirs directly
475 install -d $RPM_BUILD_ROOT%{_examplesdir}/php-%{name}-%{version}
476 mv -f $RPM_BUILD_ROOT{%{_libdir}/%{name}/php,%{php_data_dir}}/gv.php
477 mv -f $RPM_BUILD_ROOT{%{_libdir}/%{name}/php/libgv_php.so,%{php_extensiondir}/gv.so}
478 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/php/gv.so
479 mv -f $RPM_BUILD_ROOT{%{_datadir}/%{name}/demo,%{_examplesdir}/php-%{name}-%{version}}/modgraph.php
480 %endif
481
482 # "man3/gv.3r.gz" and "man3/gv.3ruby.gz" are both manual for "gv" in "section 3" of man pages
483 # make manual pages unique.
484 for a in $RPM_BUILD_ROOT%{_mandir}/man3/gv.*; do
485         m=${a##*/}
486         l=${m#gv.3}
487         mv $a ${a%/*}/gv_$l.3
488 done
489
490 # created by %{_bindir}/dot -c
491 touch $RPM_BUILD_ROOT%{_libdir}/graphviz/config
492
493 %{__rm} $RPM_BUILD_ROOT%{_libdir}/graphviz/*/lib*.la
494 %{__rm} $RPM_BUILD_ROOT%{_libdir}/graphviz/libgvplugin_*.la
495
496 rm -rf doc-html doc-pdf
497 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/doc/html doc-html
498 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/doc/pdf doc-pdf
499
500 cd $RPM_BUILD_ROOT
501 patch -p1 --no-backup-if-mismatch < %{PATCH2} || exit 1
502
503 %clean
504 rm -rf $RPM_BUILD_ROOT
505
506 %post
507 /sbin/ldconfig
508 umask 022
509 [ ! -x %{_bindir}/dot ] || %{_bindir}/dot -c > /dev/null 2>&1
510
511 %postun -p /sbin/ldconfig
512
513 %post -n php-%{name}
514 %php_webserver_restart
515
516 %postun -n php-%{name}
517 if [ "$1" = 0 ]; then
518         %php_webserver_restart
519 fi
520
521 %files
522 %defattr(644,root,root,755)
523 %doc AUTHORS COPYING ChangeLog NEWS README
524 %attr(755,root,root) %{_bindir}/acyclic
525 %attr(755,root,root) %{_bindir}/bcomps
526 %attr(755,root,root) %{_bindir}/ccomps
527 %attr(755,root,root) %{_bindir}/circo
528 %attr(755,root,root) %{_bindir}/cluster
529 %attr(755,root,root) %{_bindir}/diffimg
530 %attr(755,root,root) %{_bindir}/dijkstra
531 %attr(755,root,root) %{_bindir}/dot
532 %attr(755,root,root) %{_bindir}/dot2gxl
533 %attr(755,root,root) %{_bindir}/dot_builtins
534 %attr(755,root,root) %{_bindir}/dotty
535 %attr(755,root,root) %{_bindir}/fdp
536 %attr(755,root,root) %{_bindir}/gc
537 %attr(755,root,root) %{_bindir}/gml2gv
538 %attr(755,root,root) %{_bindir}/graphml2gv
539 %attr(755,root,root) %{_bindir}/gv2gml
540 %attr(755,root,root) %{_bindir}/gv2gxl
541 %attr(755,root,root) %{_bindir}/gvcolor
542 %attr(755,root,root) %{_bindir}/gvgen
543 %attr(755,root,root) %{_bindir}/gvmap
544 %attr(755,root,root) %{_bindir}/gvmap.sh
545 %attr(755,root,root) %{_bindir}/gvpack
546 %attr(755,root,root) %{_bindir}/gvpr
547 %attr(755,root,root) %{_bindir}/gxl2dot
548 %attr(755,root,root) %{_bindir}/gxl2gv
549 %attr(755,root,root) %{_bindir}/lefty
550 %attr(755,root,root) %{_bindir}/lneato
551 %attr(755,root,root) %{_bindir}/mm2gv
552 %attr(755,root,root) %{_bindir}/neato
553 %attr(755,root,root) %{_bindir}/nop
554 %attr(755,root,root) %{_bindir}/osage
555 %attr(755,root,root) %{_bindir}/patchwork
556 %attr(755,root,root) %{_bindir}/prune
557 %attr(755,root,root) %{_bindir}/sccmap
558 %attr(755,root,root) %{_bindir}/sfdp
559 %attr(755,root,root) %{_bindir}/tred
560 %attr(755,root,root) %{_bindir}/twopi
561 %attr(755,root,root) %{_bindir}/unflatten
562 %attr(755,root,root) %{_bindir}/vimdot
563 %attr(755,root,root) %{_libdir}/libcdt.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libcdt.so.5
565 %attr(755,root,root) %{_libdir}/libcgraph.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libcgraph.so.6
567 %attr(755,root,root) %{_libdir}/libgraph.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libgraph.so.5
569 %attr(755,root,root) %{_libdir}/libgvc.so.*.*.*
570 %attr(755,root,root) %ghost %{_libdir}/libgvc.so.6
571 %attr(755,root,root) %{_libdir}/libgvpr.so.*.*.*
572 %attr(755,root,root) %ghost %{_libdir}/libgvpr.so.2
573 %attr(755,root,root) %{_libdir}/libpathplan.so.*.*.*
574 %attr(755,root,root) %ghost %{_libdir}/libpathplan.so.4
575 %attr(755,root,root) %{_libdir}/libxdot.so.*.*.*
576 %attr(755,root,root) %ghost %{_libdir}/libxdot.so.4
577 %dir %{_libdir}/graphviz
578 %ghost %{_libdir}/graphviz/config
579 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_core.so*
580 %if %{with devil}
581 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_devil.so*
582 %endif
583 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_dot_layout.so*
584 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_gd.so*
585 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_gdk_pixbuf.so*
586 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_gs.so*
587 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_gtk.so*
588 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_lasi.so*
589 %if %{with ming}
590 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_ming.so*
591 %endif
592 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_neato_layout.so*
593 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_pango.so*
594 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_rsvg.so*
595 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_visio.so*
596 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_webp.so*
597 %attr(755,root,root) %{_libdir}/graphviz/libgvplugin_xlib.so*
598 %dir %{_datadir}/graphviz
599 %dir %{_datadir}/graphviz/demo
600 %if %{with ming}
601 # for ming plugin
602 %{_datadir}/graphviz/font
603 %endif
604 %{_datadir}/graphviz/gvpr
605 %{_datadir}/graphviz/lefty
606 %{_mandir}/man1/acyclic.1*
607 %{_mandir}/man1/bcomps.1*
608 %{_mandir}/man1/ccomps.1*
609 %{_mandir}/man1/circo.1*
610 %{_mandir}/man1/cluster.1*
611 %{_mandir}/man1/diffimg.1*
612 %{_mandir}/man1/dijkstra.1*
613 %{_mandir}/man1/dot.1*
614 %{_mandir}/man1/dotty.1*
615 %{_mandir}/man1/fdp.1*
616 %{_mandir}/man1/gc.1*
617 %{_mandir}/man1/gml2gv.1*
618 %{_mandir}/man1/graphml2gv.1*
619 %{_mandir}/man1/gv2gml.1*
620 %{_mandir}/man1/gv2gxl.1*
621 %{_mandir}/man1/gvcolor.1*
622 %{_mandir}/man1/gvgen.1*
623 %{_mandir}/man1/gvmap.1*
624 %{_mandir}/man1/gvmap.sh.1*
625 %{_mandir}/man1/gvpack.1*
626 %{_mandir}/man1/gvpr.1*
627 %{_mandir}/man1/gxl2gv.1*
628 %{_mandir}/man1/lefty.1*
629 %{_mandir}/man1/lneato.1*
630 %{_mandir}/man1/mm2gv.1*
631 %{_mandir}/man1/neato.1*
632 %{_mandir}/man1/nop.1*
633 %{_mandir}/man1/osage.1*
634 %{_mandir}/man1/patchwork.1*
635 %{_mandir}/man1/prune.1*
636 %{_mandir}/man1/sccmap.1*
637 %{_mandir}/man1/sfdp.1*
638 %{_mandir}/man1/tred.1*
639 %{_mandir}/man1/twopi.1*
640 %{_mandir}/man1/unflatten.1*
641 %{_mandir}/man1/vimdot.1*
642 %{_mandir}/man7/graphviz.7*
643
644 %files devel
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libcdt.so
647 %attr(755,root,root) %{_libdir}/libcgraph.so
648 %attr(755,root,root) %{_libdir}/libgraph.so
649 %attr(755,root,root) %{_libdir}/libgvc.so
650 %attr(755,root,root) %{_libdir}/libgvpr.so
651 %attr(755,root,root) %{_libdir}/libpathplan.so
652 %attr(755,root,root) %{_libdir}/libxdot.so
653 %{_libdir}/libcdt.la
654 %{_libdir}/libcgraph.la
655 %{_libdir}/libgraph.la
656 %{_libdir}/libgvc.la
657 %{_libdir}/libgvpr.la
658 %{_libdir}/libpathplan.la
659 %{_libdir}/libxdot.la
660 %{_pkgconfigdir}/libcdt.pc
661 %{_pkgconfigdir}/libcgraph.pc
662 %{_pkgconfigdir}/libgraph.pc
663 %{_pkgconfigdir}/libgvc.pc
664 %{_pkgconfigdir}/libgvpr.pc
665 %{_pkgconfigdir}/libpathplan.pc
666 %{_pkgconfigdir}/libxdot.pc
667 %{_includedir}/graphviz
668 %{_mandir}/man3/cdt.3*
669 %{_mandir}/man3/cgraph.3*
670 %{_mandir}/man3/expr.3*
671 %{_mandir}/man3/graph.3*
672 %{_mandir}/man3/gvc.3*
673 %{_mandir}/man3/pack.3*
674 %{_mandir}/man3/xdot.3*
675
676 %if %{with qt}
677 %files gvedit
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_bindir}/gvedit
680 %{_datadir}/graphviz/gvedit
681 %{_mandir}/man1/gvedit.1*
682 %endif
683
684 %if %{with smyrna}
685 %files smyrna
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_bindir}/smyrna
688 %{_datadir}/graphviz/smyrna
689 %{_mandir}/man1/smyrna.1*
690 %endif
691
692 %files doc-html
693 %defattr(644,root,root,755)
694 %doc doc-html/*
695
696 %files doc-pdf
697 %defattr(644,root,root,755)
698 %doc doc-pdf/*
699
700 %files graphs
701 %defattr(644,root,root,755)
702 %{_datadir}/graphviz/graphs
703
704 %if %{with golang}
705 %files -n golang-%{name}
706 %defattr(644,root,root,755)
707 %dir %{_libdir}/graphviz/go
708 %attr(755,root,root) %{_libdir}/graphviz/go/libgv_go.so
709 %{_mandir}/man3/gv_go.3*
710 %endif
711
712 %if 0
713 %files -n io-%{name}
714 %defattr(644,root,root,755)
715 %dir %{_libdir}/graphviz/io
716 %attr(755,root,root) %{_libdir}/graphviz/io/libgv_io.so*
717 %{_mandir}/mann/gv_io.n*
718 %endif
719
720 %if %{with guile}
721 %files -n guile-%{name}
722 %defattr(644,root,root,755)
723 %dir %{_libdir}/graphviz/guile
724 %attr(755,root,root) %{_libdir}/graphviz/guile/libgv_guile.so
725 %{_mandir}/man3/gv_guile.3*
726 %endif
727
728 %if %{with java}
729 %files -n java-%{name}
730 %defattr(644,root,root,755)
731 %dir %{_libdir}/graphviz/java
732 %attr(755,root,root) %{_libdir}/graphviz/java/libgv_java.so
733 %{_libdir}/graphviz/java/*.java
734 %{_mandir}/man3/gv_java.3*
735 %endif
736
737 %if %{with lua}
738 %files -n lua-%{name}
739 %defattr(644,root,root,755)
740 %dir %{_libdir}/graphviz/lua
741 %attr(755,root,root) %{_libdir}/graphviz/lua/libgv_lua.so
742 %attr(755,root,root) %{_libdir}/graphviz/lua/gv.so
743 %attr(755,root,root) %{_datadir}/graphviz/demo/modgraph.lua
744 %attr(755,root,root) %{_libdir}/lua/gv.so
745 %{_mandir}/man3/gv_lua.3*
746 %endif
747
748 %if %{with ocaml}
749 %files -n ocaml-%{name}
750 %defattr(644,root,root,755)
751 %dir %{_libdir}/graphviz/ocaml
752 %attr(755,root,root) %{_libdir}/graphviz/ocaml/libgv_ocaml.so
753 %{_libdir}/graphviz/ocaml/META.gv
754 # ocamlopt temporarily disabled
755 #%{_libdir}/graphviz/ocaml/gv.a
756 %{_libdir}/graphviz/ocaml/gv.cm*
757 #%{_libdir}/graphviz/ocaml/gv.ml*
758 %{_mandir}/man3/gv_ocaml.3*
759 %endif
760
761 %if %{with perl}
762 %files -n perl-%{name}
763 %defattr(644,root,root,755)
764 %dir %{_libdir}/graphviz/perl
765 %attr(755,root,root) %{_libdir}/graphviz/perl/libgv_perl.so
766 %attr(755,root,root) %{_libdir}/graphviz/perl/gv.so
767 %{_libdir}/graphviz/perl/gv.pm
768 %attr(755,root,root) %{_datadir}/graphviz/demo/modgraph.pl
769 %attr(755,root,root) %{perl_vendorarch}/gv.so
770 %{perl_vendorarch}/gv.pm
771 %{_mandir}/man3/gv_perl.3*
772 %endif
773
774 %if %{with php}
775 %files -n php-%{name}
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{php_extensiondir}/gv.so
778 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{name}.ini
779 %{php_data_dir}/gv.php
780 %{_mandir}/man3/gv_php.3*
781 %{_examplesdir}/php-%{name}-%{version}
782 %endif
783
784 %if %{with python}
785 %files -n python-%{name}
786 %defattr(644,root,root,755)
787 %dir %{_libdir}/graphviz/python
788 %attr(755,root,root) %{_libdir}/graphviz/python/libgv_python.so
789 %attr(755,root,root) %{_libdir}/graphviz/python/_gv.so
790 %{_libdir}/graphviz/python/gv.py
791 %attr(755,root,root) %{_datadir}/graphviz/demo/modgraph.py
792 %attr(755,root,root) %{py_sitedir}/_gv.so
793 %{py_sitedir}/gv.py
794 %{_mandir}/man3/gv_python.3*
795 %endif
796
797 %if %{with ruby}
798 %files -n ruby-%{name}
799 %defattr(644,root,root,755)
800 %dir %{_libdir}/graphviz/ruby
801 %attr(755,root,root) %{_libdir}/graphviz/ruby/libgv_ruby.so
802 %attr(755,root,root) %{_libdir}/graphviz/ruby/gv.so
803 %attr(755,root,root) %{_datadir}/graphviz/demo/modgraph.rb
804 %{ruby_vendorarchdir}/gv.so
805 %{_mandir}/man3/gv_ruby.3*
806 %endif
807
808 %if %{with dotnet}
809 %files -n dotnet-%{name}-sharp
810 %defattr(644,root,root,755)
811 %dir %{_libdir}/graphviz/sharp
812 %attr(755,root,root) %{_libdir}/graphviz/sharp/libgv_sharp.so
813 %{_libdir}/graphviz/sharp/*.cs
814 %{_mandir}/man3/gv_sharp.3*
815 %endif
816
817 %if %{with tcl}
818 %files -n tcl-%{name}
819 %defattr(644,root,root,755)
820 %dir %{_libdir}/graphviz/tcl
821 %attr(755,root,root) %{_libdir}/graphviz/tcl/libgdtclft.so*
822 %attr(755,root,root) %{_libdir}/graphviz/tcl/libgv_tcl.so
823 %attr(755,root,root) %{_libdir}/graphviz/tcl/libtcldot.so*
824 %attr(755,root,root) %{_libdir}/graphviz/tcl/libtcldot_builtin.so*
825 %attr(755,root,root) %{_libdir}/graphviz/tcl/libtclplan.so*
826 %attr(755,root,root) %{_libdir}/graphviz/tcl/libtkspline.so*
827 %{_libdir}/graphviz/tcl/pkgIndex.tcl
828 %{_libdir}/tcl%{tclver}/graphviz
829 %{_mandir}/man3/gv_tcl.3*
830 %{_mandir}/man3/gdtclft.3tcl*
831 %{_mandir}/man3/pathplan.3*
832 %{_mandir}/man3/tcldot.3tcl*
833 %{_mandir}/man3/tkspline.3tk*
834 %{_datadir}/graphviz/demo/pathplan_data
835 %{_datadir}/graphviz/demo/*.README
836 %{_datadir}/graphviz/demo/*.html
837 %attr(755,root,root) %{_datadir}/graphviz/demo/doted.tcl
838 %attr(755,root,root) %{_datadir}/graphviz/demo/entities.tcl
839 %attr(755,root,root) %{_datadir}/graphviz/demo/gcat.tcl
840 %attr(755,root,root) %{_datadir}/graphviz/demo/modgraph.tcl
841 %attr(755,root,root) %{_datadir}/graphviz/demo/pathplan.tcl
842 %attr(755,root,root) %{_datadir}/graphviz/demo/spline.tcl
843 %endif
844
845 %if %{with r}
846 %files -n R-%{name}
847 %defattr(644,root,root,755)
848 %dir %{_libdir}/%{name}/R
849 %attr(755,root,root) %{_libdir}/%{name}/R/gv.so
850 %attr(755,root,root) %{_libdir}/%{name}/R/libgv_R.so
851 %{_mandir}/man3/gv_r.3*
852 %endif
This page took 0.137993 seconds and 3 git commands to generate.