]> git.pld-linux.org Git - packages/grantlee-qt5.git/blob - grantlee.spec
eb8025176cfdbd4e44ead98110b38dc2e0e0e4a7
[packages/grantlee-qt5.git] / grantlee.spec
1 %define         qt_ver          4.7.1
2
3 Summary:        Grantlee - set of frameworks for use with Qt
4 Summary(pl.UTF-8):      Grantlee - zbiór szkieletów do wykorzystania z Qt
5 Name:           grantlee
6 Version:        0.3.0
7 Release:        1
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://downloads.grantlee.org/%{name}-%{version}.tar.gz
11 # Source0-md5:  195763a3238f51f8885881fc8012cd83
12 Patch0:         %{name}-link.patch
13 URL:            http://www.gitorious.org/grantlee/pages/Home
14 BuildRequires:  QtCore-devel >= %{qt_ver}
15 BuildRequires:  QtGui-devel >= %{qt_ver}
16 BuildRequires:  QtScript-devel >= %{qt_ver}
17 BuildRequires:  QtSql-devel >= %{qt_ver}
18 BuildRequires:  QtTest-devel >= %{qt_ver}
19 BuildRequires:  QtWebKit-devel >= %{qt_ver}
20 BuildRequires:  cmake >= 2.8.0
21 BuildRequires:  qt4-build >= %{qt_ver}
22 BuildRequires:  qt4-qmake >= %{qt_ver}
23 BuildRequires:  rpmbuild(macros) >= 1.605
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Grantlee is a string template engine based on the Django template
28 system and written using Qt.
29
30 %description -l pl.UTF-8
31 Grantlee to silnik szablonów oparty na systemie szablonów Django i
32 napisany przy użyciu Qt.
33
34 %package devel
35 Summary:        Header files for grantlee libraries
36 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek grantlee
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       QtCore-devel >= %{qt_ver}
40 # only _gui (textdocument) library
41 Requires:       QtGui-devel >= %{qt_ver}
42
43 %description devel
44 Header files for grantlee libraries.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe bibliotek grantlee.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52
53 %build
54 install -d build
55 cd build
56 %cmake ..
57
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} -C build install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post   -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS CHANGELOG GOALS README
75 %attr(755,root,root) %{_libdir}/libgrantlee_core.so.*.*.*
76 %attr(755,root,root) %ghost %{_libdir}/libgrantlee_core.so.0
77 %attr(755,root,root) %{_libdir}/libgrantlee_gui.so.*.*.*
78 %attr(755,root,root) %ghost %{_libdir}/libgrantlee_gui.so.0
79 %dir %{_libdir}/grantlee
80 %dir %{_libdir}/grantlee/0.3
81 %attr(755,root,root) %{_libdir}/grantlee/0.3/grantlee_defaultfilters.so
82 %attr(755,root,root) %{_libdir}/grantlee/0.3/grantlee_defaulttags.so
83 %attr(755,root,root) %{_libdir}/grantlee/0.3/grantlee_i18ntags.so
84 %attr(755,root,root) %{_libdir}/grantlee/0.3/grantlee_loadertags.so
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/libgrantlee_core.so
89 %attr(755,root,root) %{_libdir}/libgrantlee_gui.so
90 %{_includedir}/grantlee_core.h
91 %{_includedir}/grantlee_templates.h
92 %{_includedir}/grantlee
93 %{_libdir}/cmake/grantlee
This page took 0.114627 seconds and 3 git commands to generate.