]> git.pld-linux.org Git - packages/grantlee-qt5.git/blob - grantlee.spec
5b3dc863f33ba3db698c4b6d845887e8a0c13e4a
[packages/grantlee-qt5.git] / grantlee.spec
1 %define         qtver           4.7.1
2
3 Summary:        grantlee
4 Summary(pl.UTF-8):      grantlee
5 Name:           grantlee
6 Version:        0.1.1
7 Release:        1
8 License:        GPL
9 Group:          X11/Libraries
10 Source0:        http://downloads.grantlee.org/%{name}-v%{version}.tar.gz
11 # Source0-md5:  961e583c5ab94e7a9a714063e047ace5
12 URL:            http://www.gitorious.org/grantlee/pages/Home
13 BuildRequires:  QtCore-devel >= %{qtver}
14 BuildRequires:  QtGui-devel >= %{qtver}
15 BuildRequires:  QtScript-devel >= %{qtver}
16 BuildRequires:  QtSql-devel >= %{qtver}
17 BuildRequires:  QtTest-devel >= %{qtver}
18 BuildRequires:  QtWebKit-devel >= %{qtver}
19 BuildRequires:  automoc4 >= 0.9.84
20 BuildRequires:  cmake >= 2.8.0
21 BuildRequires:  qt4-build >= %{qtver}
22 BuildRequires:  qt4-qmake >= %{qtver}
23 BuildRequires:  rpmbuild(macros) >= 1.293
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Grantlee is a string template engine based on the Django template
28 system and written in Qt.
29
30 #%description -l pl.UTF-8
31
32 %package devel
33 Summary:        Header files for grantlee
34 Summary(pl.UTF-8):      Pliki nagłówkowe dla grantlee
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for grantlee.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe dla grantlee.
43
44 %prep
45 %setup -q -n %{name}-v%{version}
46
47 %build
48 install -d build
49 cd build
50 %cmake .. \
51         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
52         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
53 %if "%{_lib}" == "lib64"
54         -DLIB_SUFFIX=64
55 %endif
56
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} -C build install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post   -p      /sbin/ldconfig
69 %postun -p      /sbin/ldconfig
70
71 %files
72 %defattr(644,root,root,755)
73 %dir %{_libdir}/grantlee
74 %dir %{_libdir}/grantlee/0.1
75 %attr(755,root,root) %{_libdir}/grantlee/0.1/grantlee_defaultfilters.so
76 %attr(755,root,root) %{_libdir}/grantlee/0.1/grantlee_defaulttags.so
77 %attr(755,root,root) %{_libdir}/grantlee/0.1/grantlee_loadertags.so
78 %attr(755,root,root) %ghost %{_libdir}/libgrantlee_core.so.?
79 %attr(755,root,root) %{_libdir}/libgrantlee_core.so.*.*.*
80 %attr(755,root,root) %ghost %{_libdir}/libgrantlee_gui.so.?
81 %attr(755,root,root) %{_libdir}/libgrantlee_gui.so.*.*.*
82
83 %files devel
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_libdir}/libgrantlee_core.so
86 %attr(755,root,root) %{_libdir}/libgrantlee_gui.so
87 %{_includedir}/grantlee_core.h
88 %{_includedir}/%{name}
89 %{_libdir}/grantlee/0.1/GrantleeUse.cmake
90 %{_libdir}/grantlee/GrantleeConfig.cmake
91 %{_libdir}/grantlee/GrantleeConfigVersion.cmake
This page took 0.039436 seconds and 2 git commands to generate.