]> git.pld-linux.org Git - packages/grantlee-qt5.git/blob - grantlee-qt5.spec
7f57bfc11cb44eaad2330d68e4f737622ff77259
[packages/grantlee-qt5.git] / grantlee-qt5.spec
1 %define         qt_ver          5.3.0
2 %define         major_ver       5.1
3
4 Summary:        Grantlee - set of frameworks for use with Qt 5
5 Summary(pl.UTF-8):      Grantlee - zbiór szkieletów do wykorzystania z Qt 5
6 Name:           grantlee-qt5
7 Version:        5.1.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          Libraries
11 Source0:        http://downloads.grantlee.org/grantlee-%{version}.tar.gz
12 # Source0-md5:  57989ae9f7c113e682ef1713a6f1e92a
13 URL:            http://www.grantlee.org/
14 BuildRequires:  Qt5Core-devel >= %{qt_ver}
15 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
16 BuildRequires:  Qt5Network-devel >= %{qt_ver}
17 BuildRequires:  Qt5Script-devel >= %{qt_ver}
18 BuildRequires:  Qt5Sql-devel >= %{qt_ver}
19 BuildRequires:  Qt5Test-devel >= %{qt_ver}
20 BuildRequires:  Qt5WebKit-devel >= %{qt_ver}
21 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
22 BuildRequires:  Qt5XmlPatterns-devel >= %{qt_ver}
23 BuildRequires:  cmake >= 3.1
24 BuildRequires:  qt5-build >= %{qt_ver}
25 BuildRequires:  qt5-qmake >= %{qt_ver}
26 BuildRequires:  qt5-linguist >= %{qt_ver}
27 BuildRequires:  rpmbuild(macros) >= 1.605
28 Requires:       Qt5Core >= %{qt_ver}
29 Requires:       Qt5Gui >= %{qt_ver}
30 Requires:       Qt5Script >= %{qt_ver}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Grantlee is a string template engine based on the Django template
35 system and written using Qt.
36
37 %description -l pl.UTF-8
38 Grantlee to silnik szablonów oparty na systemie szablonów Django i
39 napisany przy użyciu Qt.
40
41 %package devel
42 Summary:        Header files for grantlee libraries
43 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek grantlee
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       Qt5Core-devel >= %{qt_ver}
47 # only textdocument library
48 Requires:       Qt5Gui-devel >= %{qt_ver}
49 Conflicts:      grantlee-devel
50
51 %description devel
52 Header files for grantlee libraries.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe bibliotek grantlee.
56
57 %prep
58 %setup -q -n grantlee-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake ..
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc AUTHORS CHANGELOG README.md
82 %attr(755,root,root) %{_libdir}/libGrantlee_Templates.so.*.*.*
83 %attr(755,root,root) %ghost %{_libdir}/libGrantlee_Templates.so.5
84 %attr(755,root,root) %{_libdir}/libGrantlee_TextDocument.so.*.*.*
85 %attr(755,root,root) %ghost %{_libdir}/libGrantlee_TextDocument.so.5
86 %dir %{_libdir}/grantlee
87 %dir %{_libdir}/grantlee/%{major_ver}
88 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaultfilters.so
89 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_defaulttags.so
90 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_i18ntags.so
91 %attr(755,root,root) %{_libdir}/grantlee/%{major_ver}/grantlee_loadertags.so
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libGrantlee_Templates.so
96 %attr(755,root,root) %{_libdir}/libGrantlee_TextDocument.so
97 %{_includedir}/grantlee_templates.h
98 %{_includedir}/grantlee_textdocument.h
99 %{_includedir}/grantlee
100 %{_libdir}/cmake/Grantlee5
This page took 0.080023 seconds and 3 git commands to generate.