]> git.pld-linux.org Git - packages/granite.git/blob - granite.spec
disable gsettings and icon update at packaging time, do it at install time
[packages/granite.git] / granite.spec
1 Summary:        An extension of GTK
2 Name:           granite
3 Version:        0.1.1
4 Release:        1
5 License:        GPL v3
6 Group:          X11/Libraries
7 URL:            http://elementaryos.org/
8 Source0:        https://launchpad.net/granite/0.x/%{version}/+download/%{name}-%{version}.tar.gz
9 # Source0-md5:  1bc0bc2df9176940097a26f3d031034a
10 BuildRequires:  cmake
11 BuildRequires:  gettext-devel
12 BuildRequires:  glib2-devel
13 BuildRequires:  gobject-introspection-devel
14 BuildRequires:  gtk+3-devel >= 3.3.14
15 BuildRequires:  libgee0.6-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  pkgconfig
18 BuildRequires:  vala
19 BuildRequires:  vala-libgee0.6
20 BuildRequires:  which
21 Requires:       %{name}-libs = %{version}-%{release}
22 Requires:       glib2 >= 1:2.26.0
23 Requires:       gtk-update-icon-cache
24 Requires:       hicolor-icon-theme
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Granite is an extension of GTK. Among other things, it provides the
29 commonly-used widgets such as modeswitchers, welcome screens,
30 AppMenus, search bars, and more found in elementary apps.
31
32 %package libs
33 Summary:        Library for libgranite
34 Group:          Libraries
35
36 %description libs
37 Library for libgranite.
38
39 %package devel
40 Summary:        Header files for libgranite
41 Group:          Development/Libraries
42 Requires:       %{name}-libs = %{version}-%{release}
43
44 %description devel
45 This package contains the header files for libgranite.
46
47 %prep
48 %setup -q
49
50 %build
51 install -d build
52 cd build
53 %cmake \
54         -DGSETTINGS_COMPILE=OFF \
55         -DICON_UPDATE=OFF \
56         ..
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} install -C build \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %if "%{_lib}" != "lib"
65 mv $RPM_BUILD_ROOT%{_prefix}/lib $RPM_BUILD_ROOT%{_libdir}
66 %endif
67
68 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/rue
69 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sma
70
71 %find_lang %{name}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   libs -p /sbin/ldconfig
77 %postun libs -p /sbin/ldconfig
78
79 %post
80 %update_icon_cache hicolor
81 %glib_compile_schemas
82
83 %postun
84 %update_icon_cache hicolor
85 %glib_compile_schemas
86
87 %files -f %{name}.lang
88 %defattr(644,root,root,755)
89 %doc AUTHORS
90 %attr(755,root,root) %{_bindir}/granite-demo
91 %{_iconsdir}/hicolor/*/actions/application-menu.svg
92 %{_iconsdir}/hicolor/*/actions/application-menu-symbolic.svg
93 %{_libdir}/girepository-1.0/Granite-0.1.1.typelib
94 %{_datadir}/vala/vapi/granite.*
95
96 %files libs
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libgranite.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libgranite.so.0
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_includedir}/%{name}
104 %{_pkgconfigdir}/granite.pc
105 %{_libdir}/libgranite.so
106 %{_datadir}/gir-1.0/Granite-0.1.1.gir
This page took 0.140774 seconds and 4 git commands to generate.