]> git.pld-linux.org Git - packages/granite.git/blob - granite.spec
4e166feb2f0c160af010a2f237d07302d615ebc9
[packages/granite.git] / granite.spec
1 Summary:        An extension of GTK
2 Name:           granite
3 Version:        0.1.1
4 Release:        1
5 License:        GPL v3
6 Group:          X11/Libraries
7 URL:            http://elementaryos.org/
8 Source0:        https://launchpad.net/granite/0.x/%{version}/+download/%{name}-%{version}.tar.gz
9 # Source0-md5:  1bc0bc2df9176940097a26f3d031034a
10 BuildRequires:  cmake
11 BuildRequires:  glib2-devel
12 BuildRequires:  gobject-introspection-devel
13 BuildRequires:  gtk+3-devel
14 BuildRequires:  libgee0.6-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  vala
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Granite is an extension of GTK. Among other things, it provides the
21 commonly-used widgets such as modeswitchers, welcome screens,
22 AppMenus, search bars, and more found in elementary apps.
23
24 %package devel
25 Summary:        Header files for libgranite
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28
29 %description devel
30 Granite is an extension of GTK. Among other things, it provides the
31 commonly-used widgets such as modeswitchers, welcome screens,
32 AppMenus, search bars, and more found in elementary apps.
33
34 This package contains the header files
35
36 %prep
37 %setup -q
38
39 %build
40 install -d build
41 cd build
42 %cmake ..
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} install -C build \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %if "%{_lib}" != "lib"
51 mv $RPM_BUILD_ROOT%{_prefix}/lib $RPM_BUILD_ROOT%{_libdir}
52 %endif
53
54 %find_lang %{name}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post   -p /sbin/ldconfig
60 %postun -p /sbin/ldconfig
61
62 %files -f %{name}.lang
63 %defattr(644,root,root,755)
64 %doc AUTHORS
65 %attr(755,root,root) %{_bindir}/granite-demo
66 %attr(755,root,root) %{_libdir}/libgranite.so.*.*.*
67 %attr(755,root,root) %ghost %{_libdir}/libgranite.so.0
68 %{_iconsdir}/hicolor/*/actions/application-menu.svg
69 %{_iconsdir}/hicolor/*/actions/application-menu-symbolic.svg
70 %{_libdir}/girepository-1.0/Granite-0.1.1.typelib
71 %{_datadir}/vala/vapi/granite.*
72
73 %files devel
74 %defattr(644,root,root,755)
75 %{_includedir}/%{name}
76 %{_pkgconfigdir}/granite.pc
77 %{_libdir}/libgranite.so
78 %{_datadir}/gir-1.0/Granite-0.1.1.gir
This page took 0.061488 seconds and 2 git commands to generate.