]> git.pld-linux.org Git - packages/gr-osmosdr.git/blob - gr-osmosdr.spec
- rebuild with boost 1.57.0
[packages/gr-osmosdr.git] / gr-osmosdr.spec
1 %define snap    20140111
2 %define rel     4
3 Summary:        Common software API for various radio hardware
4 Name:           gr-osmosdr
5 Version:        0.1.1
6 Release:        0.%{snap}.%{rel}
7 License:        GPL v3+
8 Group:          Applications/Engineering
9 URL:            http://sdr.osmocom.org/trac/wiki/GrOsmoSDR
10 Source0:        %{name}-%{snap}.tar.bz2
11 # Source0-md5:  15fbc7e472ee40669c083c1715c7bc58
12 BuildRequires:  boost-devel
13 BuildRequires:  cmake
14 BuildRequires:  doxygen
15 BuildRequires:  gnuradio-devel >= 3.7
16 BuildRequires:  graphviz
17 BuildRequires:  librtlsdr-devel
18 BuildRequires:  python-devel
19 BuildRequires:  swig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Primarily gr-osmosdr supports the OsmoSDR hardware, but it also offers
24 a wrapper functionality for FunCube Dongle, Ettus UHD and rtl-sdr
25 radios. By using gr-osmosdr source you can take advantage of a common
26 software api in your application(s) independent of the underlying
27 radio hardware.
28
29 %package devel
30 Summary:        Development files for gr-osmosdr
31 Group:          Applications/Engineering
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Development files for gr-osmosdr.
36
37 %prep
38 %setup -q -n %{name}
39
40 %build
41 install -d build
42 cd build
43 %cmake \
44         -DENABLE_DOXYGEN=on \
45         -DGR_PKG_DOC_DIR=%{_docdir}/%{name} \
46         ..
47
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} -C build install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 rm -rf doc-inst
57 mv $RPM_BUILD_ROOT%{_docdir}/%{name} doc-inst
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files
66 %defattr(644,root,root,755)
67 %doc AUTHORS COPYING doc-inst/*
68 %attr(755,root,root) %{_bindir}/osmocom_fft
69 %attr(755,root,root) %{_bindir}/osmocom_siggen
70 %attr(755,root,root) %{_bindir}/osmocom_siggen_nogui
71 %attr(755,root,root) %{_bindir}/osmocom_spectrum_sense
72 %attr(755,root,root) %{_libdir}/libgnuradio-osmosdr-*.so.*.*
73 %attr(755,root,root) %ghost %{_libdir}/libgnuradio-osmosdr-*.so.0
74 %dir %{py_sitedir}/osmosdr
75 %attr(755,root,root) %{py_sitedir}/osmosdr/*.so
76 %{py_sitedir}/osmosdr/*.py*
77 %{_datadir}/gnuradio/grc/blocks/osmosdr_sink.xml
78 %{_datadir}/gnuradio/grc/blocks/osmosdr_source.xml
79 %{_datadir}/gnuradio/grc/blocks/rtlsdr_source.xml
80
81 %files devel
82 %defattr(644,root,root,755)
83 %{_includedir}/osmosdr
84 %attr(755,root,root) %{_libdir}/libgnuradio-osmosdr.so
85 %attr(755,root,root) %{_libdir}/libgnuradio-osmosdr-*.so
86 %{_pkgconfigdir}/gnuradio-osmosdr.pc
This page took 0.167196 seconds and 3 git commands to generate.