]> git.pld-linux.org Git - packages/gr-osmosdr.git/blob - gr-osmosdr.spec
- release 7 (by relup.sh)
[packages/gr-osmosdr.git] / gr-osmosdr.spec
1 #
2 # Conditional build:
3 %bcond_with     python          # build with python support
4 #
5 Summary:        Common software API for various radio hardware
6 Name:           gr-osmosdr
7 Version:        0.1.4
8 Release:        7
9 License:        GPL v3+
10 Group:          Applications/Engineering
11 URL:            http://sdr.osmocom.org/trac/wiki/GrOsmoSDR
12 Source0:        http://git.osmocom.org/gr-osmosdr/snapshot/%{name}-%{version}.tar.xz
13 # Source0-md5:  da9733eee05e1409beb1c606c2db4521
14 BuildRequires:  boost-devel
15 BuildRequires:  cmake
16 BuildRequires:  doxygen
17 BuildRequires:  gnuradio-devel >= 3.7.3
18 BuildRequires:  graphviz
19 BuildRequires:  log4cpp-devel
20 BuildRequires:  librtlsdr-devel
21 %{?with_python:BuildRequires:   python-devel}
22 %{?with_python:BuildRequires:   swig}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Primarily gr-osmosdr supports the OsmoSDR hardware, but it also offers
27 a wrapper functionality for FunCube Dongle, Ettus UHD and rtl-sdr
28 radios. By using gr-osmosdr source you can take advantage of a common
29 software api in your application(s) independent of the underlying
30 radio hardware.
31
32 %package devel
33 Summary:        Development files for gr-osmosdr
34 Group:          Applications/Engineering
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Development files for gr-osmosdr.
39
40 %prep
41 %setup -q
42
43 %build
44 install -d build
45 cd build
46 %cmake \
47         %{!?with_python:-DENABLE_PYTHON=OFF} \
48         -DENABLE_DOXYGEN=on \
49         -DGR_PKG_DOC_DIR=%{_docdir}/%{name} \
50         ..
51
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} -C build install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 rm -rf doc-inst
61 mv $RPM_BUILD_ROOT%{_docdir}/%{name} doc-inst
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS COPYING doc-inst/*
72 %if %{with python}
73 %attr(755,root,root) %{_bindir}/osmocom_fft
74 %attr(755,root,root) %{_bindir}/osmocom_siggen
75 %attr(755,root,root) %{_bindir}/osmocom_siggen_nogui
76 %attr(755,root,root) %{_bindir}/osmocom_spectrum_sense
77 %dir %{py_sitedir}/osmosdr
78 %attr(755,root,root) %{py_sitedir}/osmosdr/*.so
79 %{py_sitedir}/osmosdr/*.py*
80 %{_datadir}/gnuradio/grc/blocks/osmosdr_sink.xml
81 %{_datadir}/gnuradio/grc/blocks/osmosdr_source.xml
82 %{_datadir}/gnuradio/grc/blocks/rtlsdr_source.xml
83 %endif
84 %attr(755,root,root) %{_libdir}/libgnuradio-osmosdr-*.so.*.*
85 %attr(755,root,root) %ghost %{_libdir}/libgnuradio-osmosdr-*.so.0
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_includedir}/osmosdr
90 %attr(755,root,root) %{_libdir}/libgnuradio-osmosdr.so
91 %attr(755,root,root) %{_libdir}/libgnuradio-osmosdr-*.so
92 %{_pkgconfigdir}/gnuradio-osmosdr.pc
This page took 0.212589 seconds and 3 git commands to generate.