]> git.pld-linux.org Git - packages/gpgme.git/blob - gpgme.spec
- rel 2; -devel C kde4-kdepimlibs-devel
[packages/gpgme.git] / gpgme.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # do not build static libraries
4 %bcond_without  commonlisp      # Common Lisp interface
5 %bcond_without  cxx             # C++ interface (GpgMEpp library)
6 %bcond_without  qt5             # Qt 5 interface (QGpgME library), requires cxx
7 %bcond_without  python          # Python interfaces (PyME, both python2+python3)
8 %bcond_without  python2         # Python 2 interface (PyME)
9 %bcond_without  python3         # Python 3 interface (PyME)
10 %bcond_with     tests           # perform tests
11 #
12 %if %{without python}
13 %undefine       with_python2
14 %undefine       with_python3
15 %endif
16 %if %{without cxx}
17 %undefine       with_qt5
18 %endif
19 Summary:        Library for accessing GnuPG
20 Summary(pl.UTF-8):      Biblioteka dająca dostęp do funkcji GnuPG
21 Name:           gpgme
22 Version:        1.11.1
23 Release:        2
24 Epoch:          1
25 License:        LGPL v2.1+
26 Group:          Libraries
27 Source0:        ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
28 # Source0-md5:  129c46fb85a7ffa41e43345e48aee884
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-kill-tests.patch
31 Patch2:         %{name}-largefile.patch
32 Patch3:         %{name}-python.patch
33 URL:            http://www.gnupg.org/gpgme.html
34 BuildRequires:  autoconf >= 2.59
35 BuildRequires:  automake >= 1:1.14
36 BuildRequires:  libassuan-devel >= 1:2.4.2
37 BuildRequires:  libgpg-error-devel >= 1.29
38 %{?with_cxx:BuildRequires:      libstdc++-devel >= 6:4.7}
39 BuildRequires:  libtool >= 2:2.2.6
40 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
41 %{?with_python3:BuildRequires:  python3-devel >= 1:3.4}
42 %{?with_python:BuildRequires:   rpm-pythonprov}
43 BuildRequires:  rpmbuild(macros) >= 1.219
44 %{?with_python:BuildRequires:   swig-python}
45 BuildRequires:  texinfo
46 %if %{with qt5}
47 BuildRequires:  Qt5Core-devel >= 5.0.0
48 %{?with_tests:BuildRequires:    Qt5Test-devel >= 5.0.0}
49 BuildRequires:  doxygen
50 BuildRequires:  graphviz
51 BuildRequires:  qt5-build >= 5.0.0
52 %endif
53 BuildConflicts: gnupg < 1.3.0
54 Suggests:       gnupg >= 1.4.0
55 Suggests:       gnupg-smime >= 1.9.8
56 Suggests:       gnupg2 >= 2.0.4
57 Requires:       libassuan >= 1:2.4.2
58 Requires:       libgpg-error >= 1.29
59 Obsoletes:      cryptplug
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 A library for accessing GnuPG.
64
65 %description -l pl.UTF-8
66 Biblioteka dająca dostęp do funkcji GnuPG.
67
68 %package devel
69 Summary:        Header files for GPGME library
70 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GPGME
71 Group:          Development/Libraries
72 Requires:       %{name} = %{epoch}:%{version}-%{release}
73 Requires:       libassuan-devel >= 1:2.4.2
74 Requires:       libgpg-error-devel >= 1.29
75 Conflicts:      kde4-kdepimlibs-devel
76
77 %description devel
78 Header files for GPGME library, needed for compiling programs using
79 GPGME.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki GPGME, potrzebne do kompilacji programów
83 używających GPGME.
84
85 %package static
86 Summary:        Static version of GPGME library
87 Summary(pl.UTF-8):      Statyczna wersja biblioteki GPGME
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
90
91 %description static
92 Static version of GPGME library.
93
94 %description static -l pl.UTF-8
95 Statyczna wersja biblioteki GPGME.
96
97 %package c++
98 Summary:        GpgMEpp - C++ interface for GPGME library
99 Summary(pl.UTF-8):      GpgMEpp - interfejs C++ do biblioteki GPGME
100 Group:          Libraries
101 Requires:       %{name} = %{epoch}:%{version}-%{release}
102
103 %description c++
104 GpgMEpp is a C++ wrapper (or C++ bindings) for the GnuPG project's
105 gpgme (GnuPG Made Easy). It's based on KF5gpgmepp library.
106
107 %description c++ -l pl.UTF-8
108 GpgMEpp to interfejs C++ (wiązania C++) do biblioteki gpgme (GnuPG
109 Made Easy) z projektu GnuPG. Jest oparty na bibliotece KF5gpgme.pp.
110
111 %package c++-devel
112 Summary:        Header files for GpgMEpp library
113 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GpgMEpp
114 Group:          Development/Libraries
115 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
116 Requires:       libstdc++-devel >= 6:4.7
117
118 %description c++-devel
119 Header files for GpgMEpp library.
120
121 %description c++-devel -l pl.UTF-8
122 Pliki nagłówkowe biblioteki GpgMEpp.
123
124 %package c++-static
125 Summary:        Static GpgMEpp library
126 Summary(pl.UTF-8):      Statyczna biblioteka GpgMEpp
127 Group:          Development/Libraries
128 Requires:       %{name}-c++-devel = %{epoch}:%{version}-%{release}
129
130 %description c++-static
131 Static GpgMEpp library.
132
133 %description c++-static -l pl.UTF-8
134 Statyczna biblioteka GpgMEpp.
135
136 %package qt5
137 Summary:        QGpgME - Qt 5 interface for GPGME library
138 Summary(pl.UTF-8):      QGpgME - interfejs Qt 5 do biblioteki GPGME
139 License:        GPL v2+ with Qt linking exception
140 Group:          Libraries
141 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
142 Requires:       Qt5Core >= 5.0.0
143
144 %description qt5
145 QGpgME is Qt 5 interface for GPGME library, based on library from
146 KF5gpgmepp. QGpgME provides a very high level Qt API around GpgMEpp.
147
148 %description qt5 -l pl.UTF-8
149 QGpgME to interfejs Qt 5 do biblioteki GPGME, oparty na bibliotece z
150 KF5gpgmepp. QGpgME udostępnia API Qt do GpgMEpp bardzo wysokiego
151 poziomu.
152
153 %package qt5-devel
154 Summary:        Header files for QGpgME library
155 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki QGpgME
156 License:        GPL v2+ with Qt linking exception
157 Group:          Development/Libraries
158 Requires:       %{name}-c++-devel = %{epoch}:%{version}-%{release}
159 Requires:       %{name}-qt5 = %{epoch}:%{version}-%{release}
160 Requires:       Qt5Core-devel >= 5.0.0
161
162 %description qt5-devel
163 Header files for QGpgME library.
164
165 %description qt5-devel -l pl.UTF-8
166 Pliki nagłówkowe biblioteki QGpgME.
167
168 %package qt5-static
169 Summary:        Static QGpgME library
170 Summary(pl.UTF-8):      Statyczna biblioteka QGpgME
171 License:        GPL v2+ with Qt linking exception
172 Group:          Development/Libraries
173 Requires:       %{name}-qt5-devel = %{epoch}:%{version}-%{release}
174
175 %description qt5-static
176 Static QGpgME library.
177
178 %description qt5-static -l pl.UTF-8
179 Statyczna biblioteka QGpgME.
180
181 %package -n common-lisp-gpgme
182 Summary:        Common Lisp binding for GPGME library
183 Summary(pl.UTF-8):      Wiązanie Common Lispa do biblioteki GPGME
184 Group:          Libraries
185 Requires:       %{name} = %{epoch}:%{version}-%{release}
186 Requires:       common-lisp-controller
187
188 %description -n common-lisp-gpgme
189 Common Lisp binding for GPGME library.
190
191 %description -n common-lisp-gpgme -l pl.UTF-8
192 Wiązanie Common Lispa do biblioteki GPGME.
193
194 %package -n python-gpg
195 Summary:        PyME - Python 2 interface for GPGME library
196 Summary(pl.UTF-8):      PyME - interfejs Pythona 2 do biblioteki GPGME
197 Group:          Libraries/Python
198 Requires:       %{name} = %{epoch}:%{version}-%{release}
199 Requires:       python-libs >= 1:2.7
200 Obsoletes:      python-pyme < 1.8.0
201
202 %description -n python-gpg
203 PyME is a Python interface for GPGME library.
204
205 %description -n python-gpg -l pl.UTF-8
206 PyME to interfejs Pythona do biblioteki GPGME.
207
208 %package -n python3-gpg
209 Summary:        PyME - Python 3 interface for GPGME library
210 Summary(pl.UTF-8):      PyME - interfejs Pythona 3 do biblioteki GPGME
211 Group:          Libraries/Python
212 Requires:       %{name} = %{epoch}:%{version}-%{release}
213 Requires:       python3-libs >= 1:3.4
214 Obsoletes:      python3-pyme < 1.8.0
215
216 %description -n python3-gpg
217 PyME is a Python interface for GPGME library.
218
219 %description -n python3-gpg -l pl.UTF-8
220 PyME to interfejs Pythona do biblioteki GPGME.
221
222 %prep
223 %setup -q
224 %patch0 -p1
225 %{!?with_tests:%patch1 -p1}
226 %patch2 -p1
227 %patch3 -p1
228
229 %build
230 %{__libtoolize}
231 %{__aclocal} -I m4
232 %{__autoconf}
233 %{__autoheader}
234 %{__automake}
235 # in enable-languages:
236 # "python" means both pythons (if available), "python2" just python2, "python3" just python3
237 # (cannot specify "python2 python3" due to script limitations)
238 %configure \
239         --enable-languages="%{?with_commonlisp:cl} %{?with_cxx:cpp} %{?with_python2:python%{!?with_python3:2}} %{?with_python3:%{!?with_python2:python3}} %{?with_qt5:qt}" \
240         %{?with_static_libs:--enable-static}
241
242 %{__make}
243
244 %install
245 rm -rf $RPM_BUILD_ROOT
246
247 %{__make} install \
248         DESTDIR=$RPM_BUILD_ROOT
249
250 %if %{with python2}
251 %py_postclean
252 %endif
253
254 %clean
255 rm -rf $RPM_BUILD_ROOT
256
257 %post   -p /sbin/ldconfig
258 %postun -p /sbin/ldconfig
259
260 %post   devel -p /sbin/postshell
261 -/usr/sbin/fix-info-dir -c %{_infodir}
262
263 %postun devel -p /sbin/postshell
264 -/usr/sbin/fix-info-dir -c %{_infodir}
265
266 %post   c++ -p /sbin/ldconfig
267 %postun c++ -p /sbin/ldconfig
268
269 %post   qt5 -p /sbin/ldconfig
270 %postun qt5 -p /sbin/ldconfig
271
272 %files
273 %defattr(644,root,root,755)
274 %doc AUTHORS ChangeLog README NEWS THANKS TODO
275 %attr(755,root,root) %{_bindir}/gpgme-json
276 %attr(755,root,root) %{_bindir}/gpgme-tool
277 %attr(755,root,root) %{_libdir}/libgpgme.so.*.*.*
278 %attr(755,root,root) %ghost %{_libdir}/libgpgme.so.11
279
280 %files devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_bindir}/gpgme-config
283 %attr(755,root,root) %{_libdir}/libgpgme.so
284 %{_libdir}/libgpgme.la
285 %{_includedir}/gpgme.h
286 %{_aclocaldir}/gpgme.m4
287 %{_infodir}/gpgme.info*
288
289 %if %{with static_libs}
290 %files static
291 %defattr(644,root,root,755)
292 %{_libdir}/libgpgme.a
293 %endif
294
295 %if %{with cxx}
296 %files c++
297 %defattr(644,root,root,755)
298 %doc lang/cpp/README
299 %attr(755,root,root) %{_libdir}/libgpgmepp.so.*.*.*
300 %attr(755,root,root) %ghost %{_libdir}/libgpgmepp.so.6
301
302 %files c++-devel
303 %defattr(644,root,root,755)
304 %attr(755,root,root) %{_libdir}/libgpgmepp.so
305 %{_libdir}/libgpgmepp.la
306 %{_includedir}/gpgme++
307 %{_libdir}/cmake/Gpgmepp
308
309 %if %{with static_libs}
310 %files c++-static
311 %defattr(644,root,root,755)
312 %{_libdir}/libgpgmepp.a
313 %endif
314
315 %if %{with qt5}
316 %files qt5
317 %defattr(644,root,root,755)
318 %doc lang/qt/README
319 %attr(755,root,root) %{_libdir}/libqgpgme.so.*.*.*
320 %attr(755,root,root) %ghost %{_libdir}/libqgpgme.so.7
321
322 %files qt5-devel
323 %defattr(644,root,root,755)
324 %attr(755,root,root) %{_libdir}/libqgpgme.so
325 %{_libdir}/libqgpgme.la
326 %{_includedir}/QGpgME
327 %{_includedir}/qgpgme
328 %{_libdir}/cmake/QGpgme
329
330 %if %{with static_libs}
331 %files qt5-static
332 %defattr(644,root,root,755)
333 %{_libdir}/libqgpgme.a
334 %endif
335 %endif
336 %endif
337
338 %if %{with commonlisp}
339 %files -n common-lisp-gpgme
340 %defattr(644,root,root,755)
341 %doc lang/cl/README
342 %{_datadir}/common-lisp/source/gpgme
343 %endif
344
345 %if %{with python2}
346 %files -n python-gpg
347 %defattr(644,root,root,755)
348 %doc lang/python/README
349 %dir %{py_sitedir}/gpg
350 %attr(755,root,root) %{py_sitedir}/gpg/_gpgme.so
351 %{py_sitedir}/gpg/*.py[co]
352 %{py_sitedir}/gpg/constants
353 %{py_sitedir}/gpg-%{version}-py*.egg-info
354 %endif
355
356 %if %{with python3}
357 %files -n python3-gpg
358 %defattr(644,root,root,755)
359 %doc lang/python/README
360 %dir %{py3_sitedir}/gpg
361 %attr(755,root,root) %{py3_sitedir}/gpg/_gpgme.cpython-*.so
362 %{py3_sitedir}/gpg/*.py
363 %{py3_sitedir}/gpg/__pycache__
364 %{py3_sitedir}/gpg/constants
365 %{py3_sitedir}/gpg-%{version}-py*.egg-info
366 %endif
This page took 0.152252 seconds and 3 git commands to generate.