]> git.pld-linux.org Git - packages/gpgme.git/blob - gpgme.spec
53885ca988ca7a7ce84491a0befb8ab946308d43
[packages/gpgme.git] / gpgme.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # do not build static libraries
4 %bcond_without  commonlisp      # Common Lisp interface
5 %bcond_without  cxx             # C++ interface (GpgMEpp library)
6 %bcond_without  qt5             # Qt 5 interface (QGpgME library), requires cxx
7 %bcond_without  python          # Python interfaces (PyME, both python2+python3)
8 %bcond_without  python2         # Python 2 interface (PyME)
9 %bcond_without  python3         # Python 3 interface (PyME)
10 %bcond_without  tests           # perform tests
11 #
12 %if %{without python}
13 %undefine       with_python2
14 %undefine       with_python3
15 %endif
16 %if %{without cxx}
17 %undefine       with_qt5
18 %endif
19 Summary:        Library for accessing GnuPG
20 Summary(pl.UTF-8):      Biblioteka dająca dostęp do funkcji GnuPG
21 Name:           gpgme
22 Version:        1.12.0
23 Release:        1
24 Epoch:          1
25 License:        LGPL v2.1+
26 Group:          Libraries
27 Source0:        ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
28 # Source0-md5:  902fca3a94907efe4e929b2ade545a7c
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-kill-tests.patch
31 Patch2:         %{name}-largefile.patch
32 Patch3:         %{name}-python.patch
33 URL:            http://www.gnupg.org/gpgme.html
34 BuildRequires:  autoconf >= 2.59
35 BuildRequires:  automake >= 1:1.14
36 %{?with_tests:BuildRequires:    gnupg-agent}
37 %{?with_tests:BuildRequires:    gnupg-smime}
38 BuildRequires:  libassuan-devel >= 1:2.4.2
39 BuildRequires:  libgpg-error-devel >= 1.29
40 %{?with_cxx:BuildRequires:      libstdc++-devel >= 6:4.7}
41 BuildRequires:  libtool >= 2:2.2.6
42 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
43 %{?with_python3:BuildRequires:  python3-devel >= 1:3.4}
44 %{?with_python:BuildRequires:   rpm-pythonprov}
45 BuildRequires:  rpmbuild(macros) >= 1.219
46 %{?with_python:BuildRequires:   swig-python}
47 BuildRequires:  texinfo
48 %if %{with qt5}
49 BuildRequires:  Qt5Core-devel >= 5.0.0
50 %{?with_tests:BuildRequires:    Qt5Test-devel >= 5.0.0}
51 BuildRequires:  doxygen
52 BuildRequires:  graphviz
53 BuildRequires:  qt5-build >= 5.0.0
54 %endif
55 BuildConflicts: gnupg < 1.3.0
56 Suggests:       gnupg >= 1.4.0
57 Suggests:       gnupg-smime >= 1.9.8
58 Suggests:       gnupg2 >= 2.0.4
59 Requires:       libassuan >= 1:2.4.2
60 Requires:       libgpg-error >= 1.29
61 Obsoletes:      cryptplug
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 A library for accessing GnuPG.
66
67 %description -l pl.UTF-8
68 Biblioteka dająca dostęp do funkcji GnuPG.
69
70 %package devel
71 Summary:        Header files for GPGME library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GPGME
73 Group:          Development/Libraries
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75 Requires:       libassuan-devel >= 1:2.4.2
76 Requires:       libgpg-error-devel >= 1.29
77
78 %description devel
79 Header files for GPGME library, needed for compiling programs using
80 GPGME.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki GPGME, potrzebne do kompilacji programów
84 używających GPGME.
85
86 %package static
87 Summary:        Static version of GPGME library
88 Summary(pl.UTF-8):      Statyczna wersja biblioteki GPGME
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
91
92 %description static
93 Static version of GPGME library.
94
95 %description static -l pl.UTF-8
96 Statyczna wersja biblioteki GPGME.
97
98 %package c++
99 Summary:        GpgMEpp - C++ interface for GPGME library
100 Summary(pl.UTF-8):      GpgMEpp - interfejs C++ do biblioteki GPGME
101 Group:          Libraries
102 Requires:       %{name} = %{epoch}:%{version}-%{release}
103
104 %description c++
105 GpgMEpp is a C++ wrapper (or C++ bindings) for the GnuPG project's
106 gpgme (GnuPG Made Easy). It's based on KF5gpgmepp library.
107
108 %description c++ -l pl.UTF-8
109 GpgMEpp to interfejs C++ (wiązania C++) do biblioteki gpgme (GnuPG
110 Made Easy) z projektu GnuPG. Jest oparty na bibliotece KF5gpgme.pp.
111
112 %package c++-devel
113 Summary:        Header files for GpgMEpp library
114 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GpgMEpp
115 Group:          Development/Libraries
116 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
117 Requires:       libstdc++-devel >= 6:4.7
118 Conflicts:      kde4-kdepimlibs-devel
119
120 %description c++-devel
121 Header files for GpgMEpp library.
122
123 %description c++-devel -l pl.UTF-8
124 Pliki nagłówkowe biblioteki GpgMEpp.
125
126 %package c++-static
127 Summary:        Static GpgMEpp library
128 Summary(pl.UTF-8):      Statyczna biblioteka GpgMEpp
129 Group:          Development/Libraries
130 Requires:       %{name}-c++-devel = %{epoch}:%{version}-%{release}
131
132 %description c++-static
133 Static GpgMEpp library.
134
135 %description c++-static -l pl.UTF-8
136 Statyczna biblioteka GpgMEpp.
137
138 %package qt5
139 Summary:        QGpgME - Qt 5 interface for GPGME library
140 Summary(pl.UTF-8):      QGpgME - interfejs Qt 5 do biblioteki GPGME
141 License:        GPL v2+ with Qt linking exception
142 Group:          Libraries
143 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
144 Requires:       Qt5Core >= 5.0.0
145
146 %description qt5
147 QGpgME is Qt 5 interface for GPGME library, based on library from
148 KF5gpgmepp. QGpgME provides a very high level Qt API around GpgMEpp.
149
150 %description qt5 -l pl.UTF-8
151 QGpgME to interfejs Qt 5 do biblioteki GPGME, oparty na bibliotece z
152 KF5gpgmepp. QGpgME udostępnia API Qt do GpgMEpp bardzo wysokiego
153 poziomu.
154
155 %package qt5-devel
156 Summary:        Header files for QGpgME library
157 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki QGpgME
158 License:        GPL v2+ with Qt linking exception
159 Group:          Development/Libraries
160 Requires:       %{name}-c++-devel = %{epoch}:%{version}-%{release}
161 Requires:       %{name}-qt5 = %{epoch}:%{version}-%{release}
162 Requires:       Qt5Core-devel >= 5.0.0
163 Conflicts:      kde4-kdepimlibs-devel
164
165 %description qt5-devel
166 Header files for QGpgME library.
167
168 %description qt5-devel -l pl.UTF-8
169 Pliki nagłówkowe biblioteki QGpgME.
170
171 %package qt5-static
172 Summary:        Static QGpgME library
173 Summary(pl.UTF-8):      Statyczna biblioteka QGpgME
174 License:        GPL v2+ with Qt linking exception
175 Group:          Development/Libraries
176 Requires:       %{name}-qt5-devel = %{epoch}:%{version}-%{release}
177
178 %description qt5-static
179 Static QGpgME library.
180
181 %description qt5-static -l pl.UTF-8
182 Statyczna biblioteka QGpgME.
183
184 %package -n common-lisp-gpgme
185 Summary:        Common Lisp binding for GPGME library
186 Summary(pl.UTF-8):      Wiązanie Common Lispa do biblioteki GPGME
187 Group:          Libraries
188 Requires:       %{name} = %{epoch}:%{version}-%{release}
189 Requires:       common-lisp-controller
190
191 %description -n common-lisp-gpgme
192 Common Lisp binding for GPGME library.
193
194 %description -n common-lisp-gpgme -l pl.UTF-8
195 Wiązanie Common Lispa do biblioteki GPGME.
196
197 %package -n python-gpg
198 Summary:        PyME - Python 2 interface for GPGME library
199 Summary(pl.UTF-8):      PyME - interfejs Pythona 2 do biblioteki GPGME
200 Group:          Libraries/Python
201 Requires:       %{name} = %{epoch}:%{version}-%{release}
202 Requires:       python-libs >= 1:2.7
203 Obsoletes:      python-pyme < 1.8.0
204
205 %description -n python-gpg
206 PyME is a Python interface for GPGME library.
207
208 %description -n python-gpg -l pl.UTF-8
209 PyME to interfejs Pythona do biblioteki GPGME.
210
211 %package -n python3-gpg
212 Summary:        PyME - Python 3 interface for GPGME library
213 Summary(pl.UTF-8):      PyME - interfejs Pythona 3 do biblioteki GPGME
214 Group:          Libraries/Python
215 Requires:       %{name} = %{epoch}:%{version}-%{release}
216 Requires:       python3-libs >= 1:3.4
217 Obsoletes:      python3-pyme < 1.8.0
218
219 %description -n python3-gpg
220 PyME is a Python interface for GPGME library.
221
222 %description -n python3-gpg -l pl.UTF-8
223 PyME to interfejs Pythona do biblioteki GPGME.
224
225 %prep
226 %setup -q
227 %patch0 -p1
228 %patch1 -p1
229 %patch2 -p1
230 %patch3 -p1
231
232 %build
233 %{__libtoolize}
234 %{__aclocal} -I m4
235 %{__autoconf}
236 %{__autoheader}
237 %{__automake}
238 # in enable-languages:
239 # "python" means both pythons (if available), "python2" just python2, "python3" just python3
240 # (cannot specify "python2 python3" due to script limitations)
241 %configure \
242 %if %{without tests}
243         --disable-g13-test \
244         --disable-gpg-test \
245         --disable-gpgconf-test \
246         --disable-gpgsm-test \
247 %endif
248         --enable-languages="%{?with_commonlisp:cl} %{?with_cxx:cpp} %{?with_python2:python%{!?with_python3:2}} %{?with_python3:%{!?with_python2:python3}} %{?with_qt5:qt}" \
249         %{?with_static_libs:--enable-static}
250
251 %{__make}
252
253 %install
254 rm -rf $RPM_BUILD_ROOT
255
256 %{__make} install \
257         DESTDIR=$RPM_BUILD_ROOT
258
259 %if %{with python2}
260 %py_postclean
261 %endif
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %post   -p /sbin/ldconfig
267 %postun -p /sbin/ldconfig
268
269 %post   devel -p /sbin/postshell
270 -/usr/sbin/fix-info-dir -c %{_infodir}
271
272 %postun devel -p /sbin/postshell
273 -/usr/sbin/fix-info-dir -c %{_infodir}
274
275 %post   c++ -p /sbin/ldconfig
276 %postun c++ -p /sbin/ldconfig
277
278 %post   qt5 -p /sbin/ldconfig
279 %postun qt5 -p /sbin/ldconfig
280
281 %files
282 %defattr(644,root,root,755)
283 %doc AUTHORS ChangeLog README NEWS THANKS TODO
284 %attr(755,root,root) %{_bindir}/gpgme-json
285 %attr(755,root,root) %{_bindir}/gpgme-tool
286 %attr(755,root,root) %{_libdir}/libgpgme.so.*.*.*
287 %attr(755,root,root) %ghost %{_libdir}/libgpgme.so.11
288
289 %files devel
290 %defattr(644,root,root,755)
291 %attr(755,root,root) %{_bindir}/gpgme-config
292 %attr(755,root,root) %{_libdir}/libgpgme.so
293 %{_libdir}/libgpgme.la
294 %{_includedir}/gpgme.h
295 %{_aclocaldir}/gpgme.m4
296 %{_infodir}/gpgme.info*
297
298 %if %{with static_libs}
299 %files static
300 %defattr(644,root,root,755)
301 %{_libdir}/libgpgme.a
302 %endif
303
304 %if %{with cxx}
305 %files c++
306 %defattr(644,root,root,755)
307 %doc lang/cpp/README
308 %attr(755,root,root) %{_libdir}/libgpgmepp.so.*.*.*
309 %attr(755,root,root) %ghost %{_libdir}/libgpgmepp.so.6
310
311 %files c++-devel
312 %defattr(644,root,root,755)
313 %attr(755,root,root) %{_libdir}/libgpgmepp.so
314 %{_libdir}/libgpgmepp.la
315 %{_includedir}/gpgme++
316 %{_libdir}/cmake/Gpgmepp
317
318 %if %{with static_libs}
319 %files c++-static
320 %defattr(644,root,root,755)
321 %{_libdir}/libgpgmepp.a
322 %endif
323
324 %if %{with qt5}
325 %files qt5
326 %defattr(644,root,root,755)
327 %doc lang/qt/README
328 %attr(755,root,root) %{_libdir}/libqgpgme.so.*.*.*
329 %attr(755,root,root) %ghost %{_libdir}/libqgpgme.so.7
330
331 %files qt5-devel
332 %defattr(644,root,root,755)
333 %attr(755,root,root) %{_libdir}/libqgpgme.so
334 %{_libdir}/libqgpgme.la
335 %{_includedir}/QGpgME
336 %{_includedir}/qgpgme
337 %{_libdir}/cmake/QGpgme
338
339 %if %{with static_libs}
340 %files qt5-static
341 %defattr(644,root,root,755)
342 %{_libdir}/libqgpgme.a
343 %endif
344 %endif
345 %endif
346
347 %if %{with commonlisp}
348 %files -n common-lisp-gpgme
349 %defattr(644,root,root,755)
350 %doc lang/cl/README
351 %{_datadir}/common-lisp/source/gpgme
352 %endif
353
354 %if %{with python2}
355 %files -n python-gpg
356 %defattr(644,root,root,755)
357 %doc lang/python/README
358 %dir %{py_sitedir}/gpg
359 %attr(755,root,root) %{py_sitedir}/gpg/_gpgme.so
360 %{py_sitedir}/gpg/*.py[co]
361 %{py_sitedir}/gpg/constants
362 %{py_sitedir}/gpg-%{version}-py*.egg-info
363 %endif
364
365 %if %{with python3}
366 %files -n python3-gpg
367 %defattr(644,root,root,755)
368 %doc lang/python/README
369 %dir %{py3_sitedir}/gpg
370 %attr(755,root,root) %{py3_sitedir}/gpg/_gpgme.cpython-*.so
371 %{py3_sitedir}/gpg/*.py
372 %{py3_sitedir}/gpg/__pycache__
373 %{py3_sitedir}/gpg/constants
374 %{py3_sitedir}/gpg-%{version}-py*.egg-info
375 %endif
This page took 0.191881 seconds and 2 git commands to generate.