]> git.pld-linux.org Git - packages/gpgme.git/blob - gpgme.spec
20e3ff34fc4c77648ec6bcfaf69548cf0e92a647
[packages/gpgme.git] / gpgme.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # do not build static libraries
4 %bcond_without  commonlisp      # Common Lisp interface
5 %bcond_without  cxx             # C++ interface (GpgMEpp library)
6 %bcond_without  qt5             # Qt 5 interface (QGpgME library), requires cxx
7 %bcond_without  python          # Python interfaces (PyME, both python2+python3)
8 %bcond_without  python2         # Python 2 interface (PyME)
9 %bcond_without  python3         # Python 3 interface (PyME)
10 %bcond_with     tests           # perform tests
11 #
12 %if %{without python}
13 %undefine       with_python2
14 %undefine       with_python3
15 %endif
16 %if %{without cxx}
17 %undefine       with_qt5
18 %endif
19 Summary:        Library for accessing GnuPG
20 Summary(pl.UTF-8):      Biblioteka dająca dostęp do funkcji GnuPG
21 Name:           gpgme
22 Version:        1.11.1
23 Release:        1
24 Epoch:          1
25 License:        LGPL v2.1+
26 Group:          Libraries
27 Source0:        ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
28 # Source0-md5:  129c46fb85a7ffa41e43345e48aee884
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-kill-tests.patch
31 Patch2:         %{name}-largefile.patch
32 Patch3:         %{name}-python.patch
33 URL:            http://www.gnupg.org/gpgme.html
34 BuildRequires:  autoconf >= 2.59
35 BuildRequires:  automake >= 1:1.14
36 BuildRequires:  libassuan-devel >= 1:2.4.2
37 BuildRequires:  libgpg-error-devel >= 1.29
38 %{?with_cxx:BuildRequires:      libstdc++-devel >= 6:4.7}
39 BuildRequires:  libtool >= 2:2.2.6
40 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
41 %{?with_python3:BuildRequires:  python3-devel >= 1:3.4}
42 %{?with_python:BuildRequires:   rpm-pythonprov}
43 BuildRequires:  rpmbuild(macros) >= 1.219
44 %{?with_python:BuildRequires:   swig-python}
45 BuildRequires:  texinfo
46 %if %{with qt5}
47 BuildRequires:  Qt5Core-devel >= 5.0.0
48 %{?with_tests:BuildRequires:    Qt5Test-devel >= 5.0.0}
49 BuildRequires:  doxygen
50 BuildRequires:  graphviz
51 BuildRequires:  qt5-build >= 5.0.0
52 %endif
53 BuildConflicts: gnupg < 1.3.0
54 Suggests:       gnupg >= 1.4.0
55 Suggests:       gnupg-smime >= 1.9.8
56 Suggests:       gnupg2 >= 2.0.4
57 Requires:       libassuan >= 1:2.4.2
58 Requires:       libgpg-error >= 1.29
59 Obsoletes:      cryptplug
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 A library for accessing GnuPG.
64
65 %description -l pl.UTF-8
66 Biblioteka dająca dostęp do funkcji GnuPG.
67
68 %package devel
69 Summary:        Header files for GPGME library
70 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GPGME
71 Group:          Development/Libraries
72 Requires:       %{name} = %{epoch}:%{version}-%{release}
73 Requires:       libassuan-devel >= 1:2.4.2
74 Requires:       libgpg-error-devel >= 1.29
75
76 %description devel
77 Header files for GPGME library, needed for compiling programs using
78 GPGME.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki GPGME, potrzebne do kompilacji programów
82 używających GPGME.
83
84 %package static
85 Summary:        Static version of GPGME library
86 Summary(pl.UTF-8):      Statyczna wersja biblioteki GPGME
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
89
90 %description static
91 Static version of GPGME library.
92
93 %description static -l pl.UTF-8
94 Statyczna wersja biblioteki GPGME.
95
96 %package c++
97 Summary:        GpgMEpp - C++ interface for GPGME library
98 Summary(pl.UTF-8):      GpgMEpp - interfejs C++ do biblioteki GPGME
99 Group:          Libraries
100 Requires:       %{name} = %{epoch}:%{version}-%{release}
101
102 %description c++
103 GpgMEpp is a C++ wrapper (or C++ bindings) for the GnuPG project's
104 gpgme (GnuPG Made Easy). It's based on KF5gpgmepp library.
105
106 %description c++ -l pl.UTF-8
107 GpgMEpp to interfejs C++ (wiązania C++) do biblioteki gpgme (GnuPG
108 Made Easy) z projektu GnuPG. Jest oparty na bibliotece KF5gpgme.pp.
109
110 %package c++-devel
111 Summary:        Header files for GpgMEpp library
112 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GpgMEpp
113 Group:          Development/Libraries
114 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
115 Requires:       libstdc++-devel >= 6:4.7
116
117 %description c++-devel
118 Header files for GpgMEpp library.
119
120 %description c++-devel -l pl.UTF-8
121 Pliki nagłówkowe biblioteki GpgMEpp.
122
123 %package c++-static
124 Summary:        Static GpgMEpp library
125 Summary(pl.UTF-8):      Statyczna biblioteka GpgMEpp
126 Group:          Development/Libraries
127 Requires:       %{name}-c++-devel = %{epoch}:%{version}-%{release}
128
129 %description c++-static
130 Static GpgMEpp library.
131
132 %description c++-static -l pl.UTF-8
133 Statyczna biblioteka GpgMEpp.
134
135 %package qt5
136 Summary:        QGpgME - Qt 5 interface for GPGME library
137 Summary(pl.UTF-8):      QGpgME - interfejs Qt 5 do biblioteki GPGME
138 License:        GPL v2+ with Qt linking exception
139 Group:          Libraries
140 Requires:       %{name}-c++ = %{epoch}:%{version}-%{release}
141 Requires:       Qt5Core >= 5.0.0
142
143 %description qt5
144 QGpgME is Qt 5 interface for GPGME library, based on library from
145 KF5gpgmepp. QGpgME provides a very high level Qt API around GpgMEpp.
146
147 %description qt5 -l pl.UTF-8
148 QGpgME to interfejs Qt 5 do biblioteki GPGME, oparty na bibliotece z
149 KF5gpgmepp. QGpgME udostępnia API Qt do GpgMEpp bardzo wysokiego
150 poziomu.
151
152 %package qt5-devel
153 Summary:        Header files for QGpgME library
154 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki QGpgME
155 License:        GPL v2+ with Qt linking exception
156 Group:          Development/Libraries
157 Requires:       %{name}-c++-devel = %{epoch}:%{version}-%{release}
158 Requires:       %{name}-qt5 = %{epoch}:%{version}-%{release}
159 Requires:       Qt5Core-devel >= 5.0.0
160
161 %description qt5-devel
162 Header files for QGpgME library.
163
164 %description qt5-devel -l pl.UTF-8
165 Pliki nagłówkowe biblioteki QGpgME.
166
167 %package qt5-static
168 Summary:        Static QGpgME library
169 Summary(pl.UTF-8):      Statyczna biblioteka QGpgME
170 License:        GPL v2+ with Qt linking exception
171 Group:          Development/Libraries
172 Requires:       %{name}-qt5-devel = %{epoch}:%{version}-%{release}
173
174 %description qt5-static
175 Static QGpgME library.
176
177 %description qt5-static -l pl.UTF-8
178 Statyczna biblioteka QGpgME.
179
180 %package -n common-lisp-gpgme
181 Summary:        Common Lisp binding for GPGME library
182 Summary(pl.UTF-8):      Wiązanie Common Lispa do biblioteki GPGME
183 Group:          Libraries
184 Requires:       %{name} = %{epoch}:%{version}-%{release}
185 Requires:       common-lisp-controller
186
187 %description -n common-lisp-gpgme
188 Common Lisp binding for GPGME library.
189
190 %description -n common-lisp-gpgme -l pl.UTF-8
191 Wiązanie Common Lispa do biblioteki GPGME.
192
193 %package -n python-gpg
194 Summary:        PyME - Python 2 interface for GPGME library
195 Summary(pl.UTF-8):      PyME - interfejs Pythona 2 do biblioteki GPGME
196 Group:          Libraries/Python
197 Requires:       %{name} = %{epoch}:%{version}-%{release}
198 Requires:       python-libs >= 1:2.7
199 Obsoletes:      python-pyme < 1.8.0
200
201 %description -n python-gpg
202 PyME is a Python interface for GPGME library.
203
204 %description -n python-gpg -l pl.UTF-8
205 PyME to interfejs Pythona do biblioteki GPGME.
206
207 %package -n python3-gpg
208 Summary:        PyME - Python 3 interface for GPGME library
209 Summary(pl.UTF-8):      PyME - interfejs Pythona 3 do biblioteki GPGME
210 Group:          Libraries/Python
211 Requires:       %{name} = %{epoch}:%{version}-%{release}
212 Requires:       python3-libs >= 1:3.4
213 Obsoletes:      python3-pyme < 1.8.0
214
215 %description -n python3-gpg
216 PyME is a Python interface for GPGME library.
217
218 %description -n python3-gpg -l pl.UTF-8
219 PyME to interfejs Pythona do biblioteki GPGME.
220
221 %prep
222 %setup -q
223 %patch0 -p1
224 %{!?with_tests:%patch1 -p1}
225 %patch2 -p1
226 %patch3 -p1
227
228 %build
229 %{__libtoolize}
230 %{__aclocal} -I m4
231 %{__autoconf}
232 %{__autoheader}
233 %{__automake}
234 # in enable-languages:
235 # "python" means both pythons (if available), "python2" just python2, "python3" just python3
236 # (cannot specify "python2 python3" due to script limitations)
237 %configure \
238         --enable-languages="%{?with_commonlisp:cl} %{?with_cxx:cpp} %{?with_python2:python%{!?with_python3:2}} %{?with_python3:%{!?with_python2:python3}} %{?with_qt5:qt}" \
239         %{?with_static_libs:--enable-static}
240
241 %{__make}
242
243 %install
244 rm -rf $RPM_BUILD_ROOT
245
246 %{__make} install \
247         DESTDIR=$RPM_BUILD_ROOT
248
249 %if %{with python2}
250 %py_postclean
251 %endif
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 %post   -p /sbin/ldconfig
257 %postun -p /sbin/ldconfig
258
259 %post   devel -p /sbin/postshell
260 -/usr/sbin/fix-info-dir -c %{_infodir}
261
262 %postun devel -p /sbin/postshell
263 -/usr/sbin/fix-info-dir -c %{_infodir}
264
265 %post   c++ -p /sbin/ldconfig
266 %postun c++ -p /sbin/ldconfig
267
268 %post   qt5 -p /sbin/ldconfig
269 %postun qt5 -p /sbin/ldconfig
270
271 %files
272 %defattr(644,root,root,755)
273 %doc AUTHORS ChangeLog README NEWS THANKS TODO
274 %attr(755,root,root) %{_bindir}/gpgme-json
275 %attr(755,root,root) %{_bindir}/gpgme-tool
276 %attr(755,root,root) %{_libdir}/libgpgme.so.*.*.*
277 %attr(755,root,root) %ghost %{_libdir}/libgpgme.so.11
278
279 %files devel
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_bindir}/gpgme-config
282 %attr(755,root,root) %{_libdir}/libgpgme.so
283 %{_libdir}/libgpgme.la
284 %{_includedir}/gpgme.h
285 %{_aclocaldir}/gpgme.m4
286 %{_infodir}/gpgme.info*
287
288 %if %{with static_libs}
289 %files static
290 %defattr(644,root,root,755)
291 %{_libdir}/libgpgme.a
292 %endif
293
294 %if %{with cxx}
295 %files c++
296 %defattr(644,root,root,755)
297 %doc lang/cpp/README
298 %attr(755,root,root) %{_libdir}/libgpgmepp.so.*.*.*
299 %attr(755,root,root) %ghost %{_libdir}/libgpgmepp.so.6
300
301 %files c++-devel
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_libdir}/libgpgmepp.so
304 %{_libdir}/libgpgmepp.la
305 %{_includedir}/gpgme++
306 %{_libdir}/cmake/Gpgmepp
307
308 %if %{with static_libs}
309 %files c++-static
310 %defattr(644,root,root,755)
311 %{_libdir}/libgpgmepp.a
312 %endif
313
314 %if %{with qt5}
315 %files qt5
316 %defattr(644,root,root,755)
317 %doc lang/qt/README
318 %attr(755,root,root) %{_libdir}/libqgpgme.so.*.*.*
319 %attr(755,root,root) %ghost %{_libdir}/libqgpgme.so.7
320
321 %files qt5-devel
322 %defattr(644,root,root,755)
323 %attr(755,root,root) %{_libdir}/libqgpgme.so
324 %{_libdir}/libqgpgme.la
325 %{_includedir}/QGpgME
326 %{_includedir}/qgpgme
327 %{_libdir}/cmake/QGpgme
328
329 %if %{with static_libs}
330 %files qt5-static
331 %defattr(644,root,root,755)
332 %{_libdir}/libqgpgme.a
333 %endif
334 %endif
335 %endif
336
337 %if %{with commonlisp}
338 %files -n common-lisp-gpgme
339 %defattr(644,root,root,755)
340 %doc lang/cl/README
341 %{_datadir}/common-lisp/source/gpgme
342 %endif
343
344 %if %{with python2}
345 %files -n python-gpg
346 %defattr(644,root,root,755)
347 %doc lang/python/README
348 %dir %{py_sitedir}/gpg
349 %attr(755,root,root) %{py_sitedir}/gpg/_gpgme.so
350 %{py_sitedir}/gpg/*.py[co]
351 %{py_sitedir}/gpg/constants
352 %{py_sitedir}/gpg-%{version}-py*.egg-info
353 %endif
354
355 %if %{with python3}
356 %files -n python3-gpg
357 %defattr(644,root,root,755)
358 %doc lang/python/README
359 %dir %{py3_sitedir}/gpg
360 %attr(755,root,root) %{py3_sitedir}/gpg/_gpgme.cpython-*.so
361 %{py3_sitedir}/gpg/*.py
362 %{py3_sitedir}/gpg/__pycache__
363 %{py3_sitedir}/gpg/constants
364 %{py3_sitedir}/gpg-%{version}-py*.egg-info
365 %endif
This page took 0.098808 seconds and 2 git commands to generate.