]> git.pld-linux.org Git - packages/gperftools.git/blob - gperftools.spec
- up to 1.10; new sonames
[packages/gperftools.git] / gperftools.spec
1 # NOTE: shared /%{_lib}/libtcmalloc* is useless without /usr/%{_lib}/libstdc++.so.6
2 #
3 Summary:        Fast, multi-threaded malloc and performance analysis tools
4 Summary(pl.UTF-8):      Szybka, wielowątkowa implementacja malloc i narzędzia do analizy wydajności
5 Name:           gperftools
6 Version:        2.0
7 Release:        1
8 License:        BSD
9 Group:          Libraries
10 # Source0Download: http://code.google.com/p/gperftools/downloads/list
11 Source0:        http://gperftools.googlecode.com/files/%{name}-%{version}.tar.gz
12 # Source0-md5:  13f6e8961bc6a26749783137995786b6
13 Patch0:         %{name}-glibc216-siginfo_t.patch
14 URL:            http://code.google.com/p/gperftools/
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 %ifarch %{x8664} ia64
18 BuildRequires:  libunwind-devel >= 0.98.6
19 %endif
20 Requires:       libtcmalloc = %{version}-%{release}
21 Obsoletes:      google-perftools < 2.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Perf Tools is a collection of performance analysis tools, including a
26 high-performance multi-threaded malloc() implementation that works
27 particularly well with threads and STL, a thread-friendly
28 heap-checker, a heap profiler, and a cpu-profiler.
29
30 %description -l pl.UTF-8
31 Perf Tools to zbiór narzędzi do analizy wydajności, zawierający także
32 bardzo wydajną, wielowątkową implementację malloc(), działającą dobrze
33 w szczególności z wątkami i STL-em, a także przyjazne wątkom narzędzie
34 do kontroli sterty, profilter sterty oraz profile wykorzystania CPU.
35
36 %package devel
37 Summary:        Development files of perftools libraries
38 Summary(pl.UTF-8):      Pliki programistyczne bibliotek perftools
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       libtcmalloc-devel = %{version}-%{release}
42 Obsoletes:      google-perftools-devel < 2.0
43
44 %description devel
45 The google-perftools-devel package contains the header files needed to
46 develop applications with google-perftools libraries.
47
48 %description devel -l pl.UTF-8
49 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji z
50 użyciem bibliotek google-perftools.
51
52 %package static
53 Summary:        Static perftools libraries
54 Summary(pl.UTF-8):      Statyczne biblioteki perftools
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57 Obsoletes:      google-perftools-static < 2.0
58
59 %description static
60 The google-perftools-static package contains the static libraries of
61 google-perftools.
62
63 %description static -l pl.UTF-8
64 Ten pakiet zawiera biblioteki statyczne google-perftools.
65
66 %package -n libtcmalloc
67 Summary:        Fast, multi-threaded malloc by Google
68 Summary(pl.UTF-8):      Szybka, wielowątkowa implementacja malloc firmy Google
69 Group:          Libraries
70 Conflicts:      google-perftools < 1.8.3-3
71
72 %description -n libtcmalloc
73 Fast, multi-threaded malloc by Google.
74
75 %description -n libtcmalloc -l pl.UTF-8
76 Szybka, wielowątkowa implementacja malloc firmy Google.
77
78 %package -n libtcmalloc-devel
79 Summary:        Fast, multi-threaded malloc by Google - header files
80 Summary(pl.UTF-8):      Szybka, wielowątkowa implementacja malloc firmy Google - pliki nagłówkowe
81 Group:          Development/Libraries
82 Requires:       libstdc++-devel
83 Requires:       libtcmalloc = %{version}-%{release}
84
85 %description -n libtcmalloc-devel
86 Fast, multi-threaded malloc by Google - header files.
87
88 %description -n libtcmalloc-devel -l pl.UTF-8
89 Szybka, wielowątkowa implementacja malloc firmy Google - pliki
90 nagłówkowe.
91
92 %package -n libtcmalloc-static
93 Summary:        Fast, multi-threaded malloc by Google - static libraries
94 Summary(pl.UTF-8):      Szybka, wielowątkowa implementacja malloc firmy Google - biblioteki statyczne
95 Group:          Development/Libraries
96 Requires:       libtcmalloc-devel = %{version}-%{release}
97
98 %description -n libtcmalloc-static
99 Fast, multi-threaded malloc by Google - static libraries.
100
101 %description -n libtcmalloc-static -l pl.UTF-8
102 Szybka, wielowątkowa implementacja malloc firmy Google - biblioteki
103 statyczne.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 %build
110 %configure \
111 %ifnarch %{x8664} ia64
112         ac_cv_lib_unwind_backtrace=no
113 %endif
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT/%{_lib}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 for pkg in libtcmalloc libtcmalloc_minimal; do
125         mv $RPM_BUILD_ROOT%{_libdir}/${pkg}.so.* \
126                 $RPM_BUILD_ROOT/%{_lib}
127         ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${pkg}.so.*.*.*) \
128                 $RPM_BUILD_ROOT/%{_libdir}/${pkg}.so
129 done
130
131 # clean docdir
132 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc/%{name}-%{version}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %post   -n libtcmalloc -p /sbin/ldconfig
141 %postun -n libtcmalloc -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 # note: INSTALL contains many perftools-specific notes
146 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO doc/*{html,png,gif,txt}
147 %attr(755,root,root) %{_bindir}/pprof
148 %attr(755,root,root) %{_libdir}/libprofiler.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libprofiler.so.0
150 %attr(755,root,root) %{_libdir}/libtcmalloc_and_profiler.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libtcmalloc_and_profiler.so.4
152 %attr(755,root,root) %{_libdir}/libtcmalloc_debug.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libtcmalloc_debug.so.4
154 %attr(755,root,root) %{_libdir}/libtcmalloc_minimal_debug.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libtcmalloc_minimal_debug.so.4
156 %{_mandir}/man1/pprof.1*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libtcmalloc_and_profiler.so
161 %attr(755,root,root) %{_libdir}/libtcmalloc_debug.so
162 %attr(755,root,root) %{_libdir}/libtcmalloc_minimal_debug.so
163 %attr(755,root,root) %{_libdir}/libprofiler.so
164 %{_libdir}/libtcmalloc_and_profiler.la
165 %{_libdir}/libtcmalloc_debug.la
166 %{_libdir}/libtcmalloc_minimal_debug.la
167 %{_libdir}/libprofiler.la
168 %{_includedir}/google/profiler.h
169 %{_includedir}/gperftools/profiler.h
170 %{_pkgconfigdir}/libprofiler.pc
171 %{_pkgconfigdir}/libtcmalloc_debug.pc
172 %{_pkgconfigdir}/libtcmalloc_minimal_debug.pc
173
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/libprofiler.a
177 %{_libdir}/libtcmalloc_and_profiler.a
178 %{_libdir}/libtcmalloc_debug.a
179 %{_libdir}/libtcmalloc_minimal_debug.a
180
181 %files -n libtcmalloc
182 %defattr(644,root,root,755)
183 %attr(755,root,root) /%{_lib}/libtcmalloc.so.*.*.*
184 %attr(755,root,root) %ghost /%{_lib}/libtcmalloc.so.4
185 %attr(755,root,root) /%{_lib}/libtcmalloc_minimal.so.*.*.*
186 %attr(755,root,root) %ghost /%{_lib}/libtcmalloc_minimal.so.4
187
188 %files -n libtcmalloc-devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libtcmalloc.so
191 %attr(755,root,root) %{_libdir}/libtcmalloc_minimal.so
192 %{_libdir}/libtcmalloc.la
193 %{_libdir}/libtcmalloc_minimal.la
194 %dir %{_includedir}/google
195 %{_includedir}/google/heap-*.h
196 %{_includedir}/google/malloc_extension*.h
197 %{_includedir}/google/malloc_hook*.h
198 %{_includedir}/google/stacktrace.h
199 %{_includedir}/google/tcmalloc.h
200 %dir %{_includedir}/gperftools
201 %{_includedir}/gperftools/heap-*.h
202 %{_includedir}/gperftools/malloc_extension*.h
203 %{_includedir}/gperftools/malloc_hook*.h
204 %{_includedir}/gperftools/stacktrace.h
205 %{_includedir}/gperftools/tcmalloc.h
206 %{_pkgconfigdir}/libtcmalloc.pc
207 %{_pkgconfigdir}/libtcmalloc_minimal.pc
208
209 %files -n libtcmalloc-static
210 %defattr(644,root,root,755)
211 %{_libdir}/libtcmalloc.a
212 %{_libdir}/libtcmalloc_minimal.a
This page took 0.069173 seconds and 3 git commands to generate.