]> git.pld-linux.org Git - packages/gpaste.git/blob - gpaste.spec
342c0a1919353048dd8b8e303045633d51bb2d2f
[packages/gpaste.git] / gpaste.spec
1 Summary:        Clipboard management system
2 Name:           gpaste
3 Version:        3.14.2
4 Release:        2
5 License:        GPL v3+
6 Group:          X11/Applications
7 Source0:        http://www.imagination-land.org/files/gpaste/%{name}-%{version}.tar.xz
8 # Source0-md5:  9f88556b7a3101007db93839861367e7
9 URL:            https://github.com/Keruspe/GPaste
10 BuildRequires:  clutter-devel
11 BuildRequires:  dbus-devel
12 BuildRequires:  desktop-file-utils
13 BuildRequires:  gdk-pixbuf2-devel
14 BuildRequires:  gettext-tools
15 BuildRequires:  glib2-devel
16 BuildRequires:  gnome-control-center-devel
17 BuildRequires:  gobject-introspection-devel
18 BuildRequires:  gtk+3-devel
19 BuildRequires:  intltool
20 BuildRequires:  pango-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.673
23 BuildRequires:  systemd-units
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  vala
26 BuildRequires:  xorg-lib-libX11-devel
27 BuildRequires:  xorg-lib-libXi-devel
28 BuildRequires:  xz
29 Requires:       %{name}-libs = %{version}-%{release}
30 Requires:       glib2 >= 1:2.26.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         alt_name        GPaste
34
35 %description
36 gpasted is a clipboard management daemon with DBus interface. gpaste
37 is its CLI client and gpaste-settings is a tool to edit gpasted
38 settings.
39
40 %package libs
41 Summary:        Library to manage the clipboard history
42 Group:          Libraries
43
44 %description libs
45 libgpaste is a library to manage the clipboard history (used by
46 gpasted).
47
48 %package devel
49 Summary:        Development files for %{name}
50 Group:          Development/Libraries
51 Requires:       %{name}-libs = %{version}-%{release}
52
53 %description devel
54 The %{name}-devel package contains libraries and header files for
55 developing applications that use %{name}.
56
57 %package -n gnome-shell-extension-%{name}
58 Summary:        GNOME Shell extension for GPaste
59 Group:          X11/Applications
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       gnome-shell >= 3.14.0
62 %if "%{_rpmversion}" >= "5"
63 BuildArch:      noarch
64 %endif
65
66 %description -n gnome-shell-extension-%{name}
67 %{summary}.
68
69 %package applet
70 Summary:        Tray icon to manage GPaste
71 Group:          X11/Applications
72 Requires:       %{name} = %{version}-%{release}
73
74 %description applet
75 %{summary}.
76
77 %package -n bash-completion-%{name}
78 Summary:        Bash completion for GPaste commands
79 Group:          Applications/Shells
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       bash-completion >= 2.0
82 %if "%{_rpmversion}" >= "5"
83 BuildArch:      noarch
84 %endif
85
86 %description -n bash-completion-%{name}
87 Bash completion for GPaste commands.
88
89 %package -n zsh-completion-%{name}
90 Summary:        zsh completion for GPaste commands
91 Group:          Applications/Shells
92 Requires:       %{name} = %{version}-%{release}
93 %if "%{_rpmversion}" >= "5"
94 BuildArch:      noarch
95 %endif
96
97 %description -n zsh-completion-%{name}
98 zsh completion for GPaste commands.
99
100 %prep
101 %setup -q
102
103 %build
104 [ -f configure ] || NOCONFIGURE=1 ./autogen.sh
105 %configure \
106         --disable-schemas-compile \
107         --disable-silent-rules \
108         --disable-unity \
109         --enable-applet \
110         --enable-vala
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 rm $RPM_BUILD_ROOT%{_libdir}/*.la
119
120 # Install bash/zsh completion support
121 install -d $RPM_BUILD_ROOT%{bash_compdir}
122 cp -p data/completions/%{name} $RPM_BUILD_ROOT%{bash_compdir}
123 install -d $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions
124 cp -p data/completions/_%{name} $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions
125
126 %find_lang %{alt_name}
127
128 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/org.gnome.GPaste.Settings.desktop
129 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/org.gnome.GPaste.Applet.desktop
130 desktop-file-validate $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/org.gnome.GPaste.Applet.desktop
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   libs -p /sbin/ldconfig
136 %postun libs -p /sbin/ldconfig
137
138 %post
139 %glib_compile_schemas
140
141 %postun
142 %glib_compile_schemas
143
144 %files -f %{alt_name}.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS COPYING NEWS README.md THANKS TODO
147 %attr(755,root,root) %{_bindir}/%{name}
148 %{_mandir}/man1/%{name}.1.*
149 %dir %{_libdir}/%{name}
150 %attr(755,root,root) %{_libdir}/%{name}/gpaste-daemon
151 %attr(755,root,root) %{_libdir}/%{name}/gpaste-settings
152 %attr(755,root,root) %{_libdir}/%{name}/gpasted
153 %{_datadir}/appdata/org.gnome.GPaste.Settings.appdata.xml
154 %{_desktopdir}/org.gnome.GPaste.Settings.desktop
155 %{_datadir}/dbus-1/services/org.gnome.GPaste.Applet.service
156 %{_datadir}/dbus-1/services/org.gnome.GPaste.Settings.service
157 %{_datadir}/dbus-1/services/org.gnome.GPaste.service
158 %{_datadir}/glib-2.0/schemas/org.gnome.GPaste.gschema.xml
159 %{_datadir}/gnome-control-center/keybindings/*-gpaste.xml
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libgpaste.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libgpaste.so.2
165 %{_libdir}/girepository-1.0/GPaste-1.0.typelib
166
167 %files devel
168 %defattr(644,root,root,755)
169 %{_datadir}/gir-1.0/GPaste-1.0.gir
170 %{_datadir}/vala/vapi/gpaste-1.0.deps
171 %{_datadir}/vala/vapi/gpaste-1.0.vapi
172 %{_includedir}/%{name}
173 %{_libdir}/libgpaste.so
174 %{_pkgconfigdir}/gpaste-1.0.pc
175
176 %files applet
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/%{name}/%{name}-applet
179 %{_mandir}/man1/%{name}-applet.1.*
180 %{_datadir}/appdata/org.gnome.GPaste.Applet.appdata.xml
181 %{_desktopdir}/org.gnome.GPaste.Applet.desktop
182 /etc/xdg/autostart/org.gnome.GPaste.Applet.desktop
183
184 %files -n gnome-shell-extension-%{name}
185 %defattr(644,root,root,755)
186 %{_datadir}/gnome-shell/extensions/GPaste@gnome-shell-extensions.gnome.org
187
188 %files -n bash-completion-%{name}
189 %defattr(644,root,root,755)
190 %{bash_compdir}/%{name}
191
192 %files -n zsh-completion-%{name}
193 %defattr(644,root,root,755)
194 %{_datadir}/zsh/site-functions/_%{name}
This page took 0.062553 seconds and 2 git commands to generate.