]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- rel 14; missing epoch in BR js-devel
[packages/gpac.git] / gpac.spec
1 #
2 # Conditional build:
3 %bcond_with     amr             # AMR-NB and AMR-WB (floating-point) support
4 %bcond_without  faad            # AAC decoding support
5 %bcond_without  ffmpeg          # ffmpeg support
6 %bcond_without  freetype        # freetype support
7 %bcond_without  jpeg            # JPEG support
8 %bcond_without  js              # JavaScript support
9 %bcond_without  mad             # MP3 support
10 %bcond_without  png             # PNG support
11 %bcond_without  xvid            # xvid support
12 %bcond_without  wx              # wxWidgets support
13 #
14 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
15 Summary(pl.UTF-8):      GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
16 Name:           gpac
17 Version:        0.4.5
18 Release:        14
19 License:        LGPL v2+
20 Group:          Applications/Multimedia
21 Source0:        http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
22 # Source0-md5:  755e8c438a48ebdb13525dd491f5b0d1
23 Patch0:         %{name}-install.patch
24 Patch1:         %{name}-libpng.patch
25 Patch2:         %{name}-pic.patch
26 Patch3:         %{name}-xulrunner.patch
27 Patch4:         %{name}-amr.patch
28 Patch5:         %{name}-ffmpeg.patch
29 Patch6:         %{name}-install-is-not-clean.patch
30 Patch7:         %{name}-flags.patch
31 Patch8:         %{name}-idl_uuid.patch
32 Patch9:         240_all_libpng15.patch
33 Patch10:        250_all_openjpeg14.patch
34 Patch11:        260_all_ffmpeg_bump.patch
35 Patch12:        270_all_ffmpeg_trunk.patch
36 URL:            http://gpac.sourceforge.net/
37 BuildRequires:  SDL-devel
38 BuildRequires:  a52dec-libs-devel
39 BuildRequires:  alsa-lib-devel >= 0.9
40 %{?with_amr:BuildRequires:      amrnb-devel}
41 %{?with_amr:BuildRequires:      amrwb-devel}
42 %{?with_faad:BuildRequires:     faad2-devel}
43 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.6}
44 %{?with_freetype:BuildRequires: freetype-devel}
45 BuildRequires:  jack-audio-connection-kit-devel
46 %{?with_js:BuildRequires:       js-devel < 2:1.8.5}
47 %{?with_jpeg:BuildRequires:     libjpeg-devel}
48 %{?with_mad:BuildRequires:      libmad-devel}
49 BuildRequires:  libogg-devel
50 %{?with_png:BuildRequires:      libpng-devel}
51 BuildRequires:  libtheora-devel
52 BuildRequires:  libvorbis-devel
53 BuildRequires:  libxml2-devel
54 BuildRequires:  openjpeg-devel
55 BuildRequires:  pulseaudio-devel
56 BuildRequires:  rpmbuild(macros) >= 1.357
57 BuildRequires:  sed >= 4.0
58 BuildRequires:  unzip
59 %{?with_wx:BuildRequires:       wxGTK2-unicode-devel >= 2.6.0}
60 BuildRequires:  xmlrpc-c-server-devel
61 BuildRequires:  xorg-lib-libXext-devel
62 BuildRequires:  xorg-lib-libXv-devel
63 BuildRequires:  xulrunner-devel >= 2:9.0.0
64 %{?with_xvid:BuildRequires:     xvid-devel}
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
69 14496-1) developed from scratch in ANSI C.
70
71 The main development goal is to provide a clean (a.k.a. readable by as
72 many people as possible), small and flexible alternative to the MPEG-4
73 Systems reference software (known as IM1 and distributed in ISO/IEC
74 14496-5). The MPEG-4 Reference software is indeed a very large piece
75 of software, designed to verify the standard rather than provide a
76 small, production-stable software. GPAC is written in ANSI C for
77 portability reasons (embedded platforms and DSPs) with a simple goal:
78 keep the memory footprint as low as possible. The project will at term
79 provide player(s), systems encoders and publishing tools for content
80 distribution.
81
82 %description -l pl.UTF-8
83 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
84 stworzona od zera w ANSI C.
85
86 Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
87 dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
88 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
89 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
90 jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
91 standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
92 jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
93 DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
94 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
95 do publikacji w celu dystrybucji materiałów.
96
97 %package devel
98 Summary:        Header files for GPAC library
99 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GPAC
100 Group:          Development/Libraries
101 Requires:       %{name} = %{version}-%{release}
102
103 %description devel
104 Header files for GPAC library.
105
106 %description devel -l pl.UTF-8
107 Pliki nagłówkowe biblioteki GPAC.
108
109 %package gui
110 Summary:        wxWidgets-based GUI for GPAC
111 Summary(pl.UTF-8):      Oparty na wxWidgets graficzny interfejs do GPAC
112 Group:          X11/Applications/Multimedia
113 Requires:       %{name} = %{version}-%{release}
114
115 %description gui
116 Osmo4 - wxWidgets-based GUI for GPAC.
117
118 %description gui -l pl.UTF-8
119 Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
120
121 %package -n browser-plugin-%{name}
122 Summary:        GPAC browser plugin
123 Summary(pl.UTF-8):      Wtyczka GPAC do przegląderek WWW
124 Group:          X11/Libraries
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       browser-plugins >= 2.0
127 Requires:       browser-plugins(%{_target_base_arch})
128
129 %description -n browser-plugin-%{name}
130 GPAC plugin for Netscape-compatible WWW browsers.
131
132 %description -n browser-plugin-%{name} -l pl.UTF-8
133 Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
134
135 %prep
136 %setup -q -n %{name}
137 %patch0 -p1
138 %patch1 -p1
139 %patch2 -p1
140 %patch3 -p1
141 %patch4 -p1
142 %patch5 -p1
143 %patch6 -p1
144 %patch7 -p1
145 %patch8 -p1
146 %patch9 -p1
147 %patch10 -p1
148 %patch11 -p1
149 %patch12 -p1
150
151 %if %{with amr}
152 sed -i -e 's/amr_\([nw]b\)_ft/amr\1/' modules/amr_float_dec/amr_float_dec.c
153 %endif
154 sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
155 chmod a+x configure
156
157 %build
158 cd applications/osmozilla
159 %{_libdir}/xulrunner-sdk/sdk/bin/header.py -I /usr/share/idl/xulrunner -o nsIOsmozilla.h nsIOsmozilla.idl
160 %{_libdir}/xulrunner-sdk/sdk/bin/typelib.py -I /usr/share/idl/xulrunner -o nsIOsmozilla.xpt nsIOsmozilla.idl
161 cp -f nsIOsmozilla.xpt nsIOsmozilla.xpt_linux
162 cd ../..
163 %configure \
164         --X11-path=/usr \
165         --cc="%{__cc}" \
166         --disable-opt \
167         %{!?with_wx:--disable-wx} \
168         %{?with_amr:--enable-amr} \
169         --enable-joystick \
170         --enable-pic \
171         --extra-cflags="%{rpmcflags}" \
172         --extra-ldflags="%{rpmldflags}" \
173         --mozdir=%{_browserpluginsdir} \
174         %{!?with_faad:--use-faad=no} \
175         %{!?with_ffmpeg:--use-ffmpeg=no} \
176         %{!?with_freetype:--use-ft=no} \
177         %{!?with_jpeg:--use-jpeg=no} \
178         %{!?with_js:--use-js=no} \
179         %{!?with_mad:--use-mad=no} \
180         %{!?with_png:--use-png=no} \
181         %{!?with_xvid:--use-xvid=no} \
182         --xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"
183
184 %{__make} -j1 \
185         BUILD_INSTALL=yes \
186         CXX="%{__cxx} -fPIC" \
187         libdir=%{_lib}
188
189 %install
190 rm -rf $RPM_BUILD_ROOT
191
192 %{__make} install \
193         DESTDIR=$RPM_BUILD_ROOT \
194         libdir=%{_lib} \
195         MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
196
197 install -d $RPM_BUILD_ROOT%{_includedir}
198 cp -a include/gpac $RPM_BUILD_ROOT%{_includedir}/gpac
199
200 %clean
201 rm -rf $RPM_BUILD_ROOT
202
203 %post   -p /sbin/ldconfig
204 %postun -p /sbin/ldconfig
205
206 %post -n browser-plugin-%{name}
207 %update_browser_plugins
208
209 %postun -n browser-plugin-%{name}
210 if [ "$1" = 0 ]; then
211         %update_browser_plugins
212 fi
213
214 %files
215 %defattr(644,root,root,755)
216 %doc AUTHORS BUGS Changelog README TODO
217 %attr(755,root,root) %{_bindir}/MP4Box
218 %attr(755,root,root) %{_bindir}/MP4Client
219 %attr(755,root,root) %{_libdir}/libgpac-%{version}.so
220 %attr(755,root,root) %ghost %{_libdir}/libgpac.so
221 %dir %{_libdir}/gpac
222 %attr(755,root,root) %{_libdir}/gpac/gm_*.so
223 %{_datadir}/gpac
224 %{_mandir}/man1/gpac.1*
225 %{_mandir}/man1/mp4box.1*
226 %{_mandir}/man1/mp4client.1*
227
228 %files devel
229 %defattr(644,root,root,755)
230 %{_includedir}/gpac
231
232 %if %{with wx}
233 %files gui
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_bindir}/Osmo4
236 %endif
237
238 %files -n browser-plugin-%{name}
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
241 %{_browserpluginsdir}/nposmozilla.xpt
This page took 0.079991 seconds and 4 git commands to generate.