]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- build with -fPIC
[packages/gpac.git] / gpac.spec
1 #
2 # Conditional build:
3 %bcond_with     amr
4 %bcond_without  faad
5 %bcond_without  ffmpeg
6 %bcond_without  freetype
7 %bcond_without  jpeg
8 %bcond_without  js
9 %bcond_without  mad
10 %bcond_without  png
11 %bcond_without  xvid
12 %bcond_with     wx
13 #
14 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
15 Summary(pl):    GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
16 Name:           gpac
17 Version:        0.2.4
18 Release:        1
19 License:        GPL
20 Group:          Applications
21 Source0:        http://dl.sourceforge.net/gpac/%{name}-%{version}.tar.gz
22 # Source0-md5:  cbbea28e99c23d1839d38c54c2cc090a
23 Source1:        http://www.3gpp.org/ftp/Specs/archive/26_series/26.073/26073-530.zip
24 # Source1-md5:  705f6993fbf890e92eb7a331e7c716d1
25 Patch0:         %{name}-install.patch
26 Patch1:         %{name}-wxWidgets.patch
27 URL:            http://gpac.sourceforge.net/
28 BuildRequires:  SDL-devel
29 %{?with_wx:BuildRequires:       wxGTK2-devel >= 2.5.4}
30 %{?with_faad:BuildRequires:     faad2-devel}
31 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
32 %{?with_freetype:BuildRequires: freetype-devel}
33 %{?with_js:BuildRequires:       js-devel}
34 %{?with_jpeg:BuildRequires:     libjpeg-devel}
35 %{?with_mad:BuildRequires:      libmad-devel}
36 %{?with_png:BuildRequires:      libpng-devel}
37 BuildRequires:  libxml2-devel
38 %{?with_xvid:BuildRequires:     xvid-devel}
39 Requires:       SDL
40 %{?with_faad:Requires:  faad2}
41 %{?with_ffmpeg:Requires:        ffmpeg}
42 %{?with_freetype:Requires:      freetype}
43 %{?with_js:Requires:    js}
44 %{?with_jpeg:Requires:  libjpeg}
45 %{?with_png:Requires:   libpng}
46 %{?with_mad:Requires:   libmad}
47 %{?with_xvid:Requires:  xvid}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _noautoreq   libm4systems.so
51
52 %description
53 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
54 14496-1) developed from scratch in ANSI C.
55
56 The main development goal is to provide a clean (a.k.a. readable by as
57 many people as possible), small and flexible alternative to the MPEG-4
58 Systems reference software (known as IM1 and distributed in ISO/IEC
59 14496-5). The MPEG-4 Reference software is indeed a very large piece
60 of software, designed to verify the standard rather than provide a
61 small, production-stable software. GPAC is written in ANSI C for
62 portability reasons (embedded platforms and DSPs) with a simple goal:
63 keep the memory footprint as low as possible. The project will at term
64 provide player(s), systems encoders and publishing tools for content
65 distribution.
66
67 %description -l pl
68 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
69 stworzona od zera w ANSI C.
70
71 G³ównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
72 dla jak najwiêkszej liczby ludzi), ma³ej i elastycznej alternatywy dla
73 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
74 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
75 jest bardzo du¿± porcj± kodu, zaprojektowan± raczej do zweryfikowania
76 standardu ni¿ dostarczenia ma³ej, stabilnej wersji produkcyjnej. GPAC
77 jest pisany w ANSI C ze wzglêdu na przeno¶no¶æ (platformy wbudowane i
78 DSP) z prostym celem: wymagaæ tak ma³o pamiêci, jak to tylko mo¿liwe.
79 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzêdzia
80 do publikacji w celu dystrybucji materia³ów.
81
82 %prep
83 %setup -q -n gpac
84 %patch0 -p1 
85 %{?with_wx:%patch1 -p1}
86 %if %{with amr}
87 mkdir -p Plugins/amr_dec/AMR_NB
88 cd Plugins/amr_dec/AMR_NB
89 # XXX: (conditional?) SourceN?
90 unzip -j %{_sourcedir}/26073-530.zip
91 unzip -j 26073-530_ANSI_C_source_code.zip
92 %endif
93 chmod a+x configure
94
95 %build
96 %configure \
97         --enable-oss-audio \
98         %{?with_amr: --enable-amr-nb} \
99         %{!?with_faad: --disable-faad} \
100         %{!?with_ffmpeg: --disable-ffmpeg} \
101         %{!?with_freetype: --disable-ft} \
102         %{!?with_jpeg: --disable-jpeg} \
103         %{!?with_js: --disable-js} \
104         %{!?with_mad: --disable-mad} \
105         %{!?with_png: --disable-png} \
106         --extra-cflags="-fPIC" \
107         --extra-ldflags="-fPIC" \
108         %{!?with_xvid: --disable-xvid}
109
110 %{__make} \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         bindir=$RPM_BUILD_ROOT%{_bindir} \
118         libdir=$RPM_BUILD_ROOT%{_libdir} \
119         mandir=$RPM_BUILD_ROOT%{_mandir} \
120         plugdir=$RPM_BUILD_ROOT%{_libdir}/gpac \
121         real_plugdir=%{_libdir}/gpac \
122         prefix=$RPM_BUILD_ROOT/usr
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS BUGS Changelog README TODO
133 %attr(755,root,root) %{_bindir}/*
134 %attr(755,root,root) %{_libdir}/*
135 %{_mandir}/man1/*
This page took 0.057829 seconds and 4 git commands to generate.