]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- no parallel install
[packages/gpac.git] / gpac.spec
1 # TODO:
2 # - Platinum UPnP: http://www.plutinosoft.com/platinum
3 # - AVCap: http://libavcap.sourceforge.net/
4 # - OpenSVCDecoder: http://opensvcdecoder.sourceforge.net/
5 # - libfreenect: http://openkinect.org/wiki/Main_Page
6 #
7 # Conditional build:
8 %bcond_with     amr             # AMR-NB and AMR-WB (floating-point) support
9 %bcond_without  directfb        # DirectFB support
10 %bcond_without  faad            # AAC decoding support
11 %bcond_without  ffmpeg          # ffmpeg support
12 %bcond_without  freetype        # freetype support
13 %bcond_without  jpeg            # JPEG support
14 %bcond_with     js              # JavaScript support
15 %bcond_without  mad             # MP3 support
16 %bcond_without  png             # PNG support
17 %bcond_without  xvid            # xvid support
18 %bcond_without  wx              # wxWidgets support
19 #
20 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
21 Summary(pl.UTF-8):      GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
22 Name:           gpac
23 Version:        0.5.0
24 Release:        8
25 License:        LGPL v2+
26 Group:          Applications/Multimedia
27 Source0:        http://downloads.sourceforge.net/gpac/%{name}-%{version}.tar.gz
28 # Source0-md5:  19f7bb7c16913c22bdd453db1e653ca0
29 Patch0:         %{name}-install.patch
30 Patch1:         %{name}-xulrunner.patch
31 Patch2:         %{name}-amr.patch
32 Patch3:         %{name}-install-is-not-clean.patch
33 Patch4:         %{name}-flags.patch
34 Patch5:         %{name}-idl_uuid.patch
35 Patch6:         %{name}-js.patch
36 Patch7:         %{name}-apps.patch
37 Patch8:         %{name}-export.patch
38 URL:            http://gpac.sourceforge.net/
39 %{?with_directfb:BuildRequires: DirectFB-devel}
40 BuildRequires:  OpenGL-GLU-devel
41 BuildRequires:  SDL-devel
42 BuildRequires:  a52dec-libs-devel
43 BuildRequires:  alsa-lib-devel >= 0.9
44 %{?with_amr:BuildRequires:      amrnb-devel}
45 %{?with_amr:BuildRequires:      amrwb-devel}
46 %{?with_faad:BuildRequires:     faad2-devel}
47 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.6}
48 %{?with_freetype:BuildRequires: freetype-devel}
49 %{?with_wx:BuildRequires:       gtk+2-devel >= 2:2.20.1}
50 BuildRequires:  jack-audio-connection-kit-devel
51 %{?with_js:BuildRequires:       js-devel < 2:1.8.5}
52 %{?with_jpeg:BuildRequires:     libjpeg-devel}
53 %{?with_mad:BuildRequires:      libmad-devel}
54 BuildRequires:  libogg-devel
55 %{?with_png:BuildRequires:      libpng-devel}
56 BuildRequires:  libtheora-devel
57 BuildRequires:  libvorbis-devel
58 BuildRequires:  libxml2-devel
59 BuildRequires:  openjpeg-devel
60 BuildRequires:  openssl-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  pulseaudio-devel
63 BuildRequires:  rpmbuild(macros) >= 1.357
64 BuildRequires:  sed >= 4.0
65 BuildRequires:  unzip
66 %{?with_wx:BuildRequires:       wxGTK2-unicode-devel >= 2.6.0}
67 BuildRequires:  xmlrpc-c-server-devel
68 BuildRequires:  xorg-lib-libXext-devel
69 BuildRequires:  xorg-lib-libXv-devel
70 BuildRequires:  xulrunner-devel >= 2:9.0.0
71 %{?with_xvid:BuildRequires:     xvid-devel}
72 BuildRequires:  zlib-devel
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %description
76 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
77 14496-1) developed from scratch in ANSI C.
78
79 The main development goal is to provide a clean (a.k.a. readable by as
80 many people as possible), small and flexible alternative to the MPEG-4
81 Systems reference software (known as IM1 and distributed in ISO/IEC
82 14496-5). The MPEG-4 Reference software is indeed a very large piece
83 of software, designed to verify the standard rather than provide a
84 small, production-stable software. GPAC is written in ANSI C for
85 portability reasons (embedded platforms and DSPs) with a simple goal:
86 keep the memory footprint as low as possible. The project will at term
87 provide player(s), systems encoders and publishing tools for content
88 distribution.
89
90 %description -l pl.UTF-8
91 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
92 stworzona od zera w ANSI C.
93
94 Głównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
95 dla jak największej liczby ludzi), małej i elastycznej alternatywy dla
96 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
97 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
98 jest bardzo dużą porcją kodu, zaprojektowaną raczej do zweryfikowania
99 standardu niż dostarczenia małej, stabilnej wersji produkcyjnej. GPAC
100 jest pisany w ANSI C ze względu na przenośność (platformy wbudowane i
101 DSP) z prostym celem: wymagać tak mało pamięci, jak to tylko możliwe.
102 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzędzia
103 do publikacji w celu dystrybucji materiałów.
104
105 %package devel
106 Summary:        Header files for GPAC library
107 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GPAC
108 Group:          Development/Libraries
109 Requires:       %{name} = %{version}-%{release}
110
111 %description devel
112 Header files for GPAC library.
113
114 %description devel -l pl.UTF-8
115 Pliki nagłówkowe biblioteki GPAC.
116
117 %package static
118 Summary:        Static GPAC library
119 Summary(pl.UTF-8):      Statyczna biblioteka GPAC
120 Group:          Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description static
124 Static GPAC library.
125
126 %description static -l pl.UTF-8
127 Statyczna biblioteka GPAC.
128
129 %package gui
130 Summary:        wxWidgets-based GUI for GPAC
131 Summary(pl.UTF-8):      Oparty na wxWidgets graficzny interfejs do GPAC
132 Group:          X11/Applications/Multimedia
133 Requires:       %{name} = %{version}-%{release}
134
135 %description gui
136 Osmo4 - wxWidgets-based GUI for GPAC.
137
138 %description gui -l pl.UTF-8
139 Osmo4 - oparty na wxWidgets graficzny interfejs do GPAC.
140
141 %package -n browser-plugin-%{name}
142 Summary:        GPAC browser plugin
143 Summary(pl.UTF-8):      Wtyczka GPAC do przegląderek WWW
144 Group:          X11/Libraries
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       browser-plugins >= 2.0
147 Requires:       browser-plugins(%{_target_base_arch})
148
149 %description -n browser-plugin-%{name}
150 GPAC plugin for Netscape-compatible WWW browsers.
151
152 %description -n browser-plugin-%{name} -l pl.UTF-8
153 Wtyczka GPAC dla przeglądarek WWW zgodnych z Netscape.
154
155 %prep
156 %setup -q -n %{name}
157 %patch0 -p1
158 %patch1 -p1
159 %patch2 -p1
160 %patch3 -p1
161 %patch4 -p1
162 %patch5 -p1
163 %patch6 -p1
164 %patch7 -p1
165 %patch8 -p1
166
167 sed -i -e 's/wx-config/wx-gtk2-unicode-config/' configure
168 chmod a+x configure
169
170 %build
171 # not autoconf configure
172 ./configure \
173         --prefix=%{_prefix} \
174         --libdir=%{_lib} \
175         --mandir=%{_mandir} \
176         --X11-path=/usr \
177         --cc="%{__cc}" \
178         --cpp="%{__cxx}" \
179         --disable-opt \
180         %{!?with_wx:--disable-wx} \
181         %{?with_amr:--enable-amr} \
182         --enable-joystick \
183         --enable-pic \
184         --extra-cflags="%{rpmcflags}" \
185         --extra-ldflags="%{rpmldflags}" \
186         --mozdir=%{_browserpluginsdir} \
187         %{!?with_faad:--use-faad=no} \
188         %{!?with_ffmpeg:--use-ffmpeg=no} \
189         %{!?with_freetype:--use-ft=no} \
190         %{!?with_jpeg:--use-jpeg=no} \
191         %{!?with_js:--use-js=no} \
192         %{!?with_mad:--use-mad=no} \
193         %{!?with_png:--use-png=no} \
194         %{!?with_xvid:--use-xvid=no} \
195         --xulsdk-path="/usr/include/xulrunner -I/usr/include/nspr"
196
197 %{!?with_directfb: sed -i 's/CONFIG_DIRECTFB.*/CONFIG_DIRECTFB=no/' config.mak}
198
199 %{__make} -j1
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
204
205 %{__make} -j1 install install-lib \
206         DESTDIR=$RPM_BUILD_ROOT
207
208 %{__make} -j1 -C applications install \
209         DESTDIR=$RPM_BUILD_ROOT \
210         MOZILLA_DIR=$RPM_BUILD_ROOT%{_browserpluginsdir}
211
212 %clean
213 rm -rf $RPM_BUILD_ROOT
214
215 %post   -p /sbin/ldconfig
216 %postun -p /sbin/ldconfig
217
218 %post -n browser-plugin-%{name}
219 %update_browser_plugins
220
221 %postun -n browser-plugin-%{name}
222 if [ "$1" = 0 ]; then
223         %update_browser_plugins
224 fi
225
226 %files
227 %defattr(644,root,root,755)
228 %doc AUTHORS BUGS Changelog README TODO
229 %attr(755,root,root) %{_bindir}/MP4Box
230 %attr(755,root,root) %{_bindir}/MP4Client
231 %attr(755,root,root) %{_libdir}/libgpac.so.*.*.*
232 %attr(755,root,root) %ghost %{_libdir}/libgpac.so.2
233 %dir %{_libdir}/gpac
234 %attr(755,root,root) %{_libdir}/gpac/gm_*.so
235 %{_datadir}/gpac
236 %{_mandir}/man1/gpac.1*
237 %{_mandir}/man1/mp4box.1*
238 %{_mandir}/man1/mp4client.1*
239
240 %files devel
241 %defattr(644,root,root,755)
242 %attr(755,root,root) %{_libdir}/libgpac.so
243 %{_includedir}/gpac
244 %{_pkgconfigdir}/gpac.pc
245
246 %files static
247 %defattr(644,root,root,755)
248 %{_libdir}/libgpac_static.a
249
250 %if %{with wx}
251 %files gui
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/Osmo4
254 %endif
255
256 %files -n browser-plugin-%{name}
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{_browserpluginsdir}/nposmozilla.so
259 %{_browserpluginsdir}/nposmozilla.xpt
This page took 0.066356 seconds and 3 git commands to generate.