]> git.pld-linux.org Git - packages/gopls.git/blob - gopls.spec
up to 0.12.2
[packages/gopls.git] / gopls.spec
1 %define         vendor_version  0.12.2
2
3 Summary:        Official Go language server developed by the Go team
4 Name:           gopls
5 Version:        0.12.2
6 Release:        1
7 License:        BSD
8 Group:          Development/Tools
9 Source0:        https://github.com/golang/tools/archive/gopls/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  76ff68c87ab64ad1140382e77d6722ab
11 Source1:        %{name}-vendor-%{vendor_version}.tar.xz
12 # Source1-md5:  c15d029d1e15e64b659ed1a40f5dae28
13 URL:            https://pkg.go.dev/golang.org/x/tools/gopls
14 BuildRequires:  golang >= 1.18
15 BuildRequires:  rpmbuild(macros) >= 2.009
16 BuildRequires:  tar >= 1:1.22
17 BuildRequires:  xz
18 ExclusiveArch:  %go_arches
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _debugsource_packages   0
22
23 %description
24 gopls (pronounced "Go please") is the official Go language server
25 developed by the Go team. It provides IDE features to any
26 LSP-compatible editor.
27
28 %prep
29 %setup -q -n tools-%{name}-v%{version} -a1
30
31 %{__mkdir} .go-cache
32
33 %build
34 cd gopls
35 %__go build -v -mod=vendor -o target/gopls
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 install -d $RPM_BUILD_ROOT%{_bindir}
41
42 cp -p gopls/target/gopls $RPM_BUILD_ROOT%{_bindir}/gopls
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46 %files
47 %defattr(644,root,root,755)
48 %doc gopls/doc/*.md gopls/README.md
49 %attr(755,root,root) %{_bindir}/gopls
This page took 0.087669 seconds and 3 git commands to generate.