]> git.pld-linux.org Git - packages/gperftools.git/blob - google-perftools.spec
35252faa64ab3648e6f5f2cd741c47c35bf8ae15
[packages/gperftools.git] / google-perftools.spec
1 # NOTE: shared /%{_lib}/libtcmalloc* is useless without /usr/%{_lib}/libstdc++.so.6
2 #
3 Summary:        Fast, multi-threaded malloc and performance analysis tools
4 Summary(pl.UTF-8):      Szybka, wielowątkowa implementacja malloc i narzędzia do analizy wydajności
5 Name:           google-perftools
6 Version:        1.10
7 Release:        1
8 License:        BSD
9 Group:          Libraries
10 # Source0Download: http://code.google.com/p/google-perftools/downloads/list
11 Source0:        http://gperftools.googlecode.com/files/%{name}-%{version}.tar.gz
12 # Source0-md5:  d3821ffd8a99497c230a1c9652c9c304
13 URL:            http://code.google.com/p/google-perftools/
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 %ifarch %{x8664} ia64
17 BuildRequires:  libunwind-devel >= 0.98.6
18 %endif
19 Requires:       libtcmalloc = %{version}-%{release}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Perf Tools is a collection of performance analysis tools, including a
24 high-performance multi-threaded malloc() implementation that works
25 particularly well with threads and STL, a thread-friendly
26 heap-checker, a heap profiler, and a cpu-profiler.
27
28 %description -l pl.UTF-8
29 Perf Tools to zbiór narzędzi do analizy wydajności, zawierający także
30 bardzo wydajną, wielowątkową implementację malloc(), działającą dobrze
31 w szczególności z wątkami i STL-em, a także przyjazne wątkom narzędzie
32 do kontroli sterty, profilter sterty oraz profile wykorzystania CPU.
33
34 %package devel
35 Summary:        Development files of perftools libraries
36 Summary(pl.UTF-8):      Pliki programistyczne bibliotek perftools
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       libtcmalloc-devel = %{version}-%{release}
40
41 %description devel
42 The google-perftools-devel package contains the header files needed to
43 develop applications with google-perftools libraries.
44
45 %description devel -l pl.UTF-8
46 Ten pakiet zawiera pliki nagłówkowe niezbędne do tworzenia aplikacji z
47 użyciem bibliotek google-perftools.
48
49 %package static
50 Summary:        Static perftools libraries
51 Summary(pl.UTF-8):      Statyczne biblioteki perftools
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 The google-perftools-static package contains the static libraries of
57 google-perftools.
58
59 %description static -l pl.UTF-8
60 Ten pakiet zawiera biblioteki statyczne google-perftools.
61
62 %package -n libtcmalloc
63 Summary:        Fast, multi-threaded malloc by Google
64 Summary(pl.UTF-8):      Szybka, wielowątkowa implementacja malloc firmy Google
65 Group:          Libraries
66 Conflicts:      google-perftools < 1.8.3-3
67
68 %description -n libtcmalloc
69 Fast, multi-threaded malloc by Google.
70
71 %description -n libtcmalloc -l pl.UTF-8
72 Szybka, wielowątkowa implementacja malloc firmy Google.
73
74 %package -n libtcmalloc-devel
75 Summary:        Fast, multi-threaded malloc by Google - header files
76 Summary(pl.UTF-8):      Szybka, wielowątkowa implementacja malloc firmy Google - pliki nagłówkowe
77 Group:          Development/Libraries
78 Requires:       libstdc++-devel
79 Requires:       libtcmalloc = %{version}-%{release}
80
81 %description -n libtcmalloc-devel
82 Fast, multi-threaded malloc by Google - header files.
83
84 %description -n libtcmalloc-devel -l pl.UTF-8
85 Szybka, wielowątkowa implementacja malloc firmy Google - pliki
86 nagłówkowe.
87
88 %package -n libtcmalloc-static
89 Summary:        Fast, multi-threaded malloc by Google - static libraries
90 Summary(pl.UTF-8):      Szybka, wielowątkowa implementacja malloc firmy Google - biblioteki statyczne
91 Group:          Development/Libraries
92 Requires:       libtcmalloc-devel = %{version}-%{release}
93
94 %description -n libtcmalloc-static
95 Fast, multi-threaded malloc by Google - static libraries.
96
97 %description -n libtcmalloc-static -l pl.UTF-8
98 Szybka, wielowątkowa implementacja malloc firmy Google - biblioteki
99 statyczne.
100
101 %prep
102 %setup -q
103
104 %build
105 %configure \
106 %ifnarch %{x8664} ia64
107         ac_cv_lib_unwind_backtrace=no
108 %endif
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT/%{_lib}
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 for pkg in libtcmalloc libtcmalloc_minimal; do
120         mv $RPM_BUILD_ROOT%{_libdir}/${pkg}.so.* \
121                 $RPM_BUILD_ROOT/%{_lib}
122         ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${pkg}.so.*.*.*) \
123                 $RPM_BUILD_ROOT/%{_libdir}/${pkg}.so
124 done
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %post   -n libtcmalloc -p /sbin/ldconfig
133 %postun -n libtcmalloc -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 # note: INSTALL contains many perftools-specific notes
138 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO doc/*{html,png,gif,txt}
139 %attr(755,root,root) %{_bindir}/pprof
140 %attr(755,root,root) %{_libdir}/libprofiler.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/libprofiler.so.0
142 %attr(755,root,root) %{_libdir}/libtcmalloc_and_profiler.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libtcmalloc_and_profiler.so.4
144 %attr(755,root,root) %{_libdir}/libtcmalloc_debug.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libtcmalloc_debug.so.4
146 %attr(755,root,root) %{_libdir}/libtcmalloc_minimal_debug.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libtcmalloc_minimal_debug.so.4
148 %{_mandir}/man1/pprof.1*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libtcmalloc_and_profiler.so
153 %attr(755,root,root) %{_libdir}/libtcmalloc_debug.so
154 %attr(755,root,root) %{_libdir}/libtcmalloc_minimal_debug.so
155 %attr(755,root,root) %{_libdir}/libprofiler.so
156 %{_libdir}/libtcmalloc_and_profiler.la
157 %{_libdir}/libtcmalloc_debug.la
158 %{_libdir}/libtcmalloc_minimal_debug.la
159 %{_libdir}/libprofiler.la
160 %{_includedir}/google/profiler.h
161 %{_pkgconfigdir}/libprofiler.pc
162 %{_pkgconfigdir}/libtcmalloc_debug.pc
163 %{_pkgconfigdir}/libtcmalloc_minimal_debug.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libprofiler.a
168 %{_libdir}/libtcmalloc_and_profiler.a
169 %{_libdir}/libtcmalloc_debug.a
170 %{_libdir}/libtcmalloc_minimal_debug.a
171
172 %files -n libtcmalloc
173 %defattr(644,root,root,755)
174 %attr(755,root,root) /%{_lib}/libtcmalloc.so.*.*.*
175 %attr(755,root,root) %ghost /%{_lib}/libtcmalloc.so.4
176 %attr(755,root,root) /%{_lib}/libtcmalloc_minimal.so.*.*.*
177 %attr(755,root,root) %ghost /%{_lib}/libtcmalloc_minimal.so.4
178
179 %files -n libtcmalloc-devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libtcmalloc.so
182 %attr(755,root,root) %{_libdir}/libtcmalloc_minimal.so
183 %{_libdir}/libtcmalloc.la
184 %{_libdir}/libtcmalloc_minimal.la
185 %dir %{_includedir}/google
186 %{_includedir}/google/heap-*.h
187 %{_includedir}/google/malloc_extension*.h
188 %{_includedir}/google/malloc_hook*.h
189 %{_includedir}/google/stacktrace.h
190 %{_includedir}/google/tcmalloc.h
191 %{_pkgconfigdir}/libtcmalloc.pc
192 %{_pkgconfigdir}/libtcmalloc_minimal.pc
193
194 %files -n libtcmalloc-static
195 %defattr(644,root,root,755)
196 %{_libdir}/libtcmalloc.a
197 %{_libdir}/libtcmalloc_minimal.a
This page took 0.063913 seconds and 2 git commands to generate.