]> git.pld-linux.org Git - packages/google-drive-ocamlfuse.git/blob - google-drive-ocamlfuse.spec
- started update to 0.5.22
[packages/google-drive-ocamlfuse.git] / google-drive-ocamlfuse.spec
1 #
2 # Conditional build:
3 %bcond_with     opt             # build opt
4
5 Summary:        FUSE filesystem over Google Drive
6 Name:           google-drive-ocamlfuse
7 Version:        0.5.22
8 Release:        0.1
9 License:        BSD
10 Group:          Applications/Networking
11 Source0:        https://github.com/astrada/google-drive-ocamlfuse/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  f89dd58e71a8db024b69a449649510f2
13 URL:            https://github.com/astrada/google-drive-ocamlfuse
14 BuildRequires:  cppo >= 0.9.3
15 BuildRequires:  ocaml >= 3.04-7
16 BuildRequires:  ocaml-biniou-devel >= 1.0.6
17 BuildRequires:  ocaml-cryptokit-devel >= 1.9
18 BuildRequires:  ocaml-curl-devel >= 0.6.0
19 BuildRequires:  ocaml-easy-format-devel >= 1.0.1
20 BuildRequires:  ocaml-extlib-devel >= 1.5.4
21 BuildRequires:  ocaml-findlib >= 1.4
22 BuildRequires:  ocaml-fuse-devel >= 2.7.1
23 BuildRequires:  ocaml-gapi-ocaml-devel >= 0.2.10
24 BuildRequires:  ocaml-idl-devel >= 1.05
25 BuildRequires:  ocaml-sqlite-devel >= 2.0.4
26 BuildRequires:  ocaml-xmlm-devel >= 1.1.1
27 BuildRequires:  ocaml-yojson-devel >= 1.1.6
28 %requires_eq    ocaml-runtime
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define debug_package %{nil}
32
33 %description
34 google-drive-ocamlfuse is a FUSE filesystem backed by Google Drive,
35 written in OCaml. It lets you mount your Google Drive on Linux.
36
37 Features
38 - Full read/write access to ordinary files and folders
39 - Read-only access to Google Docs, Sheets, and Slides (exported to
40   configurable formats)
41 - Multiple account support
42 - Duplicate file handling
43 - Access to trash (.Trash directory)
44
45 %package devel
46 Summary:        Google Drive ocamlfuse - development part
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 %requires_eq    ocaml
50
51 %description devel
52 This package contains files needed to develop OCaml programs using
53 this library.
54
55 %description devel -l pl.UTF-8
56 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
57 tej biblioteki.
58
59 %prep
60 %setup -q
61
62 %build
63 ocaml setup.ml -configure \
64         --prefix %{_prefix} \
65         --destdir $RPM_BUILD_ROOT
66 ocaml setup.ml -build
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
71 install -d $OCAMLFIND_DESTDIR
72 ocaml setup.ml -install
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc doc/*.md README.md
80 %attr(755,root,root) %{_bindir}/google-drive-ocamlfuse
This page took 0.072128 seconds and 3 git commands to generate.