]> git.pld-linux.org Git - packages/google-drive-ocamlfuse.git/blob - google-drive-ocamlfuse.spec
6bfeefaf06fa510a0664dfd37697278403a8f223
[packages/google-drive-ocamlfuse.git] / google-drive-ocamlfuse.spec
1 #
2 # Conditional build:
3 %bcond_with     opt             # build opt
4
5 Summary:        FUSE filesystem over Google Drive
6 Name:           google-drive-ocamlfuse
7 Version:        0.5.14
8 Release:        0.1
9 License:        BSD
10 Group:          Applications/Networking
11 Source0:        https://github.com/astrada/google-drive-ocamlfuse/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  7db02eba7ab012f5e967641a256e5e7d
13 URL:            https://github.com/astrada/google-drive-ocamlfuse
14 BuildRequires:  cppo >= 0.9.3
15 BuildRequires:  ocaml >= 3.04-7
16 BuildRequires:  ocaml-biniou-devel >= 1.0.6
17 BuildRequires:  ocaml-cryptokit-devel >= 1.9
18 BuildRequires:  ocaml-curl-devel >= 0.6.0
19 BuildRequires:  ocaml-easy-format-devel >= 1.0.1
20 BuildRequires:  ocaml-extlib-devel >= 1.5.4
21 BuildRequires:  ocaml-findlib >= 1.4
22 BuildRequires:  ocaml-fuse-devel >= 2.7
23 #BuildRequires: ocaml-fuse-devel >= 2.7.1
24 BuildRequires:  ocaml-gapi-ocaml-devel >= 0.2.4
25 BuildRequires:  ocaml-idl-devel >= 1.05
26 BuildRequires:  ocaml-sqlite-devel >= 2.0.4
27 BuildRequires:  ocaml-xmlm-devel >= 1.1.1
28 BuildRequires:  ocaml-yojson-devel >= 1.1.6
29 %requires_eq    ocaml-runtime
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define debug_package %{nil}
33
34 %description
35 google-drive-ocamlfuse is a FUSE filesystem backed by Google Drive,
36 written in OCaml. It lets you mount your Google Drive on Linux.
37
38 Features
39 - Full read/write access to ordinary files and folders
40 - Read-only access to Google Docs, Sheets, and Slides (exported to
41   configurable formats)
42 - Multiple account support
43 - Duplicate file handling
44 - Access to trash (.Trash directory)
45
46 %package devel
47 Summary:        Google Drive ocamlfuse - development part
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %requires_eq    ocaml
51
52 %description devel
53 This package contains files needed to develop OCaml programs using
54 this library.
55
56 %description devel -l pl.UTF-8
57 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
58 tej biblioteki.
59
60 %prep
61 %setup -q
62
63 %build
64 ocaml setup.ml -configure \
65         --prefix %{_prefix} \
66         --destdir $RPM_BUILD_ROOT
67 ocaml setup.ml -build
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 export OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml
72 install -d $OCAMLFIND_DESTDIR
73 ocaml setup.ml -install
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc doc/*.md README.md
81 %attr(755,root,root) %{_bindir}/google-drive-ocamlfuse
This page took 0.099851 seconds and 2 git commands to generate.