]> git.pld-linux.org Git - packages/goocanvas2.git/blob - goocanvas2.spec
deecb20a9a243d3a00f3b4ef884bd6a26a787615
[packages/goocanvas2.git] / goocanvas2.spec
1 Summary:        Cairo/GTK+3 Canvas
2 Summary(pl.UTF-8):      Płótno Cairo/GTK+3
3 Name:           goocanvas2
4 Version:        2.0.4
5 Release:        1
6 License:        LGPL v2
7 Group:          X11/Libraries
8 Source0:        https://download.gnome.org/sources/goocanvas/2.0/goocanvas-%{version}.tar.xz
9 # Source0-md5:  a603f9459d29348b88ba3592bca03274
10 URL:            https://wiki.gnome.org/Projects/GooCanvas
11 BuildRequires:  autoconf >= 2.50
12 BuildRequires:  automake >= 1:1.7
13 BuildRequires:  cairo-devel >= 1.10.0
14 BuildRequires:  docbook-dtd412-xml
15 BuildRequires:  gettext-tools >= 0.19.4
16 BuildRequires:  glib2-devel >= 1:2.28.0
17 BuildRequires:  gobject-introspection-devel >= 0.6.7
18 BuildRequires:  gtk+3-devel >= 3.0.0
19 BuildRequires:  gtk-doc >= 1.16
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  python-pygobject3-devel >= 3
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.752
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       cairo >= 1.10.0
28 Requires:       glib2 >= 1:2.28.0
29 Requires:       gtk+3 >= 3.0.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 GooCanvas is a new canvas widget for GTK+ that uses the Cairo 2D
34 library for drawing. It has a model/view split, and uses interfaces
35 for canvas items and views, so you can easily turn any application
36 object into canvas items.
37
38 This version is for GTK+ 3.
39
40 %description -l pl.UTF-8
41 GooCanvas to nowy widget "płótna" dla GTK+ wykorzystujący do rysowania
42 bibliotekę Cairo 2D. Ma podział model/widok i używa interfejsów dla
43 elementów i widoków, więc można łatwo zamieniać dowolny obiekt
44 aplikacji w elementy płótna.
45
46 Ta wersja jest przeznaczona dla GTK+ 3.
47
48 %package devel
49 Summary:        Header files for goocanvas
50 Summary(pl.UTF-8):      Pliki nagłówkowe goocanvas
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       cairo-devel >= 1.10.0
54 Requires:       glib2-devel >= 1:2.28.0
55 Requires:       gtk+3-devel >= 3.0.0
56
57 %description devel
58 Header files for goocanvas.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe goocanvas.
62
63 %package static
64 Summary:        GooCanvas static library
65 Summary(pl.UTF-8):      Statyczna biblioteka GooCanvas
66 Group:          X11/Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 GooCanvas static library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka GooCanvas.
74
75 %package apidocs
76 Summary:        goocanvas API documentation
77 Summary(pl.UTF-8):      Dokumentacja API goocanvas
78 Group:          Documentation
79 Requires:       gtk-doc-common
80 %{?noarchpackage}
81
82 %description apidocs
83 goocanvas API documentation.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API goocanvas.
87
88 %package examples
89 Summary:        Example programs using goocanvas library
90 Summary(pl.UTF-8):      Przykładowe programy używające biblioteki goocanvas
91 Group:          X11/Development/Libraries
92 %{?noarchpackage}
93
94 %description examples
95 Example programs using goocanvas library.
96
97 %description examples -l pl.UTF-8
98 Przykładowe programy używające biblioteki goocanvas.
99
100 %package -n python-%{name}
101 Summary:        Python binding for GooCanvas 2.x library
102 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GooCanvas 2.x
103 Group:          Development/Languages/Python
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       python-pygobject3 >= 3.0
106
107 %description -n python-%{name}
108 Python binding for GooCanvas 2.x library.
109
110 %description -n python-%{name} -l pl.UTF-8
111 Wiązania Pythona do biblioteki GooCanvas 2.x.
112
113 %prep
114 %setup -q -n goocanvas-%{version}
115
116 %build
117 %{__gtkdocize}
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         --disable-silent-rules \
125         --enable-gtk-doc \
126         --with-html-dir=%{_gtkdocdir}
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 # prepare and install examples
137 %{__make} clean -C demo
138 cp demo/*.c demo/*.h demo/*.png $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
139
140 # obsoleted by pkgconfig support
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
142
143 %find_lang %{name}
144 %py_postclean
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README TODO
155 %attr(755,root,root) %{_libdir}/libgoocanvas-2.0.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libgoocanvas-2.0.so.9
157 %{_libdir}/girepository-1.0/GooCanvas-2.0.typelib
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libgoocanvas-2.0.so
162 %{_includedir}/goocanvas-2.0
163 %{_datadir}/gir-1.0/GooCanvas-2.0.gir
164 %{_pkgconfigdir}/goocanvas-2.0.pc
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libgoocanvas-2.0.a
169
170 %files apidocs
171 %defattr(644,root,root,755)
172 %{_gtkdocdir}/goocanvas2
173
174 %files examples
175 %defattr(644,root,root,755)
176 %{_examplesdir}/%{name}-%{version}
177
178 %files -n python-%{name}
179 %defattr(644,root,root,755)
180 %{py_sitedir}/gi/overrides/GooCanvas.py[co]
This page took 0.069015 seconds and 2 git commands to generate.