]> git.pld-linux.org Git - packages/goocanvas2.git/blob - goocanvas2.spec
50488eaf6c7ff210167b46953e61fa12367aea64
[packages/goocanvas2.git] / goocanvas2.spec
1 Summary:        Cairo/GTK+3 Canvas
2 Summary(pl.UTF-8):      Płótno Cairo/GTK+3
3 Name:           goocanvas2
4 Version:        2.0.4
5 Release:        1
6 License:        LGPL v2
7 Group:          X11/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/goocanvas/2.0/goocanvas-%{version}.tar.xz
9 # Source0-md5:  a603f9459d29348b88ba3592bca03274
10 URL:            http://live.gnome.org/GooCanvas
11 BuildRequires:  autoconf >= 2.50
12 BuildRequires:  automake >= 1:1.7
13 BuildRequires:  cairo-devel >= 1.10.0
14 BuildRequires:  docbook-dtd412-xml
15 BuildRequires:  gettext-tools >= 0.19.4
16 BuildRequires:  glib2-devel >= 1:2.28.0
17 BuildRequires:  gobject-introspection-devel >= 0.6.7
18 BuildRequires:  gtk+3-devel >= 3.0.0
19 BuildRequires:  gtk-doc >= 1.16
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  python-pygobject3-devel >= 3
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.219
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       cairo >= 1.10.0
28 Requires:       glib2 >= 1:2.28.0
29 Requires:       gtk+3 >= 3.0.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 GooCanvas is a new canvas widget for GTK+ that uses the Cairo 2D
34 library for drawing. It has a model/view split, and uses interfaces
35 for canvas items and views, so you can easily turn any application
36 object into canvas items.
37
38 This version is for GTK+ 3.
39
40 %description -l pl.UTF-8
41 GooCanvas to nowy widget "płótna" dla GTK+ wykorzystujący do rysowania
42 bibliotekę Cairo 2D. Ma podział model/widok i używa interfejsów dla
43 elementów i widoków, więc można łatwo zamieniać dowolny obiekt
44 aplikacji w elementy płótna.
45
46 Ta wersja jest przeznaczona dla GTK+ 3.
47
48 %package devel
49 Summary:        Header files for goocanvas
50 Summary(pl.UTF-8):      Pliki nagłówkowe goocanvas
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       cairo-devel >= 1.10.0
54 Requires:       glib2-devel >= 1:2.28.0
55 Requires:       gtk+3-devel >= 3.0.0
56
57 %description devel
58 Header files for goocanvas.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe goocanvas.
62
63 %package static
64 Summary:        GooCanvas static library
65 Summary(pl.UTF-8):      Statyczna biblioteka GooCanvas
66 Group:          X11/Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 GooCanvas static library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka GooCanvas.
74
75 %package apidocs
76 Summary:        goocanvas API documentation
77 Summary(pl.UTF-8):      Dokumentacja API goocanvas
78 Group:          Documentation
79 Requires:       gtk-doc-common
80 %if "%{_rpmversion}" >= "5"
81 BuildArch:      noarch
82 %endif
83
84 %description apidocs
85 goocanvas API documentation.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API goocanvas.
89
90 %package examples
91 Summary:        Example programs using goocanvas library
92 Summary(pl.UTF-8):      Przykładowe programy używające biblioteki goocanvas
93 Group:          X11/Development/Libraries
94 %if "%{_rpmversion}" >= "5"
95 BuildArch:      noarch
96 %endif
97
98 %description examples
99 Example programs using goocanvas library.
100
101 %description examples -l pl.UTF-8
102 Przykładowe programy używające biblioteki goocanvas.
103
104 %package -n python-%{name}
105 Summary:        Python binding for GooCanvas 2.x library
106 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GooCanvas 2.x
107 Group:          Development/Languages/Python
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       python-pygobject3 >= 3.0
110
111 %description -n python-%{name}
112 Python binding for GooCanvas 2.x library.
113
114 %description -n python-%{name} -l pl.UTF-8
115 Wiązania Pythona do biblioteki GooCanvas 2.x.
116
117 %prep
118 %setup -q -n goocanvas-%{version}
119
120 %build
121 %{__gtkdocize}
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --disable-silent-rules \
129         --enable-gtk-doc \
130         --with-html-dir=%{_gtkdocdir}
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 # prepare and install examples
141 %{__make} clean -C demo
142 cp demo/*.c demo/*.h demo/*.png $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
143
144 # obsoleted by pkgconfig support
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
146
147 %find_lang %{name}
148 %py_postclean
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files -f %{name}.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog NEWS README TODO
159 %attr(755,root,root) %{_libdir}/libgoocanvas-2.0.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libgoocanvas-2.0.so.9
161 %{_libdir}/girepository-1.0/GooCanvas-2.0.typelib
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libgoocanvas-2.0.so
166 %{_includedir}/goocanvas-2.0
167 %{_datadir}/gir-1.0/GooCanvas-2.0.gir
168 %{_pkgconfigdir}/goocanvas-2.0.pc
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libgoocanvas-2.0.a
173
174 %files apidocs
175 %defattr(644,root,root,755)
176 %{_gtkdocdir}/goocanvas2
177
178 %files examples
179 %defattr(644,root,root,755)
180 %{_examplesdir}/%{name}-%{version}
181
182 %files -n python-%{name}
183 %defattr(644,root,root,755)
184 %{py_sitedir}/gi/overrides/GooCanvas.py[co]
This page took 0.043427 seconds and 2 git commands to generate.